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Introduction to Web Design 
 

When Will I Ever Use This Stuff Anyway??? 
  

(Reasons to take Web Design) 

  
If you are thinking that this class can be a computer credit for you and not much else, think 

again.  Will you really ever use any of this stuff again?   
  
Here is a very short list of questions and the answers . . . 

  
Why do I need to learn to create web pages?  I already know 

[Dreamweaver/WordPress/GoLive/the editor of your choice]? 

  
Even if you already know how to use an editing program (and chances are good you will learn 

plenty of new stuff you can do with a web editor), web design will help you use it more 

effectively.  You will learn proper design technique, navigation and organization, how to add 

graphics, multimedia, interactivity - and a host of things you probably never thought of.  You 

may know how to use a word processor - but there is so much more to writing than just typing.  

Same thing with web design.  There is so much more to creating websites than just typing into a 

web editor! 

  
Why should I learn to make web pages if I don't want to pursue this as a career? 

  
Keep in mind that any job skill you have will help you in the job market and makes you a more 

valuable employee.  You may find a company in your chosen field which would love to hire you 

because you can also help them with their website.  Planning to join a huge company that already 

has a web staff?  You may want to create a personal page or one for your hobby, band, team, or 

organization.  You just never know!  

  
I'm a programmer/I'm just not a programmer 

  
Whether or not you love programming, whether you are a computer nerd, an artist, a musician, a 

poet, or a business person - there is something in web design for you!  In web design, we study 

graphics (for the artistic), writing (for the writer), organization, JavaScript (for the programmer), 

even animation (for the outrageously creative).   

 

Web Design has something for everyone.  And you will use the skills you learn here again and 

again!  
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Web Design Course Outline 

Course Information:  

This class covers the TEKS (Texas Essential Knowledge and Skills) for the course Web Design.  

This course requires students to have access to a computer outside of class. Students may use the 

computers available in the library before and after school as available.  

At the conclusion of the course, students will be able to do many things, including:  

 Understand technology terms, hardware and software concepts, and the impact of 

technology on society;  

 Create original graphics making use of appropriate design techniques considering 

elements such as size, color, contrast, and composition;  

 Create a presentation for the purpose of communicating information to a diverse audience 

through the use of a variety of electronic media.  

Supplies:  You should come each day with a writing utensil, notebook paper, a folder or 

notebook, and at least one portable USB drive in case you need to work on a project 

outside of class. 

Book:  Each student is given his/her own copy of the class textbook by the instructor which is 

the student’s to keep and write on.  If the student should lose the class book, he/she must 

purchase a replacement.   

Printer:  No one is to print without first getting permission.  No one but the teacher is to remove 

paper from the printer for any reason.  No assignments, papers, or materials may be 

printed for another class. 

Additional Help: 

If you need additional assistance or need more time to use the class software, please talk to me 

about meeting before or after school or during your study hall if possible.  I am happy to help, 

but please let me know ahead of time so I can make arrangements to meet with you. 
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I expect that every student will:  

 Come to class every day prepared with completed assignments and supplies;  

 Always show respect for the teacher and other students;  

 Complete all eating, drinking, gum chewing, and personal grooming before entering the 

classroom;  

 Refrain from bringing electronic gaming devices /cd players/mp3 players/cell phones and 

hats into the classroom. If you bring these items (on or off) to class they will be taken up 

and given to the assistant principal; 

 Turn in all work on time. If you have a need to turn an assignment in after the due date, 

consult your teacher before due date to obtain permission.  If circumstances beyond your 

control (meetings not being kept by a teacher, etc.) keep you from turning in an 

assignment on time, a letter of explanation signed by appropriate parties (the teacher) 

must be turned in on the due date;  

 Be responsible for make-up work.  If you were absent, it is your responsibility to get your 

assignments and new due dates.  You have the same number of days to make up work as 

you were absent.  If you were absent one day, then ask for that make up work two days 

later, you will not be able to receive credit for that work.  You have only one day to make 

up the work.  

 Remember that you are part of a team and that others will be depending on you.  

 Follow rules of appropriate computer usage and appropriate Internet usage at all times.  

 Follow all rules contained in the student handbook; and, most importantly  

 Participate - education is not a spectator sport! 

Course Outline: 

First Semester: 

 

 Internet Basics/Search Engines 

 Computer Ethics/Netiquette 

 HTML basics 
 HTML (images and tables) 

 GIFs vs. JPEGs 

 Copyright 

 Structure of a website 

 Design/Organization/Navigation 

 Graphics 

 Creating and Modifying Images using 

Photoshop 

 Using Scanners and Digital Cameras 

Second Semester: 

 

 Web Credibility 

 Issues in Technology 

 Web Authoring Software:  Dreamweaver 

 JavaScript 

 Multimedia 
 Forms 

 Flash 

 Ad Banners 

 Class Portfolios 
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Dear Parents: 

 

An integral part of preparing students for the 21st century is introducing them to the world 

of electronic communications.  We are very pleased to offer access to the Internet. 

 

The Internet is an electronic highway connecting thousands of computers all over the world 

and millions of individual subscribers. Through the district’s electronic communications 

system, your child will have access to hundreds of databases, libraries, and computer 

services all over the world.  The resources available are invaluable to you child’s education 

because the information is current and “real-time.”  Research and communication are the 

primary uses of the Internet. 

 

With this educational opportunity also comes responsibility.  It is important that you and 

your child read the information and sign the included form indicating that you have read 

it.  If you have questions, concerns, or need more information, please contact your child’s 

school. 

 

Please note that since the Internet provides access to computers and people all over the 

world, there is a possibility that your child may encounter areas of adult content and 

material you might find objectionable.  While the district will take reasonable steps 

through filtering and training to preclude access to such material and does not encourage 

such access, it is not possible for us to absolutely prevent such access.  Expectations and 

procedures will be explained to the students by their classroom teacher.  Access to the 

district’s electronic communications system, including the Internet, is a privilege, not a 

right.  Inappropriate use will result in disciplinary action and/or a loss of the privilege to 

use this educational tool.   

 

Please sign the included agreement form indicating you and your child have reviewed this 

information.  . 

 

Responsibilities for Using the Internet 

Student Responsibilities 

 Obtain permission from your teacher before accessing network resources 

 Follow teacher guidelines and instructions on appropriate use of the Internet and other 

network resources 

 Limit searches to the content being researched 

 Visit only those websites you are using for the current classroom activity – no surfing 

 Do not check your home e-mail at school 

 Credit all resources when utilizing information accessed (observe copyright guidelines) 

 Obtain permission from your teacher before downloading or printing 

 Do not use computer resources for playing games or listening to music or watching 

videos except when that is the focus of the lesson 

 Follow appropriate network etiquette 

 Follow all rules of the district Digital Citizenship Policy 
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Network Etiquette 

 Be polite; messages typed in all capital letters are the computer equivalent of shouting 

and considered rude 

 Use appropriate language; swearing, vulgarity, ethnic or racial slurs and any other 

inflammatory language are prohibited 

 Pretending to be someone else when sending/receiving messages is considered 

inappropriate 

 Transmitting obscene messages or pictures is prohibited 

 Revealing personal addresses or phone numbers of the user or others is prohibited 

 Using the Internet in such a way that would disrupt the use of the network by other users 

is prohibited 

 

The network is a resource, just as books, newspapers, magazines and videos are sources of 

information.  Students may not access or bring inappropriate materials into the classroom, 

whether in print or electronic formats. 

 

Violations of the above may result in disciplinary actions and/or loss of access privileges. 

 

STUDENT AGREEMENT FOR PARTICIPATION 
 

I have read the information on the Internet and understand my responsibilities as a student.  I 

agree to abide by the attached regulations and understand that inappropriate use could result in 

disciplinary action and/or a loss of privileges. 

 

PLEASE PRINT CLEARLY (EXCEPT FOR SIGNATURE) 

 
Name ________________________________ Class/Period ______ 
               (FIRST)                      (MIDDLE INITIAL)                     (LAST) 

 

DATE          

 

 

SIGNATURE          

 
 

PARENT AGREEMENT FOR PARTICIPATION 
 

I have read the information on the Internet and understand my child’s responsibilities.  Due to 

the public nature of the Internet, I understand the school cannot take the responsibility for 

materials available on-line. 

 

 

PARENT SIGNATURE                    DATE     

 

PARENT   EMAIL      ___________    PHONE  _______ _____                           
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Me and the Web 

A little exercise to see what I know about Web Design … 

 

In this class I expect to learn: __________________________________________ 

__________________________________________________________________ 

__________________________________________________________________ 

 

I have a computer at home:  YES  NO 

List type (PC, MAC, etc.) & operating system (Linux, Windows, Mac OS etc.)    

 

_____________________________________________________________ 

I use my computer primarily for: 

_____________________________________________________________ 

My e-mail address: 

 _____________________________________________________________ 

My favorite website:

 ______________________________________________________________ 

I have my own Web page:  YES  NO 

URL of my page:  ______________________________________________ 

Web page program I use: _________________________________________ 
 

I have my own blog:   YES  NO  What is a blog? 

 URL of my blog (optional):   

 _____________________________________________________________ 

  

 

Now let's see how much stuff you already know!!! 

 

1.  What does HTML stand for? ________________________________________ 

2.  What does HTTP stand for? _________________________________________ 

3.  Why is the Internet called a Web? ____________________________________ 

__________________________________________________________________ 

4. What is the HTML code to insert an image titled helmet.jpg? 

__________________________________________________________________ 

5. <TR> in HTML code defines what? __________________________________ 

6. Bright pink text on a bright yellow background is an effective set up for my Web page. 

 TRUE FALSE 

7. The most effective Web pages are ones with lots and lots of graphics. 

TRUE FALSE 

8.  What does FAQ stand for? ________________________________________ 

9.  What are GIFs and JPEGs? ________________________________________ 

10.  Before designing a web page, what are a few of the things you should consider?  
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Read the 10 commandments of ethical computer behavior and think of examples in which 

someone is either upholding or violating the commandment.  

 

The Ten Commandments of Computer Ethics 

by the Computer Ethics Institute  

1. Thou shalt not use a computer to harm other people.  

2. Thou shalt not interfere with other people's computer work.  

3. Thou shalt not snoop around in other people's computer files.  

4. Thou shalt not use a computer to steal.  

5. Thou shalt not use a computer to bear false witness.  

6. Thou shalt not copy or use proprietary software for which you have not paid.  

7. Thou shalt not use other people's computer resources without authorization or proper 

compensation.  

8. Thou shalt not appropriate other people's intellectual output.  

9. Thou shalt think about the social consequences of the program you are writing or the 

system you are designing.  

10. Thou shalt always use a computer in ways that insure consideration and respect for your 

fellow humans.  

Computer Ethics Institute 

A project of the Brookings Institution 

http://www.brook.edu/its/cei/cei_hp.htm 

 

 

Discussion questions: 

 

1.  Commandment 1 refers to using a computer to harm someone.  Besides physically harming 

someone with computer peripherals (which really isn’t what they meant), what are some other 

ways you can harm someone using a computer? 

 

 

2.  What does it mean to use a computer to “bear false witness?”  How could this cause harm to 

someone? 

 

3.  What exactly does it mean to “not appropriate other people’s intellectual output?”  How does 

this cause harm to someone? 

 

 

4.  If a user creates a computer virus, which commandment(s) are being violated and how? 

 

 

5.  Write two commandments that could be used to summarize the main ideas of the 10 

commandments.   

http://www.brook.edu/its/cei/cei_hp.htm
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Vocabulary Exercise, Part 1 

 
For each of the following general computer terms, write one definition that relates to computers, and one definition 

that defines how the term is used in everyday speech. 

 

1. Monitor ___________________________________________________________________ 

_____________________________________________________________________________ 

 

2. Form _____________________________________________________________________ 

______________________________________________________________________________ 

 

3. Icon ______________________________________________________________________ 

_____________________________________________________________________________ 

 

4. RAM _____________________________________________________________________ 

_____________________________________________________________________________ 

 

5. Mouse _____________________________________________________________________ 

______________________________________________________________________________ 

 

6. Cookie ____________________________________________________________________ 

_____________________________________________________________________________ 

 

7. Memory____________________________________________________________________ 

______________________________________________________________________________ 

 

8. Floppy_____________________________________________________________________ 

______________________________________________________________________________ 

 

9. Windows __________________________________________________________________ 

______________________________________________________________________________ 

 

10. Desktop ___________________________________________________________________ 

_____________________________________________________________________________ 

 

11. Process  ___________________________________________________________________ 

______________________________________________________________________________ 

 

12. Enter ______________________________________________________________________ 

______________________________________________________________________________ 

 

13. Key _______________________________________________________________________ 

______________________________________________________________________________ 

 

14. Return _____________________________________________________________________ 

______________________________________________________________________________ 
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15. Drag ______________________________________________________________________ 

______________________________________________________________________________ 

 

16. Control____________________________________________________________________ 

______________________________________________________________________________ 

 

17. Error______________________________________________________________________ 

______________________________________________________________________________ 

 

18. Mouse pad__________________________________________________________________ 

______________________________________________________________________________ 

 

19. Type______________________________________________________________________ 

______________________________________________________________________________ 

 

20. Escape_____________________________________________________________________ 

_____________________________________________________________________________ 

 

21. Tag _______________________________________________________________________ 

______________________________________________________________________________ 

 

22. Network ___________________________________________________________________ 

______________________________________________________________________________ 

 

23. Provider ___________________________________________________________________ 

______________________________________________________________________________ 

 

24. Source ____________________________________________________________________ 

______________________________________________________________________________ 

 

25. Resolution _________________________________________________________________ 

______________________________________________________________________________ 

 

26. Attributes __________________________________________________________________ 

______________________________________________________________________________ 

 

27. List _______________________________________________________________________ 

______________________________________________________________________________ 

 

28. Web ______________________________________________________________________ 

______________________________________________________________________________ 

 

21.  Browser ___________________________________________________________________ 

______________________________________________________________________________ 

 

22.  Domain ___________________________________________________________________ 

______________________________________________________________________________ 
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Vocabulary Exercise, part 2 

For each of the following general computer terms, write one definition that relates to computers. 

 

1. Disk _____________________________________________________________________ 

______________________________________________________________________________ 

 

2. Applet _____________________________________________________________________ 

______________________________________________________________________________ 

 

3. Multimedia_________________________________________________________________ 

______________________________________________________________________________ 

 

4. Pixel _____________________________________________________________________ 

______________________________________________________________________________ 

 

5. Click ______________________________________________________________________ 

______________________________________________________________________________ 

 

6. Document __________________________________________________________________ 

______________________________________________________________________________ 

 

7. Graphic____________________________________________________________________ 

______________________________________________________________________________ 

 

8.  Bandwidth __________________________________________________________________ 

______________________________________________________________________________ 

 

9.  Firewall ____________________________________________________________________ 

______________________________________________________________________________ 

 

10.  Spyware __________________________________________________________________ 

______________________________________________________________________________ 

 

11.  Comment _________________________________________________________________ 

______________________________________________________________________________ 

 

12.  Spam  ____________________________________________________________________ 

______________________________________________________________________________ 

 

13.  Wiki ___________________________________________________________________ 

______________________________________________________________________________ 

 

14.  Blog       ___________________________________________________________________ 

______________________________________________________________________________ 

 

15.  Podcast  ___________________________________________________________________ 

______________________________________________________________________________ 
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Webmastering Vocabulary 

Across 

 

3. One (or a pair) of modifier keys found on all modern keyboards which does not generate any input but modifies 

the function of other keys.  To reboot, press __ - Alt – Delete. 

5. A command inserted in a web document that specifies how the document, or a portion of the document, should be 

formatted.   

6. A device that controls the movement of the cursor or pointer on a display screen. 

7. A description for systems capable of presenting text, pictures, sound, video, and animation. 

9. A round, magnetic plate on which data can be encoded. 

11. Data storage areas in the computer. 

15. Information created by a Web site and stored on the user's hard drive. 

17. The place in the computer where the operating system, application programs, and data in current use are kept. 

19. The number of pixels or data in a certain space.   

21. A special symbol, usually a solid rectangle or a blinking underline character, that signifies where the next 

character will be displayed on the screen. 
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Down 
 

1. To move an image or icon by moving a mouse while holding down one of its button. 

2. A characteristic or property of a file, text, graphic, etc. 

4. A group of two or more computer systems linked together is a computer __ . 

8. A set of network addresses. 

9. Part of a common graphical user interface which generally includes a work space and icons representing files and 

programs. 

10. A company or organization which provides access to the Internet to businesses and/or consumers is an Internet 

Service ___ . 

12. A computer display and related parts packaged in a physical unit that is separate from other parts of the 

computer.   

13. A page that includes areas to be filled out by the reader. 

14. All the resources and users on the Internet that are using the Hypertext Transfer Protocol.  The world wide ___ . 

16. A software application used to locate and display Web pages. 

18. An operating system created by Microsoft. 

20. A small picture that represents an object or program (or some characteristic of an object or program). 

21. To tap on a mouse button, pressing it down then immediately releasing it. 
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The Internet: An Introduction 

A Very Brief History of the Internet 

What Is The Internet And How Does It Work? 

 

To understand what the Internet is, you first need to be familiar with the concept of a network.  A 

network is a group of two or more computers linked by cables, telephone lines, or other 

communication media (such as satellite signals).  The linked computers include a special computer 

called a network server, which stores files and programs that can be used by everyone on the 

network.  Networks are useful because they allow many people to share the software resources 

stored on the network server as well as hardware resources, such as a printer. 

 

 

 

 

 

 

 

 

 

 

The Internet has its origins in the late 1960’s.  Many researchers including J.C.R. Licklider (who 

proposed the idea of computer networks) and Leonard Kleinrock (who developed the basic theory 

of packet switching) at MIT,  Donald Davies and Roger Scantlebury of NPL (the National Physical 

Lab in the United Kingdom), and Paul Baran and others at RAND (who proposed theories about 

non-centralized networks consisting of separate nodes which can function separately or as a group) 

all worked in parallel on the theory that it was possible to create a global network where computers 

separated by great distances could still communicate and share data.  The U.S. Department of 

Defense was working diligently to overtake the Soviet Union (after being beaten into space by 

SPUTNIK) and was interested in methods of pooling data from researchers throughout the United 

States and facilitating their cooperation in furthering research into the space program.  With the 

Cold War still a concern, the Department of Defense was also concerned with creating a 

geographically dispersed network that could function even if part of it was damaged or destroyed. 

To accomplish these goals, the DoD funded the development a network of military computers called 

the ARPANET (Advanced Research Project Agency NETwork).   

 

The original ARPAnet consisted of four nodes each at a major university (UCLA, Stanford, UC 

Santa Barbara, and the University of Utah) and used a method of communicating called the 

Network Control Protocol.  NCP allowed individual computers to communicate remotely with other 

computers that were very similar.  Quickly realizing the usefulness of such a network, researchers at 

colleges and universities began using ARPANET to share data.  Wanting to expand further, and to 

connect even more diverse computers and networks of computers, Robert Kahn and Vint Cerf 

worked to develop a new protocol called Transmission Control Protocol/Internet Protocol (TCP/IP).  

TCP/IP is the most widely used protocol today, and it allows diverse machines and networks to 

communicate and share data effectively even over great distances.   

 

Computer 

Example 

of a 

Network 

Network 

Printer 

Computer 
Computer Computer 

Computer 

Network 

Server 
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The Internet was widely used by researchers and scientists who had access to the expensive 

computer equipment.  Marc Andreessen, an undergraduate student at the University of Illinois, led a 

team that developed a new browser for the Internet called Mosaic in 1993.  Mosaic was superior to 

previous browsers because it allowed for the basic formatting of pages (text could be aligned and 

formatted) and allowed images and text to be displayed together on the page.  Mosaic made it much 

easier for users to navigate the Internet.  By bringing more users to the Internet, the content 

available increased dramatically, eventually blossoming into the huge community it is today.  

Mosaic eventually evolved into Netscape, which was popularly used until 1998.  It has since been 

discontinued, but could be reintroduced sometime in the future.   
http://www.ibiblio.org/pioneers/andreesen.html 

 

So is the Internet spelled with a capital I or lowercase i?  Any two networks connected together are 

called an internetwork or internet.  The Internet is the global community of computer networks that 

allows users to view and transfer information between computers all over the world.  The Internet is 

not a single organization, and thus is not owned by any one company, but rather is a cooperative 

effort by multiple organizations managing a variety of different kinds of computers.   

 

Internet Statistics (as of March, 2013) 

 

 Worldwide Internet population is approximately 2.75 billion users (in 2000 it was 360 

million users) 

 Percent of people with Internet access worldwide:  34% 

 In the United States, 78.3% of the population are online 

 44.8% of all Internet users live in Asia 

 Worldwide, 37% of women and 41% of men are online 

 
http://www.internetworldstats.com/ 

 

WORLD WIDE WEB (WWW) 

 
The World Wide Web, or WWW, is a subset of the Internet.  It is a network of special computers, 

called Web servers, which store files called Web pages.  A collection of Web pages on a Web 

server is called a Web site.  The primary page at a Web site is called the home page and is usually 

named index or default (with either an htm or html extension). 

 

WWW pages are multimedia files, which mean that they can contain text, graphics, video, and 

audio.  In addition, they can contain hypertext links (usually just called links).  When clicked, 

links display other areas of the same Web page, load other Web pages at the same Web site, or load 

a Web page from a different Web site.  These links create a "web" of connections among pages.  

Clicking links and moving from one Web page to the next is known as browsing the Web.  The 

software you use to browse the Web is called a Web browser.  Web pages are transmitted to your 

computer via a special communication protocol, or set of rules, called Hypertext Transfer 

Protocol, or HTTP. 

 

Connection to the Internet is via an Internet Service Provider (ISP) through the use of a Web 

browser (more on Web browsers later).  When you log onto the Internet, you are actually 

connecting to a computer somewhere in the world.  Once connected, the computer you are drawing 

information from is called a host, and your computer is called a client.   
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Large routers placed in specific cities around the world handle the transfer of information from 

various networks.  If you are sitting at your home computer in Houston and you request a page that 

is sitting on a computer in Albany, New York, your request could then be sent from your home to 

your ISP (which most likely uses a computer sitting in an office building somewhere in Houston), 

then to a router in Dallas, then to a router in Nashville, then to a router in New York, then to a 

smaller router in Albany, and on to the actual computer that houses the page.  While this may seem 

like a long process, it happens almost instantaneously due to the processing power of the equipment 

involved. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Computers on the Internet use IP address numbers to communicate with each other.  The IP address 

is a series of numbers that represents the “location” of the computer on the Internet.  An IP address 

us a 32-bit number that consists of 4 sets of numbers separated by periods (for example, 

10.2.111.123 could be an IP address).  Any series of numbers can be an IP address, however if you 

want your web page to appear on the Internet, you must get a registered IP address that is unique to 

your computer.  Because the number of IP addresses is running out, a new scheme called CIDR 

(Classless Inter-Domain Routing) which will expand the number of addresses available by adding a 

prefix (which actually appears at the end of the IP address, such as 10.2.111.123/12).   
http://www.webopedia.com 

 

Because these IP addresses are hard to remember, the WWW supports a special location code, 

called a Uniform Resource Locator, or URL, to identify each Web page on the WWW.  An 

example of a URL might be: http://www.yahoo.com, where http:// is the communication protocol 

and syntax, and www.yahoo.com is the name of the location of the actual page we wish to view.  

When you request information from a Web page, your browser uses a DNS (domain name server) to 

match the domain name to an IP address.  If you use IP numbers instead of URL’s you will find that 

the pages link faster. 

 

The URL Explained 

 

http://www.esc4.net/regioniv/information/campus.asp/ 
 

 

 

 

1} protocol/data source - The name of the protocol used to access the data that resides on the other 

end of the link.  In this case, http points to a hypertext document.  Other possible protocol/data 

sources are ftp, gopher, news, mailto and telnet, among others. 

A graphic representing the 

Internet.  Thick lines indicate 

larger lines of transfer (such as 

a T1); while thinner lines 

represent smaller modem 

connections (such as 56 and 

28K) 

 

Note that a large number of 

people still use 56.6K Internet 

connections. 

1 2 3 4 5 6 
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2} World Wide Web - Indicates that this is a site on the World Wide Web. 

3} directory path -This is the location of the Web page in the Web server's file system. 

4} domain extension - Indicates that this is a network site (and hints at what type of site). 

5} location - Indicates the path to the Web page location. 

6} object name - This is the actual name of the HTML file for the desired Web page.  Browsers will 

automatically take you to the index.html file when an exact location is not indicated. 

 

Common Domain Extensions 

 

Domain 

Extension 

Description Example of Internet Address 

.com Commercial Service www.disney.com (the Disney company) 

.edu Education www.alief.isd.tenet.edu (Alief ISD) 

.gov Government www.whitehouse.gov (the White House) 

.mil Military www.army.mil/ (US Army home page) 

.net Network Provider www.Internet.net (the Internet Shopping Network) 

.org Organization www.dinosociety.org (The Dinosaur Society) 

   

Domain names can also end in extensions that let you know the state or country the computer is 

located in.  For example: 

.uk = United Kingdom .ca = Canada  .fi = Finland  .sa = Saudi Arabia 

.hk = Hong Kong  .tn = Tennessee .us = United States .au = Australia 

 

Connecting to the Internet 

 

As stated earlier, to connect to the Internet, you need to have an ISP or Internet Service Provider.  

Once you have decided on a provider (examples include AOL, Roadrunner, Everyone’s Internet), 

you will need to choose a method of connecting.  There are two basic categories of connections:  

Dial-up and Broadband.  The speed of the connection is generally called the bandwidth, which 

refers to the amount of data that can be transmitted in a given period of time.   

    

Dial-up connections use existing phone lines and modems to connect to the Internet.  When you 

want to connect to the Internet, you dial the phone number using your modem.  When using dial-up, 

the maximum bandwidth speed is around 56 Kbps (kilobits per second).  The average speed can run 

much more slowly.  Certain software (such as WebJet) can be used to optimize download times by 

compressing data.  Advantages of dial-up is that it is generally the least expensive connection 

option, you can connect using any phone line (so you can dial up from home, school, or on the 

road).  Disadvantages of dial-up is the slower access speed, delays in establishing a connection, 

occasional unintentional disconnections and the fact that (unless you have a dedicated phone line) 

dial-up will interfere with your phone use. 

 

A broadband connection allows a single wire to carry multiple signals, so it can use existing wires 

to provide a connection to your ISP.  Broadband connections differ from dial-up in two main ways.  

The first is that the connections are “always on,” meaning the user can leave the connection active 

all the time without interfering with any other services.  The second is that the connection speed is 

much greater than that of dial-up.  The most popular methods of broadband connection are Cable 

Modems and DSL. 
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Cable Modems make use of the coaxial cable that brings cable TV to your home.  Can offer speeds 

up to 2 - 5 Mbps (megabits per second) although most connections average about 1 Mbps.  Cable 

modem access is typically from $30-$50 per month or it can be purchased as part of a package 

including digital phone and cable.  In addition to the cable, you need an Ethernet modem and 

browser software.  Advantages to cable modem use includes the speed, the “always-on” connection, 

and general reliability of service.  Some disadvantages are that you have to live in an area where 

cable modem service is available  (meaning the local cable company has upgraded to the fiber-optic 

line needed for the service).  Also, because you share a line with other cable-modem customers in 

your area, there may be issues with security and slower access speeds if there are many users on-

line at the same time.   

 

Another broadband option is a Digital Subscriber Line (DSL).  When using DSL, it is your phone 

line that is used to transfer data (because it transfers the data differently than dial-up, you can get 

much more bandwidth).  Speed can be up to 1.5 Mbps, and in addition to your phone line, you will 

need an Ethernet modem, browser software, and special filters to separate your phone line from the 

DSL line (to keep you from getting noise on your phone line).  Costs average between $30 - $50 per 

month, and you can often get discounts by bundling a DSL service with other phone services like 

long-distance or cellular service.  Advantages of DSL include the speed, the “always on” 

connection, and general reliability of service.  The main disadvantage is that the reliability and 

speed of your connection ultimately depends on how far you are from the phone company office 

(not always easy to figure out).  While most DSL providers make sure to only connect users within 

a certain range of the main station, if you are close to the edge of the boundary, you may notice 

significantly slower connection speeds.   

  

Although having an Internet connection that is “always on” may seem like a great idea, if you 

actually leave your computer connected to the Internet while you are away, you are exposing your 

system to security risks.   

 

The World Wide Web is only one of many services available on the Internet.  Below are some other 

options (Note: this is not a comprehensive list): 

 

Communication 
 

E-mail 

 

The term e-mail refers to electronic messages sent or received from one computer to another ('e-

mail' is short for 'electronic mail').  E-mail was adapted for the Internet by an engineer named Ray 

Tomlinson in late 1971.  He used the format username@domain, because the @ symbol was rarely 

used and he liked the implication that the user was “at” a location.  E-mail is by far the most 

common Internet application.   

 

The way e-mail works is that you must have an ISP or other e-mail provider (there are many free 

ones available on the web).  Mail is delivered to your “mailbox” which is really a storage location 

on the mail server, which stores it until you connect and access the messages either by reading them 

on-line or by downloading them to your computer.   

 

E-Mail has many advantages over traditional mail (called “snail-mail”).  The main ones are the cost 

(minimal); the speed; the ability to send pictures, documents, or media files; the ability to send to 

large groups; and the ability to track messages easily (including when the user receives the e-mail).    
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There are many drawbacks of e-mail, however.  The main complaint is spam.  Spam refers to 

unsolicited mass e-mailing (which are free and simpler than postal junk mail).  Spam is perceived to 

be such a problem that there has been anti-spam legislation proposed at various times, and some 

legislation may have been passed by the time you read this.   

 

Other disadvantages of e-mail include a lack of formality (or even professionalism) in the content of 

the e-mail.  There is a risk of transmitting viruses using e-mail, systems often go down preventing 

users from accessing their mail, and occasionally e-mail may get “lost in cyberspace.” 

One of the results of the widespread use of e-mail has been a change in people’s expectation of 

response time.  Where once we were content to wait days for a response to a question, it is common 

today to be annoyed if e-mail is not responded to almost immediately. 

 

When using E-mail, here are some tips to keep in mind:  

 

 Never send chain letters through the Internet!  

 Be professional and careful what you say about others.   

 Be careful when using sarcasm and humor.  

 You may use emoticons and acronyms (see the section on Chatting below)  

 Remember how easy it is to forward messages – be careful what you say!  

 Never assume your e-mail is private.  

 Never send something you would mind seeing on the evening news.  

 Keep paragraphs and messages short and to the point  

 Capitalize words only to highlight an important point or to distinguish a title or heading. 

Don’t SHOUT!  

 

Social Networking 

 

Wikipedia defines social networking as “Online social networks of people who share common 

interests or activities or who are interested in exploring the interests and activities of others.”  

Currently, the most popular social networking site is Facebook.   

 

Facebook was created in 2004 by Mark Zuckerberg, a 23 year old psychology student at Harvard.  It 

began with Harvard, then expanded to Ivy League schools, then all universities.  In September 

2005, Facebook was expanded to include high schools, by invitation only.  In September 2006, it 

was opened up to anyone with an e-mail address.  As of 2010, Facebook estimates that it has 400 

million active users, who spend an average of 55 minutes per day on Facebook.  The average user 

has 130 friends, and writes an average of 25 comments on Facebook per month.   

 

You should pay close attention to your privacy settings and make sure you choose controls that are 

appropriate for you.  When you are using Facebook, keep in mind that what goes on Facebook 

belongs to Facebook (even if you delete it) and may resurface years from now to be viewed by 

potential colleges, employers, and family members.  Always maintain a Facebook presence that you 

would not be embarrassed for others to see.   

  

 

Newsgroups 

 

Newsgroups are electronic 'bulletin boards' where people with common interests (like hobbies or 

professional associations) post messages (called 'articles') that can be read and responded to by 
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other participants around the world; sometimes called Internet discussion groups.  Google groups or 

Yahoo groups are common places to find newsgroups.   

 

Newsgroups provide areas for you to exchange ideas, ask questions, offer opinions, or just do some 

lurking (reading without expressing an opinion to the group).  Most news areas are organized 

according to related topics.  You can choose a topic to investigate and read specific news articles.  If 

you want to communicate with others on the topic, you can reply to an article. 

 

Some newsgroups are supervised by a moderator who may read each article before it is posted to 

the newsgroup (some moderators choose to read every article, many choose to read posts as they 

occur and delete objectionable ones) .  When you begin to participate in a newsgroup, it is 

recommended that you see if the group has their FAQs (Frequently Asked Questions) posted and 

take a few moments to look them over.  The FAQs are designed to prevent new newsgroup users 

from asking the same questions over and over.   

 

Web 2.0 

 

The term Web 2.0 was first widely used as part of a Web 2.0 conference held in 2004.  In general, 

Web 2.0 refers to sites using “advanced Internet technology,” generally refer to some level of 

interactivity between users and the site.  Web 2.0 tools may include blogging tools (like blogger), 

multimedia tools (such as Prezi), photo sharing sites, social bookmarking, and some online gaming.   

 

Mailing lists/Listserv 

 

A listserv is a service similar to newsgroups except that participants exchange information via e-

mail. 

 

A listserv is a discussion group focused on a particular interest area.  Each listserv is composed of 

people who have voluntarily subscribed themselves.  When one member of the listserv posts a 

message to the listserv, all members of the listserv will receive an email message (although some 

listservs will only allow messages to be sent back to a moderator who will determine what to pass 

on to the group).  There is no charge for joining a listserv.  To find a list of listserv that you would 

like to subscribe to, just use a search engine to locate a listing of available services.  You must 

subscribe using an email account.  If you do subscribe to a listserv, it is a good idea to check your e-

mail often as the amount of mail you receive can be quite extensive.  Some listservs allow you to 

choose to receive a digest version periodically which puts all the messages into one e-mail.  If you 

know you are not going to be checking e-mail for a while, you may want to investigate whether 

your listserv has a “vacation” option allowing you to not receive e-mail during a period of time.   

 

Instant Messaging 

 

Instant Messaging allows users to participate in real-time online conversations in which you type 

messages to other people and receive responses they can read on their screens within a few seconds.  

Social Networking sites such as Facebook, MySpace and Twitter offer real time connections.  You 

can also IM using clients such as AIM or GoogleTalk.  Also extremely popular is SMS, or short 

message service, provided by mobile phones or other portable devices.   

 

Because of the speed needed to chat or text efficiently, and just general laziness of chatters, the use 

of emoticons and acronyms has become popular.  Emoticons are keyboard characters which are 

supposed to resemble a picture of some sort.  Here are some examples:  
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:-)    happy  

;-)    winking   

8-)    glasses or really paying attention :-p    sticking tongue out  

>:-(  angry (or goat-man)  {:-)    eyebrows or hair parted in middle  

(:-)    bald  (:-(    sad bald man 

:-o    surprised  (:-*    kisses  

:-x    sour  (:-1    ambivalent  

 

Acronyms are abbreviations of common expressions 

 

BFN - bye for now  HTH - hope this helps  

BRB – be right back TTFN - ta ta for now  

BTW - by the way  GTG – got to go 

IMHO - in my humble opinion  TIA – thanks in advance 

LOL - laughing out loud  AFK – away from keyboard 

 

 

Be careful when chatting with or IMing or texting people you don’t know.  Never agree to meet in 

person anyone you meet in a chat room!  And if you receive any inappropriate communication, 

notify the moderator of the chat, your ISP or cell phone service provider, and your parents.  You 

may even need to notify law enforcement officials if you receive contact that is inappropriate or 

obscene.  Do not ever use your cell phone to send images that may be perceived by anyone as 

extremely private in nature.  It is illegal to send images using electronic media that could be 

considered pornographic, even if the person pictured consents.  You should also never text while 

driving. 

 

Blogs 

 

Short for web logs, blogs are personal journals that are posted online for people to share with the 

public.  It generally takes on the form of an online diary, with dated entries about whatever topic the 

blogger is interested in.   

 

Microblogging 

 

Microblogs are very short blog entries based on the SMS text messaging system.  The most popular 

microblog is Twitter, which allows users to express themselves in short posts limited to 140 

characters.  Tweets may contain text, or links to web pages or images. 

 

FILE access 
 

FTP 

 

FTP is a method for sending (uploading) or receiving (downloading) computer files via the File 

Transfer Protocol (FTP) communication rules.   

 

FTP pages are usually very plain, with only hypertext links and information about the files.  For 

some FTP files, such as text documents, you can download the file and display it immediately on 

your screen.  Other documents (for example, word processing, spreadsheet, or database) may have 
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to be downloaded and then opened by running the appropriate program.  For example, to open an 

Excel spreadsheet, you must have the Microsoft Excel software.  For software programs, you must 

download such FTP files directly to your hard drive.  You may then have to uncompress the file 

before you can run the program.  Some FTP sites require you to have a login and password to view 

or download files, and most require a login to upload files.  Some sites do permit you to download 

(or possibly upload) files without logging in – this is called anonymous FTP. 

 

When using FTP, as with any occasion you download files to your computer, you should be very 

careful that you trust the source of the file, and that you are running virus protection on your 

computer.   

 

Gopher  (OR:  There are small, hairy animals running around inside my computer…really!) 

 

Gopher is an old method of displaying and downloading files from lists of files located on the 

Internet at computers called Gopher sites 

  

Gopher is a menu-based tool that allows you to search millions of directories and databases of text 

documents throughout the Internet.  When you access gopher sites, you navigate from one menu to 

another menu and then to submenus by choosing menu items until you find information that 

interests you.  Gopher menus are usually very plain, with only hypertext links.  If you find a menu 

or page that you may want to visit again, remember to bookmark it (to avoid having to go through 

all those menus every time).  The URL for a gopher site begins with gopher:// 

 

Be aware that as it becomes easier and easier to create WWW pages that gopher driven sites are 

disappearing from the Internet.  While they are still used at many research institutions, they plain 

appearance and lack of interactivity are dooming them for public use. 

 

Terminal emulation 
 

Terminal emulation is a method for connecting directly to another computer on the Internet using 

the TELNET communication rules.  It is rarely used today.  It may be occasionally used by 

organizations that use an older mainframe, like banks or government offices.  Terminal emulation 

programs may be used to access decades old programs that would not run on newer operating 

systems.   

 

Search tools 
 

Search engines 

 

Search Engines are web-based tools to help you find specific information on the WWW by 

searching for specific words or phrases.  We will deal extensively with search engines shortly. 

 

Other Web-Based Technologies 
 

Intranets 

 

Intranets are internal networks which use internet and web technology, but are not available to the 

public.  In general, intranets are only available to people who are using computers connected to that 

network, but some intranets allow users to connect remotely. 
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Some of the most common uses for an intranet are scheduling, calendars, conferencing, and 

publishing large amounts of information.  Some companies make use of discussion boards and 

allow applications to be downloaded from the intranet to the employees’ individual computers.     

 

When you create an intranet, the main concern is access.  You must make sure that people have 

access to the information they need and that outsiders do not have access to private data.  

 

Security 

 

Security is a major issue with any web technology.  Using your computer to access the global 

community of the Internet, you must be aware that some in the global community may want to 

access you back. 

 

A firewall is a general term for hardware or software used to restrict access to data on a network.  

The purpose of a firewall is to deny access to outsiders.  All data entering or leaving the network 

pass though the firewall which examines it, looks at specific criteria, and determines whether the 

data can be passed on.  Many new computers come with the built-ability to enable their own 

software firewall, which prevents outsiders from accessing files and peripherals on your computer.  

You can also use hardware to act as a firewall. 

 

A proxy server is a computer that acts to separates a client program (such as a web browser) from a 

network or the Internet.  A proxy server is used to monitor and control access to resources, so it can 

be used as a firewall.  It can also be used to “cache” or store a copy of a page in local storage.  This 

helps speed up access to the Internet, as new requests for the same page are given the cached copy 

rather than continually retrieving the original page from the Internet.  It can also be used to deny 

access to certain Internet sites or categories of websites.   

 

Do you need a personal firewall at home? 

 

o Do you have broadband (cable, DSL) access?  These make it easier for hackers to access 

your system. 

o Do you leave your computer connected to the Internet when you are not using it?  Even if 

your computer is off, it is possible to remotely wake your computer and access your data. 

o Do you use Windows and Outlook?  These are major targets for hackers (because they are 

so commonly used and many hackers hate Microsoft) 

o Do you operate a web server?  If you allow some traffic in, you increase the risk of 

unwanted access to your system. 

 

No computer system is 100% hackproof, but implementing a personal firewall will at least make it 

more difficult.   

 

How to protect yourself from unwanted intrusions: 

 

o Use virus protection software (and keep it updated!) 

o Keep your operating system, your browser and email software up to date. 

o Have your ISP scan your email for viruses and junk mail (spam). 

o Delete spam without opening it.  Never respond to requests to “unsubscribe” – that just 

verifies to the sender that you do exist and will open their mail. 



23 

o Never open attachments or Twitter DMs from people you do not know (or suspicious 

messages from people you do know). 

o Back up your data files on a regular basis 

o Keep all passwords secure – do not use a single password for all your needs.  Choose several 

depending on the category of security you need (bank or credit card passwords should not be 

used as your password for Twitter).   

o Never send your passwords via e-mail to anyone (even if they claim to be your bank – your 

bank knows your passwords, they don’t need to ask you). 

o When you are not accessing the Internet, consider disconnecting the network cable from 

your computer.   

 

If you just take some simple precautions, you can help protect your system.  Even a minimal delay 

may be enough to persuade hackers to move on to the next victim. 

 

Wireless 

Wireless refers to the process by which electromagnetic waves carry telecommunication signals 

without the use of any type of wire.  There are many different devices that make use of wireless 

technology, ranging from television remote controls to cell phones to GPS systems to home 

computer networks.   

IR wireless uses infrared (IR) radiation to carry a signal.  It is useful for short to medium range 

communication and control.  IR is most commonly found in home entertainment remote controls 

(TV/DVD/DVR).  It is also used in home intrusion detection systems, computer peripherals (mice, 

keyboards, printers).   

IR wireless is limited in that cannot pass through walls.  This does provide some privacy, though,  

and generally protects you from having your neighbor change the channels on your TV (unless you 

have windows facing each other and he/she is very determined).      

 

Bluetooth uses a small radio chip to send short-range radio transmissions between electronic 

devices.  It gives the user wireless, hands-free devices, and also allows communication between 

peripherals (mice, keyboards, printers) and computers.  Gaming systems also use Bluetooth in their 

wireless controllers.  Because Bluetooth uses radio waves instead of IR radiation, it allows for a full 

range of motion for the devices, with no need to worry about “line of sight” (such as pointing your 

remote at the TV so it will work properly).  Bluetooth will work with your cell phone in your pocket 

or a printer in the next room.  Bluetooth does have a short range, from 30’ to 300’ depending on the 

device.   

 

GPS stands for Global Positioning System.  GPS receivers use signals from orbiting satellites to 

determine your position.  Each satellite transmits a synchronized signal.  The GPS receives the 

signal and calculates the distance from each satellite based on how long it took the signal to arrive 

at the receiver.  It needs to have a signal from at least 4 satellites to be able to determine your 

position properly.  GPS receivers need an unobstructed view of the sky to work properly, so they 

are only useful outdoors.  Most hand-help GPS units are accurate within 30’.  Car GPS receivers 

combine the position information received from the satellite with maps stored in memory to help 

tell you how to find your destination.   

 

Mobile wireless is used for cellular phones.  Cell phones actually use radio waves to transmit 

information, like a walkie-talkie or a CB radio. Unlike walkie-talkies which are half-duplex devices 

(only one person can talk at a time), cell phones are full-duplex devices, using one frequency for 
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talking and a different one for listening, so both people can talk at the same time.  First and second 

generations of mobile telephone use (1G and 2G) were designed for voice transmission.  1G used 

analog signal, 2G used digital.  Third generation (3G) was intended for voice and data.  4G and LTE 

(Long Term Evolution) typically offers 4 to 10 times the performance of 3G.  3G technology 

generally allows download speeds of .4Mbps to 1.5Mbps.  4G allows for 2Mbps to 6Mbps, with 

peak speeds of 10Mbps.  The 4G LTE currently available on phones is actually a hybrid of 4G and 

3G (mainly for phone calls, but also for areas without 4G LTE coverage). There are visions of 5G, 

perhaps representing a major increase in bandwidth, hopefully approaching speeds of 100Mbps to 1 

Gbps.  But for now, that is still a long way away.  

 

Fixed wireless is generally used for fixed locations such as homes or offices (as a WLAN, or 

wireless local area network).  It generally is powered by the local power sources (not by batteries).  

It is limited in range physically (as opposed to mobile wireless) but provides much higher 

bandwidth and download speeds than mobile.   Advantages of fixed wireless over wired networks is 

that you have more flexibility to move networked equipment, fewer cables to manage, and the 

ability to add equipment or users without making changes to the infrastructure.  Disadvantages are 

that security is generally a concern (measures must be taken to ensure that outside users are not 

accessing the signal). 

What do you need to go to a fixed wireless network in your home?  In general, you need a wireless 

network adapter (most laptops sold today come with wireless network cards, and they can also be 

purchased for desktop PCs) and some type of wireless router, which will physically connect to your 

home’s Internet connection, then allow other devices to connect wirelessly.    Older Wi-Fi routers 

were designed to reach around 100’, although walls will limit the signal somewhat.   Newer routers 

claim a range of up to 1400’.  There are several general wireless protocols:  802.11b was the 

original standard for home use, but isn’t used much anymore (mainly in areas where the original 

hardware hasn’t been upgraded).  802.11a is faster, but more expensive and is more commonly 

found in businesses.  802.11g is faster than 802.11b, and 802.11n is the newest standard for home 

use (802.11n draft version 2.0 is being introduced).  Once you have connected your wireless router 

(or wireless access point if you already have a local home network you just want to be able to 

access wirelessly), the remote device should be able to detect the wireless network and connect.   

 

Wireless vs. Wired networks 

How do wired home networks compare with wireless home networks? 

 

Flexibility:  Wired networks require cables to physically connect devices to the network.  In a 

home, this may require running cables along walls and/or ceilings to get connections where you 

want them.  Wireless devices can be moved within the range of the signal (but do generally need to 

be connected to a power outlet) which gives much more flexibility.   

 

Bandwidth:  Older Ethernet wired networks supported up to 10Mbps and but generally, most 

routers today support fast Ethernet wired technology which gives up to 100Mbps (actual 

performance isn’t quite that fast, but close).   Newer equipment advertises speeds close to 

1000Mbps.  Wireless LANS using 802.11a and 802.11g support up to 54Mbps.   802.11n claims 

peak speeds of 300Mbps.  

 

Reliability:  Wired networks are very reliable.  In general, network problems are the result of a 

service outage or a loose cable.  Wireless technology is newer, so it has had less time to be 

improved.  Older 802.11b and 802.11g networks had problems with interference from microwave 

ovens, cordless telephones,  Bluetooth devices, and even garage door openers, but most of those 

issues have been resolved.  802.11n is the newest standard, so there are still some minor issues that 
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may come up.  It’s important to periodically check the manufacturer website to see if there are any 

updates which may need to be installed.   Also with wireless, you may experience connection 

problems if you routinely operate your devices close to the maximum range of the wireless router 

signal.   

  

Security:  In theory, wireless networks are less secure than wired networks, simply because you 

have a signal travelling through the air.  If you have a wireless computer in a neighborhood, you 

may be able to detect a number of wireless networks in your area.  As long as you take a few 

minutes to protect your home wireless network using WPA/WPA2/WEP encryption (one of the 3, 

depending on your need and your router), your wireless network should be as reasonably safe as a 

wired one.   All home networks should have a firewall enabled, run updated anti-virus software, and 

users should be aware of the dangers of downloading spyware or responding to phishing schemes.   

The decision to go with wireless or a wired network really depends on where your Internet 

connections are, where you would like to be able to use your computer, and how much bandwidth 

you need.  If you are a heavy gamer, you may want to connect directly to your network using a fast 

Ethernet connection.   If you want the freedom to be able to use a laptop in different parts of your 

home, you may want to consider network.   

 

http://searchmobilecomputing.techtarget.com/definition/wireless 

http://compnetworking.about.com/cs/homenetworking/a/homewiredless.htm 

http://www.networkworld.com/news/2010/042710-4g-wireless-20-questions-asked.html?page=1 

http://electronics.howstuffworks.com 

http://www.nasm.si.edu/gps/work.html 
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Internet Error Messages Explained 

Below is a list of some of the most common Internet error messages and what they mean.  This 

is not every Internet error message – other messages you may encounter are likely variations 

on those below. 

 

 400 Bad File Request – Indicates you may have typed part of the URL incorrectly, or that 

you used the wrong syntax, such as typing uppercase letters in lowercase.  Check to make sure 

that you have every dot, slash, and colon in the correct place. 

 401 Unauthorized – The page you want likely requires a password to open it, and you did not 

enter the password or you entered it wrong.  If you are certain your password is correct, check to 

make sure that it is still valid. 

 403 Forbidden Pages – Very similar to 401, areas that give you this message are typically 

accessible, but not to you.  Or you may be missing a password or have typed it incorrectly. 

 404 Not Found or File Not Found – Perhaps the most common error message, this indicates 

that the page you requested could not be found by the server, though a site does exist at this 

URL.  Check to make sure the URL is typed correctly.  If it is, find if any pages exist on this site 

by deleting text after each slash working from the right of the URL back.  You will eventually 

find a page, or if the author hasn’t included an index.html page, a list of pages will appear.  It 

may be that the page has either moved or been renamed.   

 408 Request Timeout – Hitting the stop button before the page finishes loading will prompt 

this message.  Request the page from the server again to view it. 

 500 Server Error or Internal Error – The page cannot be loaded because the server is down.  

Try again later. 

 501 Not Implemented – Indicates that something on the page is beyond the ability of the 

server.  This message occurs most often with the use of forms.  You will not be able to view the 

page. 

 502 Server Temporarily Overloaded – Simply means that the server has received more 

requests than it can process.  Try again later. 

 503 Service Unavailable – This message means that the page you want is probably still there, 

but not at the moment.  Wait 30 seconds and try again.  If it still doesn’t work, it could mean 

indicate a problem with your Internet connection. 

 Bad File Request – Most likely due to a form submission that is not supported by your 

browser.  Try updating your browser. 

 Host Unknown or Host Unavailable or Unable to Locate Host – These all mean the same 

thing, the server is down or URL is wrong; the site has moved for example.  Check the domain 

name at www.4domains.com to see if it is still valid. 

 File Contains No Data – If you get this message, the page still exists but is currently empty 

or is currently being updated.  The page may work later, so keep trying.  You may try adding 

:80/ to the end of the URL. 

 Failed DNS Lookup – DNS is the Domain Name System, which translates a URL into an IP 

address.  This error occurs when that translation fails or you entered a wrong URL. Try again 

later. 

 Viewer Not Found or Helper Application Not Found – You are trying to access a file that 

requires a helper program to open.  If you don’t have the correct program, you can save the file 

to your hard drive and open it once you have the helper. 
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 Too Many Connections – Try Again Later – To get around this one, just click on Refresh 

(or Reload) until you’re bumped up in line for access and the page will load. 

 Cookie Not Read – The site is trying to access a cookie on your computer and can’t find it, 

thus you may be unable to access the site.  Be sure your browser is configured to accept cookies. 

 Can’t Parse HTTP – Your browser requires that you include the http:// when entering a 

URL. 

 

Understanding the Internet Questions: 

1.  Why was the DNS system developed?  How does it help people find web pages?  

   

2.  For what purpose are each of the following domain-name suffixes supposed to be used? 

 

.com .edu .gov 

.mil .org .net 

 

   

3.  What does each of the following codes stand for? 

 

.cg .de .hk 

.ie .mx .ve 

 

   

4.  What does each of the following error messages mean, and what should you do if you get them?  

 

404 - Not Found 

 

Failed DNS lookup 

 

5.  Why was the Internet (then called ARPANET) designed?   

 

 

 

6.  What is the most common use of the Internet today?  

  

   

7.  What is the difference between a bookmark list and a history list?  

   

8.  About how many computers access the Internet? 

   

 9.  Before posting a question to a Usenet newsgroup, one should consult what? 

 

10.  What is FTP?  What is it used for? 

 

 

11.  Anonymous FTP allows users to download files without doing what? 
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12.  Is it necessary to download an FTP file in order to view it? 

 

13.  What are the most common ways to access the Internet? 

 

 

14.  What is the difference between an Internet and an intranet?  What is an intranet used for? 

 

15.  What are the main concerns when you maintain an Intranet? 

 

 

16.  Who controls the content of the Internet?                          

 

Is there a central catalog of all Internet content?     E-mail addresses? 

 

What are the advantages and disadvantages of this system?   

 

17.  What is a firewall and what is it used for? 

 

 

18.  What are the main differences between Listservs and Newsgroups? 

 

19.  What are the main steps you should take to protect your home computer from intrusions and 

viruses? 
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Search Engines Explained 

Why use search engines?  There are millions of web pages on the Internet from all over the world.  

Finding information among these ever-changing pages is an enormous task.  Search engines can 

help you find information on the Internet - if you know the right questions to ask . . . 

 

How do search engines work?  They use special software programs known as robots, spiders or 

crawlers.  A robot automatically follows links from one document to the next around the Web.  

When it finds a new site, it sends information back to be indexed.  Robots also update information 

on existing sites.  How updated and accurate the information is depends on the search engine. 

 

How do they decide which pages to list first?  This depends a great deal on the search engine.  In 

the old days, many web browsers used information contained in the META tags - these are tags that 

appear in the HEAD section of an HTML document.  Here is an example of META tags (there are 

many more): 

 

<META NAME="keywords" CONTENT="search, search engines, search engine ratings, search 

engine rankings, search tools, boolean searches, search how-to, search help"> 

<META NAME="description" CONTENT="Why use a search engine?  How do search engines 

work?  How do they decide what rankings to give you?  These questions are addressed in this 

document"> 

 

Keywords are the phrases the author feels a user might type into a search engine.  Description 

appears in the search engine result.  If no description is specified, the search engine will generally 

return the first few lines of the page.  If no keywords are specified, the search engine will generally 

do an index of the page (or part of it) and use words found frequently (excluding words like a, an, 

the, etc.).  The closer the query (the info you type into the search engine) matches the keywords, the 

higher the page is listed.   

 

Most browsers don’t rely only on META tags because webmasters would load them with phrases 

that were popular in searches, but didn’t necessarily relate to the content of the web page.    Most 

search engines today use an algorithm that takes into account link analysis - how pages link to each 

other.  Many search engines also consider the “click-through” factor.  It compares similar searches 

and looks at what pages were actually clicked on from the list and that helps the page’s ranking.   

 

What are the main drawbacks to search engines?  The biggest challenge is finding pages that are 

actually useful to you, while avoiding the tons of unrelated info.  Sometimes you will not be able to 

find enough links that are helpful to you.  This can be due to some problems built into search 

engines: 

 

 Stemming – many search engines don't return hits on keywords which are slightly 

different than the query.  For example, if you type walk, should it return pages with 

walking, walked, or walks? 

 Synonyms – most search engines can't distinguish between words that are different but 

mean the same thing. If you enter stomachache, will you get hits on pages that discuss 

gastrointestinal illness? 

 

Sometimes you will find way too much information (most of it irrelevant).  This has several causes: 
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 Most search engines can't distinguish between homonyms (words that are spelled the same, 

but have different meanings).  If you do a search for "rock", will you get information on 

music?  Geology?  Rock Hudson?  Rock Paper Scissor?  Little Rock, AR?  Schoolhouse 

Rock?  Plymouth Rock? 

 Some sites use intentionally misleading keywords, including words people search for often 

like money, games, or computers, when they are really ads.  For example, you search for 

stress relief and get a travel agency site.  META tag use is declining due to the high number 

of web authors using false and misleading keywords.  If you find this happens often, change 

search engines.  Be certain you use descriptive, and accurate, META tags so search engines 

can find your pages. 

 

Search Techniques 

Being able to play around with the browser is fine and dandy, but completely useless if you can't 

find what you're looking for.  Luckily, there are a few facts about search engines and Web page 

registries that work in your favor to find what you are looking for. 

 

 There are a large number of search engines (AltaVista [altavista.com], Lycos [lycos.com], Excite 

[excite.com], WebCrawler [webcrawler.com], Go [go.com], LookSmart [looksmart.com], 37 

[37.com], Google [google.com], Ask .com [ask.com], MetaCrawler [metacrawler.com], etc., etc., 

etc.). 

 Many search engines use Boolean text to assist in searches.  Here are a few of the Boolean 

operators (for a more complete description, see the Boolean Search Key Words handout): 

 AND - causes only pages with the words on both sides of the AND to be returned 

 OR - causes only pages with the words on either side of the OR to be returned 

 AND NOT (some browsers use NOT, others use NO, still others use NOR) - returns pages 

that include the first word, but not pages that include both words 

 " " (quotes) - causes only pages with the exact text typed between quotes to be returned 

 + (plus) - works similarly to AND 

 - (minus) - works similarly to AND NOT 

 Some search engines only look at the title of a Web page for the search criteria, while others 

will look at only the first 10 to 20 lines of HTML code.  Still others only pay attention to special 

HTML tags called META tags (which allow the Webmaster to specify a string of text that will 

represent the Web page), while others will search every Web page in a Web site (such as 

WebCrawler).  Others look only at how many other pages have linked to a certain page (such as 

Google) assuming that a page with many links to it must be relevant.  How do you know which 

search engine searches in which way?  Sorry, I can't help you there.  Precisely how each search 

engine works is a closely guarded secret, though some secrets are out. 

 Since all search engines work differently, they will each return different results.  Which one is 

best?  That is up to you.  Try using each engine to determine which one you like best. 

 

Boolean Search Key Words 

Do all those quotes and plusses and minuses make about as much sense as counting with a abacus?  

Then here is a decode page to help you sort is out. 
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+  (plus sign) 
 

Use it to mark words that must appear in each Web page.  If there's no plus sign, the word can be 

considered a request, not a requirement (particularly if there is a string of words). 

 +Elvis Presley:  This will require that Elvis appear, but Presley will be a request. 

 

-  (minus sign) 

 

Marks words that cannot appear in any Web page on the results list.  Use this to exclude pages 

containing a particular word. 

 Elvis -Costello:  This will request Elvis, but exclude anything on Elvis Costello. 

 

"  "  (quotation marks) 
 

Indicates exact multiple-word phrases.  Without quotation marks, the search engine may assume that the 

phrase is a list of separate query terms. 

 "Jail House Rock" will return a list of Web pages containing that exact phrase.  In contrast, the 

query: jail house rock (without quotes) returns pages containing the words: jail, house, and rock, not 

necessarily in that order. 

 

AND 
 

Connects two search terms, both of which must appear in each Web page on the results list.  Be sure to 

use capital AND.  Most (but not all) search sites assume this operator by default. 

 chantilly AND lace 

 

OR 
 

Connects two words, at least one of which should  

appear on each Web page returned by the query.  

 

 

This is a good way to connect synonyms or alternate spellings.  Be sure to use capital OR. 

 Ringo OR Starr OR Starkey 

 

NOT 
 

Is used much like the minus sign to exclude words.  For some engines, it must be used with AND or OR.  

Be sure to use capital NOT. 

Ringo AND Starr NOT Beatles 

 

(  )  (parentheses) 
 

With parentheses, Boolean really begins to look like algebra.  Use parentheses to connect grouped terms. 

 Beatles AND(Lennon AND McCartney):  This query should return pages about the Beatles that have 

both Lennon and McCartney mentioned in them. 
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*  (wild card or truncation) 
 

Most search engines will assume automatic truncation and search on the root plus endings.  In AltaVista 

and others, however, the asterisk symbolizes any amount of letters chopped off at the end of the word.  

Read the tips pages at each search engine.   

 The query term Elvi* returns information about Elvis, The Flying Elvi, Elvis's Graceland and Elvira. 

 

For more on Boolean logic, visit http://www.internettutorials.net/boolean.asp  

 

Remember that Boolean logic works differently across all search engines.  You are encouraged to 

visit the search engines tips page to learn more about how that search engine work 

Internet Scavenger Hunt 

 

Answer the following questions by searching the Internet.  For each question, write the answer and 

the URL of the page where you found the answer.  Note:  You may use Wikipedia for no more 

than 6 of your answers. 

 

1. What team was the first champion of the United States Football League? 

2. What was the name of the first Atlantic hurricane in 1990? 

3. What is the phone number for the Houston Public Library’s reference services, where you can 

ask a librarian a question? 

4. McDonald's has restaurants in how many countries? 

5. What was the name of the Beatles’ first album in the United States? 

6. Who is the current NASA administrator? 

7. British soldiers burned the US White House during what war? 

8. What was the exact date of the Gettysburg Address?  What is the last word in the speech? 

9. What was Dr. Seuss' (yes, the children's book author) real name? 

10. Mars has 2 moons, what are their names? 

11. What is the capital of the country of Djibouti? 

12. Who was the man considered to be the father of the video arcade because of a company he 

founded based on a game called Pong? (hint, he was born in 1943)  What was the name of the 

company, and what restaurant franchise did he also start? 

http://www.internettutorials.net/boolean.asp
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13. How many homeruns did Jeff Bagwell hit in 1994? 

14. Pegasus Coffee, a coffeehouse in Washington State, is located on what island? 

15. What is the cost for a 7-year-old to tour the Blue Bell Ice Cream plant in Brenham, Texas? 

16. Name the two sets of sibling actors that worked together in Little House on the Prairie playing 

different roles (not twins playing the same part)? 

17. According to Christopher Robin’s Winnie the Pooh Character guide, what is Eeyore stuffed 

with? 

18. Who directed the movie Star Trek II: The Wrath of Khan? 

19. On what date did the Simpson’s episode “Homer Goes to College” originally air?   

20.  Where did Spencer Tillman play college football? 

21. What year was Acme Brick founded?  

22. Name 3 actresses who played Wonder Woman’s mother during the 1976-1979 TV show:  

23. What is the highest mountain in Africa?  

24. What country administers the Davis Antarctic research station?  

25. Who wrote All Quiet on the Western Front?  

26. Who won the men's Wimbledon championship in 1900?  

27. In what month and year did comet Shoemaker-Levy 9 collide with Jupiter?  

28. Who said, “If I were playing third base and my mother were rounding third with the run that 

was going to beat us, I'd trip her. Oh, I'd pick her up and brush her off and say, ‘Sorry, Mom,’ 

but nobody beats me.” 

29. The mission patch for the second space shuttle flight (STS-2) features a profile of what animal? 

30. Who plays the gorilla Attar in the 2001 movie Planet of the Apes? 
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HTML:  Hyper Text Markup Language 
 
HTML stands for HyperText Markup Language.  It is the language all Web browsers understand.  While it is a 

programming language, it is one of the most basic programming languages, and it is used to tell the browser where and 

how to display all the elements of the Web page.   

 

Why should I learn HTML – I mean, isn’t that what [insert your favorite web editing software] is for? 

 

Believe it or not, no matter how easy it is to use a web editor (like Microsoft Frontpage or Macromedia’s Dreamweaver) 

to create and manage web pages, there are still very compelling reasons to learn HTML. 

 

Understand how browsers work.  If you understand the limitations and quirks of HTML, it will help you plan around 

those quirks when creating your page.  A knowledge of HTML helps you understand that text size is relative, colors 

may appear different on different browsers, font choices must be made carefully, and vertical spacing is very tricky. 

 

Understand how web editors work.  Understanding how the editor creates the page helps you understand how 

elements must be placed together.    

 

Help your web editor.  Occasionally there will be things you want your page to do that you just can’t manage to 

convince your editor to do.  In those cases, it’s nice to know you can switch to the HTML view and type away. 

 

Write better code.  Believe it or not, there are many things people do better than computers, and writing HTML code is 

one of them.  HTML editors are designed to create source code that displays the page elements accurately.  Not 

efficiently.  Not attractively.  Not in a manner that is easy to understand.  Not according to HTML standards as set by 

the W3C (the World Wide Web Consortium that makes recommendations about how code should be structured).  

Source code generated by web editors is generally sloppy, hard to understand, and difficult to edit.  While people are 

certainly capable of writing sloppy code to generate HTML pages, they generally can do much better than even the best 

web editors.   

 

Follow the rules.  Anyone can slap together a web page.  If you want to create good web pages, there are rules you 

must follow.  Web editors don’t know the rules, and don’t care about the rules.  They are only interested in displaying 

the elements of a page accurately (see above).  A web editor will not prompt you to add a title to your page, or alt text to 

your images, or comments for your graphics. 

 

Embrace change.  Browsers are updated often to be able to do all sorts of new and wonderful things; Web page editors 

are updated far less frequently. Knowing HTML (and staying on top of its change and implementation) will allow you 

to code for the latest and greatest and do all the things that editors won't be able to do for anywhere from months to 

years. 

  

Be flexible.  If you want to get a job at a company creating their Web page and all you know how to use is FrontPage 

and all they have on their system is Dreamweaver, what are your chances of beating out the host of other candidates 

who can code in HTML and can open Dreamweaver, go to its HTML section and begin creating? You have a learning 

curve and they do not. Enough said. 

 

Plan to Evolve.  Knowing HTML makes it easier to add more complicated elements to your page.  Scripting, plug-ins, 

all the latest and greatest can be added using HTML.   

 

While most professional web designers do use software to create web pages, having the knowledge and the ability to 

create pages from scratch using HTML will allow you to use those programs more effectively and create better pages.  

Period. 
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Section 1:  Getting the basics 

 

The simplest way to begin to use HTML is to use a text editor, like Notepad  (which comes with the Windows operating 

system)  Mac users can use SimpleText or any other text editor.  You can always use a word processing program, but be 

sure to save your files as text and to follow the naming conventions mentioned below.   

 

Save your pages as filename.htm (not .txt – browsers can only read documents of the form name.htm or name.html and 

even name.html can cause problems for older versions of Netscape).  Never use spaces in the names of Web pages, and 

avoid using any “special” characters (such as %, /, “. etc.).  For example: 

 

Good Bad 

My_file.htm My  file.htm 

Percent.htm %rate.htm 

 

 

Once you have saved your page, you can view it by opening your browser (generally Netscape or Internet Explorer), go 

to File – open page, then browse to the page you saved.  When you are creating a Web page using html, you will 

generally have both notepad and your browser opened at the same time.  Minimize one or the other, or resize the 

windows so you can see both.  As you make changes in Notepad, save and click the “Refresh” or “Reload” button in 

your browser to view the changes. 

 

The HTML commands used to format your page are called tags, and they are contained between the “less-than” sign (<) 

and the “greater-than” sign (>) on your keyboard (such as <HTML> or <B>).  Tags are generally typed in upper case 

letters.  Can the browser still read your tags if you put them in lower case?  Absolutely.  Will it make things much easier 

for you if you put them in all caps?  Absolutely.  In general, your HTML code (or source code) will be a combination of 

HTML tags and regular text.  It is much easier to spot the HTML tags if you put them in all caps – they will stand out 

among the code and make things much easier to read.   

 

Many tags allow you to specify certain attributes that affect how the tag works.  For example, inserting an image?  What 

size?  How should it be aligned?  Do you want a border?  You can control many things by specifying attributes for each 

tag.  The conventions we use when writing a tag including attributes are: 

 

<TAG ATTRIBUTE=”value”>   

 

The tag and the attribute name are capitalized, while the value of the attribute is case sensitive.  If the attribute value is a 

common word like right, left, or square, it is written in lower case.  If the attribute is a proper name like Comic Sans 

MS, or a web site like http://www.webpage.com, you use the case consistent with its proper name.  

 

There are two basic types of tags.  Start/stop tags tell your browser to either start doing something or stop doing it 

(“Make this text bold”  “Stop making this text italicized”).   The main difference between a start tag and a stop tag is 

that stop tags have a / after the first < (so <HTML> is a start tag and </HTML> (read “end HTML”) is a stop tag).   The 

tricky thing to keep in mind is that if you don’t match your start tag with a stop tag, the browser will continue bolding, 

italicizing, or linking until the page is done.   

 

The other type of HTML tags are insert tags.  They are designed to put something onto the page (like a picture, a 

horizontal line, or a text break), then they are done. In general, with insert tags the stop or end tag is optional (It isn’t 

necessary to stop inserting an image – it stops once the image is inserted) and in some cases, the end tag is not 

supported at all.   
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Basic Structure of a Web Page: 
 

The first tag you need to get started is the one that tells the browser to read your document as a web page.  You always 

want to begin your page with the <HTML> tag, and end your page with the </HTML> tag.   

 

HTML documents are divided into two sections, the HEAD and the BODY, which are created using the tags 

<HEAD></HEAD> and <BODY></BODY>.  Certain tags must be contained in the HEAD of the document but most 

tags and text will be in the BODY of the document.   

 

The basic structure of a Web page looks like this:   

 

<HTML> 

    <HEAD> 

 <TITLE>  </TITLE> 

    </HEAD> 

    <BODY> 

 

    (most of the page goes here)  

 

    </BODY> 

</HTML> 

 

Title 

The title is what will appear in the blue bar at the top of the browser (sometimes called the title bar), but will not appear 

on the page itself.    

 

The title must be contained between the <HEAD> and </HEAD> commands.   

 

<TITLE>Web Page</TITLE> 

 

There are 2 reasons why you should always have a title on every page you create.  First, many users often refer to the 

title bar to remind them of where they are (and when the page is minimized in Windows, it is the title that shows at the 

bottom).  Second, when a user bookmarks your page, this is where the browsers gets the bookmark’s descriptive text.  If 

left blank, users will not remember where the bookmark leads (and will probably delete your link).   

Line Breaks 

HTML does not recognize the enter command from the keyboard.  For example, if you type the following and save as 

HTML: 

 

<HTML> 

Mayfair High School 

 

Introductory Information 

 

Mayfair High School is located in Mayfair Independent School District. It is famous for its academics as well 

as its outstanding organizations and athletic programs. 

 

Mayfair High School has an outstanding Webmastering class. 

</HTML> 

 

 

 

 

 

 



37 

It will appear in the browser like this: 

 

Mayfair High School Introductory Information Mayfair High School is located in Fort Bend Independent 

School District. It is famous for its academics as well as its outstanding organizations and athletic programs. 

Mayfair High School has an outstanding Webmastering class. 

 

Not pretty.  If you want to control where your text ends, or if you want to insert blank lines in your document, you must 

specifically tell the browser to end one line and begin another.  There are two types of line breaks: 

   

<P> (Paragraph) tag leaves a blank line (like double-spacing) while  

<BR> (Break) ends the current line, and begins displaying text on the next line.   

 

If you add the following page breaks: 

 

Mayfair High School 

<BR> 

Introductory Information 

<P> 

Mayfair High School is located in Mayfair Independent School District. It is famous for its academics as well 

as its outstanding organizations and athletic programs. 

<P> 

Mayfair High School has an outstanding Webmastering  class. 

 

It will display like this: 

 

Mayfair High School 

Introductory Information 

 

Mayfair High School is located in Mayfair Independent School District. It is famous for its academics as well 

as its outstanding organizations and athletic programs. 

 

Mayfair High School has an outstanding Webmastering class. 

 

<P> is an insert tag, and the </P> is optional.    

 

<BR> is a strictly an insert tag, and there is no end tag supported.  You try to use an </BR>, most browsers will 

interpret it as another <BR>.   

Headings 

To display text of different sizes, use  the heading tags.  The heading tag tells the browser to make the text bold and a 

particular size.  There are six different size headings in HTML.  To add a heading use the tags that indicate the size of 

the heading you want to use.   

 

<H1>  This is a size 1 heading </H1> 
<H2>  This is a size 2 heading </H2> 
<H3>  This is a size 3 heading </H3> 
<H4>  This is a size 4 heading </H4> 
<H5>  This is a size 5 heading </H5> 
<H6>  This is a size 6 heading </H6> 

 

Different browsers will display the headings at slightly different sizes (for example, H1 might look larger on one 

computer than another) but H1 will always be larger than H2, and H2 will always be larger than H3, and so on.  

Headings will always appear on a separate line with a bit of vertical space before and after them.   
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Text Alignment: 

You can center text in one of three ways.  The least preferred method is to use the <CENTER> tag, like this: 

 

<CENTER>MY WEB PAGE </CENTER>  

or 

<CENTER><H1> MY WEB PAGE </H1></CENTER> 

 

Again, this is the least acceptable way to align text.  The <CENTER> tag is one of many HTML tags which is being 

deprecated, meaning its use is discouraged and it may not be supported in future versions of HTML. 

 

A second way to align text is to use the ALIGN attribute as part of your tag.  

 

<H1 ALIGN =”center”> will align the heading in the center of the page.  </H1> 

 

To align regular text, you can use  

 

<P ALIGN=”center”>this is the text </P> 

 

The preferred method* to align text is to use the <DIV> tag with the ALIGN attribute: 

 

<DIV ALIGN=”center”> MY WEB PAGE  </DIV> 

 

The <DIV> command creates “logical divisions,” so in a sense you are telling the browser, “Here is a section, and I 

want you to do something to it,” in this case, center it.  This tag is nice because you can have multiple lines, headings, 

and other stuff between the <DIV> and </DIV> and whatever attributes you specify will apply to all of it.   

 

Some examples (good and bad):   

 

<H3 ALIGN="LEFT">This heading is left justified</H3>  

<BR>  

<H3 ALIGN="CENTER">This heading is centered</H3>  

<BR>  

<DIV ALIGN="RIGHT">This text is right justified </DIV> 

<BR>  

<H2><CENTER>This heading is also centered</CENTER></H3>  

<BR> 

 

 

Will display like this: 

 

This heading is left justified 

 

This heading is centered 

 

This text is right justified 
 

This heading is also centered 
Keep in mind that the <CENTER>, <RIGHT>, and <LEFT> tags are being deprecated.  Their use is strongly 

discouraged. 

 

*there is actually a more preferred way to do this using CSS 
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*Check your understanding:* 

 
1. What are the two types of tags?  How are they different? 

2. What is the first tag in an HTML document? 

3. What is the last tag in an HTML document? 

4. What is the largest heading size? 

5. What is the smallest heading size? 

6. What are the two sections of an HTML document? 

7. What are “attributes” and what role do they play in HTML? 

 

Use the following HTML code to answer the questions below: 

 
<HTML> 

<HEAD> 

<TITLE> Company Profile, Camembert International </TITLE> 

</HEAD> 

<BODY> 

<H1> CAMEMBERT INTERNATIONAL</H1> 

<DIV ALIGN=”CENTER”>"Many’s the night I dreamed of cheese – toasted, mostly." Robert Louis Stevenson 

<P> 

</DIV> 

<H2> What We Do </H2> 

We make cheese. Lots of cheese; more than eight tons of cheese a year. Your Brie, your Gouda, your Havarti, we 

make it all. 

<H2>Why We Do It</H2> 

<P> We are paid an awful lot of money by people who like cheese. So we make more. Cheese is not just for mice 

anymore, you know. These days everybody is getting into cheese. On sandwiches, salads, with meat, or alone. It’s 

the perfect complement to an appetite. So remember. <P><P> 

<H3>Say cheese!</H3> 

</BODY> 

</HTML>  

 

8. Where will the phrase "Company Profile, Camembert International" appear? 

 

  

9. What affect will the <h1> tag have on the phrase "CAMEMBERT INTERNATIONAL"? 

 

  

10. How will the quote from Stevenson be displayed? 

 

 

  

11. What text (if any) will appear in bold type? (be careful) 

 

 

  

12. Which will display larger on the screen: “Why We Do It” or “Say Cheese!”? 
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Section 2:  Colors, Lines, and Lists 

Changing the Color of Your Background: 

To change the background color of your page (the default is usually gray or white), you need to add something to the 

BODY tag.  Special commands used with other tags are called attributes.  To change the background color, add the 

BGCOLOR attribute to your BODY tag: 

 

<BODY BGCOLOR="yellow">   

Changing the color of your text 

To change the color of your text, you will add the TEXT attribute to the body tag.  For example: 

 

<BODY BGCOLOR="yellow" TEXT="black">   

 

When you want to specify a color in HTML, you can either use color names or you can use a hexadecimal code.  

 

Internet Explorer 5.0 and above will recognize color names including white, black, yellow, green, blue, navy, gray, 

olive, violet, red, maroon, turquoise, brown, and orange.  Feel free to try some others.  You can actually use some 

regular English words as color names and the browser will try to translate them into a color for you.  It is not 

recommended that you ever do this in an actual page, but it is fun to see what color your name would be.   

 

 A hex code has 6 characters like:  FF23AB.  Each character is a number:  0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A (which is really 

10), B (which is really 11), C (which is really 12), D (which is really 13), E (which is really 14), or F (which is – you 

guessed it – 15).  It is called hexadecimal because each character can have one of 16 values (0 to F).  In the example 

FF23AB, the first two characters (FF) specify how much red will be in the color.  The second two characters (23) 

specify how much green, and the third two (AB) specify how much blue.  Hex codes read from a low of 00 (none of the 

color) to a high of FF (100% of that color).  In general, you put a # before the hex code and enclose it in quotes.  Black 

is “#000000” and white is “#FFFFFF”.  Using these codes, you can specify 224 (16,777,216) different colors.    

 

In general, it is safer to use the hexadecimal codes, as they will be more consistent from browser to browser.   

Some general colors and their hex codes: 

 

Red =           FF0000 Green =         00FF00 Blue =      0000FF 

Yellow =       FFFF00 Fuchsia =      FF00FF Maroon = 800000 

Turquoise = 00FFFF Gray =           808080 Olive =     808000 

Orange =      FF9900 Brown =         996633 Teal =      008080 

Navy =          000080 Med Green = 009900 Pink =      FF99CC 

 

Be sure to select background/text combinations that are easy to read (and print out). 

Horizontal Rule: 

To add a horizontal line (also called a horizontal rule) to your document, use the tag: <HR>.  <HR> is an insert tag, so 

the closing tag is not needed. 

 To change width, use <HR WIDTH=50%> or whatever % you wish to cover  

 By default, the HR will be centered.  To have HR not centered, use the ALIGN attribute <HR ALIGN=LEFT> 

or <HR ALIGN = RIGHT>  

 Make the line thicker by adding the SIZE attribute:  <HR SIZE = 5>  

Some versions of IE will allow you to change the color of the HR using the COLOR attribute                

<HR COLOR=”red”> 
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Creating Lists 

There are three main types of lists used in HTML:  Unordered (or bulleted) lists, Ordered (or numbered) lists, and 

Definition (or Directory) Lists. 

 

Unordered and Ordered Lists use two tags, the <UL> or <OL> tag which begins the list, and the <LI> tag which is used 

to begin each item in the list (list item).    

An example of an unordered list: 

 

Highlights from our School 

<UL> 

<LI>Student Council 

<LI>Football Program 

<LI>Math Department 

</UL> 

 

Will display like this: 

 

Highlights from our School 

 

 Student Council 

 Football Program 

 Math Department 

 

Notice the title of the list (“Highlights from our School”) goes before the <UL> tag. 

 

By default, unordered lists use a disc for each item and ordered lists use numbers.  You can change the appearance of 

either by including the TYPE attribute, for example: 

 

<UL TYPE=”CIRCLE”> 

<LI>Item one 

<LI> Item two 

</UL> 

 

An ordered list is created like this: 

 

This is my schedule 

<OL> 

<LI> First period: 

<LI> Second Period: 

<LI> Third period: 

<LI> Fourth period: 

<LI> Fifth period: 

<LI> Sixth period: 

</OL> 

 

And displays like this: 

 

This is my schedule 

 

1. First period: 

2. Second Period: 

3. Third period: 

4. Fourth period: 

5. Fifth period: 

6. Sixth period: 

 

This code will create an unordered list using a circle or hollow bullet for each item.  You can also use 

TYPE=”SQUARE” to use squares (like checkboxes) for each bullet.   
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Ordered lists can use several different types: 

 

 TYPE=”1” (the default) labels each item with numbers (1, 2, 3) 

 TYPE=”A” uses capital letters (A, B, C) 

 TYPE=”a” uses lowercase letters (a, b, c, and so on) 

 TYPE=”I” uses capital roman numerals (I, II, III, and so on) 

 TYPE=”i” uses lowercase roman numerals (i, ii, iii, iv, and so on) 

 

If you want your ordered list to start at a number other than 1 (or A or I) then you may include the START attribute. 

 

<OL TYPE=”1” START="3"> 

<LI>Item three 

<LI>Item four 

</OL> 
 

Definition lists are a little different.  They consist of a term, followed by an indented definition.  They use three tags: 

<DL> is used to begin the list, then <DT> begins the definition term, then <DD> begins the definition . . . er . . . 

definition (sounds redundant, but it’s a good way to remember).   

 

Here is an example of a definition list: 

 

We offer many exciting classes in many wonderful departments 

<DL> 

<DT>Math Classes 

<DD>Algebra <DD>Geometry <DD> Algebra II  

<DT>Science Classes 

<DD>Physical Science<DD>Biology  

</DL> 

 

Which will display like this: 

 

We offer many exciting classes in many wonderful departments 

 

Math Classes 

     Algebra  

     Geometry  

     Algebra II  

Science Classes 

     Physical Science 

     Biology 

  

You can also nest lists within lists.  Look at the following: 

  

You Will Need the Following Steps to become a Cheerleader 

<BR>  

<OL>  

<LI>Attend a mandatory meeting with your parents  

<LI>Get your progress report signed for every subject  

<LI>Perform a cheerleading routine  

<UL>  

 <LI>In front of the judges  

 <LI>In front of your fellow students  

</UL>  

<LI>Attend a cheerleading camp  

</OL>  

 

Which will display like this: 

 



43 

You Will Need the Following Steps to become a Cheerleader 

 

1. Attend a mandatory meeting with your parents  

2. Get your progress report signed for every subject  

3. Perform a cheerleading routine  

 

 In front of the judges  

 In front of your fellow students  

 

4. Attend a cheerleading camp  

 

If you nest lists, you can use a different TYPE for each level you create. 

 

 

*Check your understanding:* 

 
1. What does RGB stand for? 

2. What color is “#000000”? 

3. What color is “#FFFFFF”? 

4. What color is “#FF0000”? 

5. What color is “#00FF00”? 

6. What color is “#0000FF”? 

7. How many BODY tags can you have in an HTML document? 

8. To make an <HR> wider, what attribute should be set?    What if you want to make it thicker? 

9. Is it better to use color names or hexadecimal codes? 

10. What are the 3 types of lists?  How do they differ? 

11. What is the default type for an UL?  What other values can TYPE have in an UL? 

12. What is the default type for an OL?  What other values can TYPE have in an OL? 

Create an HTML document that displays the following in green text with a gray background.  You may substitute 

your own favorites if you wish: 

 

 

These are my favorite things 

 
My favorite foods are 

 

1. Pizza 

2. Cheeseburgers 

3. Grilled Chicken 

 

My favorite animals are 

 

o Cats 

o Dogs 

o Parakeets 

 

Why did the chicken cross the road? 

    To get to the other side 

 

What do you get when you pour boiling water down a rabbit hole? 

     Hot cross bunnies 
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Section 3:  Character Formatting 

There are several tags that can be used to format the text in an html document: 

 

This creates <I> italics </I> 

 

This creates<B> bold text</B> 

 

This creates <SUB>  subscript</SUB> 

 

This creates <SUP> superscript</SUP> 

 

This tag <U> underlines text</U> 

 

This creates <STRONG> strong text, usually bold </STRONG> 

 

This creates text with <EM> emphasis, usually italics </EM> 

 

<SMALL>This tag makes your text smaller</SMALL> 

 

<BIG>This tag makes your text bigger</BIG> 

 

This creates text with a <STRIKE> strikethrough effect </STRIKE> 

 

So does <S>this </S> 

 
<BLOCKQUOTE>Blockquote is nifty because it takes your text and indents it on both sides so it stands 

out in the document like a quoted section of text might.  </BLOCKQUOTE> 

 

Pre: 

One of the disadvantages of HTML is that it can be difficult to format the spacing of text.  If you type a table like this: 

 

<HTML> 

 

MONTH       January      February      March     April  

=====================================================   

Bob            12,114            16,034            23,778            42,524    

Jack          12,436  13,207  18,051            65,951    

Linda              14,539            13,428            24,689            57,133    

Mary               12,548            14,250            22,326            56,958    

 

</HTML> 

 

And display it in a browser, you will get this: 

 

MONTH January February March April 

===================================================== Bob 12,114 

16,034 23,778 42,524 Jack 12,436 13,207 18,051 65,951 Linda 14,539 13,428 24,689 

57,133 Mary 12,548 14,250 22,326 56,958 

 

Notice that none of the spacing was maintained.  There is a tag in HTML called the <PRE> tag (PREviously formatted 

text) which can be used to maintain spacing.  Add the tag <PRE> before the text, and </PRE> after it, save and open in 

a browser, and the display will look exactly like the source code. 
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The disadvantage of using the <pre> tag is that all text is displayed in the courier font.  The reason is that courier is a 

non-proportional font.  In most fonts, certain letters (like w or m) are allocated more space than narrower characters 

(like i or l or !).  Note the difference: 

 
By using a non-proportional font, the browser can maintain the nice spacing of the table.  The drawback is that 

proportional fonts just look better (that’s why most fonts are proportional).  Because of it’s overall appearance flaws, 

the <PRE> tag is limited in its usefulness.   

 

Changing Fonts: 

Beginning with Netscape 3.0 and Internet Explorer 3.0, you have the ability to format specific parts of a document using 

the <FONT> … </FONT> commands.  You can specify which font you want the text to appear in (called the FACE), 

size (called the SIZE), and color (called the COLOR) for a specific section of text (or the entire document if you 

choose).    

 

Font Size: 

 

In general: 

 Size 1 = 8 points  

 Size 2 = 10 points  

 Size 3 = 12 points (this is the default size used by most browsers) 

 Size 4 = 14 points  

 Size 5 = 18 points  

 Size 6 = 24 points  

 Size 7 = 36 points  

These are just guidelines.  The actual size of the font will vary depending on the users’ browser setting and screen 

resolution.   

Font face: 

 
You can use the FACE attribute to specify which font you would like your text to appear in.  Remember that the name 

of the font is case-sensitive. 

 

<FONT FACE=”Arial”> 

 

Be careful whenever using unusual fonts - if the user does not have the font installed the browser will substitute another 

one with possibly unpredictable results.   Whenever you specify a font face, it is a good idea to specify alternate font 

choices.  For example: 

 

<FONT FACE="Verdana,Helvetica,Courier" SIZE="3">Alternate fonts</FONT> 

 

In this example, the html requests Verdana (a nice PC font).  If the machine does not have Verdana, the next choice is 

Helvetica (a popular Mac font).  If neither font is on that machine, then Courier will be used (both Mac and PC).  If 

Courier is not on the machine (highly unlikely), the default font should be used (you can never predict with certainty 

what the browser will do – that is why the FACE attribute should be used with caution).  In general, if you try to insert a 

font which the user does not have, Times New Roman will be used instead. 

 

Font Colors: 

 
You can use the COLOR attribute to specify the color of the text. 
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<FONT COLOR=”red”> will change your font color to red. 

 

Combine all three attributes to control all aspects of your font: 

 

<FONT FACE="COURIER" SIZE="3" COLOR=”black”>Courier New 12 Points</FONT>  

 

<FONT FACE="TIMES NEW ROMAN" SIZE="5" COLOR=”#000000”>Times New Roman 18 Points</FONT>  

 

<FONT FACE="ARIAL" SIZE="7" COLOR=”#FFFF00”>Arial 36 Points</FONT> 

 

 

 *Check your understanding:* 

 
1. What does the <strong> tag do?  How is it different from the <b>? 

2. What does the <em> tag do?  How is it different from the <i>? 

3. When specifying the FACE attribute, what are some things you should keep in mind? 

4.     Add the needed HTML tags to the text below so it will match the desired output (shown on the next page): 

 

 

Web Page Class 

 

The Best of Austin High School 

 

Purpose 

 

The purpose of this class is to learn to design and produce pages for the World Wide Web. 

  

Objectives 

 

The objectives for this class include 

 

Discussing issues related to technology 

 

Designing the Austin High School web site 

 

Publishing the Austin High school web site 

 

Why We Do It 

 

Because we are a select group of hard working, knowledgeable students with the creativity and dedication to 

do a good job. 

 

We also want to earn A’s. 
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Desired Output: 

 

 

Web Page Class 
 

The Best of Austin High School 
 

Purpose 

 
The purpose of this class is to learn to design and produce pages for the World Wide Web. 

 

Objectives 
 
The objectives for this class include  

 

 Discussing issues related to technology 

 Designing the Austin High School web site 

 Publishing the Austin High school web site 

 

Why We Do It 
 

Because we are a select group of hard working, knowledgeable students with the creativity and dedication to do 

a good job. 

 

We also want to earn A’s. 
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HTML Assignment 1 

You will create a web page about the person sitting to your left (see your instructor if there is no 

one to your left).  You will be using all the HTML commands we have learned to this point. Both 

your web page and your source code will be graded. Name your document first.htm. Your source 

code should be a Notepad document. No graphics of any sort should appear on your page. You 

should correctly use all of the following:  

 

 

 Title  

 Headings (at least 3 different sizes)  

 Text and background color  

 All three types of lists  

 Horizontal rule  

 Interesting and informative text  

 

You should choose colors based on the preferences of the person you are interviewing.   

 

Your grade will be based on how well you:  

 

 Created a site which is a attractive, informative, and well-organized  

 Used all appropriate elements and no inappropriate elements  

 Followed directions  

 Presented the page adequately to the rest of the class 

  

 

Good Luck! 
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Section 4:  Images 

Graphics are a powerful tool to use with html pages, but as with all tools, they must be used carefully.   At this time, 

there are two graphic formats which are commonly used in Web browsers:  GIFs (Graphic Interchange Format)  and 

JPEGs (Joint Photographic Experts Group).   

GIF’s vs. JPEG’s: What difference does it make, really? 

There are several differences between the GIF and JPEG (or JPG) file formats that might influence which you choose 

when saving a file. 

 Joint Photographic Experts Group (JPEG) 

 Lots of colors (24 bit = 16.7 million colors)  

 Images are compressed  

 Some data is lost to compression  

 Less detailed pictures  

 Best for photographs or paintings  

 Best for graphics with shading, lots of colors  

  

Graphics Interchange Format (GIF’s) 

 Fewer colors (8 bit = 256 colors)  

 Colors are excellent, but fewer colors available  

 Images are not compressed as much a jpegs can be  

 Less image degradation  

 Larger than JPEG’s, slower transfer (in general - although they can be very small if you don't use many colors)  

 Best for line art, logos, screen captures  

 Best for images with solid colors, little shading, not a large variety of colors  

 Only GIF’s can have a transparent color, animation  

  

When creating original graphics, using the appropriate file format will improve the quality of your final image. 

To do the following activities, you will need to acquire several images.  For the examples shown, the following images 

were used: 

   

TEDDY.GIF SWAN.GIF SOCCER.GIF 
 

To save a graphic from the Internet 

 
When you find a page with a graphic you want to use, right-click on the graphic and choose “Save Picture As . . .”.  Be 

sure to save graphics on your h: drive, and they must be in the same folder as the page you want them to appear on. 

 

To insert an image into an html document 

To insert an image in HTML, you use the <IMG> (IMaGe) tag (the image tag is an insert tag and does not require an 

end tag).   You must specify the SRC (SouRCe) attribute for the image you are using.  Type the following into notepad, 

save as images.htm and open in your browser:  (you can substitute any image for TEDDY.GIF): 
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<HTML>  

<HEAD>  

</HEAD>  

<BODY>  

<H2>Here is a single image:  </H2>  

<IMG SRC="TEDDY.GIF">  

</BODY>  

</HTML> 

  
 

 

The name of the graphic is case sensitive, so it matters whether your image is called “Happy.gif” or “happy.gif.”   

 

 

To insert multiple images in HTML, repeat the command: 

 

<HTML>  

<HEAD>  

</HEAD>  

<BODY>  

<H2>Here are multiple images</H2>  

<IMG SRC="TEDDY.GIF">  

<IMG SRC="TEDDY.GIF">  

<IMG SRC="TEDDY.GIF">  

<IMG SRC="TEDDY.GIF">  

<BR>  

<IMG SRC="SOCCER.GIF">  

<IMG SRC="SOCCER.GIF">  

<IMG SRC="SOCCER.GIF">  

<IMG SRC="SOCCER.GIF">  

 

</BODY>  

</HTML>  

 

 

 

Notice the browser will continue to place images side by side until it runs out of room, then it will drop to the next line 

(if your images don’t wrap to the next line, try resizing your browser window to see what happens).  Inserting a <BR> 

forces the browser to drop to the next line. 

 

Adjusting the Height and Width of Images 

 Whenever you insert images into a Web page, you should always specify the height and width attributes: 

 

<HTML>  

<H2>Here is a teddy bear which is 180 pixels x 180 pixels:  </H2>  

<IMG SRC="TEDDY.GIF" HEIGHT=180 WIDTH=180>  

</HTML> 

 

Any graphics program should be able to tell you the size of an image.  It is important to specify the height and width of 

a graphic in html because it aids in downloading the page.  Graphics generally take the longest time to download.  When 

the browser encounters a graphic, it will sit and wait for the graphic to download.  If you specify the size of the graphic, 

the browser will leave a space for the graphic, and continue to download the text.  This gives the illusion the page 

downloads more quickly. 

An important note:  if you want to change the size of the image (especially if you want to make it smaller) do not just 

change the height and width in the <IMG> tag!  This will cause the image to display smaller, but the size of the image 

file won’t change, and you will be slowing the download time unnecessarily (and often the quality of the image will 



51 

suffer as well).  If you want a smaller image, use a graphics program to change the size of the original image to the size 

you want, then display it in your page accurately. 

ALT: 

Another attribute that should always be included in an image tag is the ALT (short for ALTernate) attribute.  The ALT 

attribute will be a short text phrase: 

 

<HTML>  

<IMG SRC="TEDDY.GIF" HEIGHT=180 

WIDTH=180 ALT=”This is a picture of a 

Teddy Bear”>  

</HTML> 

 

 
 

 

The ALT text will appear in the blank space as the graphic is loading, and will also “pop up” when the user holds the 

mouse pointer over the image (try it).  Including an ALT is useful if someone is browsing without images or using a text 

reader on the page (due to a visual impairment).  It can also clue someone in as to what to expect while they wait for the 

image to load.  Additionally, it will appear if the image fails to load for some reason. 

Comments: 

<!-- This is a comment, which is ignored by the browser. -->  

 

Comments display in the source of the HTML document, but not on the page itself.  Comments are very useful for 

documenting the source of graphics, or including other information you may want to refer back to later. 

  

Documenting graphics: 

You should use comment tags to specify the source of any graphics that appear on your page (even if the graphics are 

original – think of it as giving yourself credit).   

<HTML>  

<IMG SRC="TEDDY.GIF" HEIGHT=180 WIDTH=180 ALT=”This is a picture of a Teddy Bear”>  

<!-- This image is from the html guide notes --> 

</HTML> 

 

You should always document the source of your graphics.   

 

Lowsrc 
 

If you are determined to use large, high-quality graphics on your page, you may wish to make use of the LOWSRC 

attribute.  LOWSRC allows you to create an additional image (ideally one that is the same physical size, but much 

smaller file size) which will load first, and is then replaced by your ideal image.  The LOWSRC graphic may have 

fewer colors, or be of a lower quality than the final image, but it will give your users something to look at while they 

wait for the larger file to download. 

 

<IMG SRC=”hugefile.jpg” LOWSRC=”smallfile.jpg”>  

To align images: 

You can use the ALIGN attribute to position your images.  Copy the following into notepad, save, and open in your 

browser: 
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<HTML>  

<H2>I CAN ALIGN IMAGES</H2>  

 

<DIV ALIGN="left"> 

<IMG SRC="TEDDY.GIF"> 

</DIV> 

 

<DIV ALIGN="center"> 

<IMG SRC="SWAN.GIF">  

</DIV> 

 

<DIV ALIGN="right"> 

<IMG SRC="SOCCER.GIF"> 

</DIV> 

 

</HTML> 

 
 

 

There are many other values you can use to align images relative to the text around it.  Besides left, center, and right, 

you can use ALIGN= . . . 

 

o top 

o middle 

o center 

o bottom 

o abstop (absolute top) 
o absmiddle 
o absbottom 
 

You are welcome to explore how each of these values affects the placement of the image relative to the text.  

Ultimately, however, it is much better to use tables when you plan to use images and text side-by-side, and we will 

cover that shortly. 

 

*Check your understanding:* 

 
1. What are the two image types supported by most browsers? 

2. Why is it important to specify the HEIGHT and WIDTH attributes of an image? 

3. Should you use the HEIGHT and WIDTH attributes to resize an image?         Why? 

4. Where does the ALT text appear? 

5. Why is it important to use ALT text? 

6. Where does the text in a comment tag appear? 

7. For what purpose should you use a comment tag? 
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HTML Exercise – Paleontology Page 

Open Notepad and create the HTML code that will display the following page in a browser.  You are free to use your 

notes, but do not use other students in the class.  Use the information in the formatting instruction boxes to guide you as 

you type the code (the boxes should not display in the browser).  Your page displayed in a browser may not look 

exactly like the page below.   

 
For items where no formatting instructions are given, use the default.  Do not forget to include the ALT attribute and to 

comment the source of your graphic.  The title of your page is ‘Paleontology’.  Save the file as Exercise1.htm. 

 

 

 
 

 

PALEONTOLOGY 
 

Paleontology is the study of fossils.  A fossil is any trace of a past life form.  Although wood, bones, and shells are the 

most common types of fossils, under certain conditions soft tissue, tracks, and trails can be preserved as fossils. 

 
Paleontology is divided into several different fields: 

 

1. Paleobotany 

2. Paleoanthropology 

3. Taphonomy 

4. Ichnology 

5. Paleoecology 

 
There are many explanations for why dinosaurs disappeared (asteroid, lack of H2O, volcano), and 

paleontologists devote their lives to studying the fossil records to help determine what happened. 

 

 

 
 
Originally, dinosaurs were thought to be reptiles.  The general belief now is that they were early ancestors of birds.  

More information on dinosaurs is available at many sites on the Web. 

Heading size 2, centered and 

underlined 
Bold Italics 

Font style: Bookman Old Style 

Font size: 5 

Font color: Blue 

Horizontal rule 

Page background color: Silver Text color (unless noted otherwise): Black 

  

       

Ordered 

List 

You may use any dinosaur 

graphic here. 
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Section 5:  Hyperlinks 

Adding Hyperlinks :  Linking to External Sites (Absolute links): 

To add a hyperlink to your document, use the <A HREF =”  “>…</A> tags.   The “A” stands for anchor, and the HREF 

(Hypertext REFerence) specifies the location of the file you are linking to.   Whatever text appears between the <A 

HREF=”  “> and the </A> will become the link within your document. 

 

To create external links within your document, add the following to your page (remember, URLs must be exact and 

must include the ‘http://’): 

 

<H3>Check out these related sites</H3> 

<UL> 

<LI><A HREF= "http://www.fortbend.k12.tx.us" >The Fort Bend Web Page</A> 

<LI><A HREF="http://www.tenet.edu ">TENET</A> 

</UL> 

(Notice you can include links within a list) 

 

This type of link is called an absolute link because you are giving the absolute address (URL) of the page to which you 

want to link. 

 

Linking to another file on the same computer (relative links): 

 

To link from one file to another within the same folder, you specify the name of the file within the href=”… “.   

For example:   

 

<A HREF=”mydoc.htm”>Click here to link to mydoc.htm</A>   

 

Will create a link to the page called mydoc.htm that is in the same folder as the current document.  You can also link to 

other documents on the same computer in other folders using the dos directory structure.  For example, <A 

HREF=”../mydoc.htm> links to the page mydoc.htm contained in a folder one level up from the current folder. 

 

 

This type of link is called a relative link, because although you don’t know the URL of the page, you know where it is 

in relation to the current page. 

 

Linking to another part of your page (Target links) 

 

If your page is particularly long (and carefully consider whether it would be better to break it into smaller sections), you 

may want to link from one part of a document to another part of the document, or to a specific part of another document.  

To do this, you must first create an anchor, then link to that anchor.   

 

To create the anchor, you use the <A NAME=”   “>... </A> command.  For example: 

 

<A NAME=”part3”>This is section 3 of this document </A> 

 

The text between the <A NAME> and the </A> won’t look any different when displayed, but this is the text we will 

link to.  To link to this section of the document, use the <A HREF = “… “> command with a little twist: 

 

<A HREF=”#part3”>Click here to skip to part 3</A> 
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The pound sign (#) tells the browser it is looking for a section within a document.  You can link to sections of other 

documents by combining a standard link with a target link.  Let’s say the document above is named doc1.htm.  To link 

to part 3 of the document from another page, you will use the tag: 

 

<A HREF=”doc.htm#part3”>Click here to link to section 3 of document 1 </A>. 

 

Keep in mind; you must name an anchor first before you can link to it.  Do not use any spaces in the name of the 

anchor, just as you would not use spaces in the name of an html page. 

 

Using a graphic as a link 

You can use a graphic as a hyperlink.  To do this, you use the same tags you used to create a text hyperlink, but instead 

of putting text between the <A HREF=” “> and the </A>, you put the <IMG SRC> tag.   

 

<A HREF=”http://www.houstonzoo.org”><IMG SRC=”TIGER.JPG” BORDER=0></A> 

 

Text links are underlined in blue (or another color if you use the LINK attribute of the BODY tag) to indicate they are 

links, and graphics are created with a blue border to indicate that they are links.  This is very unprofessional looking, so 

to get rid of the blue border, use the BORDER attribute to set the image border to 0. 

 

Hyperlinks:  Linking to an E-mail address 

 

To link to an e-mail address use the following tag:  <A HREF=”mailto:username@wherever.com”> . . . . </A> 

 

For example: 

 

<A HREF=”mailto:homer@simpsons.com”>E-mail Homer </A> 

 

 

*Check your understanding:* 

 
1. What does the A in <A HREF> stand for?  What does the HREF stand for? 

2. When is it necessary to include the http:// as part of the link? 

3. When creating target links, what is A NAME used for? 

4. What does the # indicate as part of a hyperlink? 

5. How is an e-mail link similar to a hyperlink? 

6. What is the difference between absolute links and relative links? 
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Hyperlink assignment: 
 

Create a page similar to the following (you may use your own favorites in place of the examples 

shown):   

 

 
 

Favorites Page 
 

My favorite: 

 Sports Teams 

 Bands/Music 

 Foods 

 Vacation Sites 

 
Click the word above to go to the section 

 

 

 

 

Sports Teams 

 Houston Astros 

 Houston Texans 

 Houston Rockets 

 
[add ~5 blank lines here] 

 

Bands/Music 

 Duran Duran 

 Maroon 5 

 
[add ~5 blank lines here] 
 

Foods 

 Cheeseburgers 

 Pizza 

 Potatoes 

 
[add ~5 blank lines here] 

 

Vacation Sites 

 Disney World 

 Hawaii 

 Grand Canyon 

 

 
[add ~40 blank lines here] 

Note: 

 

The words at the top need to 

link to the appropriate list 

further down the page (for 

example, “Sports Teams” in 

the My Favorite list should 

link to the second list titled 

“Sports Teams”).   

 

Each item in the lists below 

the horizontal line should link 

to an external link related to 

that topic.  For example, 

Houston Astros could link to 

the main Astros page.  Pizza 

could link to your favorite 

pizza delivery company. 

 

Where it says [add ~20 blank 

lines here], use HTML code to 

add about 20 blank lines in 

that space.   
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Section 6:  Color Controls and Background Images   

Changing the color of your hyperlinks 

 

In general, unvisited hyperlinks are blue, and visited hyperlinks are red (or purple depending on the browser).  

Depending on what color you select for your page background, you may want to change the color of your hyperlinks.  

To do this, you will add more attributes to the <BODY > tag.   

 

<BODY BGCOLOR = “yellow” TEXT= ”black” LINK=”green” VLINK=”orange” ALINK=”white”> 

 

This tag sets the link color for unvisited links to green and visited links to orange.  ALINK changes the color of the 

“active” link (the link color once the user clicks on it or otherwise selects it).  As a joke, some people set the active link 

color to the same color as the background, so when the user clicks on the link, it appears to vanish.  This is strongly 

frowned upon . . . but amusing. 

Using an Image as a Background: 

You can use an image as the background of your page.  Be very wary of using this technique as it will increase your 

download time (generally) and might make your text extremely difficult to read.  Browsers will also tile your image to 

fit both horizontally and vertically on the background, so choose an image that can be repeated and still look OK. 

To use an image as a background, you need to add the BACKGROUND attribute to the <BODY> tag. 

 

<BODY BGCOLOR=”GREEN” BACKGROUND=”IMAGE.JPG” TEXT=”BROWN”> 

 

Notice you can use both a BGCOLOR and a BACKGROUND attribute at the same time.  Generally, the BGCOLOR 

will display until the image loads and fills the background.  This is helpful if the text color won’t show up well against a 

white or gray background, and often makes the background seem less abrupt when it appears (and it will usually appear 

after the text for the page has loaded. 

Controlling the Background Image 

There are a few things you can control when you use a background image. 

 

To create a watermark (where the background picture does not scroll as page scrolls – as if the text is floating above the 

background), use the BGPROPERTIES attribute in the BODY tag. 

 

<BODY BGCOLOR=”GREEN” BACKGROUND=”IMAGE.JPG” BGPROPERTIES=FIXED> 

 

To control how the background image tiles (or repeats), you can use the STYLE attribute in the BODY tag. 

 

To set the background image to appear once, positioned in the upper-left corner of the page use: 

<BODY BGCOLOR=”GREEN” BACKGROUND=”IMAGE.JPG” STYLE=”background-repeat: no-repeat”> 

 

To set the background image to tile (or repeat) across the top: 

<BODY BGCOLOR=”BLUE” BACKGROUND=”IMAGE.JPG” STYLE=”background-repeat: repeat-x”> 

 

To set the background image to tile (or repeat) down the left side: 

<BODY BGCOLOR=”BLUE” BACKGROUND=”IMAGE.JPG” STYLE=”background-repeat: repeat-y”> 

 

*Check your understanding:* 

 
1. What are the three link color attributes you can set? 
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2. Is it a good idea to use a BGCOLOR if you are using a background image? 

3. What is the default position of the background image? 

4. If you set the BGPROPERTIES to “fixed,” what happens to the background image?  

  

HTML Assignment 2 

You will create a personal web site using all the HTML commands we have learned to this point. 

Your site should consist of three pages. There should be links between the three pages and at least 

one external link. Your source code should be a Notepad document.    

You should correctly use all of the following:  

 Title (every page) 

 Headings  

 Text color  

 All three types of lists  

 Horizontal rule  

 External links  

 Interesting and informative text  

 Links between the three pages  

 Images  

 Each page should have either a background image or background color (you must have at 

least one background image) 

 At least one graphic which serves as a link  

 At least two different font sizes and at least two different font faces 

 Your grade will be based on whether you:  

o Created a site which is attractive, informative, and well-organized  

o Used all required elements and no additional elements (which we have not learned)  

o Followed directions  

All graphics should include the ALT, HEIGHT and WIDTH attributes and a comment indicating 

the source of the graphics. 
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Section 7:  Tables 

Tables in HTML allow you to arrange text, images and other HTML content into rows and columns with or without 

borders. 

Creating Basic Tables 

Before coding your table, sketch out the table, include headings, data, caption, alignments, borders, and cell colors.  

Basic tables are fairly easy to code in HTML but more advanced tables are easier to create in an HTML editor. 

Table Parts  

 Caption – tells you what the table is about 

 Table Headings – labels the row and column 

 Table Data – values in the table 

 Table Cells – individual squares in the table, contains table data or headings 

The <TABLE> Tag 

To create a table, you use the <TABLE> … </TABLE> tags. 

 

The most common attribute of the TABLE tag is the BORDER. 

 

<TABLE BORDER=2> 

 

You use the BORDER attribute to control the size of the border around your table.  If you set the BORDER=0, the 

border will be invisible.  You may want an invisible border if you are using the table to control your page layout. 

Rows and Cells 

Within the TABLE tag you include tags for each individual row. Within the row you include tags for each individual 

cell.  Columns are calculated by how many cells are in each row. 

 
To create each row: 

<TR> … </TR> tag is used for each row in a table.  

To create each cell (within a row)  

<TH> … </TH> tag is used for a table heading, and the  

<TD> … </TD> is used for table data, for each cell in a row.   

For example: 

 

<TABLE BORDER=1> 

<TR> 

<TH>Row 1</TH> 

<TD>Cell 1 </TD> 

<TD>Cell 2 </TD> 

<TD>Cell 3 </TD> 

</TR> 

</TABLE> 

 

 

Looks like this: 
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This table has only one row (created by the one <TR> command) and four cells (created by the one <TH> plus the three 

<TD>). 

 

To create a table with headings across the top: 

 

<TABLE BORDER=2> 

<TR> 

<TH>Student Name</TH> 

<TH>GPA</TH> 

</TR> 

<TR> 

<TD>Bulldogs, Austin</TD> 

<TD>5.0</TD> 

</TR> 

<TR> 

<TD>Rangers, Terry</TD> 

<TD>2.5</TD> 

</TR> 

<TR> 

<TD>Longhorns, Texas</TD> 

<TD>0.0</TD> 

</TR> 

</TABLE> 

 

 
 

To create a table with headings on the side: 

 

<TABLE BORDER = “2”> 

<TR> 

<TH>Student Name</TH> 

<TD>Shmoe, Joe</TD> 

<TD>Astros, Houston</TD> 

<TD>Longhorns, Texas</TD> 

</TR> 

<TR> 

<TH>GPA</TH> 

<TD>5.0</TD> 

<TD>2.5</TD> 

<TD>0.0</TD> 

</TR> 

</TABLE> 

 

  

Table headers are bold and centered by default.  Regular cells are left justified by default. 

 

Each cell of a table can contain links, lists, forms, other tables, or any other HTML code. 

What if you want to represent a cell that is empty? Then enclose a line break within the cell tag. 
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<TABLE BORDER=”2”> 

<TR> 

<TD><BR></TD> 

<TD>one</TD> 

<TD>two</TD> 

</TR> 

</TABLE> 

 

 
 

If you want space in the cell, you can use the “non-breaking space” symbol (&nbsp) to create blank spaces: 

 

<TABLE BORDER=2> 

<TR> 

<TD>&nbsp;&nbsp;&nbsp;&nbsp</TD> 

<TD>one</TD> 

<TD>two</TD> 

</TR> 

</TABLE> 

  

 

Table Captions 

A table caption is used to add a title, description, or explanation to a table. The caption tag <CAPTION> is placed 

immediately after the <TABLE> tag. 

  

<TABLE> 

<CAPTION>Table 1.1 Mixing Colors</CAPTION> 

<TR> … 

 

The default for the caption is top, centered.  In Internet Explorer you can change the caption to display at the bottom of 

the table by using VALIGN=BOTTOM or you can change the horizontal positioning using ALIGN=LEFT, 

ALIGN=RIGHT, or ALIGN=CENTER. 
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Table Alignment 

 

The table is displayed on the left side of the page on a line by itself, by default. Text will be above and below the table.   

Like images, the ALIGN attribute can be used to align the table to the left, right, or center.   For example, to center a 

table on a page, you use:  

<TABLE ALIGN = “center”>  

Cell Alignment 

Cell alignment allows you to align individual cells in order to make your table more readable.  By default, heading cells 

are centered both horizontally and vertically, and data cells are centered vertically but aligned flush left.  

 

Horizontal Alignment  

 

Using the ALIGN attribute, you can left or right align the content of the cell to the cell’s left (LEFT) or right (RIGHT) 

margin, or you can center (CENTER) the content in the cell.   

 

<TD ALIGN=”left”>  

 

Vertical Alignment  

 

Using the VALIGN attribute, you can TOP or BOTTOM align the content of the cell to the cell’s top or bottom margin, 

or you can center (MIDDLE) the content in the cell. You can use these attributes in the TABLE, TR, TH, or TD tags.  

 

<TD VALIGN=”top”> 

 

For example: 

  

<TABLE BORDER=”2”> 

<TR> 

<TH>&nbsp </TH> 

<TH>Left</TH> 

<TH>Center</TH> 

<TH>Right</TH> 

</TR> 

<TR> 

<TH>Top</TH> 

<TD ALIGN=”left” VALIGN=”top”><IMG SRC=" BLUE.GIF "> </TD> 

<TD ALIGN=”center” VALIGN=”top”><IMG SRC=" BLUE.GIF "> </TD> 

<TD ALIGN=”right” VALIGN=”top”><IMG SRC=" BLUE.GIF "> </TD> 

</TR> 

<TR> 

<TH>Middle</TH> 

<TD ALIGN=”left” VALIGN=”middle”><IMG SRC=" BLUE.GIF "> </TD> 

<TD ALIGN=”center” VALIGN=”middle”><IMG SRC=" BLUE.GIF "> </TD> 

<TD ALIGN=”right”  VALIGN=”middle”><IMG SRC=" BLUE.GIF "> </TD> 

</TR> 

<TR> 

<TH>Bottom</TH> 

<TD ALIGN=”left” VALIGN=”bottom”><IMG SRC=" BLUE.GIF "> </TD> 

<TD ALIGN=”center” VALIGN=”bottom”><IMG SRC=" BLUE.GIF "> </TD> 

<TD ALIGN=”right”  VALIGN=”bottom”><IMG SRC=" BLUE.GIF "> </TD> 

</TABLE> 
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Setting Breaks in Text 

You can use the <BR> tag to break a long heading or data in a table. You can also use the NOWRAP attribute in the 

<TH> or <TD> tag so that your heading/data will not break in the wrong place.  Make sure you resize and view your 

window several different times so you have an idea of how your table will be viewed in different window sizes. 

Defining Table and Column Widths 

The browser will automatically set your table’s columns and width.  This is often the best and certainly the easiest way.  

If you want to size columns and rows yourself; however, it is possible. 

 

Table Width 

 

The WIDTH attribute can be used inside the <TABLE> tag to set the width of the table in pixels or as a percentage of 

the browser window. 

 

<TABLE WIDTH=”100%”> 

 

Column Width 

 

The WIDTH attribute can be used on individual cells to set the width of the column in pixels or as a percentage.  

Column widths are used when you have several columns that you want to be the same size.  If you set the same column 

to different widths in different rows, generally the browser will set the column to the largest choice. 

  

Row Height 

 

The HEIGHT attribute can be used as part of the TR tag to standardize the height of the row.   

 

*Check your understanding:* 

 
1. What should you do before you start writing the HTML for your table? 

2. How does HTML know how many rows/columns to create in a table? 

3. What is the difference between TD and TH? 

4. What is the default alignment for a table? 

5. What kinds of things can be included in a table cell? 

6. What is the default position of a <CAPTION> ? 
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Table Activity 1:   
 

You will create a Calendar of Activities for yourself.  Create a Web page that displays a calendar of 

activities for yourself for the month of October, 2013. You will also add a caption to the table and 

format it.  

 

To create the calendar:  

 

1. In your text editor, create an html file and then save the file as Oct_calendar.htm on your H: 

drive.  

2. Set the table width to use 100% of the display area.  

3. Insert the days of the week in the cells of the table header row, starting with Sunday.  

4. Enter at least 20 activities for the month of October.  Some of these activities should appear 

several times throughout the month.  At least seven days should have two or more activities 

on the same day.  

5. Insert the table caption "My Schedule for the Month of October” centered at the top of the 

table.  

 

 Save your changes, and then view the page in your Web browser.  
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Section 8:  Other Features of Tables 

Border Widths 

 

You can use the BORDER attribute in the <TABLE> tag to set the width of the border around the table. The border is in 

pixels. The default is BORDER=1. If BORDER=0, there is no border.  Zero borders (or invisible borders) are extremely 

useful for formatting web pages.  Any time you need to place text next to an image, the best method is to create a table 

with border=0, put the graphic in one cell and the text in another and format accordingly. 

 

Cell Spacing 

 

Cell spacing is responsible for amount of space between the 

lines in the table that separate the cells. Use CELLSPACING 

in the <TABLE> tag to set the width of the inner lines. 

Default is CELLSPACING=2. 

 

  

 

Cell Padding 

 

Cell padding is responsible for the space between the content and border of the cell. Use CELLPADDING in the 

<TABLE> tag to set the padding of the cell. Default is CELLPADDING=1. 

 

Cell Width 

 
You can set the width or height of cells in a table, by adding the WIDTH or HEIGHT attributes to either the <TD> or 

the <TH> command.  Keep in mind that each cell is only part of the column, and setting the width only makes sure the 

width of that column isn't less than that value.  If another cell in the same column is set for a larger value, the column 

size will reflect the larger value.  The same goes for the height of a row (the largest height value of that row will be 

used).  The WIDTH or HEIGHT can be set to either a number (of pixels) or a percent. 

 

Color in Tables 

 

Use the BGCOLOR attribute in the <TABLE>, <TR>, <TH>, or <TD> tag to change the background color of the 

cell(s).  If you change the color of the cell, don’t forget to change the font of the text within the cell using <FONT 

COLOR=… >. 

 

In order for empty cells to have color there must be content so use the <BR> tag or &nbsp code in the empty cells. 

 
<TABLE BGCOLOR="#FFFFFF" WIDTH=”50%”> 

<TR ALIGN=CENTER> 

<TD BGCOLOR="#000000" WIDTH=”33%”><IMG SRC="HEART.GIF"></TD> 

<TD BGCOLOR="#000000" WIDTH=”33%”><IMG SRC="HEART.GIF"></TD> 

<TD BGCOLOR="#000000" WIDTH=”33%”><IMG SRC="HEART.GIF"></TD> 

</TR> 

<TR ALIGN=”center”> 

<TD> <IMG SRC="HEART.GIF"></TD> 

<TD BGCOLOR="#000000"><BR></TD> 

<TD><BR></TD> 

</TR> 

<TR ALIGN=”center”> 

<TD BGCOLOR="#000000"><BR></TD> 

<TD><IMG SRC="HEART.GIF”></TD> 

<TD BGCOLOR="#000000"><IMG SRC="HEART.GIF"></TD> 

</TR> 

</TABLE> 
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You can specify a color for the border of the table.  Add the BORDERCOLOR attribute to the table tag: 

     

<TABLE BORDERCOLOR=color> 

 

This command may not work with all browsers. 

Cells that Span Multiple Rows or Columns 

Sometime table headings or data span more than one row/column.  To create a row or column that spans more than one 

row/column add a ROWSPAN or COLSPAN attribute to the <TD> or <TH> tag.  You need to specify how many rows 

or columns you want to span. 

 

<TABLE BORDER=2> 

<TR> 

<TH COLSPAN=3>Students per Grade </TH> 

</TR> 

<TR> 

<TH>6th</TH> 

<TH>7th</TH> 

<TH>8th</TH> 

</TR> 

<TR> 

<TD>121</TD> 

<TD>118</TD> 

<TD>145</TD> 

</TR> 

</TABLE> 

 

 
 

Cells always span downward and to the right.  To create a cell that spans several columns, you add the COLSPAN 

attribute to the leftmost cell in the span, and for cells that span rows, you add ROWSPAN to the topmost cell. 

 

Remember:  before you code a table, draw it out first! 

 

You can combine ROWSPAN and COLSPAN within the same table: 

  

<TABLE BORDER=2> 

<TR> 

<TH COLSPAN=2>&nbsp</TH> 

<TH>GPA<BR>Fall</TH> 

</TR> 

<TR ALIGN=CENTER> 

<TH ROWSPAN=2>Students</TH> 

<TH>Spartan</TH> 

<TD>5.0</TD> 

</TR> 

<TR ALIGN=CENTER> 

<TH>Carolyn</TH> 

<TD>1.0</TD> 

</TR> 

</TABLE> 
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*Check your understanding:* 

 
1. What does the BORDER attribute control? 

2. What does the BORDERCOLOR attribute do? 

3. What is the difference between CELLPADDING and CELLSPACING? 

4. What do COLSPAN and ROWSPAN do? 

5. Including the attribute COLSPAN=3 will create a cell that goes from where to where? 

6. What does the BGCOLOR attribute do? 

7. What must a cell have to ensure it will display the BGCOLOR? 
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 Table Activity 2: 

You are in charge of creating web pages for KHOU TV in Houston.  One of these pages should 

include the weekly prime-time television schedule from 7pm to 10pm.  You'll create this schedule 

with a table broken down in half-hour installments. Because some programs in the schedule last 

longer than 30 minutes, you will have to include spanning cells to cover those time periods.  The 

schedule should look similar to this:  (but with the current programming) 

 
To create the television schedule table-  

1. In your text editor, create the TVList.htm file and save to your H: drive  

2. Create a table that has seven columns and eight rows, one of the rows consisting of table 

headers.  

3. Set the table border width to 5 pixels, the cell spacing to 3 pixels, and the cell padding to 5 

pixels.  

4. Set the width of each cell in the first column to 50 pixels.  Days of the week should be bold 

and aligned left.   

5. Set the width of the table header cells (aside from the first column) to 90 pixels.   

6. Enter the table text. You can find this week's lineup at http://www.khou.com/ 

7. Create spanning cells as indicated in Figure 4-63. 8. For each half-hour program, set the cell 

width to 90 pixels; set the cell width of hour programs to 180 pixels, of two-hour programs 

to 360 pixels, and of three-hour programs to 540 pixels.  

8. Set the background color of the first row and first column of the table to yellow.  

9. Center the table on the page.  

10. Save your changes to the file.  

11. View the page in your web browser.  
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Section 9:  Special Characters 

 

Some characters are difficult to display.  For certain characters, you can use codes to display them. 

 

For example, if you want to create a page showing someone how to create a tag, you need a code to generate the < sign.  

You would use the code &lt (to create a less than sign).  Follow the code with a space if you want a space between the 

character and the next character, or a semicolon if you want the next character to appear immediately after. 

 

So:  &lt;5 would display <5 

        &lt 5 would display < 5 

 

You can also use: 

 &gt; to generate a >  

 &amp; to generate a &  

 &quot; to generate a "  

 &nbsp to create a blank space 

 &reg to create the registered symbol 

 &copy to create the copyright symbol 

See the Appendix for more special characters you can use. 

Two other special HTML tags you should know are the <ACRONYM> and the <ABBR> tags.  If you use abbreviations 

on your page, you should indicate so by using either the <ACRONYM> tag (if the abbreviation is generally read as a 

word, like NATO or GUI) or the <ABBR> tag (if the abbreviation is usually spelled out like HTML or IRS).  When you 

use the tag, specify the full name as the TITLE attribute.  For example: 

Please contact the <ABBR TITLE=”Internal Revenue Service”>IRS</ABBR> as soon as possible. 

This does two things.  It ensures that your page will be read correctly by a text reader (to assist people with visual 

impairments).  It also allows the user to point the mouse at the abbreviation and get a small window to pop up and tell 

them what the abbreviation stands for (just like the ALT attribute you will learn shortly).   

*Check your understanding:* 

 
1. Why is there a need for special codes like &lt;? 

2. Why is it important to use <ACRONYM> and <ABBR> tags? 
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Copyright & Fair Use 

Works which may be copyrighted  

 literary works  

 musical works (including words and music)  

 dramatic works (including accompanying music)  

 pantomimes and choreography  

 Pictorial, graphic, and sculptural works  

 motion pictures and other audiovisual works  

 sound recordings  

 architectural works  

Works which may not be copyrighted:  

 Titles  

 Names  

 Short phrases and slogans  

 Familiar symbols or designs  

 Listings of ingredients or contents  

 Ideas  

 Procedures  

 Methods  

 Systems  

 Processes  

 Discoveries  

 Devices  

 Concepts  

 Principles  

 Standard Calendars  

 Height and weight charts  

 Tape measures and rulers  

 Lists or tables taken from public documents or other common sources  

When is a work protected by copyright laws?  

**  At the moment of creation  ** 

Copyright Laws:  

Duration of Copyright  

 Most creations:  The life of the author plus 50 years  

 Two or more authors:  The life of the last surviving author plus 50 years  

 Anonymous work:  75 years from first publication or one hundred years from its creation 

(whichever expires first)  
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Why is this important?  

 The (relatively) short existence of the Internet means virtually everything is still protected 

by copyright law.  

Fair Use Is Not Just For Copies: It Applies to:  

 Making copies of copyrighted works  

 Making derivative works (for example, scanning pictures)  

 Distributing works, including electronic distribution  

 Displaying and performing works publicly  

Fair Use   
The Copyright Act of 1976 states that individuals may use portions of a copyrighted work without 

permission in certain situations.  But how do the courts determine *Fair Use*? 

 

There are 4 factors to consider:  
1.  The purpose and character of the use, including whether such use is of a commercial nature or is 

for nonprofit educational purposes; 

 Is the use for profit or non-profit?  

 Is the use for the purpose of Criticism, Comment, News reporting, Teaching, Scholarship,  

or Research?  

 Does the use merely supplant the original or is it for the purpose of creating something new?  

2.  The nature of the copyrighted work;  

 How worthy is the work of copyright?  

3.  The amount and substantiality of the portion used in relation to the copyrighted work as a whole  

 Is the quality and value of the materials used reasonable in relation to the purpose of 

copying?  (Did they use no more than necessary?)  

4.  The effect of the use upon the potential market for or value of the copyrighted work.  

 Is the use causing someone to lose money or potential sales?  

How much is too much? 

(General guidelines)  

 Video - up to 10% or 3 minutes, whichever is less  

 Text - up to 10% or 1000 words, whichever is less  

 Poetry - up to 250 words, but further limited to:  

 three poems or portions of poems by one poet; or  

 five poems or portions of poems by different poets from an anthology  

 Music - up to 10% or 30 seconds, whichever is less  

 Photos and images - up to 5 works from one author; up to 10% or 15 works from a 

collection, whichever is less  

What are the responsibilities of the student?  
 Class assignments:  Students should seek permission to retain and use the digital images.  
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 School web site:  Only images with permission granted should be used.  Schools should 

pursue and keep records of inquiry (better safe than sorry).  

 Credit the source including:  

o creator/author  

o title  

o publisher, and  

o place and date of publication  

o electronic address if the work is online  

 Display the copyright notice(s) with any copyright ownership information shown in the 

original.  

Be Careful!  

 Beware when using images downloaded from the Internet. Some of these images may have 

been published without permission from the actual copyright holder.  

What does this mean for classes?  
 

Students may:  

 Use digital images in an academic course assignment such as a term paper or thesis, or 

multimedia presentation.  

 Publicly display their academic work including digital images if they are created for 

educational purposes.  

 Retain their academic work in their personal portfolios for later uses such as graduate school 

and employment applications.  

 

Specific Web Issues 

Can anyone link to your website without your permission? 

 

How can you find out who links to your site?  
 

 Go to www.altavista.com (so far this only works with altavista) 

 In the search box type:  link:www.yadayadayada.com 

 

Copyright:  For more information  

 U.S. Copyright Office Home Page:   http://lcweb.loc.gov/copyright  

 U.S. Patent and Trademark Office:   http://www.uspto.gov/  

Bibliography  

 U.S. Copyright Office Home Page http://lcweb.loc.gov/copyright  

 U.S. Patent and Trademark Office http://www.uspto.gov/  

 http://www.utsystem.edu/OGC/IntellectualProperty/image.htm  

 “Legal Matters Matter” Building Websites that Work:  PCNovice Learning Series.  1997, 

pp. 163 - 166.  

 

http://www.altavista.com/
http://lcweb.loc.gov/copyright
http://www.uspto.gov/
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Copyright Law Questions: 

 

 

What is the purpose of copyright law?  Specify who it is designed to protect from whom . . .  

 

 

 

 

 

 

 

 

In general, what is the main consideration when deciding whether something qualifies as “Fair 

Use”? 

 

 

 

 

 

Give at least 2 examples of situations which could be considered “Fair Use” and at least 3 which 

would not meet the standard. 
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Citing Electronic Resources 
 

The purpose of citing electronic resources is the same as that for citing print resources:  to give 

credit to the authors and publishers whose work influenced the author of the current work.  The 

most important elements of any citation are similar:  the author, the title, the place of publication, 

the publisher, the date of publication, and the location or page number of the article.  Unlike print 

sources, however, often when citing electronic sources one or more of these elements may be 

missing or difficult to express in a traditional manner.  For example: 

 

 Author:  Online sources often do not include an author, or an alias or login name may be 

included instead of the author’s proper name 

 Title:  Many online sources do not have a title, but may have a filename 

 Place of publication:  Will often be an address and/or protocol (method of publication) 

 Publication date:  It may be difficult to determine the date of publication of the media, the 

access date may need to be substituted  

 Page number: Generally omitted in an online document 

 

When in doubt, it is better to give too much information than too little.  The most important thing is 

that anyone reading the current work should be able to locate the original source material easily. 

 

The following examples are guidelines for citing electronic resources.  Your teacher may have 

specific requirements for specific projects. 

 

WWW page: 
 

It is common to cite information from WWW pages.  Try to include as much information as 

possible in your citation, but you must include the URL and date accessed (date accessed is 

important because web pages are often updated and the information may change).  You may need to 

go to the home page of the site to find all the information needed.   

 

Author(s).  “Title of Article (if any).”  Name of Page.  Date of Posting/Revision.  Name of 

institution/organization affiliated with the site.  Date of Access.  <URL>.  

 

You should try to include the actual URL whenever possible, however if the URL includes a long 

index number or search string parameters (for example, a resource on the FBIDS website may look 

like http://www.fortbend.k12.tx.us/campuses/documents/Teacher/teacher_20031202_1041.doc).  In 

that case, put the URL of the site’s home page.   

 

 Examples of WWW Page Citations 

 Smith, Russell G. "Identity-related economic crime: risks and 

countermeasures." Trends and Issues in Crime and Criminal Justice. No. 

129.  September 1999. Australian Institute of Criminology.  8 Nov 1999 

<http://www.aic.gov.au/publication/tandi/tandi129.html>. 

 

White House., Home page. 2002. 15 May 2003. 

         <http://www.whitehouse.gov> 

  

Burka, Lauren P. "A Hypertext History of Multi-User Dimensions." 1993. 
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MUD History. 2 Aug. 1996. 

<http://www.utopia.com/talent/lpb/muddex/essay>  

 

Email, Discussion Lists, and Newsgroups 
 

You may need to cite quotes or information from experts who have posted to a newsgroup or have 

corresponded with you via e-mail.  You should include: 

 

Writer's name (if known) or the author's email or login name.  “Subject line of the posting or e-

mail.”  Recipient of the e-mail (if applicable).  Date of the message if different from the date 

accessed.  Name of the discussion list (if applicable).  Date accessed.  <URL of the list>. 

 

 Examples of Email, Discussion Lists, and Newsgroups  
  

Kleppinger, Eugene. "How to Cite Information from the Web." E-mail to 

Andrew Harnack. 10 Jan. 1999. 

 

Crump, Eric. "Re: Preserving Writing.”  Alliance for Computers and Writing 

Listserv.  31 Mar. 1995 <acw-l@ unicorn.acs.ttu.edu>.   

 

Colleen. "Climbing Questions." Online posting. 20 Mar. 1999. Climbing 

Forum. 27 May 1999  < http://www2.gorp.com/forums/ 

Index.cfm?CFApp=55&Message_ID=18596>.  

 

Marcy, Bob. "Think They'll Find Any Evidence of Mallory & Irvine?" Online 

posting. 30 Apr. 1999. Mt. Everest >99 Forum. 28 May 1999   

         < http://everest.mountainzone.com/99/forum>. 

 

Online Reference Sources:  
 

Online Reference Sources include online encyclopedias, journals, and library databases such as 

Gale.  Often, these online references use works from other sources, so you must cite the original 

publication information first.   

 

Author(s).  “Title of the article.” Title of the complete work.  Print publication information, 

including the date.  Name of the online service.  Online publication information.  Date of access.  

<URL>  
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 Examples of Online Reference Sources 

 Jones, Barbara. "Doing what they say or saying what they do?:  Study of 

Students’ Performance and Attitudes."   Texas Journal of Education.  

June 1999.  Student Resource Center Gold. Gale Group. 8 Nov. 2002 

<http://infotrac.galegroup.com>. 

 

Bunn, Susan A.  “Joan Didion.”  Reference Guide to American Literature.  3rd 

Ed.  Ed. Jim Kamp.  St. James, 1994.  254-56.  Student Resource Center 

Gold.  Gale Group.  2002.  3 Mar. 2004.  <http:  

galenet.galegroup.com/>. 

 

Feldman, Paula R.  “Joan Didion.”  Dictionary of Literary Biography.  Ed. 

Jeffrey Helterman and Richard Layman.  Vol. 2.  Detroit:  Gale Research, 

1978.  121-27.   Student Resource Center Gold.  Gale Group.  2002.  3 

Mar. 2004.  <http:  galenet.galegroup.com/>. 

 

Harrison, Barbara Grizzuti.  “Joan Didion:  The Courage of Her Afflictions.”  

The Nation 229.9 (1979):  277-86.  Student Resource Center Gold.  Gale 

Group.  2002.  3 Mar. 2004.  <http:  galenet.galegroup.com/>. 

 

Photographs: 

 

When including photographs obtained either from the Internet or from a library database such as the 

AP Photo Archive, you should include: 

Photographer name.  “Title of photograph” Date of photograph.  Title of Collection.  Date of 

Access.   <URL>. 

 Examples of Photograph Citations: 

 

 

 

O'Sullivan, Timothy H. "Incidents of war." 1865. Selected Civil War 

Photographs from the Library of Congress, 1861-1865. 14 August 1996.  

<http://memory.loc.gov/ammem/cwphome.html>.  

Rangel, Cesar. “Picasso Exhibit.”  24 Feb 24 2003.  AP Photo Archive.  11 

March 2004.  <http://accuweather.ap.org>. 

Software or Video Games: 
 

When citing information or images from a piece of software or a video game, you should include: 

 

Author or corporate author.  Title of the software program.  Version number (if applicable and if not 

included in the software title).  Publication information.  

 

 Example of Software or Video Game 

 
ID Software. The Ultimate Doom.  New York: GT Interactive Software, 1995. 
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Sounds and/or video from the Internet: 

You should include: 

 

Performer(s).  “Title of Work.”  Date of performance.  Title of Collection or Special Presentation.  

Date of visit.  <URL>.  

 

 Examples of Sounds and/or Video from the Internet 

 Scott, Ben and Wilkinson, Myrtle B. "Haste to the Wedding." 31 October 

1939. California Gold: Northern California Folk Music From the 

Thirties.  15 May 

1998<http://memory.loc.gov/ammem/afccchtml/cowhome.html>   

Sound from CD (Professional Recording): 
 

You should include: 

 

Artist(s).  “Song Title.”  Title of Recording.  Distributor.  Year of release 
 

 Example of Song from CD 

 

 Brooks, Garth. "The Cowboy Song." In Pieces. Pearl Records, 1987. 

 

 

 

Resources: 

 
 Columbia Guide to Online Style  

<http://www.columbia.edu/cu/cup/cgos/idx_basic.html> (17 May 2003) 

 A Guide to Citing Electronic Resources 

<http://www.gu.edu.au/ins/info/lils/infosheet85.html> (17 May 2003) 

 Learning Page of the Library of Congress  

<http://memory.loc.gov/ammem/ndlpedu/resources/cite/> (17 May 2003) 

 MLA Style Page:  <http://www.mla.org>  (17 May 2003) 
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 Creating a Website:  A never ending process . . . 
 

Before you begin:  Choose a topic 

 

Ask yourself these questions: 

 Does anyone care about this topic? 

 Is it important enough to justify my time? 

 Will I be able to get information? 

 What will be the benefits of having a website about this topic rather than just a brochure 

or flyer? 

 

Step 1:  State the purpose of the website. 

 

Ask yourself:  What do I want people to get from my website? 

 

Most pages have a purpose that falls into one (or more) of these categories: 

 Informational/Educational:  designed to convey factual information  

 Business:  designed to sell or promote a product or company 

 Portal:  provides a variety of information in one spot (news, financial, weather, 

search engine) 

 eCommerce:  a virtual store, designed to sell products  

 Entertainment:  designed for entertainment, may include music, video, games 

 Social Network:  provides an environment for users to be part of an online 

community  

 Personal/Blogs:  sites devoted to individuals 

 

Examples of purpose: 

 To promote Austin High School Baseball. 

 To teach students how to write effective web pages. 

 To sell books/music/t-shirts to everyone in North America. 

 Belong to and interact with online community of knitters 

 

Step 2:  Write specific goals for your website. 

 

Identify multiple goals for your website 

 Each goal should start with an action verb 

 Be as specific as possible 

 Be as universal as you can 

 Keep your purpose in mind – there should be a correlation between each goal and the 

website purpose 

 

Examples of goals: 

 Promote USGA golf tournaments.  

 Sell products to golfers including equipment, souvenirs, and memberships in the USGA. 

 Inform people interested in the game of golf about all the rules and how they should be 

interpreted and enforced. 
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Step 3:   Identify your audience 

 

Each goal will have a target audience 

Identify your audience with general statements 

Determine audience factors, such as 

 Age group  

 Technological proficiency 

Other interests of your audience 

 

Step 4:  Determine content for your website 

 

Find content to address each goal 

Be certain to address every goal 

Content should be as specific as possible 

 

Step 5:  Organize your website 

  

Consider all your content 

Divide it into small, logical sections 

The most important content should go on the main page 

Other content should be easily accessible from the main page 

Limit content to 100 to 500 words per page 

The fewer clicks, the better 

 

Step 6:  Determine your navigation system 

  

Decide which pages will be accessible from: 

 Main page 

 Subpages 

Will there be links to any higher pages in the website (if your page is a subweb)? 

What type of links will be used? (text or text/graphics) 

Where will the navigation links be positioned?  (navigation should appear on the same place on 

each page) 

What words or phrases will you use as links?  Should make sense to user  

 

Step 7:  Design your page 

  

Sketch what your main page might look like.  Consider: 

 color scheme (2 to 4 dominant colors) 

 graphics (reuse same graphics on multiple pages)  

 fonts (no more than 3 fonts including graphics) 

 white space (should be at least 50% of your page) 

 navigation system 

 future updates (design with flexibility in mind) 

  

Follow all design principles carefully 

Keep in mind:  The simpler, the better 

Design should be appropriate for your purpose and audience 
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 All pages should have a similar look and design 

 

Step 8:  Maintaining your website 

 

Websites must be updated regularly 

Develop a plan to update and maintain the site  

Determine what information will need to be updated   

Determine a schedule for updates   

Determine a plan for obtaining updated information 

 

Keep in mind . . . 

 

The better your planning, the better the website 

Content is key:  Better content=better site 

Always plan to update the site 

 

The 6 Questions to Answer Before Creating a Website 

 

The first step in creating an effective Web site is to identify the goals for the site. 

Begin by asking the following questions: 

 

1. What is the reason for the site?  Knowing what kind of site you wish to publish will guide 

you not only in creating the look of the page, but in gathering information as well.  Sites that are 

intended to convey personal or specific information do not have to follow the rules of page design 

so stringently (but should still be well designed), whereas informational and business sites should. 

 

2. What information do I want to present?  When presenting information on a given topic, it 

is virtually impossible to cover every single aspect of that topic.  Instead, you must pick and choose 

items of interest from the usually vast amount of information available.  Having an idea what you 

want to cover in your site before you begin the page construction will help guide you as you gather 

information. 

 

3. Who is my target audience?  This is the most important issue – if you don’t know who 

your audience is, how you can hope to reach them?  Identifying whom you wish to reach will allow 

you to focus your pages.  For example, a page directed toward nuclear physicists would probably 

not be well received if it contained a large amount of animated graphics. 

 

4. What is the best way to reach my target audience?  Remember that potential viewers of 

your Web page can live anywhere in the world.  Try to design your page for a variety of browsers 

and users.  Keep in mind the age, education level, gender, interests, etc. of your would-be visitors.  

Knowing the preferences of your users will allow you to construct pages that are non-offensive and 

appreciated.  Being familiar with your audience also ensures that you have proper usage of ‘cutesy’ 

design elements. 

 

5. How can I keep my visitors interested?  The only real answer to this question is to present 

interesting and compelling information in a concise, easy to use format. 
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6. How do I keep my visitors coming back?  Remember that it is the information in your page 

that keeps people coming back!  Regular updates with new and useful information will ensure that 

you have a group of dedicated users that enjoy regular visits to your site. 

 
Review Questions 

 

Give a real-world example of each type of website: 

 

a) Informational/Educational:  ____________________________________________  

b) Business:  ____________________________________________ 

c) Portal:  ____________________________________________ 

d) eCommerce:  ____________________________________________ 

e) Entertainment:  ____________________________________________  

f) Social Network:  ____________________________________________ 

g) Personal/Blogs:  ____________________________________________ 

  

List some characteristics of the likely target audience for each of these sites (for example: age, 

interests, gender): 

 

a) Chron.com 

 

 

b) Xbox.com 

 

 

c)  Espn.go.com 
 

 
d)  etsy.com
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Creating an Organizational Chart 
 

A very important aspect of creating a Web site is page organization.  This is more important even 

than how your pages look – if users can’t find them it doesn’t matter what they look like.  Before 

building your first page, you should have a clear path laid out to ensure your site is easy to use.   

 

TYPES OF ORGANIZATIONAL CHARTS 
 

1. Hierarchy (most common) – Also referred to as a 

page tree, this organizational method is 

characterized by a centralized starting point – 

the home page.  Additional pages in the site 

are linked in levels (or branches, hence the 

tree reference) off of the home page, with 

each level being stored in its own folder.  

This structure follows this basic layout: 

 

 

 

 

 

 

 

 

With hierarchy, users move up levels for general 

information, or down levels for specific 

information.  Users generally have little 

difficulty knowing where they are in the 

structure.  Providing a link to the home page on 

all lower level pages allows users to quickly 

reorient themselves in the site. 

 

 

2. Linear – Also referred to as a slide show,  

this structure begins at the home page and 

follows a succession of pages, each leading from 

the one before it to the one after it: 

 

 

 

This layout works best if you are creating a site 

with step-by-step instructions. Typically, the 

user can choose to go forward or back within the 

structure.  Because this type of organization is 

similar to reading a book, it is very limiting in 

allowing you to present a variety of information. 

 

 

3. Multi-level Linear – While many directions 

have a beginning to end progression, it may be 

necessary at times to deviate from the path to 

cover supplemental material.  That is the purpose 

of this structure.  Observe the difference between 

this and a normal linear layout: 

 

 

 

 

 

 

 

As an example, let’s say you are presenting 

instructions on how to load an operating system 

on a computer.  After several pages explaining 

steps common to both a PC and Mac, you may 

want to split the instruction so users are taken to 

different pages that cover their particular 

machine.  After discussing the things that are 

unique to each computer, both paths may then 

converge as you explain general steps to testing 

the installation. 

 

 

4. Hierarchy/Linear – The reality is that very 

 few Web sites are strict linear sites.   More 

common is a mix of hierarchy and linear 

elements.  A hierarchy/linear structure may look 

like this: 

 

 

 

 

 

 

 

 

 

 

Home 

Home 

Home 

Home 
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Authors can build a page that offers a wide 

variety of information, while also including 

instances of slide show use. 

 

Continuing our example from above, your page 

may include a discussion of the various types of 

OS’s (pricing, performance, features, 

availability, etc.), and then include links to the 

installation instructions.  Keep in mind that 

combining two organizational styles may cause 

users to get lost more easily.  A site map is a big 

help when using this structure. 

 

5. Random – This layout is simply a set of 
pages that are linked together in some way, but with no 

real underlying organization or overall structure.  Users 

move from page to page at random (hence the name): 

 

 

 

 

 

 

 

 

 

 

This structure is very similar to playing a 

computer game where the player wanders 

through various rooms.  It is amorphous and 

without restrictions.  Each page usually defines 

itself well, and provides links that allow users to 

explore, similar to moving from room to room in 

an unfamiliar building.  The main problem with 

the layout is that users may get lost easily.  Be 

sure to provide them a way back to the home 

page. 

 

6. Grid – This structure is somewhat complex 

in that all pages are of equal importance.  This 

layout often includes an image map or a complex 

table design.  The main 

disadvantage of this 

structure is that it is very 

easy for users to get lost in 

the site.  Care must be taken 

to ensure users always 

know where they are.   

 

Storyboarding 
 

Storyboarding is a concept taken from the film 

industry, and works much the same way for the 

Web.  It involves planning the pages you intend 

to create, what information will appear on them, 

how they will look, and how they will be linked 

together before you begin creating pages.  The 

idea is to create a visual representation of the 

Web site that can be easily manipulated, and 

allows you to work without having to remember 

where each pages fits in an often complex design. 

 

Storyboards allow multiple users to build 

different parts of the same site in an efficient 

manner.  Additionally, members can physically 

check a page off the storyboard when completed 

and move to the next one. 

 

Storyboards can get rather complicated, as the 

following example shows: 

 

 

 

 

 

 

 

 

 

 

 

 

There are several ways to set up a storyboard, 

from a simple piece of paper with boxes and lines 

on it, to placing note cards on a bulletin board 

with strings to indicate links.  However you 

choose to do it, be sure that the storyboard is 

easily manipulated, and that you provide a way 

for each page creator to indicate when a page is 

complete. 

 

If you are building a site with just a few pages, a 

storyboard may seem unnecessary.  While this 

may be true for laying out how pages link to each 

other, a storyboard can still help to organize your 

thoughts and to get you started working. 

Home 

Home 
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Site Organization Exercise 

 

Working with your group members, choose one of the following topics to create several practice 

storyboards for.  Choose 3 of the six types of organizational charts and create a different storyboard for 

each type, all using the same topic. 

 

 Choose a topic that you are somewhat familiar with – it is very difficult to create a Web site on a topic you 

know nothing about. 

 

Use the following instructions to complete each storyboard: 

 Use a separate sheet of paper for each storyboard 

 Indicate the home page 

 Indicate the main topic of discussion on each page – it is not necessary to list, or even be familiar 

with, every fact that would go on each page 

 Every page must cover a unique topic not covered anywhere else in the site 

 Use lines to indicate every page that any given page is linked to – be certain that your links make 

sense and that your site has a logical flow 

 Define a minimum of 15 pages 

 Place the names of all group members on each storyboard and staple them together before turning 

them in  

 

 Topic choices: 

1. Famous Fashion Designers 

2. The Japanese Attack on Pearl Harbor 

3. Phone Psychics 

4. How a Bill Becomes a Law 

5. Violence in Schools 

6. The Best Children’s Movies 

7. Makeup and Hair Styles 

8. Eating While Pregnant 

9. American Olympic Athletes 

10. The Titanic 

11. Christmas Traditions 

12. Italian Cooking 

13. History of Computers 

14. Bats Are Not So Bad 

15. Mountain Climbing 

16. The Truth About Smoking 

17. The Gulf War 

18. Soap Operas 

19. Why Does My Baby Cry So Much? 

20. Aircrafts Used in War 

 

Each group must choose a different topic – no two groups can have the same topic.  Each group must get 

their topic choice approved by the teacher on a first come first served basis. 

 

Keep one very important point in mind as you choose your topic: you are not allowed to 

use the Internet to research these topics.  When creating your own site most of the 

information should come from you and not from other sites (if this were the case, your 

page could simply be a list of links).  Choose wisely! 
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Investigating Navigation 

 
One of the best ways to get ideas about what is good or bad web design is to evaluate websites.  In this 

activity you will get into your groups and evaluate the websites below writing down your thoughts in the 

areas outlined on this sheet.  

A zoo is a zoo is a zoo, right?   

Well, maybe . . .  If you had an assignment to do internet research of one zoo in the world, what do you 

think would help you pick that zoo?  More than likely you would do an internet search on zoos and then 

start following links.  So what determines whether you explore a site in depth or bounce there and then 

quickly off on to another site?   Whether you consciously realize it or not, the two main determining factors 

will be how informative the first page of the site is and how easy it is to navigate. 

 

1. Visit the zoo websites listed below focusing on the navigation system of each one.   

2. Pick your favorite and your least favorite site. 

3. Discuss in your group why you like or dislike the navigation system of each while answering the 

questions below.   

 If you have different opinions, make sure you write them all down.  Not everyone’s tastes 

are the same and that’s important to remember when planning and designing a website. 

4. Each group will then show the rest of the class the websites they chose and explain what they 

liked and didn’t like about them based on their answers to the questions. 

 

 http://zoo.sandiegozoo.org/ 

 http://www.birminghamzoo.com/ 

 http://www.cincinnatizoo.org/ 

 http://www.zoo.org/ 

 http://www.aza.org/ 

 http://www.philadelphiazoo.org/ 

 http://www.oregonzoo.org/ 

 http://www.brookfieldzoo.org/ 

 http://www.bronxzoo.com/ 

 http://www.memphiszoo.org/  

 http://www.calgaryzoo.ab.ca/ 

 http://www.milwaukeezoo.org/ 

 http://www.edinburghzoo.org.uk/ 

 http://www.belizezoo.org/ 

 https://www.australiazoo.com.au/ 

 

 

 

http://zoo.sandiegozoo.org/
http://www.birminghamzoo.com/
http://www.cincinnatizoo.org/
http://www.zoo.org/
http://www.aza.org/
http://www.philadelphiazoo.org/
http://www.oregonzoo.org/
http://www.brookfieldzoo.org/
http://www.bronxzoo.com/
http://www.memphiszoo.org/
http://www.calgaryzoo.ab.ca/
http://www.milwaukeezoo.org/
http://www.edinburghzoo.org.uk/
http://www.belizezoo.org/
https://www.australiazoo.com.au/
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URL of Zoo website you liked the best:  _____________________________________ 

 

1. How long did it take to figure out how to navigate? 

 

 

2. How is the information categorized? 

 

 

3. As you go to different pages in the site, do you always know where you are? 

 

 

4. Is it clear how to get back to the previous page?  The home page?  Is there a link to  

the home page on every page? 

 

 

5. Can you tell how the site is organized?  Which of the organization models does it 

most closely resemble (Hierarchical?  Grid?  Random?) 

 

 

6. What were the main categories of information? 

 

 

7. Did the navigation system ever change?  Did the change seem to serve a purpose or 

was it just poor design? 

 

 

8. Does every page have a unifying graphic identity? 

 

 

9. Did the navigation system enhance the overall design of the page? 

 

 

10. Is color used to organize information? 

 

 

11. Were there any links that were ambiguous (you couldn’t tell where they were going)? 

Were there any links that were redundant? 

 

 

12. Did the navigation seem appropriate for the intended audience? 

 

 

13. Was there excessive scrolling required?   

 

 

14. Did any information require more than 3 clicks to get to? 
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URL of Zoo website you liked least:  ____________________________________ 

 

15. How long did it take to figure out how to navigate? 

 

 

16. How is the information categorized? 

 

 

17. As you go to different pages in the site, do you always know where you are? 

 

 

18. Is it clear how to get back to the previous page?  The home page?  Is there a link to  

the home page on every page? 

 

 

19. Can you tell how the site is organized?  Which of the organization models does it 

most closely resemble (Hierarchical?  Grid?  Random?) 

 

 

20. What were the main categories of information? 

 

 

21. Did the navigation system ever change?  Did the change seem to serve a purpose or 

was it just poor design? 

 

 

22. Does every page have a unifying graphic identity? 

 

 

23. Did the navigation system enhance the overall design of the page? 

 

 

24. Is color used to organize information? 

 

 

25. Were there any links that were ambiguous (you couldn’t tell where they were going)? 

Were there any links that were redundant? 

 

 

26. Did the navigation seem appropriate for the intended audience? 

 

 

27. Was there excessive scrolling required?   

 

 

28. Did any information require more than 3 clicks to get to? 
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Navigation/Organization Activity 

 

For this activity we are going to focus our attention on the relationship between the organizational structure 

of a website and the navigational system you use.  This is the foundation upon which websites are built. 

 

XYZ Zoo is going to hire someone to design their website, and you are going to put together your ideas to 

show them.  They know the information they want to have on the site and give it to you as a list with no 

apparent organization.   

 

These are the topics the Zoo would like on their website (in no particular order).  You may add 

additional content if you feel it is needed. 

 

Directions Memory Card Game 

Party Information Goat Milking Game 

Corporate Donations Wild Animal Club 

Press Releases Memberships 

Summer Camp Volunteer 

Links to local hotels/attractions Adopt an Animal 

Zoo History Donate online 

Gift Shop Board of Directors 

Conservation Information Interactive Tour 

Educator workshops Zoo News 

Children’s Zoo Animal Webcam 

Animal Database XYZ Zoo FAQ 

Lectures/chat with the keeper Ticket prices 

Zoo Newsletter School Programs 

Map of Zoo Events Calendar 

 

 

Your job is to  
 

o organize their information into logical categories (use Inspiration or pencil and paper) 

o create a sketch of an opening page for their website including the navigation bar (using pencil and 

paper) 

 

Make sure you organize the topics logically, and that the navigation system is clear, easy to understand, and 

adds to the personality of the page.  You should be able to get to any information on the site with no more 

than 3 clicks. 
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Navigating Between Web Pages 

There are three types of hyperlinks: 

 Absolute Links 

 Relative Links 

 Target Links 

Absolute Links:  This type of hyperlink specifies the URL of the linked page.  For 

example: 

 

<A HREF = "http://www.fortbend.k12.tx.us">Fort Bend Web Page </A> 

 

Relative Links:  This is used to link between pages on the same server.  To use relative 

links, you must know the organizational chart.  Use the organizational chart to determine 

the relationship between the two pages.  For example, consider the following page 

structure: 

 
Assume that all the boxes in the organizational chart above represent folders in a 

company web page.   
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Linking between pages in the same folder: 

To link between pages in the same folder, specify the name of the file.   For example, to 

link from page1.htm to page2.htm both located in the Marketing folder use the command: 

<a href = "page2.htm"> 

 

To link from one page to another page which is located lower in the hierarchy, specify 

the path to get to the page.  For example, to link from the page index.htm, located in the 

Main folder to page1.htm located in the Marketing folder as shown below, use the 

following command: 

 

<a href = "Marketing/page1.htm"> 

 

Moving up one level: 

To move up a level in the hierarchy, you need to use "../"  for each level you need to 

move up.  In the diagram above, to link from Page1.htm to index.htm, you would use the 

command: 

<a href = "../index.htm"> 
The ../ takes you to the Main folder, then you link to the file index,htm.  

Moving up two levels: 

To link from a page in the Research folder called sample.htm to the index.htm page 

located in the Main folder, you would use the following command: 
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<a href = "../../index.htm"> 
Beginning in the Research folder, the first ../ takes you to the Marketing folder, the 

second ../ takes you to the Main folder where the index.htm page is located. 

Moving between pages on different branches of the hierarchy: 

Consider the following diagram: 

 
The task:  To link from beta.htm to Page1.htm: 

To get from beta.htm, you must move all the way up to Main, and then down from Main 

to Page1.htm.  The command is: 

<a href = "../../Marketing/page1.htm">   
And how do you link from Pag1.htm back to beta.htm?  

<a href = "../Engineering/Testing/beta.htm"> 
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Navigation Practice 

Use the chart to answer the questions: 

 
Write an HTML tag to do each of the following: 
 

1.  Link from the page index.htm located in the Main folder to the page specs.htm located 

in the Engineering folder. 
 

2. Link from the page index.htm located in the Main folder to the page 2003.htm located 

in the Budget folder. 
 

3.  Link from the page specs.htm located in the Engineering folder to the page index.htm 

located in the Main folder. 
 

4. Link from the page 2003.htm located in the Budget folder to the page index.htm 

located in the Main folder. 
 

5.  Link from the page 2003.htm located in the Budget folder to the page specs.htm 

located in the Engineering folder. 
 

6.  Link from the page specs.htm located in the Engineering folder to the page  2003.htm 

located in the Budget folder. 
 

7.  Link from the page specs.htm located in the Engineering folder to the page  plan.htm 

located in the Publicity folder. 
 

8.  Link from the page research.htm located in the Marketing folder to the page  plan.htm 

located in the Publicity folder. 

 

9.  Link from plan.htm located in the Publicity folder to the page test.htm located in the 

Research folder. 
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Designing Your Web Page 
 

The 8 Things that Every Page Must Have 

Every page that you make, whether it is the home page or a page 27 (or more!) levels deep, must 

have the following 8 basic items.   

 

a) A TITLE (APPEARS IN THE TITLE BAR) 
There are 2 main reasons for this.  First, many users often refer to the title bar to remind them of 

where they are.  Second, when a user bookmarks your page, this is where the browsers gets the 

bookmark’s descriptive text.  If left blank, users will not remember where the bookmark leads 

(and will probably delete your link).   

 

b)  CONTRASTING TEXT AND BACKGROUND COLORS 
Pages must be easy for users to read or they will not stick around very long. 

 

c)  EXPLANATION OF WHAT THE PAGE IS ABOUT THAT APPEARS IN THE 

FIRST WINDOW WITHOUT SCROLLING (known as the first pane) 
Users want to know right away what every page they visit is about.  If they have to scroll down a 

long way or decipher complex graphics they will likely just leave.  Remember that Web users 

want pages easy to use and understand. 

 

d) LINK TO THE HOME PAGE 
Other Web pages may link to your site using upper-level pages (pages other than your home 

page).  Users may look at this page and want more information.  Without a way to get to your 

home page users may feel lost and frustrated and simply leave. 

 

e)  ALT TEXT FOR EVERY IMAGE ON THE PAGE 
There are 4 main reasons for this.  First, believe it or not, some users still have browsers that 

don’t support images (called text-only browsers).  Second, many users browse with image 

loading turned off because it causes pages to load much faster.  With no ALT text, each of these 

types of users will see a blank space where your image should be.  Third, technology that allows 

blind persons to use the Internet needs the ALT text.  These devices look at the HTML code and 

read the page text to the user.  When a picture is reached, the device will read the ALT text in 

place of the image.  Finally is the fact that ALT text gives the user something to read while the 

image loads.  This can be particularly important on large images. 

 

f)  HTML COMMENT DOCUMENTING EVERY GRAPHIC 
You should document the source of every graphic on your page (i.e. :  <!-- This graphic was 

created by me, Jane Student --> or <!--This graphic from Bob’s Free Clip Art Emporium – used 

with permission --> ).  This allows whoever created the graphics to receive the credit he/she so 

richly deserves.  Note:  If the page is to be posted on a school website, you must obtain 

permission to use any graphic which is not original.    
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g)  EMAIL LINK 
You should not make visitors have to return to your home page to send you comments.  An email 

link on every page will allow users to send you comments quickly and easily.  No matter how 

carefully you proofread (which of course you will), you will make mistakes, and it is generally 

better to find out about them so you can fix them.  If you are using frames, users may be linked to 

a specific page that you have placed in a frame and may not see the static frame that you have 

placed the email link in.  While placing email links in every frame may seem redundant, it will 

ensure that all users have an avenue to communicate with you. 

 

h)  DATE LAST MODIFIED 
Pages, like groceries, become stale quickly.  How can someone tell if the information on your 

page is accurate and up-to-date?  Tell them.  Always include a statement such as “This page last 

modified on . . . “ on every page of your site. 

 

Key Elements of Effective Web Page Design 

 

The design of a website can either help the cause or hinder it.  People actually prefer 

boring sites to those that are too confusing or disruptive.  Think of it as a continuum: 

 

 
 

As long as users can find the information they need, the page has some appeal for them.  

If there are problems finding information, waiting through long download times, being 

surprised with unwanted multimedia and requests to download the latest plug-in, you 

may find people leave the site rather quickly.  

 

Think about your favorite website.  What about it makes it your favorite?  The design?  

The graphics?  Chances are good, it’s the content.  When it comes to websites, content is 

key.  Design should add to the appeal of the site’s content, not distract from it.  Here are 

some tips to help you design more effective pages: 

 

Getting Started 

 
Make a good first impression.  Look at your home page as if you have just opened it for 

the very first time.  What is the first thing you notice?  Is something spinning?  Singing?  

Unreadable text?  Endless paragraphs?  Huge graphics with no content at all?  Or do you 

see a clean, professional look?  What you see is what the users will see – make sure it 

looks good. 
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Place important information at the top of the first page (and every page).  Don't 

force your users to click forever to get to the information they want.  When a page is first 

displayed, the information that shows without scrolling should be important and enticing 

(if it isn't, why would anyone scroll?).  Put the most important information in the first 

window to appear, near the top on every page.  This is prime real estate – don’t waste it 

on meaningless titles and graphics. 

 

The clearer the better.  Don’t clutter with too many graphics.  Use no more than 2 to 4 

main colors.  Use no more than 3 different fonts (including graphics).  AVOID 

WRITING IN ALL CAPS (it’s rude and it is harder for users to read). 

 

Include important information.  Give users a way to contact you (e-mail address).  Post 

revision dates (so users can gage accuracy of information).  Give pages meaningful 

names (in case readers bookmark them). 

 
Splash pages are a no-no.  Your first page 

should never ever be a splash page.  No 

one wants to sit and wait for a large 

graphic to load which serves no purpose 

other than to welcome them to the page 

(duh) and tell them to click and wait for 

another page to load.   

 
 

Content 
 

Don’t waste people’s time.  Personal web pages may have whatever interests you.  

Professional web pages should interest your reader with updated information.  Content 

should be well-organized, clear, concise, and to the point.  Information should be updated 

and relevant.  
 

Never, ever, ever, ever be redundant.  Every page in your website should have at least 

one piece of unique information.    

 

The content should encourage people to come back another time.  Ask yourself:  Is 

there anything here that would encourage someone to return a second time?  Have I 

planned for updating and adding to the current content? 
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Layout 

 
Be Consistent.  Every page on a website should look like it belongs to the same website.  

That means the same colors, fonts, navigation, and graphics should appear throughout the 

site. 

 

Speaking of fonts, your web page is not a good place to show off all the really cool fonts 

you just got installed on your computer (besides, if visitors don't have the font installed 

on their system they will see the default browser font, usually Times New Roman) or all 

the pretty colors your monitor can display.  Each major section should use like colors, 

fonts, and layouts.  Inconstancy in design indicates poor planning and unprofessional 

design. 

 

Repetition is not necessarily a bad thing.  Redundancy in content is bad.  Repetition in 

design elements is good.  Repeating images helps keep download time to a minimum.  

Pages that use the same background image will not have to load new images for each 

page (images are stored in your computer's cache and accessed from there instead of 

being called from the server).  If each page uses a different background, each change will 

require loading a new image, which slows everything down.  This is also true for images, 

logos, and banners.  If repeated, they require no additional download time. Reuse the 

same images throughout the site to avoid re-downloading images.   

 

Be Accessible.  The idea is for as many people as possible to access your page.  Don’t 

make it difficult for them.  Use browser-safe colors (which look the same on different 

machines.   

 Use common fonts (if you want to use unusual fonts, make a graphic) 

 Carefully consider before using plug-ins (flash, shockwave), or Java applets.  If 

you must use them, make sure you tell the users where to get the plug-ins they 

need to view them, and consider that some users may be using a device that can’t 

display those plugins.  

 Give users choices (don’t force long download times) 

 

If you are designing a website for a federal agency, you must make sure the website is in 

compliance with section 508 of the Americans with Disabilities Act.  It is a good idea to 

be familiar with these recommendations and make any professional website as accessible 

as possible to those with disabilities.   

 

Check your page on different devices.  You should check different browsers (IE and 

Google Chrome, Safari), different resolutions, different platforms (Mac, Windows, 

mobile, tablet).  Be sure you test all pages that you make.  You can't make assumptions 

about what device people may be using to access your site.  Check your pages by viewing 

them on as many different devices and platforms as you can get your hands on, including 

previous browser versions if possible.  There are some huge differences in the way the 

same browser displays pages on different devices.  You may also find that certain plugins 

or multimedia won’t play on some devices. 
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Avoid clutter.  You want pages to load as quickly as possible.  Don’t overload pages 

with text or graphics.  Keep it short and simple.  Most users will not scroll more than one 

page, and you should avoid horizontal scrolling at all costs (many people still set their 

resolution at 800x600 – it’s true!). 

 

Note:  Online documents are different from web pages.  An online document is often 

described as a large amount of related material that is designed to be read at one 

time or printed out for offline use.  Online documents should be designed with 

scrolling because it is easier to print or search if the information is all contained 

on the same page.   
 

Plan to expand.  Your design should be flexible enough to allow for changes and 

updates in information.   

 

Organize behind the scenes.  Create folders for each section of your site, and consider 

creating a separate folder just for images (so they can be reused throughout the site).   

 

Use tables to organize layout.  They will resize depending on screen size and resolution 

and keep the elements organized on the page. 

 

Navigation 
 

Don’t hide your hyperlinks.  Your navigation should be easy to spot and easy to use.  

Don’t use underlined text except as a hyperlink.  Users may try to click on it and wonder 

why it doesn’t go anywhere.  If you use buttons, they should look like buttons.  Avoid 

buttons that appear and disappear.  And whenever possible, use the standard link colors 

(unless it really impacts your color scheme).  People expect purple or red links to indicate 

places they have already visited – especially for external links.   

 
Consistency is Key.   Use the same navigation links on each page.  Put them in the same 

location on each page.  Navigation is a snap when link lists are always on the left (or 

always at the bottom, or always at the top, or always…oh, well, you get the idea…).   

 

Help users find the home page.  Users should be able to get the home page from every 

lower-level page.  Some of your visitors may come into your site at a lower-level page 

(through links from other pages or the use of a search engines).  You don't want these 

visitors to be confused about where they are. 

 

Give links names that are meaningful.  Don’t make users guess where the link leads. 

 
A less-than-effective navigation bar: 
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Give Text-Based Options.  Consider that there are many users browsing without 

graphics, and some with visual impairments.  In addition, navigation icons which seem 

intuitive to you may leave your users clueless. 

 
Another less-than-effective navigation bar: 

 
 

Make use of External Links.  Research and include external links to related topics.  

Verify links frequently.  Be sure all links are educationally appropriate (at least 2 levels) 

 

Make the link significant text. 

Poor:  For more info about our graduate school click here 

Better:  Want more info about our graduate school? 

 
The reason hyperlinks usually appear in a different color and underlined is so they will 

stand out on the page.  If the user is scanning the page looking for something, make sure 

the text that draws their eye also gives them a hint what it is linking to.  Highlighting 

words like “click here” or “go there” requires the user to read the surrounding text to 

figure out where “here” is.  Take the guesswork out of it – they will be thankful.  

 

Images/Multimedia 

 
The use of images is one of the most powerful tools you have when designing your web 

page.  It can also cause tremendous problems if not used carefully. 

 

Specify WIDTH and HEIGHT attributes for images.  This causes the browser to create a 

space for the image while the page loads.  Users can thus read the text as the images are loading 

without having the page rearrange as the images come in. 

 

Choose the correct format for your graphics or multimedia.  Graphics should always 

be kept as small as possible.  When choosing between GIF and JPG, let the type of 

picture guide you.  The GIF format usually works best for graphics that have bold colors 

and sharp line changes between the colors.  The JPG format usually works best for 

photographs and images with gradual changes in colors. iDevices won’t play flash videos, so 

you may want to use a different format for video. 

 

Optimize Images.  Make image files as small as possible.  Crop out unnecessary 

elements from the image.  Create images at the size you plan to display them – don’t use 

height and width to resize images. Use the correct image format (JPEG for photos, GIF 

for logos).  The most important thing to remember is that the fewer colors the smaller the 

image.  Since browsers are only capable of displaying images to a certain depth, your 

beautiful multi-million color image may appear very different to your users.  Try first 

reducing to 256 colors, and then reduce again to between 8 and 32 colors.  See how small 

a file you can live with (without sacrificing the quality of your graphics). 
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Use thumbnails for scanned photographs and large images.  If users want to 

download larger versions, they can choose to do so. 
 

Use good-quality images.  Poor images affect the professional look of your page.  

Images with transparency should have clean edges, and all text in your images should be 

easy to read. 

 

When including sound, less is always best.  Never include a song as a background 

sound.  Remember that every time users visit the page the entire song will play (again).  

Sound bites, or short sounds such as a doorbell ringing, may be OK to include (but even 

they can grow tiring), but if you want to include an entire song be sure to give the user 

controls so they can turn the song off.   

 

Be careful with backgrounds.   
Since the purpose of your page is content, 

you should avoid hiding your content on 

distracting backgrounds.  Background 

colors/images should fit your design scheme.  

Make sure your text can be read easily.  If 

you are going to use a background image, set 

your background to a similar color so the text 

can be easily read before the background 

loads.  Avoid busy (or yucky) backgrounds. 

 

 

Follow copyright guidelines on every page, and get permission for all copyrighted 

material you use.  Sure, it's easy for users to borrow information from other pages on the 

Internet, but that doesn't mean that it is OK to freely use the work of others on your page.  

All material created by you (text and sound as well as images) is covered by copyright 

law.  So is the material created by others.  Respect the intellectual property of others and 

expect that they will respect yours.  If you have material that visitors can freely use be 

sure to clearly state this. 

 

You should always include ALT text with all images.  Period.  No exceptions. 
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The 12 Things To Avoid On Your Web Page At All 

Costs 

 

There are many things to avoid when building a web page – enough, in fact, to fill a 

book.  What follows in a list of the 12 most common mistakes, annoyances, and design 

problems. 

 

1.   Links that go nowhere.  The main purpose of a web page is to provide information, 

thus having links that either lead to blank pages or to no pages at all defeats the entire 

purpose.  Be sure to check all links on your pages often and fix or remove any that go 

nowhere. 

 

2.   'Under construction' pages.  The reality of web site maintenance is that pages are 

always under construction, so putting a sign that says 'under construction' is redundant - 

not to mention unprofessional.  Users understand that pages are always in the works, you 

don’t have to remind them.  Be sure that you are emphasizing the content of your page, 

not the lack of it.  Simply avoid creating links to these pages until they are ready (which 

does not have to mean finished, as a page can be posted with some but not all of the 

information you wish to share). 

 

 

 
 

 

3. Welcome to …  While a welcome message may seem like the courteous thing to do, it 

is in reality redundant.   The entire point of web pages is to get visitors, thus you are 

obviously welcoming users to your page or you wouldn't have a page in the first place.  

Simply begin with a description of what visitors will find on your site. 

 

4. 'Click here' text links.  Intentional or not, this tends to make users feel that you think 

they are not bright enough to locate the links on their own.  Links should be set apart in 

clearly defined navigation areas, as in a side navigation bar, or incorporated into the text 

of the page, as in 'I really like donuts' where 'donuts' is a link to your favorite shop.  A 

little more flexibility is allowed in reference to pictures, as it is a good idea to indicate 

with some type of text that a given picture is a link - for example, 'click the donut above 

to find out about my favorite shop.' 

 

5.  Frames.  Don't use frames.  While frames do offer you some control over how content 

is displayed there are way more disadvantages than advantages.  It is hard to control how 
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frames display on some devices, it is hard to link properly to frames, search engines don’t 

always handle frames properly, printing pages with frames can be difficult.   
 

If you look at examples of the best pages on the web, how many use frames?  Not one.  

Avoid, avoid, avoid.   

 

6.  Large, numerous, or animated graphics.  Graphics have always given users 

problems, despite the fact that it was graphics that caused the Internet to take off in the 

first place.  Slow connections - remember that most users are still using dial-up - mean 

that pages with large or numerous graphics cause many users to leave your site if they are 

not presented with the completely loaded page in about 15 seconds.  Additionally, 

animated graphics are usually a distraction as they tend to draw the eye away from your 

information, which is why people visit your page in the first place.  Before using an 

animated gif, ask yourself if the page will loose functionally without it.  If it won't, ditch 

the graphic. 

 

 

It’s annoying, it’s distracting, and most 

experienced users hate it, and will actually 

leave a page due to excessive animation. 

 

Except when used sparingly, tastefully, and 

with awareness of the target audience (for 

example, a children’s site), avoid animation 

on your page.   

 
 

7.   Full color background images.  Background images in generally are not that big of 

a faux pas (unless it is a large image that increases download time), but using full color 

photographs is.  There is a reason descriptions of photographs are written on the back of 

the picture - if written on the front they would be difficult to read.  The same holds true 

for web pages.  Your goal should always be to make things as easy on your users as 

possible - especially reading your information.  Additionally, you should always include 

a background color that is similar to your image - just in case the image does not load the 

text will still be readable. 

 

8.   Background sound.  Web surfing is generally a quiet, solitary exercise.  Blasting 

your user with unwanted sound will cause many users to leave.  Background sound 

increases page download time, is often inserted with no way to turn it off, and can be 

especially annoying if it repeats forever.  If you must include sound, give your users 

controls so they can start and stop it as they wish.   
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9.  Obscure or unavailable plug-ins.  While using the latest and greatest in technology 

can make you feel like you are on the cutting edge, putting it on a web page used by the 

general public isn’t necessarily a good idea.  Users may get upset that they can't see your 

really cool stuff because they lack a plug-in.  Wait to post those new and innovative 

things until the technology has become mainstream (unless, of course, you are working 

with an Intranet and know everyone has the necessary plug-in).  Additionally, avoid 

using anything that will require old or outdated technology that never caught on.  Many 

users have long since deleted, or never bothered to get, these unused plug-ins. 

 

10.  Pop-up windows.  Some companies display advertisements this way.  The reality is 

that these are simply ignored and closed immediately by the vast majority of web users or 

blocked by pop-up blockers.  Any message you place here is likely not to be seen - just 

put it in the body of your page. 

 

11.  Status bar text.  Many people have come to rely on the status bar area of the 

browser to supply them with information, such as where a particular link will take them.  

Also, most users will not see your status bar message until they point at a link, then get 

annoyed at having a new piece of information presented to them.  Work any message that 

you would insert here into the body of the page.  If there is no place to work it in, just get 

rid of it as it does not add to your page. 

 

12.  Hit counter.  There are 3 main reasons for this:  1. They don't actually count the 

number of visitors to your page, but instead record the number of times the page was 

requested from the server (for example, when users hit the refresh button, the hit counter 

goes up).  2. If the server goes down, the hit counter is reset to zero.  3. They can be set to 

any number the Webmaster wishes.  Remember that number of hits does not make or 

break your web site.  Ideally, people will come to peruse your content, not because 

"everyone else goes there."  High traffic on a site is no reason to visit it - useful, up to 

date, and compelling information is. 

 

 

Bottom Line . . . you are designing pages to convey information not to impress other 

web designers! 
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Keep it simple! 
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Evaluating Page Design Activity: 

Your instructor will give you a list of websites.  Visit each one, and in the space indicated, write the 

name of the company or business that owns the site.  Evaluate each page using the guidelines we have 

discussed in class.  Note any problems on the lines provided.  Evaluate only the page that loads, not the 

entire site (in other words, don’t click on any links or visit any other pages in the site unless told to do so 

- you are evaluating an individual page, not the entire site structure).  If a page is no longer active, 

simply note that and move on to the next page.  If you need additional space, use another sheet of paper. 

 
1. URL: ________________________________________________    

Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

2. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

3. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

 

4. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

5. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

6. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

7. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 
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___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

8. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

9. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

10. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

11. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

12. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

13. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

14. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 

15. URL: ________________________________________________    
Site name/company/business:_______________________________ 

Problems: __________________________________________________________________ 

___________________________________________________________________________

___________________________________________________________________________ 

___________________________________________________________________________ 
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Graphics Basics 

You have been working on the steps involved in planning a Web site, developing a 

design document, and adding text and images to Web pages. Before you start learning to 

create and edit images in Photoshop, you need to get comfortable with a few basic 

graphics concepts. 

Bitmap vs. Vector-Based Graphics 

 

There are two main categories of graphic images: bitmap and vector. 

Bitmap images, also referred to as 

raster images, are pixel-based. This 

means that location and color 

information about the image is stored 

as individual pixels within a grid. 

Figure 5.1-1 shows a small blue 

arrow image at its actual size. Figure 

5.1-2 shows the same image 

magnified. The upper left quadrant 

of Figure 5.1-2 shows the individual 

pixels of the image. As the figure 

illustrates, each pixel has an assigned 

color; some pixels are white, while 

other pixels are blue. The 

information stored in a bitmap image 

regarding pixel location and color is 

what forms the image. Bitmap 

images are edited at the pixel level; 

in other words, the color of any one 

pixel can be changed.  

 

 

Figure 5.1-1: Arrow Image, Actual Size 

 

 

Figure 5.1-2: Magnified Arrow Image 

with Pixel Grid 

Additional attributes of bitmap images include: 

1. Bitmap images are usually created and edited in "photo" or "paint" programs 

such as Adobe Photoshop.  

2. Bitmap images are mapped to a grid.  

3. The size of the image is based on the image's resolution.  

4. Bitmap images are not easily scalable.  

5. Bitmap images are used for photorealistic images and, therefore, may 

involve complex color variations.  
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Vector images are mathematically-based. All 

lines, shapes, etc. (also called objects) of a 

vector-based image are independent of one 

another. Figure 5.1-3 shows an image of a rose 

(actual size). Figure 5.1-4 shows one leaf of 

the same rose magnified, along with the paths 

and handles used within vector images.  

Additional attributes of vector-based images 

include: 

1. Vector-based images are usually 

created and edited in "draw" or 

"illustrate" programs such as Adobe 

Illustrator.  

2. Vector-based images have smooth 

edges.  

3. Vector-based images create curves or 

shapes.  

4. Vector-based images are good for 

precise illustrations, but are not as good 

for photorealistic images.  

Vector-based images are easily scalable, due to 

their use of mathematic formulas. 

 

Figure 5.1-3: Rose sample 

 

Figure 5.1-4: Rose Leaf with 

Handles 

 

   

Color/Bit Depth and Image Resolution 

Bit Depth 

A bit is the smallest unit of measurement regarding computer data. Each bit is an 

electronic pulse that can either be on (represented by a 1) or off (represented by a 0). Bit 

depth refers to the number of colors that can be displayed. The higher the bit depth, the 

more colors used in the image, therefore, the larger the file size. Note that the maximum 

number of colors increases exponentially after the original two colors: 

Bit Depth Formula Number of Colors 

1-bit 21 2 

2-bit 22 4 

3-bit 23 8 

4-bit 24 16 

5-bit 25 32 

6-bit 26 64 
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7-bit 27 128 

8-bit 28 256 

24-bit 224 16,777,216 

Image Resolution 

Resolution is defined by WhatIs.com as: 

... the number of pixels (individual points of color) contained on a display 

monitor, expressed in terms of the number of pixels on the horizontal axis and the 

number on the vertical axis. The sharpness of the image on a display depends on 

the resolution and the size of the monitor. The same pixel resolution will be 

sharper on a smaller monitor and gradually lose sharpness on larger monitors 

because the same number of pixels are being spread out over a larger number of 

inches. 

 

You can think about image resolution as a measure of the output quality of an image. 

Traditional print work requires high resolution images to display the image quality we are 

all used to in magazines, brochures, and various other types of print materials. 

Images prepared specifically for the Web don't require a high resolution. Computer 

monitors are limited to an image resolution of 72 pixels per inch (ppi) or 96 pixels per 

inch; therefore, high resolution images prepared for the Web actually waste a lot of 

valuable resources (i.e., bandwidth). 

Images prepared for the Web at 72 ppi will not look good in print, so it is important to 

consider the various ways images will be used when determining the desired resolution of 

an image. There is definitely a trade-off that must be considered: higher resolution 

images that may be used for print will have a larger file size and require more bandwidth 

without displaying any better on a computer monitor; lower resolution images may 

display fine on a computer monitor, but will not be sufficient for print pieces. 

Next, we will explore Web file formats and then discuss the concept of optimizing 

images for the Web. Optimizing images for the Web is one way to deal with dual purpose 

images, such as those used for both a print piece and a Web page. 

 

 

 

 

http://whatis.com/
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Graphic File Formats 

File Formats 

Anyone using a computer should be familiar with the concept of file formats. File 

formats help to identify what kind of file is being worked with and are usually 

distinguished by the file extension. Most computer applications have a native file 

format, i.e., a default format for files created in that program. (For example, by default, 

Adobe InDesign saves files with an .indd extension, while Adobe Illustrator saves files 

with an .ai extension.) In addition, many applications allow the user to save files in 

formats other than the application's native format. It is a good idea to save files in the 

native format in addition to any desired non-native format. 

There are three primary graphic file formats for Web images: GIF (Graphic Interchange 

Format), JPEG (Joint Photographic Experts Group), and PNG (Portable Network 

Graphics). Each of these graphic file formats is cross-platform and uses some form of 

compression to be optimized for use on the Web. 

GIF (Graphic Interchange Format) 

GIF is the preferred file format for images with large areas of solid color, such as logos, 

text as graphics, cartoons, etc. The GIF file format supports 8-bit images (up to 256 

colors). 

Here are some other important features of GIF images: 

1. GIFs use a lossless compression scheme, i.e., images do not lose data when 

compressed and, therefore, don't lose image quality.  

2. GIF images allow for transparency.  

3. GIF interlaced images can be displayed as low-resolution images initially and 

then develop clarity and detail gradually.  

4. GIF images can be used to create simple animations.  

5. GIFs are saved with a .gif extension.  

JPEG (Joint Photographic Experts Group) 

JPEG is the preferred file format for photographic images. In addition, the JPEG format 

works well with subtle transitions in color, such as watercolors, pencil or charcoal 

drawings, etc. The JPEG file format supports 24-bit images (over 16 million colors). 

Here are some other important features of JPEG images: 

1. JPEGs use a lossy compression scheme; data is removed from the image to make 

the file size smaller when compressed.  

2. JPEG images allow for various compression levels, providing for the adjustment 

of compression to best display the image without losing too much of the image 
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quality. Due to the various compression levels, it is suggested that the original 

image be saved and used for editing purposes; don't edit a JPEG image that has 

been compressed.  

3. JPEG images are not interlaced; however, progressive JPEG images can be 

interlaced.  

4. JPEGs are saved with a .jpeg or .jpg extension.  

PNG (Portable Network Graphics) 

PNG is kind of a hybrid of GIF and JPEG. The PNG file format can be 24-bit or 8-bit 

color, eliminating some of the limitations of the other formats. 

Here are some other important features of PNG images: 

1. PNG images use a lossless compression scheme.  

2. PNG images are interlaced.  

3. PNG images support transparency.  

4. PNG images include the ability to correct for gamma information based on the 

computer monitor on which they are being viewed.  

5. PNGs are saved with a .png extension.  

Optimizing Web Graphics 

Optimizing graphics for the Web involves eliminating as much unnecessary data from an 

image as possible without significantly impacting the overall quality of the image. There 

are several things that can be done to help optimize images: 

 Reduce the overall image size — This might include creating a thumbnail of the 

image, if appropriate, or cropping the image.  

 Reduce the number of colors saved with an image — You might be asking 

yourself, "How can you reduce the number of colors saved with an image; doesn't 

the image use all the colors that it is saved with?" Interestingly enough, an image 

saved as an 8-bit image (256 colors) might only use 60 of the possible 256 colors 

available. In this case, data about an additional 196 colors is stored with the 

image, making the file size significantly larger than necessary. This method of 

optimization is most appropriate for images that utilize solid colors.  

 Use compression schemes — Optimizing graphics via compression schemes 

requires applying the best compression scheme for the image as well as adjusting 

the compression levels. This method of optimization is most appropriate for 

images that utilize complex color combinations.  
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Introduction to Color 

We talked about bit-depth and how the number of colors impacts the size of a file. It's 

time to explore a few specifics about color before we jump into Photoshop to see how it 

all works from a practical perspective. 

RGB and CMYK Color 

Color is an important aspect of any Web page. In general, a Web designer should use 

limited colors to establish a theme that can be used throughout the site. Establishing a 

color scheme helps give each page the same look and feel, regardless of content, and lets 

your audience know they are still within the same site. 

RGB vs. CMYK Color 

The RGB color model is typically used when dealing with color viewed on a computer 

monitor. The CMYK color model, on the other hand, is used on print material when 

printing in full color. 

  CMYK RGB 

Colors 

Cyan 

Magenta 

Yellow 

Black 

Red 

Green 

Blue 

Color 

Model 

Reflective — light comes from 

a source, hits an object, and 

reflects from the object into the 

eye. 

Non-reflective — light comes straight 

from the light source to our eyes. 

Values 

Images are separated into 

various values of the four 

colors. 

Each individual color (red, green, and 

blue) has a value, or intensity, from 0 to 

255. The various combinations of the 

values produce different colors. 

 

Indexed Color 

Indexed color is a limited palette of up to 256 colors. When using a limited palette, the 

computer approximates a non-included color by combining the colors within the palette; 

this is called dithering. 

The indexed palette can have up to 256 colors, but does not require that many colors; the 

palette can have any number of colors up to 256. The fewer colors within the palette, the 

smaller the file size. 



112 

You now know that one way to optimize graphics for the Web is to reduce the number of 

colors saved with the image. Using an indexed palette with only the colors used in the 

image is one of the best ways to limit an image's file size. 

Hue, Saturation, and Brightness 

The Color Wheel 

Let's briefly discuss the concept of the color wheel and why you should have a general 

understanding of its significance when working with color. Think of the color wheel as a 

360-degree circle of color (red starts the circle at 0 degrees). It is divided into three types 

of colors: 

 Primary colors — Red, Yellow, Blue. Primary colors are true colors; they don't 

involve blending colors together.  

 Secondary colors — Orange, Green, Purple. Secondary colors are the result of 

the blending of two primary colors. Orange results from blending red and yellow; 

green results from blending yellow and blue; and purple results from blending 

blue and red.  

 Tertiary colors — Tertiary colors are the result of blending a primary color with 

a secondary color.  

So why is it important to have a basic understanding of the color wheel? When we begin 

exploring color in Photoshop and Illustrator, you'll put some of the basic color wheel 

information to use. 

Hue, Saturation, and Brightness 

The basic color terms hue, saturation, and brightness are used to describe color. You will 

have an opportunity to see how these terms are used and actually manipulate their values 

in an upcoming lesson, but right now, let's check out the definitions of hue, saturation, 

and brightness: 

Hue  

Refers to what most of us mean by "color." It is the generic name used to describe 

a color, e.g., red, green, yellow, orange, etc.  

 

Saturation  

Refers to how pure the color is. A fully saturated color is the truest version of that 

color. Primary colors (red, yellow, and blue) are fully saturated.  

Brightness  

Refers to the amount of white there is in the color.  
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Browser Safe Colors 

Browser safe colors play an important role when designing graphics for the Web. 

Although most monitors today can display thousands of colors, there are only 216 

common colors recognized by browsers and operating systems of computers using a 256-

color display. This limited common palette can result in a couple of potential problems 

for those users: 

1. The browser will convert colors not included in the common palette to the closest 

color it can find.  

2. The browser may attempt to mix the colors within the common palette to 

approximate the desired color (dithering).  

Browser safe colors can be represented by RGB values, percentages, or hexadecimal 

equivalents. Robin Williams and John Tollett, in their book The Non-Designer's Web 

Book, provide the following chart that is very handy when trying to determine whether a 

color is a browser safe color: 

RGB hex % 

0 00 0 

51 33 20 

102 66 40 

153 99 60 

204 CC 80 

255 FF 100 
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Graphics Basics Questions 

Bitmap vs. Vector-Based Graphics 

What are bitmap images? 

Main Attributes of bitmap images: 

 

 

 

What are vector graphics? 

Main Attributes of vector graphics: 

 

  

 What are the main differences between Bitmap and Vector graphics? 

 

   

Color/Bit Depth and Image Resolution 

What is a bit? 

How does bit depth affect the size of the image? 

Image Resolution 

What is Resolution?  

 

What resolution should be used for web graphics?                 

Why is it different from the resolution you should use for print? 
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Graphic File Formats: 

How can you tell what file format an image is saved as? 

 

Characteristics of GIF (Graphic Interchange Format): 

Best used for: 

Number of Colors: 

Other features of GIFs: 

 

JPEG (Joint Photographic Experts Group): 

JPEGs are best used for: 

Number of Colors: 

Other features of JPEGs: 

 

PNG (Portable Network Graphics): 

Number of Colors: 

Other features of PNGs: 

 

 

 

 

Optimizing Web Graphics 

What is the point of optimizing graphics? 

Ways to optimize graphics: 

1.    

2.   

3.    
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Introduction to Color 

 

What are the main differences between RGB and CMYK Color? 

 

Indexed Color 

What is the significance of the size of the palette? 

What is dithering? 

Hue, Saturation, and Brightness 

The Color Wheel 

Primary colors: 

Secondary colors: 

Tertiary colors: 

Hue, Saturation, and Brightness 

Hue  

 

Saturation  

 

Brightness  

 

Browser Safe Colors 

How many browser-safe colors are there? 

How does the browser compensate for colors it can’t display? 

What is the hex code for the approximate percentage of each: 

 0% 

 20% 

 40% 

 60% 

 80% 

100% 
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Graphics File Types 

BMP (Bitmap)  

 

 The bit-mapped file format used by Microsoft Windows 

 Common file for paint programs 

 Tend to be very large files 

 Cannot be displayed on the Internet 

  

JPG or JPEG (Joint Photographic Experts Group) 

 

 Web graphic format 

 Can display approximately 16.7 million colors 

 Good for photographs, paintings, or images with lots of colors 

 Small files, good format to use in PowerPoint 

 JPEGS are compressed, at a ratio varying generally from 5:1 to 15:1.  The more 

compressed the file the lower the image quality (lossy compression – cannot 

restore original quality of file after compression) 

 

GIF (Graphics Interchange Format) 

 

 Web graphic format 

 Can only display 256 colors 

 Best used for logos, cartoons, graphics with minimal shading 

 Can be transparent 

 Can be animated (note:  animated gifs only move in web browsers.  They will not 

move in PowerPoint) 

 Can be “interlaced” – this means the graphic can appear in a low-resolution 

format, then gradually come into focus 

 

TIFF (Tagged-Image File Form) 

 

 A standard file format for storing images as bit maps. It is used especially for 

scanned images because it can support any size, resolution, and color depth. 

 Good quality – often used for professional environments and commercial printing 

 Cannot be displayed on the Internet 

 Can be compressed (lossless compression) 

 

PNG (Portable Network Graphics) 

 

 Relatively new file format  

 Good quality 

 Can be compressed (lossless compression) 

 Supports transparency (including variable transparency – any pixel can have up to 

254 levels of opacity) 
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PICT 

 

 Supported by Apple/Macintosh-based graphics programs 

 More than 16 million colors 

 Cannot be displayed on the Intenet 

 

To compare file sizes, the same photo was scanned and saved under each image type, the 

size of each file was: 

 

 Bitmap – 1090K (would barely fit on one diskette) 

 JPEG – 118K at the highest resolution/lowest compression 

 JPEG - 38K at highest compression 

 GIF – 128K 

 TIFF (not compressed) - 2228K (about twice the capacity of a diskette) 

 TIFF (compressed) – 756K  

 GIFs vs. JPEGs: What difference does it make, really? 

There are several differences between the gif and jpg file formats that might influence 

which format you choose when saving a file. 

 Joint Photographic Experts Group (JPEG) 

 Lots of colors (24 bit color = 16.7 million colors)  

 Images are compressed with some data lost to compression (and you can control 

the amount of compression) 

 Best for photographs or paintings  

 Best for graphics with shading, lots of colors  

 Graphics Interchange Format (GIFs) 

 Fewer colors (8 bit = 256 colors)  

 Colors are excellent, but fewer colors available  

 Images can be compressed with no loss of data  

 No image degradation  

 Larger than JPEGS, slower transfer (in general - although they can be very small 

if you don't use many colors)  

 Best for line art, logos, screen captures  

 Best for images with solid colors, little shading, not a large variety of colors  

 Only GIFs can have a transparent color, animation  
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Learning Adobe Photoshop CS6 

Photoshop Basics 

Getting Started 

 

The Photoshop CS6 Workspace 

 
The Photoshop CS6 Essentials Workspace.  This is the default Workspace for CS6. 

 

 
 

 

To Open a new image in photoshop, go to File>Open and browse to the location where 

your image is stored.   

 

 

Panels in the Essentials Workspace 

 

The most important panel is the Tools Panel, which opens on the left side of the 

workspace.   
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When you select a tool, the options bar at the top of the workspace will change to display 

settings for the tool you have chosen.    

For example, the options bar for the Text tool includes settings for font, style, size, and 

alignment. 

 

Most of the tools have hidden tools underneath them, as indicated by the small arrow in 

the lower right corner of the tools.  If you click and hold down for a second on a tool with 

an arrow in the lower right, you can see what other tools are available.  Select a different 

tool from that pop-out list, and that tool will be displayed on the Tools Panel.   

For example, if you click on the Rectangular Marquee Tool, you will see the other hidden 

tools underneath: 

 

Rectangle Marquee Fly-out Options 

Note the letter M appearing next to the Rectangular Tool Marquee.  This is a shortcut 

key.  Pressing the letter M on the keyboard will switch you to the Marquee Tool (either 

the Rectangular or Elliptical, whichever is visible on the toolbar. 

Set Foreground Color and Set Background Color — This section of the Toolbox 

allows the user to select the desired foreground color (top square) and background color 

(bottom square). Clicking the double arrow in the upper right portion of the section 

switches the foreground and background colors. Finally, the small black and white boxes 

in the lower left portion of the section sets the foreground and background colors to 

their default values, black and white, respectively.  

Edit in Quick Mask Mode — The default editing mode is Standard Mode. The 

Quick Mask Mode turns a selection into a mask.  

Screen Mode — There are four screen modes: Standard Screen Mode, 

Maximized Screen Mode, Full Screen Mode with No Menu Bar, and Full Screen 

Mode.  
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The Photoshop Toolbar 
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Toolbar Review Worksheet 

Directions: Write the name of each tool symbol pictured, the shortcut key, and its general 

purpose in the appropriate spaces.   

 

Icon Tool Shortcut 

Key 

Purpose 

 Rectangular Marquee M selecting 

    

    

    

    

   retouching 

    

 
   

 
   

 
  painting 

 
   

 
   

 
   

 
   

 
   

 
   

 
   

 
   

 
  unfocusing 

 
   

 
  Adjusting tone/color 
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To create a new Photoshop 

document, open Photoshop 

and make the following menu 

selections: 

File > New 

The New dialog box will 

appear: 

There are several options 

you can select: 

 Name field is where 

you will give your file 

a name   

 The Image Size section of the New dialog box provides several fields pertaining 

to and influencing image size:  

o The Preset field lets you select from preset sizes, including standard paper 

sizes such as letter and legal, standard Web graphic sizes (640 x 480, 800 

x 600, 1024 x 768, and 468 x 60) or video image sizes (e.g., NTSC, PAL, 

and HDTV).   

o If a preset size is selected, the Width, Height, and Resolution fields will 

be filled in for you, or you can enter your own custom values.  

o The Color Mode field includes options for Bitmap, Grayscale, RGB, 

CMYK, and Lab colors modes.  

o For Resolution you will generally choose 72 Pixels/Inch or 300 

Pixels/Inch for print images. 

 The Background Contents section offers three options:  

o White (creates a white background for the image)  

o Background Color (allows a color to be selected for the background)  

o  Transparent (creates a transparent layer upon which the image sits) 

Practice Activity 1: 

1. Select File > New.  

2. Enter the name "Practice" in the Name field.  

3. Choose Custom size, and set the size to 400 x 400 pixels  

4. Verify the Resolution field is set to 72 pixels/inch.  

5. Verify the color Mode field is set to RGB.  

6. Set the Contents section for a white background. 

7. Click the OK button.  
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Panels 

 

There are a number of panels which you will use frequently in Photoshop 

 

The Layers Panel shows the layers you are working with in 

Photoshop.  Layers are like sheets of plastic that are stacked on 

top of each other. Each layer can have different graphical 

information (such as images or text).   Information on each layer 

will cover up any information on the layers below it.  The image 

to the right shows the Layers Panel with three visible layers: 

background layer, one text layer and one image layer. 

 

A few important components of the Layer Panel: 

 Opacity shows the level of visibility of the elements on 

that layer.  100% Opacity means the elements are 

completely visible.  0% Opacity would mean the elements on that layer are 

completely invisible. 

 Layer Name shows the name of the layer.  By default, layers are numbered in the 

order in which they are created and text layers are named based on the text they 

contain.  You can change the name of any layer by double-clicking on the layer 

name and typing the new name. 

 Show/Hide Layer  - This icon controls whether the layer is visible or not. The 

eye icon indicates the layer is visible.  

 Active Layer — The highlighted layer identifies the active layer of the image. It 

is important to make sure that the correct layer is selected before editing. Clicking 

the name of a layer makes that layer the active layer. In this example, Layer 1 is 

the Active Layer. 

History — The History panel is a fly-out from the main panels on the right.  Click the 

icon to show the panel and the double arrows to hide the panel.  The History panel lists 

each step taken in the current Photoshop session. 

The first step in this example was opening the 

image file. The second step taken was creating a 

new layer. Deleting any layer on the list will 

restore the image to the step immediately before 

that step in the lid.  For example, selecting and 

deleting the Brush Tool layer (with the trash icon) 

from the history list at the right would restore the 

image to how it appeared when it was first opened. 

 

 

Navigator — Navigator is an optional panel which may be used to navigate within an 

image or to adjust the zoom level of an image. To show the Navigation panel, go to 

Window> Navigator.  It will appear as a fly-out from the main panel and looks like a 

compass.  
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A red rectangle called the View Box appears around the entire image until the zoom level 

of the image is altered. Once the zoom level is 

changed, the View Box Marquee is used to show 

where you are within the image. The Hand Tool 

appears when the cursor is place over the image in 

the Navigator Panel and is used to move the View 

Box to view another part of the image. At the 

bottom of the panel shows the zoom percentage 

(which you can click on and enter a new value), 

the slider which allows you to adjust the zoom, 

and Zoom In button which looks like a pair of 

triangles.   

Color — This panel has two tabs.  The Color tab is 

used to choose colors. Values can be entered directly 

into the Red, Green, and Blue fields to mix colors to 

obtain the desired color.  The Swatches tab shows a 

set of colors you can select from to use, and allows 

you to add your own colors.   

 

Opening an Image in Photoshop 

 

To open an image in Photoshop, choose one of the following options: 

1. File > Open — Navigate to the location where the file is stored and select it to 

open.    

2. File > Open As — The Open As option allows the user to select an image that 

does not have an extension associated with it and open it in Photoshop.  

3. File > Open as Smart Object – the Open as Smart Object allows you to open 

files with special content and preserve the original characteristics of the file.  This 

is particularly useful for vector graphics (such as Illustrator files) because it 

allows you to scale the object as a vector graphic.  

4. File > Open Recent — The Open Recent option displays the names of images 

you have recently opened in Photoshop.  

To close an open image in Photoshop, go to File > Close or click the X in the tab for 

the image. 

 

Photoshop tends to require a lot of memory to run, so you will generally have better 

performance if you don’t keep multiple images open if you are not using them.   
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Saving an Image in Photoshop 

 

To save a Photoshop file, select one of the three different save options found in the File 

menu: 

File > Save (Ctrl-S) — Use Save to save your file in psd  format (photoshop document).  

This allows you to keep all your layers and effects intact so you can edit them later.  

File > Save As — The Save As option is used to save your psd file under a different 

name.  It is often useful to save different versions of your file before making major 

editing changes just in case you decide to revert back to a previous version.  

Save For Web— The Save for Web option provides various options for optimizing 

graphic images for use on the Web.   More details on this later. 

 

Working with Color in Photoshop 

 

Click on the Foreground Color or Background Color in the Toolbar panel to bring up the 

Color Picker.   

The Color Picker —The Color Picker allows you to enter the RGB or hexadecimal 

value of the desired color, or the desired color can be selected from the large color 

square by selecting the general hue from the color spectrum (the rainbow column to 

the right of the large color square) then choosing the shade you want from the box. 

You can also define a color using HSB – Hue/ Saturation/Brightness or CMYK 

(Cyan/Magenta/Yellow/Black) values.  

 

To display only web-safe colors, put a check in the Only Web Colors box below 

the color square. 
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There are two color boxes to the right of the color spectrum: 

o The top color box represents the newly selected color. The bottom color 

box reflects the old color.  

o An exclamation point to the right of either color box indicates that the new 

color is not part of the printable color range.  This is only important if you 

are printing the image. Click the small color box just below the 

exclamation point to change the new color to the closest printable color.  

o A cube to the right of the old color box indicates that the current color is 

not part of the Web safe palette. Click the small color box just below the 

cube to change the new color to the closest Web safe color. This is 

significant if your image will be displayed on the web. 

If you just can’t find a color that is both printable and web safe that you like, then 

decide what format you want to use for your final image, and make sure you 

comply with that color range.   

Practice Activity 2: 

1. Select the Rectangle Tool from the Toolbox.  

2. Right-click the Custom Shape Tool in the Document Window to display the 

available custom shapes from the Options panel at the top.  

3. Double-click on one of the custom shapes.  

4. Click within the Document Window and drag at a diagonal to the desired size.  

5. Click the color square in the (top) Options Panel to access the Color Picker.  

6. Select a new color by clicking within the Swatches Panel.  

7. Click the Color Picker's OK button to accept the new color.  

8. Select a style from the Styles Panel. 

9. Drag the style to the layer containing your Custom shape.     

The Eyedropper Tool — The Eyedropper Tool can also be used to select color. It is 

the best way to select a color from an open image and find out its exact RGB value. To 

select a color using the Eyedropper Tool, make sure the Toolbox's Foreground or 

Background Color square is selected, select the Eyedropper Tool, move the Eyedropper 

icon over the image until you find the color you want, and then click on the desired color.  

That color will then appear in the selected color box. 

The Text tool 

 
When you select the type tool in the toolbox, your cursor will change to an I-beam 

pointer. A small line across the I beam marks the location of the type’s baseline. For 

vertical type, it marks the center axis that the type will be created along. 

 

You can enter type in one of two ways 
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 To add point type, click in the image.  When you enter point type, each line of 

type is independent--the length of a line grows or shrinks as you edit it.  Point 

type enters the text in a line from the point where you first click. Line breaks may 

be created by pressing Enter, but otherwise, the type does not wrap. 

 

 Paragraph type is entered by clicking and dragging a bounding box, and then 

adding text inside it.  You can enter multiple paragraphs and select a paragraph 

justification option.  Paragraph type is entered in a bounding box. Text will wrap 

to stay within the box. If you add more type than will fit within the box, it will be 

indicated by an overflow icon, and the overflow type will not show in the image. 

Resizing the text box by dragging a corner will allow the overflow text to show. 

Pressing Enter creates a new paragraph, not a line break, in paragraph text. 

 

The type tool’s options bar will appear as soon as you select the tool. You can choose the 

text orientation (horizontal or vertical), the font and the style of the type you are entering.   

 

 
 

From the type tool option bar, you can also choose the size of the type you would like 

and the anti-aliasing method.  Anti-aliasing lets you produce smooth-edged type by 

partially filling the edge pixels. As a result, the edges of the type blend into the 

background.    

 

Anti-aliasing options include: 

 None to apply no anti-aliasing.  

 Sharp to make type appear the most sharp.  

 Crisp to make type appear somewhat sharp.  

 Strong to make type appear heavier.  

 Smooth to make type appear smoother. 

Note:  Anti-aliasing increases the number of colors in your image, and will generally 

increase the file size.  It also tends to be inconsistent on small type sizes. 

 

Also on the type tool option bar you can choose the text alignment and text color.  You 

also can choose to warp the text (in a variety of styles including arc, arch, flag, twist, 

etc.).   

If you are happy with the type you’ve added or changed, accept it by either clicking the 

large check mark  on the right end of the options bar, or by pressing the Enter key on 

the numeric keypad, or by pressing Ctrl-Enter on the regular keyboard. If you don't like 

your changes, and don’t want to accept them, click the on the options bar or press the 

Esc key. 

 

As you enter the text, if you move the cursor a little ways away from the type you’ve 

added, the pointer becomes the move tool, and type can be repositioned.  If you have 

difficulty positioning type exactly where you want it, apply it (click the check) and then 
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move it with the move tool. Drag, or press the arrow keys to move the text layer in one 

pixel increments. 

 

Each time you use the type tool, a new layer is created with that text on it (unless you are 

in indexed color mode which does not support layers). Any of the layer styles, or other 

layer options can be applied to type layers (more about layer types later). 

 

 

Practice Activity 3: 

 

1. Create a Photoshop document which is 400 x 400 pixels with a white background 

(you may use the one you created earlier). 

2. Select the rectangular marquee tool 

3. On the Options bar change the Style to Fixed Size, set the width to 300 px, and 

the height to 100 px. 

4. Click in the image to create the selection. 

5. Select the Foreground color.  Use one of the methods described to choose a color 

that you like. 

6. Use the Paint Bucket tool to fill the image with the color you chose. 

7. Add a text layer to your image over the rectangle.  Choose a color that contrasts 

well with the color of the rectangle.  Be sure the text comes close to filling the 

box 

8. Using the same document as above, enter an additional text block using the 

Vertical Type Tool. This second text block is also on its own layer.  

9. Highlight the text.  

10. Change the text color using the Color Spectrum.  

11. Click the Commit Any Current Edits check mark on the Options Panel to accept 

the color change.  

12. Select the Ellipse Tool from the Toolbox.  

13. Using the document from the previous activity, click the Ellipse Tool in the 

Document Window and drag at a diagonal to the desired size.  

1. Click the color square in the Options Panel to bring up the Color Picker.  

2. Select a new color by clicking within the Color Spectrum.  

3. Click OK to accept the new color.  

 

 

Changing Image Size 

 

One way to help optimize images for the Web is to reduce the overall size of the image. 

This may or may not be appropriate, based on the image and its intended use on the Web. 

 

To change the size of an image in Photoshop, start with these menu selections: 

Image > Image Size 
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The Image Size dialog box will pop up:   

 

 

You can change the image size by either changing the width and height (best for 

web graphics) or by changing the document size (best for print documents).   

If Constrain Proportions is checked, you will change either height or width and 

the other field will be automatically filled in for you.  If you uncheck Constrain 

Proportions, you can adjust the height and width independently, but your image 

may appear distorted. 

You can also adjust the resolution when you change the image.  If Resample 

Image is checked, Photoshop will change the Pixel Dimensions to keep the 

document size the same.   

Digital photos are generally extremely large images (in order to capture as much detail as 

possible in case you want to print large photos).  For example, with one digital camera set 

to jpeg format (a slightly smaller file size) the average photo dimensions are 2448x3264 

with a file size of 1.5MB.  At 300 pixels/inch, this photo could be printed up to 8” x 10” 

at good quality.   

 

If you are displaying this image on the web, however, this is far larger than necessary.  

When working with digital photos for electronic media, it’s a good idea to reduce the 

image size to improve download speed.     

 

Practice Activity 5: 

1. Open the flag.jpg file in Photoshop.  

2. Select Image > Image Size.  

3. Verify that the Constrain Proportions checkbox has a check in it.  

4. Change the Width field to 400, then click the OK button. What happens to the 

image?  

5. Select Image > Image Size again.  

6. Uncheck the Constrain Proportions checkbox.  



131 

7. Change the Width field to 800, then click the OK button. What happens to the 

image?  

8. Select Edit > Undo Image Size to undo the last change.  

9. Select Image > Image Size once again.  

10. Check the Constrain Proportions checkbox.  

11. Resize the image to a desirable size.  

12. Save the image with the name "flag_resize.jpg."  

Cropping an Image 

 

Another way to prepare images for the Web is to crop any unnecessary parts from the 

image. 

 

Notice in our picture of Angie that we can 

see the carpet and the chair behind her.  

Cropping the image leaves the desired 

portion of the image, while discarding the 

unwanted parts. 

 

 

 

 

To crop an image in Photoshop: 

1. Select the Crop Tool from the Toolbox.  

2. Drag a marquee around the area of the picture to be cropped.  

3. Make any desired changes to the Crop Tool Options Panel (e.g., change the 

dimensions of the crop marquee, etc.). The crop size can also be adjusted by 

dragging the marquee sides to the desired location.  

4. Press the Enter key or click the check mark in the Options Panel to accept 

cropping. Clicking the circle with a line through it next to the check mark on the 

Options Panel cancels the cropping process.  

 

A cropped picture of Angie is shown here.  

Notice we can focus on her cute face 

without all the other elements in the 

original photo.  Smaller file size, also! 
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Practice Activity 6: 

1. In Photoshop, open the Angie.jpg file.  

2. Select the Crop Tool.  

3. Drag a marquee around the area to be cropped. Make the marquee a bit bigger 

than you really want it to be.  

4. Adjust the size of the marquee by selecting each side and dragging it to the 

desired location.  

5. Press the Enter key to select the area.  

6. Save the new image as "Angie_crop.jpg."  
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Tutorial 

ADOBE PHOTOSHOP CS6/CC 

 

Lesson 1:  Working with Selections 

 

 

 

 
Learning how to select areas of an image is of 

primary importance when working with 

Adobe® Photoshop® —you must first select 

what you want to affect. Once you’ve made a 

selection, only the area within a selection can 

be edited; areas outside the selection are 

protected from change. 

 

 
In this lesson, you’ll learn how to do the following: 
 

 Use the marquee, lasso, and magic wand tools to select parts of an image in various ways. 

 Reposition a selection marquee. 

 Deselect a selection. 

 Move and duplicate a selection. 

 Constrain the movement of a selection. 

 Adjust a selection with the arrow keys. 

 Add to and subtract from selections. 

 Rotate, scale, and transform a selection. 

 Combine selection tools. 

 Crop an image. 
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Tool overview 
 

In Adobe Photoshop, you can make selections based on size, shape, and color using four basic sets of 

tools—the marquee, lasso, magic wand, and pen tools. In addition, you can use a fifth tool, the move tool, 

to reposition the selections you create. 

 

Note:  In this lesson, you will use just the marquee, lasso, magic wand, and move tools.  

. 

Marquee Tool 

 

Lasso Tool 

       
 

Move Tool 

 

Magic Wand Tool 

 

 

The marquee and lasso tool icons contain hidden tools, which you can select by holding down the mouse 

button on the toolbox icon and dragging to the desired tool in the pop-up menu. 

 

The rectangular marquee tool lets you select a rectangular area in an image. The elliptical marquee tool 

lets you select elliptical areas. The single row and single column marquee tools let you select a 1-pixel-high 

row and 1-pixel-wide column.  

 

The lasso tool lets you make a freehand selection around an area. The polygon lasso tool lets you make a 

straight-line selection around an area. The magnetic lasso tool lets you draw a freehand border that snaps to 

the edges of an area.   

 

The magic wand tool lets you select parts of an image based on the similarity in color of adjacent pixels. 

This tool is useful for selecting odd-shaped areas without having to trace a complex outline using the lasso 

tool.  The quick selection tool also lets you select parts of an image based on similar colors, but it also looks 

for similar textures.  The magic wand tool works by selecting pixels, while you use the quick selection tool 

by dragging over an area, allowing it to search for similar pixels. 

 

Getting started 

 

Before beginning this lesson, open the finished art file for this lesson to see what you’ll be creating. 

 

1.  Choose File > Open. Locate and open the Lesson01 folder. Then select End01.psd and click Open. An 

image of a face, constructed using various types of fruits and vegetables, is displayed. 

 

2.  Minimize End01.psd so you can refer back to it.   

 

3.  Choose File > Open. Locate and open the Lesson01 folder, select Start01.psd, and click Open. 

 

4.  Choose File > Save As, type the name Work01.psd, and save on your H: drive. 

 

Selecting with the rectangular marquee tool 

 

You’ll start by practicing selection techniques using the rectangular marquee tool. 

 

1.  Click the rectangle marquee tool in the toolbox. 

 

2.  Drag it diagonally from the top left to the bottom right corner of the melon to create a rectangular 

selection.  (Be sure the Style is set to Normal) 
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Initial 

selection 
Marquee tool 
placed within 

selection 

Selection border 
repositioned 

 

You can move a selection border after you’ve created it by positioning the tool within the selection and 

dragging. Notice this technique changes the location of just the selection border; it does not affect the size 

or shape of the selection. 

 

3.  Place the marquee tool anywhere inside the selection surrounding the melon. The pointer becomes an 

arrow with a small selection icon next to it. Drag to reposition the border around the melon. 

 

Note:  Repositioning techniques for selection borders work with any of the marquee, lasso, and magic 

wand tools. 

 

If you are still not happy with the selection after repositioning it, you can deselect it and redraw it. 

 

4.  Deselect the selection by using either of these methods: 

 

 Choose Select > Deselect. 

 Click anywhere in the window outside the selection border. 

 

5.  Reselect the melon using the rectangle marquee tool. 

 

To back up one action at any point in the lesson, choose Edit > Undo.  To undo multiple steps, use the 

History panel or use Edit>Step Backward to go back one step at a time.   

 

Selecting with the elliptical marquee tool 

 

Next you’ll use the elliptical marquee tool to select eyes for the face. Note that in most cases, making a new 

selection replaces the existing selection. 

 

1.  Select the zoom tool and click twice on the blueberry to zoom in to a 300% view. 

 

2.  Hold down the mouse button on the rectangular marquee tool, and change to the elliptical marquee tool. 

 

3.  Move the pointer over the blueberry, and drag it diagonally from the top left to the bottom right edge of 

the blueberry to create a selection. Do not release the mouse button. 

 

Repositioning a selection border while creating it 

 

If a selection border isn’t placed exactly where you want it, you can adjust its position and size while 

creating it. 

 

1.  Still holding down the mouse button, hold down the spacebar and drag the selection. The border moves 

as you drag. 

 

2.  Release the spacebar (but not the mouse button), and drag again. Notice that when you drag without the 

spacebar, the size and shape of the selection changes, but its point of origin does not. 

 



136 

 

 
Incorrect point of 

origin (Click and 

drag) 

Corrected point of 

origin (spacebar 

depressed) 

Adjusted border 

(spacebar released) 

 

 

3.  When the selection border is positioned and sized correctly, release the mouse button. 

 

Selecting from a center point 

 

Sometimes it’s easier to make elliptical or rectangular selections by drawing a selection from the center 

point of the object to the outside edge. Using this method, you’ll reselect the blueberry. 

 

1.  Choose Select > Deselect. 

 

2.  Position the marquee tool at the approximate center of the blueberry. 

 

3.  Click and begin dragging toward the edge. Then without releasing the mouse button, hold down Alt, and 

continue dragging the selection to the blueberry’s outer edge. Notice that the selection is centered over its 

starting point. 

 

4.  When you have the entire blueberry selected, release first the mouse button and then the Alt key. 

If necessary, adjust the selection border using one of the methods you learned earlier. 

 

Moving a selection 

 

Now you’ll use the move tool to move the blueberry onto the carrot slice to create an eye for the face. 

Then you’ll duplicate and move the selection to make a second eye. 

 

1.  Make sure that the blueberry is selected. Then click the move tool and position the pointer within the 

blueberry’s selection. The pointer becomes an arrow with a pair of scissors to indicate that dragging the 

selection will cut it from its present location and move it to the new location. 

 

2.  Drag the blueberry onto the carrot slice 

 

 

 
Move tool placed 

within blueberry 

selection. 

Blueberry moved 

onto carrot slice. 

 

3.  Choose Select > Deselect. 

 

4.  Choose File > Save. 
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Moving and duplicating simultaneously 

 
Next you’ll move and duplicate a selection simultaneously. 

 

1.  Choose View > Fit on Screen to resize the document to fit on your screen. 

 

2.  Select the elliptical marquee tool. 

3.  Drag a selection around the carrot slice containing the blueberry. If necessary, adjust the selection 

border using one of the methods you learned earlier. 

 

4.  Click the move tool, then hold down Alt, and position the pointer within the selection. The pointer 

becomes a double arrow, which indicates that a duplicate will be made when you move the selection. 

 

 
 
5.  Continue holding down Alt, and drag a duplicate of the eye onto the left side of the melon face. Release 

the mouse button and Alt, but do not deselect the eye. 

Holding down Shift when you move a selection constrains the movement horizontally or vertically.  Using 

this technique, you’ll drag a copy of the left eye to the right side of the face so that the two eyes are level. 

 

6.  Hold down Shift+Alt, and drag a copy of the eye to the right side of the face.   

 

 

7.  Choose Select>Deselect.  Choose File > Save. 

 

 

 
Eye moved onto left side of 

face 

Duplicate of eye moved with 

Sift+Alt 

 

Using the Quick Selection Tool 

 
Next you’ll select the kiwi fruit for the melon’s mouth and then move it onto the melon using the Quick 

Selection Tool.  

 

1.  Select the quick selection tool from the toolbar. 

 

2.  Click the left mouse button and drag it slowly over the surface of the kiwi until it is selected.  If  you 

accidentally select outside the kiwi, hold down the alt key and drag over the area you want to deselect.   

 

3.  With the quick selection tool still selected, hold down Control and position the pointer within the 

selection. A pair of scissors appears with the pointer to indicate the selection will be cut from its current 

location. 

 

4.  Drag the kiwi mouth onto the face. Do not deselect. 
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      Selection to be cut Selection moved onto 

melon 

 

 

Moving with the arrow keys 
 

You can make minor adjustments to the position of a selection using the arrow keys, which allow you to 

nudge the selection 1 pixel or 10 pixels at a time. 

 

Note:  The arrow keys adjust the position of a selection only if you’ve already moved the selection or if you 

have the move tool selected. If you try the arrow keys on a selection that has not yet been moved, they will 

adjust the selection border, not the part of the image that is selected. 

 

1.  Press the up arrow key a few times to move the mouth upward. Notice that each time you press the 

arrow key, the mouth moves in 1-pixel increments. Experiment with the other arrow keys to see how they 

affect the selection. 

Sometimes, the border around a selected area can distract you as you make adjustments. You can hide the 

edges of a selection temporarily without actually deselecting and then display the selection border once 

you’ve completed the adjustments. 

 

2.  Choose View > Show > Selection Edges. The selection border around the mouth disappears. 

 

3.  Now hold down Shift and press an arrow key. Notice that the selection moves in 10-pixel increments. 

 

4.  Use the arrow keys to nudge the mouth until it is positioned where you want it. Then choose View > 

Show > Selection Edges. 

 

5.  Choose File > Save. 

 

Selecting with the magic wand 

 

The magic wand tool lets you select adjacent pixels in an image based on their similarity in color. 

You’ll use the magic wand tool to select the pear tomato, which you’ll use as a nose for the face. 

 

1.  Select the magic wand tool in the toolbox.  The Options bar will appear at the top of the screen. 

 

Note:  Most tools in the toolbox come with their own options bar (at the top of the screen) which allow you 

to change the way the tools work. 

 

 
Example of options bar for magic wand 

 

In the Magic Wand Options bar, the Tolerance setting controls how many similar tones of a color are 

selected when you click an area. If you set the tolerance to 20, for example, then 20 similar lighter tones 

and 20 similar darker tones will be selected. 

 

2.  For Tolerance, enter 50 to increase the number of shades that will be selected. 

 

3. Click the magic wand tool anywhere within the pear tomato. Most of it will be selected. 
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4.  To select the remaining area of the pear tomato, hold down Shift and click the unselected areas. 

Notice that a plus sign appears with the magic wand pointer indicating that you’re adding to the current 

selection. 

 

 

 

 

 

 

 

 

 

 

 

 

5.  To make the edges a bit smoother, go to Select>Refine 

Edges.  Find the slider next to Smooth and drag it to about 10.  

Press OK to accept the change. 

 

6. When the pear tomato is completely selected, hold down 

Control, position the pointer within the selection, and drag the 

tomato nose onto the melon face. 

 

7.  Choose Select > Deselect. 

 

8.  Choose File > Save. 

 

Selecting with the lasso tool 
 

You can use the lasso tool to make selections that require both freehand and straight lines. You’ll select a 

bow tie for the face using the lasso tool this way. It takes a bit of practice to use the lasso tool to alternate 

between straight line and freehand selections—if you make a mistake while you’re selecting the bow tie, 

simply deselect and start again. 

 

1.  Select the zoom tool, and click twice on the bow tie pasta to enlarge its view to 300%. 

 

2.  Select the lasso tool. Starting at the top left corner of the bow tie pasta, drag to the right to create a 

freehand outline across the curves at the top of the bow tie. Continue holding down the mouse. 

  

3.  Select the right edge of the bow tie, hold down Alt, release the mouse button, and then begin outlining 

with short, straight lines by clicking along the edge. (Notice that the pointer changes from the lasso icon to 

the polygon lasso icon.) When you reach the bottom right corner of the bow tie, do not release the mouse 

button. 

 

 
 Freehand outline with 

lasso tool. 

Straight-line outline 

with polygon lasso 

tool.   

Completed selection 

(outline crosses starting 

point). 

 

4.  Release Alt and drag to the left to create a freehand outline across the bottom of the bow tie. (The 

pointer returns to the lasso icon.) 

 
Initial Selection Adding to selection 

(Shift key 

depressed) 

Complete 

selection 
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5.  Hold down Alt again, and click the mouse button along the left edge of the bow tie to draw straight 

lines. 

 

6.  To complete the selection, make sure that the last straight line crosses the start of the selection, release 

Alt, and then release the mouse button. 

 

7.  Choose View > Fit on Screen to resize the document to fit on your screen. 

 

8.  Hold down Control and drag the bow tie selection to the bottom of the melon face. 

 

9.  Choose File > Save. 

 

 

Adding and subtracting selections 
 

Holding down Shift while you are selecting an area adds to the current selection; holding down Alt 

subtracts from the selection. You’ll now use these techniques with the lasso tool to perfect a rough 

selection of the mushroom image. The mushroom will become a hat for the melon face. 

 

1.  Select the zoom tool, and click twice on the mushroom to enlarge its view to 300%. 

 

2.  Select the lasso tool, and drag a rough outline around the mushroom (include some of the area outside 

the mushroom and some of the stem). 

 

3.  Hold down Shift. A plus sign appears with the lasso tool pointer. 

 

4.  Drag the lasso tool around an area you want to add to the selection; then release the mouse button. The 

area is added to the current selection. 

 

 
    Initial selection Adding to selection 

(Shift key depressed) 

Result 

 

Note: If you release the mouse button while drawing a selection with the lasso tool, the selection closes 

itself by drawing a straight line between the starting point and the point where you release the mouse. 

To create a more precise border, end the selection by crossing the starting point. 

 

Next, you’ll remove, or subtract, part of the selection. 

 

5.  Hold down Alt.  A minus sign appears with the lasso tool pointer. 

 

6.  Drag the lasso tool around an area you want to remove from the selection; then repeat the process until 

you’ve finished removing all the unwanted parts of the selection. 

 

 
Selection Subtracting from selection 

(Alt depressed) 

Result 
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7.  Choose View > Fit on Screen. 

 

8.  To move the mushroom hat onto the melon head, hold down Alt+Control and drag a copy of the 

mushroom to the top of the melon. 

 

9.  Choose File > Save. 

 

Selecting with the magnetic lasso 
 

You can use the magnetic lasso tool to make freehand selections of areas with high contrast edges.  When 

you draw with the magnetic lasso, the border automatically snaps to the edge you are tracing. You can also 

control the direction of the tool’s path by clicking the mouse to place occasional fastening points in the 

selection border. 

 

You’ll now make an ear for the melon face by using the magnetic lasso to select the red part of the 

grapefruit slice. 

 

1.  Select the zoom tool, and click the grapefruit slice to zoom in to a 200% view. 

 

2.  Hold down the mouse button on the lasso tool in the toolbox, and drag to the magnetic lasso tool to 

select it. 

 

3.  Now click once at the lower left corner of the red flesh of the grapefruit slice, release the mouse button, 

and begin tracing the outline of the flesh by dragging to the right over the curved upper edge. Notice that 

the tool snaps to the edge and automatically puts in fastening points. 

 

If you think the tool is not following the edge closely enough (in low contrast areas), you can place your 

own fastening point in the border by clicking the mouse button. You can add as many fastening points as 

you feel necessary. You can also remove fastening points and back up in the path by pressing the Delete 

key and moving the mouse back to the last remaining fastening point. 

 

4.  When you reach the lower right corner of the grapefruit flesh, double-click the mouse button, which 

signals the magnetic lasso tool to return to the starting point and close the selection. Notice that the tool 

automatically follows the remaining edge of the flesh as it completes the border. 

 

 
Laying down fastening 

points 

Removing fastening 

points 

Double-clicking at 

corner to close path. 

 

You can now move the selected part of the grapefruit next to the melon. 

 

5.  Double-click the hand tool to fit the image on screen. 

 

6.  Click the move tool, and drag the grapefruit ear to the middle of the left side of the melon face.  Do not 

deselect. 

 

7.  Choose File > Save. 
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Transforming a selection 
 

Next you’ll use the Free Transform command to rotate and scale the melon’s left ear, and then you’ll 

duplicate and flip a copy to create a right ear. 

 

1.  Choose Edit > FreeTransform. A bounding box appears around the ear selection. 

 

2.  To rotate the ear, position the pointer outside a corner handle until you see a double-headed arrow, and 

then drag in the direction you want the ear to rotate. Notice that the ear rotates around the selection’s center 

point ( ). 

 

3.  To scale the ear, position the pointer directly on one of the corner handles, and drag to reduce the size of 

the ear.  To scale the ear proportionately, hold down Shift as you drag. 

 

4.  To reposition the ear, place your pointer within the bounding box, but not on the center point, and drag. 

 

Note:  If you place the pointer on the center point and drag, you will move the center point.  

 

 

 
Dragging outside border 

to rotate ear 

Dragging on corner to 

scale ear 

Dragging within border 

to reposition ear 

 

5.  When you have the ear positioned correctly, press Enter to apply the transformation. The ear remains 

selected. You will now move a copy of the ear to the right side of the face, flip the ear horizontally, and 

fine tune its placement. 

 

6.  Position the pointer within the ear selection, hold down Shift+Alt and drag a copy of the ear to the right 

side of the face. 

 

7. Choose Edit > Transform > Flip Horizontal. 

 

8. If necessary, place the pointer within the selection, and drag to reposition it next to the melon face. 

 

9.  If necessary, choose Edit > Free Transform, rotate the ear to fit the right side of the face, and press 

Enter to complete the transformation. 

 

10.  Choose File > Save. 

 

Combining selection tools 
 

As you already know, the magic wand tool makes selections based on color. If an object you want to select 

is on a solid-colored background, it can be much easier to select the object and the background and then use 

the magic wand tool to subtract the background color, leaving the desired object selected.   

 

You’ll see how this works by using the rectangular marquee tool and the magic wand tool to select radish 

eyebrows for the face. 

 

1. Hold down the mouse button on the elliptical marquee tool, and drag to the rectangular marquee tool. 
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2. Drag a selection around the radishes. Notice that some of the white background is included in the 

selection.  At this point, the radishes and the white background area are selected. You’ll subtract the white 

area from the selection, resulting in only the radishes being selected. 

 

3.  Click the magic wand tool in the toolbox; then hold down Alt.  A minus sign appears with the magic 

wand pointer. 

 

4.  Click anywhere in the white area surrounding the radishes. Now only the radishes are selected. 

 

 
Initial selection Subtracting from selection 

with Alt magic wand 

Result 

 

5.  To duplicate and move the radish eyebrow to the melon face, hold down Alt+Control, and drag the 

radish above the left eye on the melon face.  Do not deselect. 

 

6.  On the options bar, place a check in the box next to Show Transform Controls.   
 

 
 
To scale the eyebrow, position the pointer directly on one of the corner handles, and drag to reduce the size 

of the eyebrow.  To scale proportionately, hold down Shift as you drag. 
 

 

6.  Hold down Shift+Alt+Control position the pointer within the selection, and drag to duplicate and 

reposition another eyebrow above the right eye. 

 

 
Left eyebrow placed 

with Alt+Control  

Right eyebrow placed with 

Shift+Alt+Control 

Right eyebrow flipped 

horizontally 

 

 

 

7.  Choose Edit > Transform > Flip Horizontal to adjust the right eyebrow. If you like, reposition the 

eyebrow using any of the methods you’ve learned. 
 

8.  Choose File > Save. 
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Cropping the completed image 

 

To complete the artwork, you’ll crop the image to a final size. 
 

1. Choose the crop tool from the toolbox.  
 

2.  Move the pointer into the image window, and drag diagonally from the top left to the bottom right 

corner of the completed artwork to create a crop marquee. 
 

 
 

3.  If you need to reposition the crop marquee, position the pointer anywhere inside the marquee and drag. 
 

4.  If you want to resize the marquee, drag a handle. 
 

5.  When the marquee is positioned where you want it, press Enter to crop the image. 

 

6.  Choose File > Save.  The fruit-and-vegetable face is complete. 
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Tutorial 
ADOBE PHOTOSHOP CS6/CC 

 

Lesson 2:  Layer Basics 

 

 
Adobe® Photoshop® lets you isolate 

different parts of an image on layers.  Each 

layer can then be edited as discrete 

artwork, allowing unlimited flexibility in 

composing and revising an image. 

 
 
 

In this lesson, you’ll learn how to do the following: 

 Organize your artwork on layers. 

 Create a new layer. 

 View and hide layers. 

 Select layers. 

 Remove artwork on layers. 

 Reorder layers to change the placement of artwork in the image. 

 Apply modes to layers to vary the effect of artwork on the layer. 

 Link layers to affect them simultaneously. 

 Apply a gradient to a layer. 

 Add text and layer effects to a layer. 

 Save a copy of the file with the layers flattened. 
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Organizing artwork on layers 
 
Every Adobe Photoshop image contains one or more layers; every new file is created with a 

background, which can be converted to a layer. You can view and manipulate layers in 

Photoshop with the Layers panel. 

 

All new layers in an image are transparent until you add artwork (pixel values). Working with 

layers in Photoshop is analogous to placing portions of a drawing on sheets of acetate—individual 

sheets of acetate may be edited, repositioned, and deleted without affecting the other sheets and 

when the sheets are stacked, the entire drawing is visible. 

 
Getting started 
 

Begin by opening the finished art file to see what you’ll be creating. 
 

1.  Choose File > Open. Locate and open the Lesson02 folder.  Select End02.psd and click Open. 

A collage of business images is displayed. 
 

2.  If you like, choose View > Zoom Out to make the image smaller and leave it on your screen as 

you work. If you don’t want to leave the image open, choose File > Close. 

 

Now, you’ll open the start file and work with the image as you learn about the Layers panel and 

layer options. 
 

3.  Choose File > Open. Locate and open the Lesson02 folder, select Start02.psd, and click Open. 
 

4.  Choose File > Save As, locate your H: drive, type the name Work02.psd, and click Save. 

 
Creating and viewing layers 
 

To begin, you’ll create a new layer in the Work02.psd file by bringing in an image from another 

file. 
 

1.  Choose File > Open. Locate and open the Lesson02 folder. Then select Clock.psd from the list 

of files.  The Clock.psd wil open in its own tab in Photoshop. 

 

  
Clock image in Clock.psd Clock image moved into Work02.psd 

 
 

2.  Go to Select  > All, then Edit > Copy.  Switch to the Work02.psd tab.  Go to Edit > Paste.  The 

clock now appears on its own layer, Layer 1, in the Work02.psd file’s Layers panel. 
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Note:  If the Layers panel is not visible on your screen, choose Window > Layers.  

 

3. Close the Clock.psd tab. 

 

You can use the Layers panel in a Photoshop file to hide, view, reposition, delete, rename, and 

merge layers. The Layers panel displays all layers with the layer name and a thumbnail of the 

layer’s image that is automatically updated as you edit the layer. 

 

You will now use the Layers panel Options dialog box to rename Layer 1 with a more descriptive 

name. 
 
 

4.  In the Layers panel, double-click on the name “Layer 1”. 
  

 

5.  Type the name Clock and press Enter. Layer 1 is now renamed Clock in the Layers panel. 

 

The Layers panel shows Work02.psd contains three layers in addition to the Clock layer, some of 

which are visible and some of which are hidden. The eye icon to the far left of a layer name in the 

panel indicates that the layer is visible. You can hide or show a layer by clicking this icon. 
 

6.  Click the eye icon next to the Clock layer to hide the clock. Click again to redisplay it. 

 
Selecting and removing artwork on a layer 
 

Notice that when you moved the clock image onto the keyboard in Work02.psd, you also moved 

the white area surrounding the clock. This opaque area blocks out part of the keyboard image, 

since the clock layer sits on top of the keyboard, or background. 

 

You’ll now remove the white area from around the clock image on the Clock layer. 
 

1.  Make sure that the Clock layer is selected. To select the layer, click the layer name in the 

Layer panel. The layer is highlighted, indicating the layer is active. 
 

2.  To make the opaque areas on this layer more obvious, hide the keyboard by clicking the eye 

icon in the Layers panel to the left of the background layer name. The keyboard image 

disappears, and the clock displays on a checkerboard background. The checkerboard indicates 

transparent areas on the active layer. 
 

3.  Now select the magic wand tool.  In the options bar, set the Tolerance to 10.  Click the white 

area surrounding the clock to select it, and press the delete key to delete the selection. Notice that 

the checkerboard fills in where the white area had been, indicating this area is now also 

transparent. 
 

4.  Choose Select > Deselect. 
 

5.  Turn the background back on by clicking the eye icon column next to its layer name. The 

keyboard image now shows through where the white area on the Clock layer was removed. 
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Rearranging layers 
 

In Photoshop, the order in which the layers of an image are organized is called the stacking order.  

The stacking order of layers determines how the image is viewed—you can change the order to 

make certain parts of the image appear in front of or behind other layers. 

 

Next you’ll rearrange layers in the Work02.psd file so that the clock image moves in front of the 

other images in the file. 
 

1. Make the Gauge and Bearing layers visible by clicking the eye icon column next to their 

layer names. Notice that the clock image is partly covered up by the other images in the file. 

 

  
Making all layers visible Result 

 

2.  Click the Clock layer in the Layers panel, and drag upward to position it at the top of the 

panel. When you see a thick black line above the Gauge layer, release the mouse button. The 

Clock layer moves to the top of the panel’s stacking order, and the clock image appears in front 

of the other images. 

 

 
Result 
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 Changing the opacity and mode of a layer 
 
The clock image now blocks out any images that lie on layers below it. You can reduce the 

opacity of the clock layer, which allows other layers to show through it. You can also apply 

different blending modes to the layer, which affect how the clock image blends with the layers 

below it. 
 

1. With the Clock layer still active, click the arrow next to the Opacity text box in the Layers 

panel and drag the slider to 50%. The clock becomes partially transparent, and you can see 

the layers underneath. Note that the change in opacity affects only the image areas on the 

Clock layer. 

 

  
Changing opacity Result 

 

2.   Next try applying some blending modes to the Clock layer. Choose Difference and then 

Darken from the mode menu (to the left of the Opacity text box), and notice the effect on the 

clock image.  Then select the Screen mode, which is the mode we used for our example, and 

change the opacity to 90%. 
 

  
Changing mode and opacity Result 

 

3.  Choose File > Save. 

 

Linking layers 
 

An efficient way to work with layers is to link two or more of them together. By linking layers, 

you can move and transform them simultaneously, thereby maintaining their alignment to each 

other.  You’ll now move the clock image away from the bearing image; link the two layers; and 

then reposition, scale, and rotate them together. 
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1.  Select the move tool, and drag the clock to the bottom right corner of the collage so that just 

the top half of the clock face is visible. 
 

 
 

2.  With the Clock layer active in the Layers panel, hold down the ctrl key and click the Bearing 

layer.   Both should now be highlighted.  Click the chain  at the bottom of the layers panel to 

link the two layers. 
 

3.  Position the move tool in the image window, and drag toward the top margin of the image. 

Notice that the clock and bearing images move simultaneously. 

 

  
Linking Clock layer to Bearing layer Result of moving layers 

simultaneously 

 

Now you’ll try scaling and rotating the linked layers by using the Free Transform command. 
 

4.  Choose Edit > Free Transform. A transformation bounding box appears around the elements 

(note – you may need to zoom out to see the entire box.) 
 

5.  To rotate the clock, position the pointer outside one of the handles until you see a double-

headed arrow, drag the face clockwise, and release the mouse button. Notice the bearing rotates 

as well. 
 

6. Hold down Shift, drag on a handle of the bounding box, and scale the clock and bearing to a 

smaller size. 



151 

 
 

7.  If necessary, position the pointer inside the bounding box, and drag to reposition the two 

images. 
 

8.  Press Enter to apply the transformation changes. 

 

9.  Choose File > Save. 

 
Adding a gradient to a layer 
 
Next, you’ll create a new layer and add a gradient effect to it. You can add a layer to a file with 

the New Layer command, which creates a transparent layer with no artwork on it. If you then add 

a special effect to the layer, such as a gradient, the effect is applied to any layers stacked below 

the new layer. 
 

1.  In the Layers panel, click the background to make it active. 
 

2.  Go to Layer > New > Layer. 

 

3.  In the New Layer dialog box, type the name Gradient, and press Enter. Drag the Gradient layer 

so it appears just above the background in the Layers panel. You can now apply a gradient to 

the new layer. A gradient is a gradual transition between one or more colors. In Photoshop, 

you control the type of transition using the gradient tool. 
 

4.  Select the gradient tool in the toolbox to select the tool and its Options bar. 
 

5.  In the Options panel, choose Foreground to Transparent for the type of Gradient. 

 

 

 
Gradient Options panel Swatches panel 

 

6.  Click the Swatches panel tab to bring it to the front of its panel group, and select a shade of 

purple 
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7.  With the Gradient layer active in the Layers panel, drag the gradient tool from the right to the 

left margin of the image. The gradient extends over the width of the layer, starting with purple 

and gradually blending to transparent, and affects the look of the keyboard on the layer below it. 

Because the gradient partially obscures the keyboard, you’ll now lighten the effect by changing 

the Gradient layer’s opacity.  
 

8.  In the Layers panel, change the opacity for the Gradient layer to 60%. The full keyboard 

should show through the gradient. 
 

 
 

9.  Choose File > Save. 
 

Adding text 
 
Now you’re ready to create and manipulate some text. You’ll create the text with the type tool, 

which places the text on its own type layer. You’ll then edit the text and apply a special effect to 

that layer. 
 

1.  In the Layers panel, click the Clock layer to make it active. 
 

2.  Select the horizontal type tool, and click the image in the upper left corner. 
 

3.  Click the color box on the Type Tool option bar, select a beige color from the color picker, 

and click OK. 
 

4.  Choose a font from the Font menu in the option bar, and enter a point size in the Size text box 

(we used 70-point Britannic Bold). 

5. Type “Z2000” in the large text box at the 

bottom of the dialog box. The text is 

automatically placed on a new layer in the 

upper left corner of the image where you 

clicked. 
 

 
 

6.  Move the cursor into the image area, where the cursor temporarily changes to the move tool, 

and reposition the text. 
 

7.  When the text is placed where you want it, click Control-Enter.  OK. Notice that the Layers 

panel now includes a layer named Z2000 with a T icon next to the name, indicating it is a type 

layer. 



153 

 

8.  Choose File > Save. 
 
Adding a layer effect 
 

You can enhance a layer by adding a shadow, glow, bevel, or emboss special effect from the 

program’s collection of automated layer effects. These effects are easy to apply and link directly 

to the layer you specify. 

 

You’ll now apply a bevel and emboss layer effect to the type. 
 

1.  With the Z2000 type layer still active, choose Layer > Layer Style > Bevel & Emboss. 
 

2.  In the Effects dialog box, change the opacity for Highlight to 20%. Then click the Highlight 

color box, select a color from the color picker (we chose a light blue). 
 

3.  Next change the opacity for Shadow to 40%. Click the Shadow color box, and select a color 

from the color picker (we chose black). 
 

4. Select Emboss from the Style menu, and click OK to apply the layer effect to the type.   

 

 

 

 

 

 

Layer effects are automatically applied to changes you make to a layer. You can edit the text and 

watch how the layer effect tracks the change. 
 

 

5. Double-click on the “T” the Z2000 type layer in the Layers 

panel.  

 
 

6. Select “Z2000” in the image and change it to “Z999.” 
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7.  Reselect the text, enter a larger point size in the Size text box 

(we used 90 points), and click Control-Enter. Note that the 

layer effect is applied to the revised text. 
 
8.  Choose File > Save. 

 
 
 
 

Flattening and saving files 
 

When you have edited all the layers in your image, you can make a copy of the file with the 

layers flattened. Flattening a file’s layers merges them into a single background layer, thus greatly 

reducing the file size. Note that you shouldn’t flatten an image until you are certain you’re 

satisfied with all your design decisions. In most cases, you will also want to retain a copy of the 

file with its layers intact, in case you later need to change a layer. 

 

To save a flattened version of the file, you will use the Save a Copy command. 
 

1.  Choose File > Save as. 
 

2.  In the dialog box, type the name Flat02.psd, check the As a Copy box and uncheck the box 

next to layers (to choose not to save the layers). 
 

3.   Click Save. The Save as command saves a flattened version of the file while leaving the 

original file and all its layers intact. 

 

 

Your collage of business images is 

now complete. 
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Tutorial 

ADOBE PHOTOSHOP CS 

Lesson 3:  Photo Retouching 

Adobe® Photoshop® provides you with a variety of tools and commands for improving the 

quality of a photographic image. This lesson explains techniques for basic image correction by 

stepping you through the process of acquiring, resizing, and retouching a photo intended for a 

print layout. 
 

 

 

In this lesson, you will learn to do the following: 
 

 Choose the correct resolution for a scanned photograph. 

 Crop an image to final size. 

 Adjust the tonal range of an image. 

 Remove a color cast from an image using an adjustment layer. 

 Use the Replace Color command to change the hue and saturation of a selected color in a 

photograph. 

 Adjust the saturation and brightness of isolated areas of an image using the sponge and 

dodge tools. 

 Use the rubber stamp tool to eliminate an unwanted object from an image. 

 Replace parts of an image with another image. 

 Apply the Unsharp Mask filter to finish the photo-retouching process. 

 Save an Adobe Photoshop file in a format that can be used by a page layout program. 

 

Strategy for retouching 
 

In Photoshop, you can retouch photographic images in ways once left only to highly trained 

professionals. You can correct problems in color quality and tonal range created during the 

original photography or during the image’s scan. You can also correct problems in composition 

and sharpen the overall focus of the image. 

 
Basic steps 
Most retouching in Photoshop follows these general steps: 

 

 Check the scan quality and make sure that the resolution is appropriate for how the image 

will be used. 

 Crop the image to final size. 

 Adjust the overall contrast or tonal range of the image. 

 Remove any color casts. 

 Adjust the color and tone in specific parts of the image to bring out highlights, midtones, 

shadows, and desaturated colors. 

 Sharpen the overall focus of the image. 

 

Intended use 
The retouching techniques you apply to an image depend in part on how the image will be used. 
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Whether an image is intended for black-and-white publication on newsprint or for full-color 

Internet distribution will affect everything from the resolution of the initial scan to the type of 

tonal range and color correction the image requires. 

 

To illustrate one application of retouching techniques, this lesson takes you through the steps of 

correcting a photograph intended for four-color print publication. The image is a scanned 

photograph of Venice that will be placed in an Adobe InDesign layout for an A4-size magazine. 

The original size of the photo is 5 inches x 7 inches and its final size in the print layout will be 

3.75 inches x 6 inches. 
 

 
 

Resolution and image size 
 

The first step in retouching a photograph in Photoshop is to make sure that the image is the 

correct resolution. The term resolution refers to the number of small squares known as pixels that 

describe an image and establish its detail. Resolution is determined by pixel dimensions or the 

number of pixels along the width and height of an image. 

 
Types of resolution 
 

In computer graphics, there are different types of resolution:  The number of pixels per unit of 

length in an image is called the image resolution, usually measured in pixels per inch (ppi). An 

image with a high resolution has more pixels, and therefore a larger file size, than an image of the 

same dimensions with a low resolution. 

 

The number of pixels per unit of length on a monitor is the monitor resolution, usually measured 

in dots per inch (dpi). In Adobe Photoshop, image pixels are translated directly into monitor 

pixels. 

 

Thus, if the image resolution is higher than the monitor resolution, the image appears larger on 

screen than its specified print dimensions. For example, when you display a 1-inch-by-1-inch, 

144-ppi image on a 72-dpi monitor, the image fills a 2-inch-by-2-inch area of the screen. 
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3.75 in x 6 in @ 72 
ppi; file size 342 

100% view on 
screen 

3.75 in x 6 in @ 200 
ppi; file size 2.48 MB 

100% view on 
screen 

 

The number of ink dots per inch produced by an imagesetter or laser printer is the printer or 

output resolution. Higher resolution printers combined with higher resolution images generally 

produce the best quality. The appropriate resolution for a printed image is determined both by the 

printer resolution and by the screen frequency or lines per inch (lpi) of the halftone screens used 

to reproduce images. 

 
Resolution for this lesson 
 

To determine the image resolution for the photograph in this lesson, we followed the computer 

graphics rule of thumb for color or grayscale images intended for print on large commercial 

printers: Scan at a resolution 1.5 to 2 times the screen frequency used by the printer. Because the 

magazine in which the image will be printed uses a screen frequency of 133 lpi, the image was 

scanned at 200 ppi (133 x 1.5). 

 

Getting started 
 

Open the final image to see how the adjustments you’ll make affect the final artwork. 
 

1.  Choose File > Open. Locate and open the Lesson03 folder. Then select End03.psd and click 

Open. 
 

2.  If you like, choose View > Zoom Out to make the image smaller, and leave it on your screen 

as you work. If you don’t want to leave the image open, choose File > Close. 

Now open the start file to view the photograph you will be retouching. (Although the photograph 

for this lesson was originally scanned at 200 dpi as described above, the file in which you will be 

working is actually a low-resolution file. The resolution was changed to limit the file size and to 

make work on the exercises more efficient.) 
 

Choose File > Open. Locate and open the Lesson03 folder, select Start03.psd, and click Open. 
 

4.  Choose File > Save As, select your H: drive, type the name Work03.psd, and click Save. 

 
Cropping an image 
 

Once you’ve scanned an image and opened it in Photoshop, you’re ready to retouch it. To start, 

you’ll use the crop tool to scale the photograph for this lesson so that it fits the space designed for 

it. 
 

1.  Select the crop tool. 
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2.  Next drag a marquee around the image, making sure you include the top of the tower and the 

orange tarp in the bottom right gondola. Because the photograph was scanned in slightly 

crooked, you’ll now use the crop tool to straighten the image before applying the new 

dimensions to it. 
  

3.  Move the pointer outside the crop marquee, and drag the image until the marquee is parallel 

with the sides of the image.   
 

4.  Place the pointer within the crop marquee, and drag the edges of the marquee until the edges 

of the marquee line up with the edges of the image.  There should be no black showing at all 

within the marquee. 

 

   
Initial Crop Marquee Rotated Image Image Cropped 

 

 

5.  Press Enter. The image is now cropped. 
 

 

6.  Choose File > Save. 

 
Adjusting the tonal range 
 

The tonal range of an image represents the amount of contrast, or detail, in the image and is 

determined by the image’s distribution of pixels, ranging from the darkest pixels (black) to the 

lightest pixels (white). You’ll now correct the photograph’s contrast using the Levels command. 
 

1.  Choose Image > Adjustments > Levels, and make sure that the Preview option is checked. 

 

Notice the histogram in the dialog box. The triangles at the bottom of the histogram represent the 

shadows (black triangle), highlights (white triangle), and midtones or gamma (gray triangle). If 

your image had colors across the entire brightness range, the graph would extend across the full 

width of the histogram, from black triangle to white triangle. Instead, the graph is clumped 

toward the center, indicating there are no very dark or light colors. 
  

You can adjust the black and white points of the image to extend its tonal range. 
 

2.  Drag the left and right triangles inward to where the histogram indicates the darkest and 

lightest colors begin. Click OK to apply the changes. 
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3.  Choose Image > Adjustments > Levels to view the new histogram. The tonal range now 

extends throughout the entire range of the histogram. Click OK. 
 

4.  Choose File > Save. 

 
Removing a color cast 
 

Some images contain color casts (imbalances of color), which may occur during scanning or 

which may have existed in the original image. The photograph of the gondolas has a color cast—

it’s too red. 

 

You will now use a Color Balance adjustment layer to correct the photograph’s color cast. An 

adjustment layer lets you edit an image as many times as you like without permanently changing 

the original pixel values. Using an adjustment layer to adjust color balance is a particular 

advantage for images you plan to print. After you see the color proof or printed copy, you can 

make additional changes to the image, if necessary. 
 

1.  Choose Layer > New Adjustment Layer > Color Balance 
 

2.  Click OK to create the adjustment layer and to 

display the Color Balance Layer dialog box. 

 

4.  Make sure the Preview option is checked. 
 

5.  To adjust the midtones so that they’re less red, drag 

the top slider to the left (we used -15) and the middle 

slider to the right (we used +8). 
 

6.  Click the double arrows at the top right of the panel 

to hide it.  Notice that a Color Balance layer has 

appeared in the Layers panel. 
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7.  In the Layers panel, click the eye icon next to the Color Balance layer to hide and show the 

layer.  You’ll see the difference between the adjusted colors and the original colors. 
 

8.  Choose File > Save. 

 

Note:  When you double-click an adjustment layer in the Layers panel, the corresponding dialog 

box appears, where you can edit the values of the adjustment layer. 

 
Replacing colors in an image 
 

With the Replace Color command, you can create temporary masks based on specific colors and 

then replace these colors.  Masks let you isolate an area of an image, so that changes affect just 

the selected area and not the rest of the image. Options in the Replace Color command’s dialog 

box allow you to adjust the hue, saturation, and lightness components of the selection.  Hue is 

color, saturation is the purity of the color, and Lightness is how much white or black is in the 

image. 

 

You’ll use the Replace Color command to change the color of the orange tarp in the gondola at 

the bottom right corner of the image. 
 

1.  In the Layers panel, select the background. 
 

2.  Select the zoom tool, and click once on the tarp to zoom in on it. 
 

3.  Select the rectangle marquee tool, and then drag a selection around the tarp. Don’t worry about 

making a perfect selection, but be sure to include all the tarp. 
 

 
 

4.  Choose Image > Adjustments > Replace Color to open the Replace Color dialog box. By 

default, the 

Selection area of the Replace Color dialog box displays a black rectangle, representing the current 

selection. 

 

You will now use the eyedropper tool to select the area of color that will be masked and replaced 

with a new color. Three eyedropper tools are displayed in the Replace Color dialog box. 
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The first eyedropper tool selects a single 

color, the eyedropper-plus tool is used to add 

colors to a selection, and the eyedropper-

minus tool is used to subtract colors from a 

selection. 

 

 
 

5.  Click the eyedropper tool in the dialog box, and click once on the orange tarp to select it. 

 
 

6.  Then select the eyedropper-plus tool, and drag over the other areas of the tarp until the entire 

tarp is highlighted in white in the dialog box. 
 

7.  In the Transform area of the Replace Color dialog box, drag the Hue slider to 149, the 

Saturation slider to –17, and the Lightness slider to -39. The color of the tarp is replaced with the 

new hue, saturation, and lightness. 
 

8.  Click OK to apply the changes. 
 

9.  Double-click the hand tool to fit the image on screen. 
 

10.  Choose Select > Deselect. 
 

11.  Choose File > Save. 
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Adjusting saturation with the sponge tool 
 

Now you’ll saturate the color of the gondolas in the foreground using the sponge tool. When you 

change the saturation of a color you adjust its strength or purity. The sponge tool is useful in 

letting you make subtle saturation changes to specific areas of an image. 
 

1.  Hold down the mouse button on the dodge tool in the toolbox, and drag to the sponge tool. 
 

2.  On the Options bar, and choose Saturate from the Mode drop-down menu. To set the intensity 

of the saturation effect, click the arrow next to the Flow text box, and drag the slider to 90%. 
 

3.  Choose a large, feathered brush and set the size to around 17px. 
 

 
 

4.  Drag the sponge back and forth over the gondolas to saturate their color. 
 

 
Adjusting lightness with the dodge tool 
 

Next you’ll use the dodge tool to lighten the highlights along the gondola’s hull and exaggerate 

the reflection of the water there. The dodge tool is based on the traditional photographer’s method 

of holding back light during an exposure to lighten an area of the image. 
 

1.  Hold down the mouse button on the sponge tool, and drag to the dodge tool.  

 

2.  From the Options bar, select a feathered brush and set the size to 13px, choose Highlights 

from the Range menu, then set the Exposure to 50%.   

 

 
 

3.  Drag the dodge tool back and forth over the gondola’s hull to bring out its highlights. 
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Removing unwanted objects 
 

With Adobe Photoshop, you can remove unwanted objects from a photograph. Using the rubber 

stamp tool, you can remove an object or area by “cloning” an area of the image over the area you 

want to eliminate. 

 

You’ll eliminate the small boat near the center of the image by painting over it with a copy of the 

water. 
 

1.  Select the zoom tool; then click the small boat to magnify that part of the image. 
 

2.  Select the clone stamp tool in the toolbox, and make sure that the Aligned checkbox in the 

Clone Stamp Options panel is deselected (unchecked).  Set the brush size to 5 px from the Brush 

drop-down menu. 
 

3.  Center the clone stamp tool over the water between the large gondola and the post to its right. 

Then hold down Alt, and click to sample or copy that part of the image.  
 

 
 

5.  Drag the clone stamp tool over the boat to paint over it with a copy of the water you just 

sampled. Notice the crosshair that follows your cursor as you paint; it represents the point from 

which the rubber stamp tool is cloning. 
 

6.  Double-click the hand tool in the toolbox to fit the image on screen. 
 

7.  Choose File > Save. 
 

Replacing part of an image 
 

Because the sky is fairly drab and overcast in this photograph, you’ll replace it with a more 

interesting sky from another file. You’ll begin by selecting the current sky. 
 

1.  Select the Quick Selection tool. Drag it over each part of the sky to select it. 
 

2.  Open the Clouds.psd file located in the Lesson03 folder. 
 

3.  Choose Select > All; then choose Edit > Copy. Close the Clouds.psd file. 
 

4.  Choose Edit > Paste Special > Paste Into   to paste the clouds into the current selection. 

Notice that a new layer has been added to the Layers panel. 
 

5.  Select the move tool, and drag the clouds into the position you want. 
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Now you’ll change the clouds’ opacity to make them blend better with the rest of the image. 
 

6.  Make sure the layer with the clouds is selected in the layers panel and bring down the opacity 

of the layer until it matches the rest of the picture (we used 55%). 
 

7.  Choose File > Save. 

 

 
Opacity set to 55% Result 

 

You will now flatten the image into a single layer so that you can apply the Unsharp Mask filter, 

the final step in retouching the photo. Because you may want to return to a version of the file with 

all its layers intact, you will use the Save As command to save the flattened file with a new name. 
 

8.  Choose Layer > Flatten Image. 
 

9.  Choose File > Save As.  Name the new image Flatten03.psd, and click Save. 
  

Applying the Unsharp Mask filter 
 

The last step you take when retouching a photo is to apply the Unsharp Mask filter, which adjusts 

the contrast of the edge detail and creates the illusion of a more focused image. 
 

1.  Choose Filter > Sharpen > Unsharp Mask. Make sure that the Preview option is selected so 

that you can view the effect before you apply it. To get a better view, you can place the pointer 

within the preview window and drag to see different parts of the image.  
 

2.  Drag the Amount slider until the image is as sharp as you want (we used 120%); then click 

OK to apply the Unsharp Mask filter. 
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Saving the image 
 

Before you save a Photoshop file for use in a four-color publication, you must change the image 

to CMYK color mode so that it will be printed correctly in four-color process inks.  
 

1.  Choose Image > Mode > CMYK.  You can now save the file in the correct format required for 

Adobe PageMaker and your publication. 

 

Because many printers use the Tagged-Image File Format (TIFF) for images that will be printed 

in process or CMYK colors, you will save the photo as a TIFF file. 
 

2.  Choose File > Save As.  In the dialog box, select TIFF from the Save As menu. 
 

3.  Click Save. 
 

4.  In the TIFF Options dialog box, click the IBM PC Byte Order for your system. 

 

The image is now fully retouched, saved, and ready for placement in the Publisher’s layout. 
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Tutorial 
ADOBE PHOTOSHOP CS 

Lesson 4:  Combining Illustrator Graphics and 

Photoshop Images 

 

 

You can easily add a graphic created in a 

drawing program to an Adobe® Photoshop® 

file. This is an effective method for seeing how 

a line drawing looks applied to a photograph 

or for trying out Photoshop special effects on 

vector art. You can also export the resulting 

artwork for use in other graphics programs. 

 
This lesson shows you how to do the following: 

 

 Differentiate between bitmap and vector graphics. 

 Place an Adobe Illustrator® graphic in an Adobe Photoshop file. 

 Scale the placed graphic. 

 Distort a graphic to match the perspective of a photograph. 

 Apply different blending modes to a graphic. 

 Use the Export Transparent Image wizard to prepare a Photoshop image for use in an 

Illustrator file. 

 

Combining artwork 
 

You can combine Photoshop artwork with art from other graphics applications in a variety of 

ways for a wide range of creative results. Sharing artwork between applications allows you to 

combine line art with continuous-tone paintings and photographs. It also allows you to move 

between two types of computer graphics—bitmap images and vector graphics. 

 

Bitmap vs. vector graphics 
 

Adobe Photoshop uses bitmap images, also called raster images, which are based on a grid of 

pixels.  In working with bitmap images, you edit groups of pixels rather than objects or shapes. 

Because bitmap graphics can represent subtle gradations of shade and color, they are appropriate 

for continuous-tone images such as photographs or artwork created in painting programs. A 

disadvantage of bitmap graphics is that they lose definition and appear “jagged” when scaled up. 

 

Vector graphics, also called draw graphics, are made up of shapes based on mathematical 

expressions and are created in drawing applications. These graphics consist of clear, smooth lines 
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that retain their crispness when scaled. They are appropriate for illustrations, type, and graphics 

such as logos that may be scaled to different sizes. 

 
Logo drawn as vector art 

 

 
Logo rasterized as bitmap art 
 

In deciding whether to use Photoshop or a vector graphics program such as Illustrator for creating 

and combining graphics, consider both the elements of the image and how the image will be used.  

In general, use Photoshop for images that have the soft lines of painted or photographic art and 

for applying special effects to line art. Use Illustrator if you need to create art or type with clean 

lines that will look good at any magnification. In most cases, you will also want to use Illustrator 

for laying out a design, since Illustrator allows you more flexibility in working with type and with 

reselecting, moving, and altering images. 

 
Project overview 
 

To illustrate how you can combine vector art with bitmap images and work between applications, 

this lesson steps you through the process of creating a composite image. In this lesson, you will 

add a logo created in Adobe Illustrator to a photographic image in Adobe Photoshop and adjust 

the logo so that it blends with the photo. You will then save the resulting image so that it can be 

brought back into Illustrator for final layout as a print advertisement. 

 

 
 

Getting started 
 
1.  Choose File > Open. Locate and open End04.psd and click Open. 
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2.  If you like, choose View > Zoom Out to make the image smaller, and leave it on your screen 

as you work. If you don’t want to leave the image open, choose File > Close. 

 

Now you’ll open the start file, the photographic image to which you will add a logo. 
 

3.  Choose File > Open. Locate and open the Lesson04 folder, select Start04.psd, and click Open. 
 

4.  Choose File > Save As, type the name Work04.psd, and click Save. 

 

Placing an Adobe Illustrator file 
 
You can open an Adobe Illustrator file as a new Adobe Photoshop file, or you can use the Place 

or Paste commands to add an Illustrator file into an existing Photoshop file.  

 

In this lesson, you will be using the Place command to add an Illustrator file to an existing 

Photoshop image. The advantage of the Place command is that it brings the image in as a smart 

object. The smart object remains vector art until you rasterize it so that the scaling does not 

sacrifice image quality. Alternatively, if you were to cut and paste a graphic from Illustrator into 

Photoshop, the image would come in already rasterized at the size it was in the Illustrator file. If 

you then scaled the graphic, it would lose image quality. 
 

 
 

 
 

1.  With the photo of the gift box open, choose File > 

Place. Select the file Logo.ai located in the 

Lesson04 folder, and click Place. Notice that the 

logo appears with a bounding box around it and that 

Photoshop automatically creates a new Logo.ai 

layer for the image in the Layers panel. 
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2.  Hold down Shift, and drag a corner handle of the bounding box to scale the logo to fit the gift 

box. (Holding down Shift constrains the proportions of the logo.) 
 

3.  Position the pointer outside the bounding box (the pointer turns into a curved arrow), and drag 

to rotate the logo slightly counter-clockwise. 

 
 

4.  If necessary, position the pointer inside the bounding box so that you see a move pointer, and 

drag to reposition the logo so that it fits within the borders of the box. Fine-tune with other 

rotation or scaling adjustments.  Once you are happy with the size of the graphic, go to 

Layer>Rasterize>Smart Object. 

 

Distorting the graphic to match the photograph 
 
Your next step is to distort the logo so that it appears to wrap around the top and front of the box.  

To create this effect, you’ll cut the logo in half, place each half on its own layer, and then apply 

the distortion to the logo’s top half. 
 

1.  With the Logo.ai layer active, select the polygon lasso tool, and click the right front corner of 

the box top. Drag to the next corner, click, and then continue dragging around the box top, 

clicking at each corner. Complete the selection by crossing over the starting point. 

 

 

 

 
 Top half of box selected Selection placed on new layer 

 

2.  Choose Layer > New > Layer Via Cut to cut the top half of the logo from the Logo.ai layer 

and place it on its own layer. Notice that a new layer, Layer 1, has appeared in the Layers panel. 

To see the artwork on the layer, turn off the other two layers by clicking the eye icon to the left of 

the layers in the Layers panel. Click again to turn all layers back on. 

 

Now you’re ready to distort the top of the logo. 
 

3.  Make sure that Layer 1 is active, and then choose Edit > Transform > Skew. A transformation 

bounding box appears around the top half of the logo. 
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4.  Experiment by dragging the handles of the bounding box to distort the logo so that it matches 

the perspective of the box. In particular, try dragging the upper left handle in the direction of the 

back left corner of the box top. 

 

 
 

Note:  To undo the last handle adjustment, choose Edit > Undo. To cancel the 

transformation, press Escape. 
 

5.  When the logo appears to wrap around the top of the box, apply the transformation by pressing 

Enter. 

 

Using blending modes on the graphic 
 

Now you’ll make the logo appear more integrated with the box by using different blending modes 

on each half of the logo. First you’ll lighten the top half of the logo so that it matches the box top. 
 

1.  With Layer 1 still active in the Layers panel, change the opacity of the layer to 60% and make 

sure that Normal is selected for the blending mode. Changing the opacity of the layer lightens the 

top of the logo and makes it blend better with the highlights on the top of the box. 

 

 
 

Next you’ll darken the bottom half of the logo so that it blends with the shadow on the box front. 
 

2.  Click the Logo layer in the Layers panel to make it active, change the opacity to 70%, and 

select Multiply from the blending mode menu. Using the Multiply blending mode on the layer 

darkens the bottom of the logo and makes it appear to be in shadow. 
 

3.  Choose File > Save. 

  

Exploring on your own 
 

Now that you’ve learned the basic steps involved in combining an Illustrator graphic with a 

Photoshop image, you can try applying the logo to a new Photoshop image. 
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1.  Locate and open the Lesson04 folder. Then select Cap.psd or Cup.psd, and click Open. 

 
 

2.  Choose File > Place. Select the Logo.ai file, and click Place. 
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Tutorial 
ADOBE PHOTOSHOP CS6 

Lesson 5:  Using Layer Masks in Photoshop 

 

 

For this lesson you will use a layer mask to 

allow a hint of color to show in a black and 

white image.  While photoshop allows you to 

make a layer transparent, using layer masks 

allows you to control the opacity of part of a 

layer.  This allows us to use non-destructive 

editing in our photos.  We can make changes, 

even erase part of our photo, without actually 

changing the pixels.   

 
This lesson shows you how to do the following: 

 

 Add an adjustment layer 

 Add a layer mask 

 

Getting started 
 

1. Choose File > Open.  Locate and open End05.psd and click Open. 

 

2.  If you like, choose View > Zoom Out to make the image smaller, and leave it on your screen 

as you work. If you don’t want to leave the image open, choose File > Close. 

 

Now you’ll open the start file, the photographic image to which you will add a logo. 
 

3.  Choose File > Open. Locate and open the Lesson05 folder, select Start05.psd, and click Open. 
 

4.  Choose File > Save As, type the name Work05.psd, and click Save. 
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Creating an adjustment layer 
 

 
Create a new Adjustment Layer by going to 

Layer>New Adjustment Layer and choosing  

Hue/Saturation. 

 
 

  

In the Layer Properties menu, reduce the 

Saturation slider to -100.  Click the double 

arrows at the upper right of the menu to hide. 

 

 
 

 

With the new layer selected, click the Add Vector 

Mask button at the bottom of the Layers Panel.   
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Click on the Layer Mask to highlight it. 

 

The Layer Mask will be used to mask or hide 

certain parts of the image so they are not 

affected by whatever is done on that layer.  

Areas that are white are visible; areas that are 

black are transparent.    

 

The Layer Mask thumbnail is currently all 

white, so no part of it is hidden from the 

black and white adjustment layer.   

 
 

We want the flower itself to show color, so we are going to paint that part of the Layer Mask 

black so it will be hidden from the adjustment layer. 

 

 

Choose the paintbrush from the toolbar, and make sure the foreground color is set to black. 

 

Make the brush size a bit larger to begin with.  I used 13 px. 

 

 

 

 

Use the paintbrush to paint over the flower.  You 

should see the yellow begin to show through as 

you “hide” that part of the black and white 

adjustment layer and reveal the color beneath.   
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Continue to paint the flower, reducing the 

size of the brush as needed to get some of the 

finer detail in the flower.   

 

If you accidentally paint some of the area 

outside the yellow, switch to white as your 

foreground color and paint over the area to 

cover it with the black and white adjustment 

layer again. 

 

 

 

 

Choose File > Save to save your file.   
 

 
 

 

Creating a layer mask from a selection. 
 

You can also make a layer mask from a selection.  Go to File>Open and open the file 

called Tulips.psd.  Go to File>Save to save the file as TulipsWork.psd. 

 

For this exercise, we are going to do the opposite of what we just did.  Instead of hiding 

the Black and White adjustment on the flower in the top layer, we are going to hide 

everything but the color in the top layer.   

 

Drag the tulips layer down to the New Layer icon in the Layers Panel (it looks like a 

sticky note) to duplicate the layer. 

 

         
 

Make sure the tulips copy layer is selected. 
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Use the Quick Selection tool to draw a 

selection around the center tulip. 

 

 

 

     

 

 

 

 

    

Click the Add Vector Mask icon to create a Layer mask.   

 

 

 

In our top layer, we are now hiding everything except the 

center tulip we selected. 

 

Select the original tulips layer.  Go to Layer>New Adjustment Layer and choose Black 

and White. 

 

 
Go to File > Save.
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Photoshop Assignments 

 

A. Create a Banner.   

 

Create a banner/title which is: 

 Size is 600 x 150 

 Has at least 3 layers (including background layer) 

 Has at least 3 different colors 

 Uses at least 1 text effect (drop shadow, outer glow, etc.) 

 Easy to read information 

 Makes good use of available space 

 Saved as a jpeg 

 Saved as banner.jpg in your folder on your H: drive 

 

B. Create a Button 

 Size is 150 x 100 

 Has at least 3 layers (including background layer) 

 Uses at least 1 text effect (drop shadow, outer glow, etc.) 

 Has an oval shape 

 Has a transparent background 

 Easy to read information 

 Makes good use of available space 

 Is saved as a gif 

 Saved as button.gif in your folder on your H: drive 

 

Magazine Assignment (major grade): 

 

Create a Magazine Cover featuring YOU.   

 

 Size is 8” x 10” 

 Feature prominently a picture of you 

 Represent a real (academically appropriate) magazine  

 Feature at least 3 stories on the cover 

 Include the date of the issue 

 Include at least 1 inset (either a second picture or a brief list of features) 

 All information must be easy to read 

 Make good use of available space 

 Save as a jpeg and save as a psd (Photoshop document) 

 Save as magazine.jpg in your web folder 

  



178 

 

Creating a Gif Animation with Photoshop   

Preparation .  Launch Photoshop. Make sure the Timeline panel is visible. If it is 

not, choose Window > Timeline to make it visible.  

 

 
 

1. Create basic image.  We will construct a simple image, a sign that says 

"WELCOME", using the Toolbox.  

 First, select File>New  

 

 In the dialog box that opens set: Name: Welcome, Image size: Width 200, 

Height 40, and background contents: transparent  

 

 Click "OK" .  Go to File > Save and save the file as Welcome.psd.  use the 

Zoom Tool to Zoom in if needed. 
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 Select the Type Tool in the Toolbox.  Change to Arial font, Bold, 30 pt and 

change the color to green. Click on the image and type "WELCOME.”  

Center the text on the canvas as best you can. 

 

2. Add animation frames.  In the Timeline panel at the bottom, click Create Frame 

Animation.   

 

3. A thumbnail of the basic image should be located in the Timeline panel.  The initial 

frame needs to be duplicated several times.  

 

4. Click the "Duplicate Current Frame" icon  twice to create frame 2 and 3.  

 

 

3.  Make changes in frames using Layer panel.  Changes will be made in the first and 

third frames to create the animation. In the third frame we will change the opacity 

so the "WELCOME" message fades away. We will change the first frame so that 

the message will move "onstage" from the left 

side to the center. 

 Go to the Layers Panel and 

uncheck Propagate Frame 1 
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 Select the third frame. Then in the Layer panel move the opacity slider to 

0%. The message in the third frame should now be invisible.  

 

 Now select the first frame. Using the Move tool (from the toolbox) hold 

down the shift key and drag the text completely off the left edge of the 

image. The image below shows the text partly moved.  

 

Make sure the text in frame 2 didn’t move as well (if it did, you forgot to uncheck 

Layer > Propagate Frame 1 Changes earlier – just click on frame 2 and move it 

back where it belongs). 

4.  Add frames with Tween.  We now have three frames which show basically what 

we want the animation to do.  The message is visible in the 2nd frame, but invisible 

in the 1st and 3rd. We will use the Tween Command to fill in frames to create the 

desired actions.  

 

First we will add frames between the 2nd and 3rd frames that will cause the message  

 Select the 2nd 

frame. Open the 

Timeline panel 

menu by clicking 

the double arrows 

on the far right and 

select Tween.  
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 In the Tween dialog box select to add 5 frames, Tween with Next Frame, 

and make sure only Opacity is checked to vary.  (This tells Photoshop what 

changes it should expect between frames.)   

 

Clicking "OK" should add 5 more frames.  

 

Now we want to use tweening to move the message from offstage to the center.  

 Select the 1st frame and select Tween from the Timeline menu as before. 

Use 5 new frames again, but this time check Position and uncheck Opacity 

as the feature to vary (since you are changing the position between frames). 

Click "OK" to add the 5 more frames as indicated.  

 

 Check your animation by pressing the play button at the bottom of the 

Animation palate.   

5. Adjust animation timing.  To slow down the rate at which the animation plays, 

you can adjust the timing of the frames.   

 Go to the Timeline panel menu and choose Select All Frames. This will 

highlight all the frames. (or you can click on the number on the first frame 
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then hold down the shift key and click in the last frame to highlight all 

frames). With all the frames selected, click the small down triangle to the 

right of sec at the bottom of one frame. Choose, for example, 0.2 seconds. 

This will be applied to all the selected frames.  

 

 

Note:  To set the timing for a single frame select only that frame and change its 

timing. 

 Continue to adjust the timing until the animation plays at a speed you like.  

Go to File > Save to save your file. 

6.  Adjust the looping options 

 You can adjust the number of times your animated gif will loop by going to 

the looping options at the lower left and clicking the down arrow.  You can 

choose to have your gif loop once, 3 times, forever, or the number of times 

you select. 
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7.  Save animation.  You have already saved the layered animation as a .psd file using 

File>Save.  It is a good idea to keep a copy of this file in case you want to make 

changes later.   

 To save it as a gif animation go to File>Save for Web. Click the optimized 

tab and change preset to GIF, No Dither.  Save then save again to your 

photoshop folder.  

You can insert your animated gif into a web page as you would insert any image 

(using the <IMG SRC = . . . .> tag. 

  

Optimizing Images Using Save for Web 
 

There are many options and multiple steps involved in using the Save for Web option; 

let's take a look. 

The Save for Web Window 

To begin the process of saving a file for the Web, make the following menu selections: 

File > Save for Web... 

Notice the four tabs at the top of the Save for Web window: 

1. Original — This tab displays the original image, including the filename and file 

size. The original image is not optimized.  

2. Optimized — This tab displays the image with current optimization settings. 

Information provided includes file format, optimization settings, file size, and 

projected download time, given the identified modem speed.  

3. 2-Up — This tab displays the original image and the optimized image side-by-

side for comparison purposes.  

4. 4-Up — This tab displays four image previews. Click on any of the 4 previews 

and you can adjust the settings on the right for that preview.  

Also notice the Image Size tab in the lower right quadrant of the window. Photoshop 

allows the image size to be changed from within the Save for Web window. The options 

available in the Image Size tab are similar to those in the Image Size dialog box discussed 

previously. 

 

Make sure you are using the proper file type for the image you are saving.  Gifs will have 

fewer colors and should be used only for text, logos, or line art.  If you are saving a 

photo, you should save it as a .jpg.   
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Practice Activity 8: 

1. In Photoshop, open one of the .jpg files.  

2. Make any adjustments to it you like regarding image size, color depth, etc.  

3. Select File > Save for Web   

4. Select the Original tab to see the original image and its relevant information.  

5. Select the Optimized tab to see the optimized image and its relevant information.  

6. Select the 2-Up tab to see the comparison of the original and the optimized image.  

7. Finally, select the 4-Up tab to see the original image and three optimized images, 

each using a different optimization. How do the images differ?  

8. Click the Cancel button to exit the Save for Web window without saving.  

 

Optimizing JPEG Images 

 

There are specific optimization settings available for JPEG 

images, the most important being the Quality setting. Photoshop 

provides several quality presets accessible via the Settings drop-

down field: 

1. JPEG Low — This preset sets the image quality to 10.  

2. JPEG Medium — This preset sets the image quality to 30.  

3. JPEG Maximum — This preset sets the image quality to 100.  
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Practice Activity 9: 

1. In Photoshop, open one of the .jpg files.  

2. Select File > Save for Web.  

3. Select the image option to the right of the original image.  

4. Select the JPEG Low setting from the preset options.  

5. Select the image option just below the original image.  

6. Select the JPEG Medium setting.  

7. Select the image option below and to the right of the original image.  

8. Select the JPEG Maximum setting.  

9. How are the images different? File size?  

10. Select the JPEG Medium image and use the Quality slider to see the difference in 

the image as you move the slider back and forth.  

11. Click the Cancel button to exit the Save for Web window without saving.  

Optimizing GIF Images 

To reduce the size of GIF images, you can reduce the number of colors being used.  GIF 

images can use as many as 256 colors, but if you reduce the number of colors to 32 or 

even 16, you may be able to significantly reduce the size of your images.  You will have 

to look at the preview images, though, to make sure you aren’t reducing the quality of the 

image.   

Practice Activity 10 

1. In Photoshop, open one of the .jpg files.  

2. Select File > Save for Web.  

3. Note the three optimized images created by Photoshop. 

What are their settings? How do they look in terms of 

quality?  

Notice the Color Table that shows the colors actually used in 

the image.   

How many colors appear in the Color field? More than in the 

Color Table? If so, what would you do?  

4. Make adjustments by choosing the various GIF preset options.  

5. Adjust the palette being used. How does that impact image quality?  

6. Adjust the compression level. How does that impact image quality?  

7. Make adjustments to the number of colors. How does that impact image quality?  

8. Make adjustments to the dithering. How does that impact image quality?  

9. Make adjustments to the Web Snap field. How does that impact image quality?  

10. Click the Cancel button to exit the Save for Web window without saving.  
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Issues in Technology 
 
Select an issue related to technology and prepare the following: 
 

o A PowerPoint Presentation for your classmates.   

o A one-page handout for your classmates 

o A bibliography for your instructor 

o One multiple-choice question about your topic 
 

Your final presentation is due:  _____________  You should conduct enough research to understand the 

problem thoroughly, but a minimum of three (3) sources is required.  For your research you should make 

use of the library databases available at AHS or book, magazine, journal, or newspaper articles (which may 

be read online if properly documented).  Important due dates are as follows: 
 

 Date:  ______________:  You must have signed up for a topic with your instructor 

 Date:  ______________:  An outline of what you plan to cover is due to your instructor 

 Date:  ______________:  Your handout, multiple choice question, and bibliography is due to your 

instructor.  If you do not turn in a handout on this date it will be your responsibility to have it 

reproduced for the class (which you will not accomplish by printing out 26 copies on the school 

computers). 

 Presentations will begin  ___________________ .  You may be called upon at any time during 

this week to present.  If you are not prepared when called, points will be deducted from your final 

grade. 
 

You should choose a topic that has some controversy associated with it.  You will be expected to present a 

thorough discussion of the topic including at least two different perspectives on either the topic itself or 

possible ways of dealing with it. 
 

Your presentation should address the following: 

 

 What is the issue and what are its implications? 

 Why is the problem important to society? 

 What are the advantages/positive aspects involved? 

 What are the concerns of opponents?  Are they justified? 

 What do you think and why? 

 
The multiple-choice question should be about a major element of your presentation and should be able to 

be answered by reading the handout and listening to the presentation.  Your presentation should be clear, 

thorough, and informative.  Your handout should summarize the information presented.  Be sure to 

proofread all materials carefully! 

 

Possible issues: 

 

Automotive computer systems Encryption Hoaxes 

Digital assistants (ex:  Blackberry) Identity Theft Spam 

Disposal of old equipment Online identity verification Steganography 

Hacking (white hats vs. black hats) Rate of Obsolescence Viruses 

Pirating (music and software) Personal firewalls VoIP 

Podcasting (audio/video) Phishing Wikis 

Social networking sites Plagiarism Wireless technology 

Video sharing sites (ex:  youtube) Protecting children online Video game technology 

Advancement of Robotics Blogs  
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Determining Web Credibility 

 

What is “Web Credibility”?   

The credibility of a website refers to the degree to which you can trust the information you read 

there.  Simply that.  Can you believe the information found on that site is accurate, believable, 

trustworthy and useful?  If the site lacks credibility, than any paper or project which uses that 

information will lack credibility, too.     

Why does Web credibility matter?    

 

There are really several reasons it is important to talk about how to determine whether websites are 

credible or not.  They can generally be narrowed down to three:  

 

 The WWW is a relatively new phenomenon for most users  

 People tend to believe what they read (especially if it looks professional) 

 Many (actually most) students are lousy judges of character 

 

Two additional things which need to be considered:  

 

The WWW has the most credible information of any medium.  Believe it.  The web provides 

researchers with better access to a variety of resources, particularly primary sources.  We no longer 

have to read what someone else thought about a study, we can look at the actual study.  We have 

access to data, notes, opinions – all directly from the source.  It’s really quite remarkable what is 

available out there. 

 

Of course, the WWW also has the least credible information of any medium.  There are no editors or 

publishers, proofreaders or fact-checkers.  No one edits, proofreads, censors, or fact checks anything 

on the WWW.  It’s just all out there for us to sort through.   

 

What we will be discussing is how to look at a web page and get a general idea about whether a site 

is credible.   

What Factors affect Credibility? 

There are two main factors which affect credibility:   

 

Trustworthiness + Expertise 

 

Trustworthiness refers to the believability of information from that source.  Expertise refers to the 

degree to which someone might be considered an expert in that field.   

Both must be present in order to truly say a site is credible.   

 

Perceived trustworthiness + perceived lack of expertise = 

perceived lack of credibility 
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Barney the Dinosaur is a very trustworthy character, but if he developed a website on nuclear 

physics I would question his expertise.   Sorry, but that page would have poor credibility. 

 

Perceived lack of trustworthiness + perceived expertise = 

perceived lack of credibility 

 

I would consider any political party to have expertise in the area of politics, but their likely bias 

toward certain candidates would make me question their trustworthiness.  If I was researching a 

political issue (like gun control or economics) I would stay away from any sites that are designed to 

promote a particular political candidate.   

Whose page is this anyway?  

 

The first step in evaluating a web page is to figure out where the page is “coming from.”  Who 

created it and pays for it? 

 

 

 Who is the author of the page?   

  

If you can’t tell who authored the page, that is a problem in itself.  If you 

can tell who the author is, try to determine his/her credentials.  Are they 

an expert in this field?  Do they include any information about where 

they are from or who they work for?  Is it obvious (for example, a 

professor at a university).   Did they explain their reasons for posting this 

page? 

 What organization pays for the page to be posted?   

 

 

There are very few examples of “free websites.”  Most websites require 

someone to pay money to have the site posted.  Think of this as rent on 

the site’s “living” quarters.  Who is paying the rent?  Why are they 

willing to pay money to have this information available?  Even free sites 

(such as Geocities) raise some questions.  If this site is a hobby, how 

much expertise does the author have?  How much time can he/she spend 

checking facts and updating information? 

 

 



189 

 What is the purpose of the website?   

 

 

Most pages have a purpose that falls into one (or more) of these 

categories: 

 

 Inform:  designed strictly to convey information 

 Sell/Promote:  designed to sell or promote a product 

 Persuade:  designed to persuade readers to believe or 

endorse something 

 Instruct:  designed to teach readers how to do something 

 Entertainment:  designed strictly for entertainment (no 

sales or product link) 

 Personal:   designed to reflect the personality or interests 

of the author, not to convey any particular information. 

 

 

o  Is the author biased? 

 

It is important to determine whether the page represents fact or opinion 

and identify any bias the author may have.  Possible indicators of bias 

include:  

 The author profits directly or indirectly from the information on 

his/her site. 

 The sponsor of the site profits directly or indirectly from the 

information on the site. 

 The content of the site promotes a political, religious, social, or 

personal opinion or agenda.  

 The author uses terms that express an opinion like “best”, 

“worst”, “most important.”  

 The author appeals to your emotions rather than to logic.  Phrases 

like “devastating” or “triumphant” may indicate an appeal to 

emotion. 

 The author does not present a balanced viewpoint.  If only one 

side of an issue is presented, that may indicate a bias.   

 

Content is Key  

  

Ultimately, the most important factor to look at when determining the 

credibility of a web page is the content itself.  Ask yourself these 

questions:  
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 What exactly is the author saying? 

 
Read the page carefully and make sure you understand the points the 

author is making.  Sometimes the headings may seem like the author is 

saying one thing, but read carefully to see what is really being said.   

 Is there any support for what the author is saying?  

 
Does the author offer any support for what he/she is saying?  Are there 

external links to similar information?  Expert opinions?  Quotes from 

known authorities?  If the author includes quotes, look for evidence of 

bias from the source quoted.   

 Does the content seem reasonable? 

  

Is the content of the page consistent with what you already know or have 

learned about the subject?  When you read the content, does your 

common sense tell you that what it says is correct?  If you find a page 

that offers a perspective which is significantly different from every other 

source you have found (and you should always use multiple sources for 

your research), you should consider the reasonableness of the argument.  

Why does every other source see the issue differently?  Does the content 

seem logical?  If your instincts tell you that something is not right, look 

for a different source. 

 

What Else Matters?  

Now that you have looked at the author and content of the site, there may be other clues to whether 

the site is credible.  The Stanford Persuasive Technology Lab created pages with particular 

characteristics, then asked users to rate how credible the information on the page seemed.  Based on 

that research, they were able to generate a list of factors which impact a site’s perceived credibility 

either positively or negatively.  It is important to understand that most of the following factors affect 

how we perceive the page – the content and author are better indicators of the actual credibility of 

the information. 

Factors which Increase Perceived Credibility:  

 

The following factors were found to increase perceived credibility of web pages: 
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  A “Real World” Connection 

 
 Response to customer service questions (do they respond to e-mail 

and/or form submissions in a timely manner?) 

 A physical address and phone number made it seem the site was 

grounded in the real world 

 A contact e-mail address made people feel like there was a real 

person connected with the site 

 Employee photographs also made people feel like there were real 

people connected with the site 

 Ease of Use 

 
 Professional design 

 Good organization 

 Clear navigation 

 Reasonable download times 

 

All these factors gave the site a professional feel.  Users felt that if someone 

had spent time and energy to create the site, the information seemed more 

reliable than that on a thrown-together site.   

 Expertise 

 
 Site includes bibliography/references 

 Site describes expertise & credentials of author 

 Site has won an award (despite the fact that anyone can give out or 

make up an “award” for web design). 

 Trustworthiness 

 

 Linked to by trustworthy sites (you can determine this by going to 

altavista.com and typing “link:  “ followed by the URL (for example 

(link: www.fortbendisd.com would tell you all the sites that link to 

the Fort Bend ISD website.   

 Links to outside materials and sources 

 URL ends with .org 

 Professionalism 

 
 Site is updated often (the more current the information the more 

credible it appeared) 

 Site includes a “last modified” date (so you can tell when it was last 

updated) 

 Domain name matches company name (like Nike.com or 

TAMU.edu) 

 Site represents an organization you are familiar with 
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 Other Factors Which Increase Perceived Credibility 
 

 

 

 

 Lots of hits on web counter (a completely arbitrary measure, as the 

webmaster can set the counter to whatever number he/she chooses) 

 Content is fair and balanced. 

 Provider is a nonprofit organization 

 Site has ads from companies you recognize  

Factors Which Decrease Perceived Credibility: 

The following factors were found to decrease perceived credibility: 

 Commercials/Advertising 

 
 Pop-up windows (the more pop-ups, the more poorly the site was 

perceived) 

 Ads which are difficult to distinguish from content 

 One or more ads on every page 

 Ads for unknown or disreputable companies or products  

 Attempts to recruit advertisers (“Your ad here!”) 

Step 15 Amateurism 

Step 15  Typographical errors (“If they don’t check their spelling, they 

probably don’t check their facts” was the perception) 

 Site is sometimes unavailable (The server is down/has moved) 

 Links that don’t work 

 Links to a non-credible site 

 Animated graphics 

Step 15 Other Factors Which Decrease Credibility 

Step 15  

 Site has AOL/Geocities/Tripod domain name 

 A political group you don’t like endorses the site 

 The site has no security protocols for transactions 

 The site doesn’t give contact information anywhere 

 Web pages move or disappear without notice 

 Font is either too large or small to read comfortably   

 Site asks for personal information without justifying why or explaining 

its privacy policy 
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Things you should keep in mind . . .   

 Pay attention to the URL – sites with domain names that match the organization tend to be 

more reliable than sites from AOL or geocities 

 Look at the domain abbreviation:  sites ending in .org or .edu tend to be more reliable 

 Look at the quality of the design – the more professional, the more work went into the 

product.  More work doesn’t necessarily mean you should trust the content, but a lack of 

effort should make you question it. 

In conclusion  

 

While there is a lot of great information available on the Internet, you cannot believe everything you 

read.  You should consider the expertise and the trustworthiness of the source.  The single most 

important factor in determining the credibility of the website is the content of the site.  Consider the 

credentials of the author, what support is offered for the opinions/arguments presented, the potential 

bias of the author or the organization that supports the site, and the reasonableness of the content.  

Other factors may influence you, such as the quality of the design and links  

 

Be a discerning web reader, and you will be able to sort out the good from the bad. 
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Determining Web Credibility Assignment 

 
URL/Site evaluated:  ____________________________________________________________________ 

 
Who is the author of the page?  ____________________________________________________________ 

 

What organization pays for the page to be posted?  _____________________________________________ 

 

What is the purpose of the page?  ___________________________________________________________ 

 

What evidence of bias do you see in the page?  ________________________________________________ 

 

Use this checklist to gain an overall sense of the credibility of a Web site.  Check any factors from 

either list that apply to the Web site you are critiquing.   

 
Increases Credibility 

 A physical address and phone number 

 A contact e-mail address 

 Professional design 

 Good organization 

 Clear navigation 

 Reasonable download times 

 Bibliography/references 

 Information about expertise & credentials 

of author 

 Linked to by trustworthy sites 

 Links to outside materials and sources 

 URL ends with .org or .edu 

 Material appears up-to-date 

 Includes a “last modified” date 

 Domain name matches company name 

 Site represents an organization you are 

familiar with  

 Content is fair and balanced 

 Site has ads from companies you 

recognize 

 

Decreases Credibility: 

 

 Pop-up windows 

 Ads which are difficult to distinguish 

from content 

 One or more ads on every page 

 Ads for unknown or disreputable 

companies 

 Attempts to recruit advertisers 

 Typographical errors 

 Site is sometimes unavailable 

 Links that do not work 

 Links to a non-credible site 

 Animated graphics 

 Site has ISP domain name (AOL, swbell, 

etc.) 

 Font is either too large or small to read 

comfortably 

 Site asks for personal information 

without justifying why or explaining its 

privacy policy 

 
Based on the factors above, determine which of the following categories best describes the credibility of the 

website: 

 

a. The site definitely appears credible 

b. The site leans toward credibility 

c. The site leans toward being non-credible 

d. The site definitely appears non-credible 

e. Unable to determine (too many factors from both lists) 

 

Write a paragraph to support your conclusion.  Be sure to include items from either list that support your 

position.   

 

 

 



195 

Sites you can practice on:  
 

1. http://www.ufos-aliens.co.uk/cosmicapollo.html 

2. http://science.nasa.gov/headlines/y2001/ast23feb_2.htm 

3. http://www.guaranteed-scholarships.com/ 

4. http://www.fafsa.ed.gov/ 

5. http://mcadams.posc.mu.edu/home.htm 

6. http://www.jfk-assassination.de/index.php 

7. http://www.alienabductions.com/ 

8. http://www.abduct.com/ 

9. http://www.tvnewslies.org/html/the_truth_about_george_w__bush.html  

10. http://www.whitehouse.org/administration/georgew.asp 

11. http://www.totalthinker.com 

12. http://www.mdani.demon.co.uk/para/rvexp1.htm 

13. http://www.davidmyers.org/Brix?pageID=15 

14. http://www.thedogisland.com/ 

15. http://asher.baseballevolution.com/bagwellconspiracy.html  

16. http://www.cropcircleresearch.com/ 

17. http://www.circlemakers.org/ 

18. http://www.dhmo.org/ 

19. http://www.nei.org/ 

20. http://www.mtholyoke.edu/~kagreeni/Disadvantages.html 

 

 

 

 

  

http://www.ufos-aliens.co.uk/cosmicapollo.html
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http://www.jfk-assassination.de/index.php
http://www.alienabductions.com/
http://www.abduct.com/
http://www.tvnewslies.org/html/the_truth_about_george_w__bush.html
http://www.whitehouse.org/administration/georgew.asp
http://www.totalthinker.com/
http://www.mdani.demon.co.uk/para/rvexp1.htm
http://www.davidmyers.org/Brix?pageID=15
http://www.thedogisland.com/
http://asher.baseballevolution.com/bagwellconspiracy.html
http://www.cropcircleresearch.com/
http://www.circlemakers.org/
http://www.dhmo.org/
http://www.nei.org/
http://www.mtholyoke.edu/~kagreeni/Disadvantages.html
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Using Dreamweaver CS6/CC 
 

Dreamweaver is a powerful tool which works with the other Adobe products to help users 

create web sites. 

 

To begin, open Dreamweaver and choose 

Create New > HTML 

 

 

 

 

 

 

 

 

 

 

 

 

 

This will open the Dreamweaver interface.   

 

Like 

Photoshop, 

Dreamweaver 

has a number 

of different 

Workspace 

views.  You 

can change 

your view 

depending on 

how you are 

planning to 

use 

Dreamweaver

.  For basic 

web site 

creation, we 

generally 

work in the 

Classic or 

Developer 

workspace.  

For now, we will work in the Classic Workspace. 
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Look in the top right of your window.  If you are not in Classic workspace, use the drop 

down to change to Classic. 

 

 

Dreamweaver allows you to view your webpages in one of several different views.  The 

Design view allows you to see the elements of your web page as you create them.  The 

Code view allows you to see the HTML source used to create your web page.  The Split 

view allows you to view both the Design and the Code side by side.   

 

  
Design View Code View 

 

 
Split View 

 

All three views are useful for different purposes.  Most of the time you will work in 

Design View, but there will be times you may want to edit the HTML directly.   

 

There is also a Live view button, which will show 

you what your page would look like in a web 

browser.  Press the Live button once to turn on Live 

view then press it again to turn it off.  You can not 

edit directly in Live view, but if you turn on Split view then press the Live button, you 

can edit the HTML and view the updated design.   
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You can also preview your web page in a browser.  Click the Preview in Browser icon 

and choose which of your installed browsers you would like to use (note, you must save 

the file before you can preview in a browser). 

 

Creating a Website using Dreamweaver 

 

You will be using files from the World Zoo Tutorial to create a sample website using 

Dreamweaver.   

 

Begin by opening Dreamweaver and creating a new HTML page. 

 

Copy the folder named WorldZoo (and all the contents) to your H: drive. 

 

In Dreamweaver, go to Site > New Site 

 

For Site Name, type WorldZoo.  Then click the folder next to the Locate Site Folder box 

and navigate to the WorldZoo folder on your H: drive.  Click once to highlight it, then 

click Open, then click Select. 

 

 
 

Press Save to save your new site. 

 

Once you have created and saved a site, the files will appear in 

the Files panel in the lower right part of the workspace.   

 

You should see two folders, images and textfiles.  As you create 

and add to your website, the list of files will update.   
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Go to File > Save, and save the new html document as index.htm into the WorldZoo 

folder on your H: drive.  If it asks you to update links, click Yes. 

 

You should now see the index.htm file in your Manage 

Sites/Assets panel.   

 

 

 

 

 

Find the Title bar and title your page World Zoo Homepage. 

 

 
 

Notice that index.htm has a * next to the name on its tab.  This tells you that the 

page has updates that have not been saved.  Go to File > Save to save the 

updates to this page.  

 

Adding and Editing an Image in Dreamweaver 

 

Now that we have added text to our page, we would like to add some images.  The easiest 

way to control elements in Dreamweaver is to create divisions or sections using the 

<DIV> tag.   

 

We will create a division to hold our banner.  Put 

your cursor at the very top of the page.  Go to Insert 

> Layout Objects > Div Tag. 

 

Leave it at Insert: At insertion point.  Don’t worry 

about the Class or ID at this time.  Div tags may be 

used with CSS to format the style of that section, but 

for now we will leave those blank.  Press OK to continue. 

 

You should now see two dashed lines and the text 

“Content for New Div Tag Goes Here.”   

 

Delete that text so you just have the two dashed lines 

indicating where the DIV is. 
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Web pages will only display images in the .jpg, .gif, or .png formats, however 

Dreamweaver will let you create a usable format from a .psd (Photoshop) file. 

 

In the Files panel, click the plus next 

to the images folder and find the 

image banner.psd.  Drag the 

banner.psd file into the DIV area you 

created. 

 

Choose JPEG as your file format and 

click OK.  Save the image into the 

images folder of your WorldZoo 

folder.  

 

Enter the ALT text “World Zoo 

Banner” and click OK. 

 

Your banner should show in place, and in the upper left hand corner of the image, 

you should see a document icon with two green arrows.  This indicates that your 

image is synced with the original image. 

 

With your image selected, look at the Properties 

panel at the bottom of the page.  In the box next 

to Link, type index.htm.  This will make the 

banner a link back to the homepage. 

 

If you look at the banner, you may notice that 

there is a typo!  We need to edit the text of the  

banner to correct the spelling of the word “our.”     

 

With your banner selected, look at the Properties 

panel at the bottom of the Dreamweaver 

workspace.  Next to the word Edit, click the 

Photoshop icon .   

 

This will launch Photoshop and open a copy of the banner.psd. 

 

Double-click the text layer and edit the text of the banner to read Come Visit Our Zoo!.  

Go to File > Save and exit Photoshop. 

 

When you return to Dreamweaver, look at the icon in the upper left hand corner of the 

banner.  The top arrow is still green, but the bottom arrow should now be red.  This 

indicates that your .jpg is no longer synced with the original file.   

 

Right-click on the green/red arrow icon and choose Update 

From Original.   
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Your image should now reflect the edited text, and both arrows should be green again.  

Go to File > Save to save your page. 

 

Creating and Inserting an Animated GIF 

 

Open Photoshop and open the ads.psd file (in the images folder).  We want to convert this 

image to an animated GIF.   

 

Notice that the image has 4 layers.  Each layer represents a frame we want to display as 

part of our Animated GIF.   

 

Make sure the Timeline panel is showing at the bottom of Photoshop (if it’s not, go to 

Window > Timeline to make it show).   

 

Click the button in the timeline to 

Create Frame Animation.  If your button 

says “Create Video Timeline,” use the 

drop-down arrow to change to Create 

Frame Animation. 

 

 

Click on the Timeline menu in the upper right of the Timeline panel and choose Make 

Frames from Layers. 

 

 
 

You should now see 4 frames.  Highlight the 

first frame, hold down the shift key and select 

the fourth frame.  This should highlight all 

four frames.  Change the timing drop-down to 

2 seconds and change the loop option to 

Forever.  Use the play button at the bottom to 
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test your animated GIF.  You may adjust the timings further if you wish. 

 

Go to File > Save for Web and save your image as ads.gif (be sure to change the file type 

to GIF) into the WorldZoo Images folder.  Note that the quality of the photos won’t be 

ideal when saved as a GIF, but the animation will work.   

 

Go back to Dreamweaver and look for the ads.gif file in the Files panel. 

 

Press enter to leave a bit of space under your page banner, then go to Insert > Layout 

Objects > Div Tag to create a new division (delete the filler text).  Drag the ads.gif image 

into the DIV section. 

 

The image won’t be animated in design view, you’ll need to switch to Live view.  Click 

the Live view button to turn on Live view.  The image should now show each frame 

every 2 seconds.   

 

We would like to center the banner and our ad banner on the webpage.  With the Live 

view still on, click the Split button to change to see both the code and the live view of the 

page.    

 

Click the banner to select it, and the 

matching HTML code will be 

highlighted.   

 

Find the DIV tag right before the IMG 

SRC tag, and add the attribute 

align=”center” to the DIV tag. 

 

Click the ad banner to select it, and 

find the DIV tag for that section.  Add 

the attribute align=”center” to that DIV 

tag as well.  Click on the live view to see the updates.  You should be able to see both 

banners centered in the live view.  Click the Live button to turn it off and click the 

Design button to return to Design view. 
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Adding Rollover Navigation Buttons 

 

Below the ad banner, we are going to add some navigation buttons.  We will also add a 

rollover effect to the buttons.   

 

First, we will insert a table to align the buttons.  Put 

your cursor below the ad banner.  Go to Insert > 

Table 

 

 

Create a table with one row and three columns.  Set 

the table width to 450 pixels and set the border 

thickness to 0.   

 

Click OK to accept. 

 

 

 

Put the cursor in the first cell of 

the table.   

 

 

 

 

 

 

 

Go to Insert > Image Objects > Rollover Image.  For the first cell, set the Image name to 

About.  For the Original image, click 

the Browse button and select the 

about.gif from the WorldZoo Images 

folder.  For Rollover image, select the 

about_ro.gif from the WorldZoo Images 

folder.  The Alternate text should be 

About the World Zoo, and When 

clicked, Go to URL:  about.htm. 

 

 

 

Put your cursor in the second cell.  Go to Insert > Image Objects > Rollover Image.  Set 

the Image name to Arrival.  For the Original image, click the Browse button and select 

the arrival.gif from the WorldZoo Images folder.  For Rollover image, select the 

arrival_ro.gif from the WorldZoo Images folder.  The Alternate text should be New 

Arrivals, and When clicked, Go to URL:  arrival.htm. 
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Put your cursor in the third cell.  Go to Insert > Image Objects > Rollover Image.  Set the 

Image name to Contact.  For the Original image, click the Browse button and select the 

contact.gif from the WorldZoo Images folder.  For Rollover image, select the 

contact_ro.gif from the WorldZoo Images folder.  The Alternate text should be Contact 

Us, and When clicked, Go to URL:  contact.htm. 

 

 

 

 

 

 

 

 

 

 

 

 

Click in the upper left corner of the table (around the line labeled with the table width) to 

select the table.  Go to the Properties panel and change the Align to center.   

 

 
 

Click the Live button to view the page in Live view.  As you hover over each button, you 

should see the color change.  To create this, we used two different images.  One is the 

button with the lighter color, the rollover image is the same size and text, but with a 

slightly darker background.  When you hover over the button, it replaces the original 

image with the rollover image. 

 

We have now created the basic template for our web pages.  Go to File > Save to save 

index.htm first, then go to File > Save As and save the page as blank.htm so we can re-

use it to create other pages later.  You should now have two tabs, index.htm and 

blank.htm.   
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Creating the Index Page 

 

In the Files panel, open the textfiles folder and double-click on the index.txt file to open.  

It will open in a third tab in Dreamweaver. 

 

Select and copy the text in index.txt and paste it into the index.htm file below the 

navigation buttons.  You can now close the index.txt file. 

 

Go to File > Save and save the index.htm file. 

 

 

Creating the About Page 

 

Click on the blank.htm tab.  Go to File > Save As and save a copy of the page as 

about.htm. 

 

In the Files panel, open the about.txt file to open.   

 

Select and copy the text into the about.htm file, below the navigation buttons.  Find the 

Title box just above your workspace (to the right of the Code/Split/Design tabs) and 

change the title of the page to About World Zoo. 

 

Go to File > Save and save the about.htm file. 

 

Formatting Headings 

 

Locate the text General Info, put your cursor at the end of 

the line and press enter to add a paragraph break.   

 

Note:  If you don’t add a paragraph break, any formatting 

you add will affect all the text on the page. 

 

Highlight the phrase General Info.   

 

In the Properties panel at the bottom, Change the Format 

to Heading 1. 

 

 

 

 

Locate the text Open Year ‘Round and press enter at the end of the line to add a 

paragraph break.  Highlight the text and change the formatting to Heading 3.  Do the 

same for Hours of Operation, Admission Pricing, and Other Attractions.  You may need 

to put a paragraph break before the text as well as after to keep unwanted text from being 

formatted.     
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Formatting Unordered Lists 

 

Highlight the text under Admission Pricing (before 

Other Attractions).   

 

Click the bulleted list icon on the Properties panel 

to change the text to a bulleted list.   

 

Repeat for the text under Other Attractions. 

 

 

 

 

 

 

Linking an Image to another image 

 

Place your cursor at the bottom of the page.  Go to Insert > Image and select the 

map_small.jpg image from the images folder to insert the small map at the bottom of the 

page.  

 

Select the map and go to the Properties panel.  Next to the Link box, find the Point to File 

icon.   

 

Click and hold down the Point to File Icon and drag your mouse to the map.jpg file in the 

Files panel.  Release the mouse to create the link. 

 

 
 

To test out your link, first go to File > Save.  Click on the Preview in Browser icon and 

choose a browser from the list (either IE or Chrome, whatever you have installed).   
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Click on the map to test the link.  When you have finished, minimize the browser and 

return to Dreamweaver.   

 

Create the New Arrivals page 

 

Click on the blank.htm tab.  Go to File > Save As and save a copy of the page as 

arrival.htm.  Find the Title box just above your workspace and change the title of the 

page to New Arrivals. 

 

In the Files panel, open the arrival.txt file to open.  Select and copy the text into the 

arrival.htm file under the navigation buttons.  Go to File > Save and save the arrival.htm 

file. 

 

Change New Arrivals to the format Heading 1. 

 

Insert a table to organize the information.  The table should have 4 rows and 2 columns, a 

width of 800 px, and a border of 0.   

 

 

 

Cut and paste each paragraph into alternating cells in the 

table (so your text eventually appears only in the table, not 

below it or above it).   

 

Click in the cell next to the paragraph about Hatti and look 

at the tabs below the menu.  Select the Common tab and 

click dropdown arrow next to the Image icon and choose 

Image.   

 

 
 

Select the elephant.jpg and add the ALT text “baby elephant.”   

 

Click on the cell next to the tiger cub information, click on the Image icon (it should say 

Images: Image when you point to it, so you should not have to choose an image from the 

drop-down) and add the tigercubs.jpg image.  Add the ALT text “tiger cubs.”   

 

Add the rhinos.jpg and the chick.jpg image either by using the Image icon or by dragging 

the image from the Files panel to the appropriate cell.  Add the ALT text “rhinos.”   
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Go to File > Save to save the arrival.htm page. 

  

Create the Contact Page 

 

Click on the blank.htm tab.  Go to File > Save As and save a copy of the page as 

contact.htm.  Find the Title box just above your workspace and change the title of the 

page to New Arrivals. 

 

In the Files panel, open the contact.txt file to open.  Select and copy the text into the 

contact.htm file.  Go to File > Save and save the contact.htm file. 

 

 

Change the Contact Us to the format Heading 1.  Change General Information to Heading 

3. 

 

Select the email address information@worldzoo.com.  

Go to Insert > Email link.   

 

Press OK to continue. 

 

 

 

Go to File > Save and save the contact.htm file. Go to the Preview in Browser icon and 

choose a browser.  Test your website to make sure it all works.   

 

Testing your Site on Other Devices 

 

Dreamweaver allows you to view how your page would look on alternate devices.   

At the bottom of the workspace (above the properties panel), you will see three icons 

representing three views:  Mobile size, Tablet size, and esktop size.  There is also a drop-

down next to Desktop size which allows you to change the resolution of the view you are 

looking at, or change your view from portrait to landscape (to see how the page would 

look if the phone/tablet was rotated).   
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Check your page on Mobile, Tablet, and Desktop views.  What issues do you notice?  

How would you change the design of your page to fix any issues? 

 

You should always take time to check your website on multiple platform views and 

preview in multiple browsers so you can identify and address any issues before your site 

is public. 
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A Guide to JavaScript and Forms 
 

Section 1:  Beginning JavaScript 

1.1  A Comparison: 
 

Java JavaScript ASP 

Requires a Java Development Kit, 

text editor, and a browser (for 

applets) 

Requires a text editor and browser   Requires a text editor and browser 

plus a web server with ASP 

support (can use MS Personal Web 

Server with Windows 95 & 98) 

Source code converted to byte 

code 

Source code visible in HTML 

source code (unless hidden) 

Source code not visible in HTML 

source 

Compiled/Interpreted Language  Interpreted Language  Interpreted Language 

Strict rules about declaring 

variables  

Allows variables to be declared as 

used and to change types within 

program  

Allows variables to be declared as 

used 

Client side Client side Server side 

 

1.2  Basic Structure and Conventions   
 
When using JavaScript, the commands are part of the source code.  You must use the  

<SCRIPT LANGUAGE=”JAVASCRIPT”> tag to make use of them.  Here is an example of a simple 

output command using JavaScript: 

 
<HTML> 

<HEAD> 

<TITLE > Beginning JavaScript </TITLE>  

<SCRIPT LANGUAGE="JAVASCRIPT">  

<!-- hide this stuff from other browsers  

document.write(‘Hello World! How are you?’) 

// end the hiding comment -->  

</SCRIPT> 

</HEAD> 

<BODY> 

 </BODY> 

</HTML> 

 
Copy the code into a text editor (like Notepad), save the file as .htm and open it with your web browser.   

 

Note the quotes around the word JAVASCRIPT.  This script demonstrates the "write" output method of the 

"document" object.  For right now, don't worry about what that means, just make sure you know how to do 

it. 

 

Here are some conventions we will follow when using JavaScript: 
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 Always use the entire command <SCRIPT LANGUAGE="JAVASCRIPT"> or  

      <script language="JavaScript">.  Although technically the default language is JavaScript,      

      this might not always be the case so start a good habit now. 

 Most of the time JavaScript commands will be in the <head> section of the HTML document.  

There will be specific times when it will appear in the body, but in general, all JavaScript code 

should be in the <head>. 

 JavaScript commands should be placed between html comment tags.  The reason for this is that 

some browsers do not understand JavaScript, so they will just type the code on the screen along 

with the rest of your text.  This will look extremely goofy.  To avoid this, you should surround 

your code with the <!--  --> comment tags.  Look at the following example:  

 
<HTML> 

<HEAD> 

<TITLE > blah blah blah </TITLE>  

<SCRIPT LANGUAGE="JavaScript">  

<!-- hide this stuff from other browsers  

 

SCRIPT GOES HERE  

 

// end the hiding comment -->  

</SCRIPT> 

 

</HEAD> 

<BODY> 

etc., etc., etc. 

</BODY> 

</HTML> 

  
Note that all the JavaScript commands are surrounded by the comment tags (remember, the <script 

language=" JavaScript"> is an HTML tag).  The only really tricky part you have to remember is 

the end comment is different.  JavaScript knows enough to ignore the <!-- but it doesn't know to 

ignore the -->  (don't ask me why - I have no idea).  SO . . . we use the // which is a JavaScript 

comment so we don't get an error when we do the HTML end comment. 

 

One option is to copy the above code into an html document and save it.  When you get ready to 

do your JavaScript, copy the above and edit the title and enter the script (where the words SCRIPT 

GOES HERE appears).  That way you won't forget the comments. 

 

1.3  Using document.write 
 
Let's look at a simple output statement.  

 

 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

document.write(‘Hello World! How are you?’) 

</SCRIPT> 

Output::   
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Practice:  Edit the source code so the output reads:  Hello World!  I am (put your name here) 

 
Not bad, but nothing you couldn’t do in HTML already.  

 

Let's look at how JavaScript and HTML can coexist in the same file.  Try the following: 

         
<HTML> 

<HEAD> 

<TITLE> Javascript practice </TITLE>  

<SCRIPT LANGUAGE="JavaScript"> 

<!-- hide this stuff from other browsers  

document.write(‘This part is JavaScript!’);  

// end the hiding comment -->  

             </SCRIPT> 

             </ HEAD > 

          <BODY> 

          <H1>THIS PART IS HTML!</H1> 

          </ BODY > 

          </HTML> 

Output:   

  
So be careful to keep everything in its place!  By the way, be careful not to put any HTML between the 

HTML comments!  

 

1.4  Formatting text 

 
The document.write command does not place a carriage return at the end of the line.  How do you get line 

breaks?  The answer is a return to HTML.  Try the following: 

  
<SCRIPT LANGUAGE = "JAVASCRIPT">   Output: 

<!-- 

document.write(‘Hello<br>‘); 

document.write(‘There’); 

document.write(‘Web 1’); 

//--> 

</SCRIPT> 

 

 

Notice the document.write command will correctly interpret the HTML formatting as long as it appears 

between the quotes ‘  ‘.  Try the following examples: 

 
Example1:   

<SCRIPT LANGUAGE = "JAVASCRIPT"> Output:   

<!-- 

document.write(‘<h1>Hello<br></h1>‘); 

document.write(‘There’); 

//--> 

</SCRIPT> 
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Example 2: 

<SCRIPT LANGUAGE = "JAVASCRIPT"> Output: 

<!-- 

document.write(‘<h1>Hello<br></h1>‘); 

document.write(‘<h2><i>There</i></h2>‘); 

//--> 

</SCRIPT> 

 

 

1.5  Using an Alert Box 

 
Let's look at another type of output.  Copy the following into Notepad, save as .htm and view in your 

browser: 

 
<html> 

<head><title> JavaScript practice </title>  

<script language="JavaScript">  

<!-- hide this stuff from other browsers  

alert(‘Hello World!’);  

// end the hiding comment -->  

</script> 

</head> 

<body> 

<H1>That is called an Alert</H1> 

</body> 

</html> 

 

This type of output is called an alert box.  It requires the user to acknowledge the message before the page 

will load.  The message must be written between quotation marks and the entire message must be written 

on one line.  JavaScript does not like carriage returns.  Try this, making sure to enter the line breaks where 

indicated (Example A): 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

alert('Welcome to Mrs. Langston\'s web site. 

Unfortunately Mrs. Langston is busy answering many many 

phone calls at this time and is unable to respond to  

you at this time. 

We won\'t be able to update the site for a few weeks,  

but ya\'ll come back later.') 

//--> 

</SCRIPT> 
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One poor solution would be the following: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

alert('Welcome to Mrs. Langston\'s web site.') 

alert('Unfortunately Mrs. Langston is busy answering many many') 

alert('phone calls at this time and is unable to respond to you at this time') 

alert('We won\'t be able to update the site for a few weeks, ') 

alert('but ya\'ll come back later.') 

//--> 

</SCRIPT> 

 
We don't get errors, but the user may get tired of clicking OK.   

 

1.6  Adding Line Breaks 

 
Try this: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

alert(‘Hello<br>There’); 

 

//--> 

</SCRIPT> 

 

Oops!  The alert command doesn't like the <br>.  There is a way to insert a carriage return in an alert, as 

shown here: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

alert('Hello\rThere') 

//--> 

</SCRIPT> 

 

Some other "Special Characters" that alert commands may use: 

 

\\ Backslash 

\' Apostrophe 

\" Double quote 

\t tab 

\r carriage return 

\n new line 

 
Exercise 1.6:  Write a JavaScript program which displays 3 alert boxes: Today’s date is . . .., My name is. . 

. , and My birthday is . . .  
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Section 2:  Variables 

Variables are letters or expressions to which a value can be assigned.  Variables are useful for storing 

information entered by the user, calculating and displaying information, and facilitating other user 

interactions.   

 

2.1  Variable Names 

 
When using variables, you should keep these tips in mind: 

 

 Use names that have some meaning for you (name, date, age, average) rather than just letters.  

This makes it easier to read your program. 

 Avoid excessively long names (8 characters max)  

 The first character of the variable name must be a letter.  After that, you may use numbers or 

letters or underscore ( _) or any combination of these , but no symbols or spaces 

 

Yes No 

Average_1 First average 

Q_1 Q#1 

Name1 First.name 

 

 JavaScript variables are case sensitive, so once you choose a variable name you must keep using 

the same capitalization. 

 

 

2.2  Assignment Statements 

 
The variable must always be on the left hand side, either by itself or preceded by the var command.   

Correct Incorrect 

var x 

x = 5 
var 5 = x 

var x = 5 x = var  5   

x = 5 5 = x 

x = x + 3 x + 3 = 15 

x += 3  

 

Note:  The use of the var command to declare a variable is completely optional, however it is a good habit 

to use it, as it makes it much easier to read your program. 
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2.3  Displaying variables 

 
To demonstrate that JavaScript are case-sensitive, try the following: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> Output: 

<!-- 

var Hello = 5; 

hello = 7; 

document.write(‘Hello = ‘ + Hello + ‘<br>’); 

document.write(‘hello = ‘ + hello); 

//--> 

</SCRIPT> 

 
Notice that Hello and hello have different values.  Be careful when you use variables to be consistent with 

capitalization and spelling.  The above example also shows how one document.write command can be used 

to output several different strings.  The + operator works differently depending what type of information is 

being used.  Try the following: 

 
<SCRIPT LANGUAGE = ‘JAVASCRIPT’> Output: 

<!-- 

v = 19 + 99; 

w = ‘19’ + ‘99’; 

x = ‘1’ + 9 + 9 + 9; 

y = ‘1’ + (9 + 9 + 9); 

z = 1 + 9 + ‘99’; 

document.write(‘v = ‘ + v + ‘<br>‘); 

document.write(‘w = ‘ + w + ‘<br>‘); 

document.write(‘x = ‘ + x + ‘<br>‘); 

document.write(‘y = ‘ + y + ‘<br>‘); 

document.write(‘z = ‘ + z + ‘<br>‘); 

//--> 

</SCRIPT> 

 

Look carefully at each output: 

19 + 99 = 118 (the + added the values) 

‘19’ + ‘99’ = 1999 (the + put the strings together) 

‘1’ + 9 + 9 + 9 = 1999 (the + put the strings together - since it started with a string, it kept going as 

if they were all strings) 

‘1’ + (9 + 9 + 9) = 127 (JavaScript will follow the rules of order of operations, so it does the 

parentheses first to get 27, then goes back, sees the string and puts the two strings together 1 + 

27 = 127) 

1 + 9 + ‘99’ = 1099 (Following order of operations, it adds the 1+9 to get 10, then sees the string 

and puts the two strings together to get 1099) 

  
When two strings are joined together, it is called concatenation.  For example: 

 

    ‘Hello’ + ‘World’ = ‘HelloWorld’ 

    ‘100’ + ‘200’ = ‘100200’ 

    'Today' + ‘ ‘ + ‘is’ + ‘ ‘ + ‘Saturday’ + ‘!’ = ‘Today is Saturday!’ 
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2.4  Variable Types 
 
Let's take a look at an example of how variables can be used in a program.  Copy the following into 

Notepad, save as .htm and view using your browser: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> Output: 

<!- - 

var a = 5; 

var b = 'Q'; 

var c = 3.14; 

var d = ‘Hello There’; 

var e = true; 

document.write(‘a = ‘ + a + ‘ which is a ‘ + typeof(a) + ‘<br>‘); 

document.write(‘b = ‘ + b + ‘ which is a ‘ + typeof(b) + ‘<br>‘); 

document.write(‘c = ‘ + c + ‘ which is a ‘ + typeof(c) + ‘<br>‘); 

document.write(‘d = ‘ + d + ‘ which is a ‘ + typeof(d) + ‘<br>‘); 

document.write(‘e = ‘ + e + ‘ which is a ‘ + typeof(e) + ‘<br>‘); 

//   typeof is a command that will tell you what data type a variable is 

// - -> 

</SCRIPT> 

 

Notice you do not need to tell JavaScript what type of data will be stored in a variable.  It will decide what 

the variable type is based on the value assigned to it.  There are 3 basic data types: 

 

Number - a numeric value (can be an integer or a real (decimal)) 

String - includes alphanumeric date, can be a single character or a word or phrase 

Boolean - has a value of either true or false 

 

The same variable can change variable type during a program if the value changes.  Try this example: 

 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

var Hello = 13 * 77; 

document.write(‘Hello = ‘ + Hello + ‘ and is a ‘ + 

typeof(Hello) + ‘<br>‘); 

Hello = ‘John’ + ‘ ‘ + ‘Smith’; 

document.write(‘Hello = ‘ + Hello + ‘ and is a ‘ + 

typeof(Hello) + ‘<br>‘); 

Hello = true;  

document.write(‘Hello = ‘ + Hello + ‘ and is a ‘ + 

typeof(Hello) + ‘<br>‘); 

//--> 

</SCRIPT> 

 

Output: 
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The value of Hello depends on what value it holds.   

If a variable has no value or data type assigned to it, it is undefined.  Try this example: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> Output: 

<!-- 

var x; 

document.write(‘x = ‘ + x + ‘ which is a ‘ + typeof(x)); 

//--> 

</SCRIPT> 

 

Exercise 2.4 
 

Look at each variable declaration, and tell the variable type: 
 

Value Type 

X = 200  

 

X = ‘200’  

 

X  =  true  

 

X = 3 + 4  

 

X = ‘hello’ + ‘world’ 
 

 

X = 1 + ‘3’  

 

Write the value of V for each statement: 
 

var V        V = _______________ 

 

V = 20 + 45 V = _______________  
 

V = ‘20’ + ‘45’ V = _______________ 
 

V = ‘2’ + ‘0’ + 45 V = _______________ 
 

V = 20 + 4 + ‘45’ V = _______________ 
 

V = ‘2’ + (4 + 5) + ‘0’ V = _______________ 
 

V = ‘pen’ + ‘guin’ V = _______________ 
 

Use the following to determine the output of each statement: 
 

 v = ‘cat’ w = ‘dog’ 

 x = ‘ ‘ y = 25 
 

document.write(v + w) document.write(v + w + x) 
 

document.write(w + v) document.write(v + w + x + y) 
 

document.write(y + x + w) document.write(v + y) 
 

document.write(y+x+y) document.write(y+y) 
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Section 3:  User Input 

3.1  The Prompt Command 
 
One way of obtaining input from a user is through the prompt command.  The syntax of the command is: 

 

prompt(“Question”, “default response”); 

 

where Question tells the user what input is needed (“What is your name”) and the default response is 

what is typed into the response box.  Try this example: 

  
<HTML> 

<HEAD> 

</HEAD> 

<SCRIPT LANGUAGE = “JAVASCRIPT”> 

prompt(“What is your name?”,”Enter Name 

Here”);  

prompt(“How old are you?”,”Enter Age Here”); 

</SCRIPT> 

<BODY> 

</BODY> 

</HTML> 

 

Output: 

 
Now this works fine, the problem is we don't have any way of using the response from the user!   

 

3.2  Storing and Using Input from the Prompt Command 

 
To keep track of what the user is inputting, we assign the prompt to a variable name.  Try the following: 

<HTML> 

<HEAD> 

</HEAD> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

var Name = prompt(“What is your name?”,”Enter Name  Here”);  

var Age = prompt(“How old are you?”,”Enter Age Here”); 

  document.write(Name + “ is “ + Age + “ years old.”);  

</SCRIPT> 

<BODY> 

</BODY> 

</HTML> 

Output: 

 
This code assigns the user's response to the name question into a variable called Name, and the user's 

response to the age question into a variable called Age.  Refresh the code above and just hit "OK" without 

entering information.  What value is assigned to Name and Age?  What happens if you hit cancel at both 

prompts? 

 
What if you don’t want a value to appear in the entry field?  Try the following: 
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<SCRIPT LANGUAGE = "JAVASCRIPT"> 

var Name = prompt(“What is your name?”); 

var Age = prompt(“How old are you?”); 

document.write(Name + ‘ is ‘ + Age + ‘ years old.’); 

</SCRIPT> 

Output: 

 
What value appeared in the entry field?  That doesn't look very professional to outsiders, does it?  If you 

want the entry field blank, you need to use the following technique: 

 
<SCRIPT LANGUAGE = ‘JAVASCRIPT’> 

var Name = prompt(“What is your name?”,””); 

var Age = prompt(“How old are you?”,””); 

document.write(Name + ‘ is ‘ + Age + ‘ years old.’); 

</SCRIPT> 

 
Notice there is a “” in the spot where the default response goes.  This leaves a blank entry field, but avoids 

that awful "undefined" from appearing there.   

 

Once you have information in variables, you can perform calculations on those values.  Look at the 

following: 

 
<HTML> Output: 

<HEAD> 

</HEAD> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

var Name = prompt(‘What is your name?’,’Enter Name Here’);  

var Age = prompt(‘How old are you?’,’16’); 

document.write(Name + ‘ is ‘ + Age + ‘ years old.<br>‘);  

Age2 = Age + 5; 

document.write(‘In five years, you will be ‘ + Age2 + ‘ years old.’);  

</SCRIPT> 

<BODY> 

</BODY> 

</HTML> 

 
We added a calculation step to add five years to the users age and print it out.  Test the code and see what 

happens.  Did it execute as expected?  Do you think you will feel that old in five years?  OOPS! 

Prompt assumes the input it receiving is a string, so it didn't add the values, it concatenated them. 
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3.3  Using ParseInt 

 
To remedy this situation, add the following to your code: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> Output:   

var Name = prompt(‘What is your name?’,’Enter Name Here’);  

var Age = prompt(‘How old are you?’,’16’); 

document.write(Name + ‘ is ‘ + Age + ‘ years old.<br>‘);  

Age=parseInt(Age); 

Age2 = Age + 5; 

document.write(‘In five years, you will be ‘ + Age2 + ‘ years old.’);  

</SCRIPT> 

 
parseInt() takes a string and turns it into a number.  Now it knows Age is a number and adds it to the 5 to 

get the correct answer.  To see how parseInt works, try the following: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> Output:   

var a = parseInt(‘7Q’); 

var b = parseInt(‘Q7’); 

var c = parseFloat(‘7.1Q’); 

var d = parseFloat(‘7.Q1’); 

var e = parseFloat(‘Q7.1’); 

var f = parseFloat(‘123e45’); 

document.write(‘a = ‘ + a + ‘<BR>‘); 

document.write(‘b = ‘ + b + ‘<BR>‘); 

document.write(‘c = ‘ + c + ‘<BR>‘); 

document.write(‘d = ‘ + d + ‘<BR>‘); 

document.write(‘e = ‘ + e + ‘<BR>‘); 

document.write(‘f = ‘ + f + ‘<BR>‘); 

</SCRIPT> 

 
NaN is JavaScript shorthand for "Not a number" What values did not convert as expected? Why?    

 

3.4  Arithmetic Operators 

 
JavaScript can perform the following Arithmetic operations: 

+ 
Addition 



222 

- Subtraction 

* Multiplication 

/ Integer or Real# Division 

% Modulus (or Remainder) Division 

The Modulus operator takes the given numbers, divides the first by the second and gives the remainder 

from the division.  For example: 

 

20%3 = 2  (20/3 = 6 with a remainder of 2) 

20%4 = 0  (20/4 = 5 with no remainder) 

13%2 = 1 (13/2 = 6 with a remainder of 1) 

 

Exercise 3.4: 
 

1. What does document.write do? 

 

2. Why should JavaScript commands be placed between HTML comment tags? 

 

3. What are the 3 data types in JavaScript?  

 

4. What is the difference between alert() and prompt()? 

 

5. The prompt() command assumes what about the input it receives? 

 

6. Find the value of V in each of the following: 

 

a. V = 20 + ‘03’ 

b. V = 20 + 03 

c. V = ‘20’ + ‘03’ 
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d. V = ‘20’ + 03 

e. V = ‘2’ + 0 + 0 + 3 

f. V =  2 + 0 + ‘0’ + 3 

g. V = 2 + 0 + (‘0’ + 3) 

h. V = 20/5 

i. V = 20%5 

j. V = 22/5 

k. V = 22%5 

 

7. How do you create a line break in a document.write command? 

 

8. How do you create a line break in an alert? 

 

9. When must you use the var command in JavaScript? 

 

 

 

Webmastering Lab Assignment 01 
 

This assignment has two parts:  

 

A.  Create a "Mad-Libs" program 

B.  Average grades 

 

Purpose:  To demonstrate knowledge of input, output, and data manipulation. 

 

 

 

Each of your JavaScript programs should include a comment section with the following information:  

 

/*  JavaScript Lab01a  

Your Name 

Date 
*/ 

 

You should also include the correct html comment tags to make sure your program is compatible with non-

JavaScript enabled browsers. 

 

Part A:  Create a Mad-Libs program  
 

This program will ask the user to input words, then put the words together to make a nonsense (potentially 

humorous) paragraph.  The user should input a minimum of five words of a part of speech you suggest, then the 

program should print out a paragraph which includes the user's words.   

 

Example: 

Enter a noun:  cat  

Enter an adjective:  tall 

Enter an adverb:  merrily 

Enter a color:  red 

Enter a city:  Houston 
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Output: 

The tall cat walked merrily,  He was trying to find the red tree.  He was sure he could do it as he was the 

tallest cat in Houston. 

 

This program will be graded on accuracy of code, formatting of input and output, and creativity of the Mad-lib 

created.  You may only use JavaScript commands we have learned to this point.  Save your program under the 

name Lab01a.htm on your H: drive.  

  

Part B:  Average grades  
 

This program will ask the user to input five grades, then average the grades and print out a list of the grades and the 

average.    

 

Example: 

Enter grade 1:  75 

Enter grade 2:  100 

Enter grade 3:  80 

Enter grade 4:  90 

Enter grade 5: 80  

 

Output: 

Grades:  75, 100, 80, 90, 80 

The average of these grades is  85. 

 

This program will be graded on accuracy of code, formatting of input and output, and accuracy of output.  You may 

only use JavaScript commands we have learned to this point. Save your program under the name Lab01b.htm on 

your H drive.  
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Section 4:  Using Built-in JavaScript Methods 

4.1  lastModified 
 
There are objects which are built into JavaScript, and they have certain attributes called "methods" 

associated with them.  We'll get to all that later.  For now, let's look at one of the characteristics (or 

methods) of a document, called "lastModified": 

 

Copy the following into Notepad, save as html then view using your browser.  What is displayed? 

 
<SCRIPT LANGUAGE="JavaScript"> 

<!-- hide this stuff from other browsers  

document.write(‘This document last altered on ‘) 

document.write(document.lastModified)  

// end the hiding comment -->  

              </SCRIPT> 

 

Output: 

 

 Note:  Remember, JavaScript commands are case-sensitive!! Notice the M is capitalized in 

lastModified.  Watch out! 

 

4.2  Dates and Times 
 
There are other methods available using JavaScript which allow the page to find the current date, time, or 

year.  Using them require you do to a few extra steps, though . . . 

 

The first thing you need is a Date object.  This is just an object which can store a date, and it will default to 

today’s date, but you can set it to any date you like.   

 

To create a Date object, use the command:   

 

var today = new Date (); 

 

This will create a Date object called “today” which contains today’s date.  You can also create a Date 

object which contains another date, for example: 

 

var today= new Date(67, 7, 1);    

 

Will create a Date object with the date August 1, 1967. The order of the parameters is (year, month, day) 

where month is between 0  (January) and 11 (December).  You can also use the format: 

 

var today= new Date("May 13, 1985"); 

 

To create a Date object with the date specified.  If you use this way, make sure you put quotes around the 

date. 

 

Now that we have a Date object, we can access its elements.  There are a variety of methods you can use to 

access the date information: 

 

getDate() Gives the day of the month (between 1 and 31) 
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getDay() Gives the day of the week between 0 (Sunday) and 6 (Saturday) 

getHours() Gives the hour of the day between 0 and 23 

getMinutes() Gives the minutes between 0 to 59 

getSeconds() Gives the seconds between 0 and 59 

getYear() Gives the year (two digits for 1900s, four digits for after 2000 or before 1900) 

toLocaleString() Gives the date and time in the form MM/DD/YY HH:MM:SS  

 

To access and print the Date methods you create a Date object, then use the methods (with the date object) 

to store the information in a variable, then print the variables.  Here’s an example: 
 

<SCRIPT LANGUAGE="JavaScript">  Output: 

<!-- hide this stuff from other browsers  

 

var today= new Date(); 

var the_day=today.toLocaleString();  

document.write(“Today is “ + the_day)  

// end the hiding comment -->  

              </SCRIPT> 

 

You don’t have to use the variable today for your new Date, but if you use something else, be sure to use 

the same thing with the method.   

 
var muskrat= new Date(); 

 var the_day=muskrat.toLocaleString(); 

 

Section 5:  Control Structures & Logical Operators 

5.1  If . . . Statements 
 
Now that you have the ability to input information from the user, you may want to be able to make 

decisions based on that input.  You may not want your program to execute every step from beginning to 

end, but you may want to control the order of the steps executed, and whether or not some steps will be 

executed at all.  Statements that allow you to change how your program executes are called control 

structures.  The first control structure we will look at is the if statement . . . 

 
    syntax:  if (condition)  

 { 
                    do something 

                 } 

  

The condition must be a variable or an expression that can be evaluated to true or false.  If the condition is 

true, the program will "do something" (whatever is specified between the curly braces { }).  If the condition 

is false, it will skip what is between the braces.  Here's an example:  (Don't try to run this part - the 

variables aren't defined) 

 

        if (student_age < 16)  

       { 

            Document.write("Ha - ha, you can't drive");  

        } 

 

We’ll look at what this code means shortly. 
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5.2  Relationship Operators 
 

There are several relationship operators that will work with JavaScript 

 

= =  Equal to  (no space between them)       ** don't use =  

 

!= Not equal to 

 

> Greater than 

 

< Less than 

 

>= Greater than or equal to 

  

<= Less than or equal to   
 

!!!  Remember that = is used to assign a value, while == compares two values. 
 

Exercise 5.2:   
 

Evaluate each of the following if x = 5, y = 3, and z = 8: 
 

(15 != 20)  

(x <= y)  

(y != z)  

(x > y)  

(‘cat’ != ‘dog’)  

(‘pig’ >= ‘cat’) 

 

When comparing strings, JavaScript will consider the one that comes first 

alphabetically to be “less than” the other. 
 

Let's look at an example: 
 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

var Name = prompt(‘What is your name?’,’Bob’); 

var Age = prompt(‘How old are you?’,’17’); 

Age = parseInt(Age) 

if (Age >= 16) 

{ 

document.write(Name + ‘, you are old enough to drive’); 

} 

</SCRIPT> 
 

What happens if the person is older than 16?  What happens if the person is younger than 16?  What 

happens if the person is exactly 16? 
 

What if you want the code to do something if the person is too young to drive?  Try this, and test it using 

the default values: 
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<SCRIPT LANGUAGE = "JAVASCRIPT"> 

var Name = prompt(‘What is your name?’,’Bob’); 

var Age = prompt(‘How old are you?’,’10’); 

 

Age = parseInt(Age) 

if (Age >= 16)  

     document.write(Name + ‘, you are old enough to drive<br>‘);  //no {} because it fits on one line 

document.write(Name + ‘, you are not old enough to drive’) 

</SCRIPT> 

 

Notice that if the “do something” part is only one line, we don’t need to use the {}. 

 

5.3  Using If . . . Else 
 
Test the same program using an age older than 16.  OOPS!  It will print the "You are not old enough" 

statement anyway.  That's not good.  The way to specify you want something to happen only if the "IF" 

statement is false is to use the command else.   
 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

var Name = prompt(‘What is your name?’,’Bob’); 

var Age = prompt(‘How old are you?’,’10’); 

 

Age = parseInt(Age) 

if (Age >= 16)  

    document.write(Name + ‘, you are old enough to drive’); 

else  

    document.write(Name + ‘, you are not old enough to drive’); 

</SCRIPT> 

 

You can use a series of "if" statements together: 
 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

var Name = prompt(‘What is your name?’,’Bob’); 

var fave = prompt(‘Which subject is your favorite: Math, English, Science, History, or 

Webmastering?’,’Webmastering’); 

 

if (fave == ‘Math’) 

{ 

    document.write(Name + ‘, You may be the next Newton (or not).’); 

} 

if (fave == ‘English’) 

{ 

    document.write(Name + ‘, You may be the next Hemmingway (or not).’); 

} 

if (fave == ‘Science’) 

{ 

    document.write(Name + ‘, You may be the next Einstein (or not).’); 
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} 

if (fave == ‘History’) 

{ 

    document.write(Name + ‘, You may be the next History teacher (or not).’); 

} 

if (fave == ‘Webmastering’) 

{ 

    document.write(Name + ‘, You may be the next Mrs. Langston (or not).’); 

} 

</SCRIPT> 

5.4  Using the Confirm command 

 
In addition to alert() and prompt(), there is another input command which can be used in conjunction with 

if statements called the confirm() command.  The user is asked a question, and must respond by clicking 

OK or Cancel.  When you click OK or enter the value of true is returned, click Cancel or X and false is 

returned.  If you assign the response to a variable (as we did with the prompt command) you can respond to 

the user based on what he/she clicked.  Try the example: 
 

<script language="JavaScript"> 

<!-- 

input_box = confirm(‘Click OK or Cancel to Continue’); 

 if (input_box==true)   

     alert (‘You clicked OK’);   // Output when OK is clicked 

 else  

     alert (‘You clicked cancel’);  // Output when Cancel is clicked   

 // --> 

</script> 

 

5.5  Using And and Or 

 
You can also combine the conditions of an "if" statement using and (&&) and or (||), for example, the 

statement 5<x<10 would translate to: if (x>5 && x<10).  Another example is that someone can drive if 

they are over 18 or if they have taken driver's ed, so that conditional might be if (age > 18 || driver_ed = = 

true). 

 

 And statements are true only when both conditions are true. 

 Or statements are true when either or both conditions are true. 

 Combinations of ands and ors are evaluated in this order:  ( ), and, or  

(in other words, it will do all the ( ) first, then the ands, then (finally) the ors 

 

 

Examples:  (For all the examples, T is a boolean variable with value of true, F is a boolean variable with 

value of false) 

 

(T && T) is true 

(T && F) is false 

(T && T && T) is true (with all ands it goes from left to right) 

(T || T) is true 

(T || F) is true 

(F || F) is false 
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(T && T || F) is true  (ands then ors: T&&T is true, true || F is true) 

(T || T && F) is true (ands then ors: T && F is false, T || false is true)  

 

 

 

 

 

 

Exercise 5.5 : 
 

Tell whether each statement is true or false if x = 15, y = 20, z = 12, a = “cat”, b = “dog” and c = “catdog”: 
 

1. (x <= y) 

 

2. (a != c) 

 

3. (x = =y) 

 

4. (a > b) 

 

5. (a = = c) 

 

6. (a < b && y < z) 

 

7. (a < b || y < z) 

 

8. (a = = a || b = = b || c = = c) 

 

9. (a = = b || a= = b && b = = b) 

 

10. (a < b && y < z || c < b) 
 

Webmastering Lab Assignment 02 
 

This assignment has two parts:  

 

A. Calculate and output the fine for a speeding ticket 

B. Average grades and output average including a letter grade 

 

Purpose:  To demonstrate knowledge of input, output, data manipulation, and if statements. 

  

Each of your JavaScript programs should include a comment section with the following information:  

 

/*  JavaScript Lab??  

Your Name 

Date 

Brief Description of Program 

*/ 

 

You should also include the correct html comment tags to make sure your program is compatible with non-

JavaScript enabled browsers. 
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Part A:  Calculate and output the fine for a speeding ticket  
 

This program will ask the user to input the speed they were going, the speed limit of the area they were 

caught, and whether or not it was a school zone.  Use a confirm() statement to determine whether the 

violation was in a school zone, and you should have at least one if . . . else statement (in addition to your if 

statements).  Fines should be calculated as follows: 

 

Not in a school zone: 

$30 base fine (regardless of speed)  

Add $10 for each mile over the speed limit  

Add $100 if the violation was more than 30 miles over the speed limit  

In a school zone: 

$50 base fine (regardless of speed)  

Add $20 for each mile over the speed limit  

Add $100 if the violation was more than 30 miles over the speed limit  

 

Example 1: 

Enter the speed limit:  35 

Enter your speed:  45 

In a School Zone? (Press yes if so, cancel if not):  Cancel 

 

Output: 

Your fine is $130.  Be careful next time. 

 

Example 2: 

Enter the speed limit:  20 

Enter your speed:  55 

In a School Zone? (Press yes if so, cancel if not):  Yes 

 

Output: 

Your fine is $850.  Wow!  Be careful next time. 

 

This program will be graded on accuracy of code, formatting of input and output, and accuracy of output.  

You may only use JavaScript commands we have learned to this point.  Save your program under the name 

Lab02a.htm in your H drive.  

  

Part B:  Averaging grades and outputting letter grades  
 

This program will build upon lab01b.htm.  You will ask the user to input five grades, then average the 

grades and print out a list of the grades, the average, and the letter grade plus an appropriate comment.   

 

Example: 

Enter grade 1:  75 

Enter grade 2:  100 

Enter grade 3:  80 

Enter grade 4:  90 

Enter grade 5: 80 

 

Output: 

Grades:  75, 100, 80, 90, 80 

The average of these grades is  85.   

Your average is a B.  Pretty good. 

 

This program will be graded on accuracy of code, formatting of input and output, and accuracy of output.  

You may only use JavaScript commands we have learned to this point. Save your program under the name 
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Lab02b.htm (do not alter Lab01b.htm) in your H drive. 
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Section 6:  Functions and JavaScript 

  
Functions are parts of programs that are designed to perform a specific task.  Consider the following 

program to average student grades: 

 
<script language=‘JavaScript’> 

<!--  

var g1 = prompt(‘Grade 1’,’’); 

var g2 = prompt(‘Grade 2’,’’); 

var g3 = prompt(‘Grade 3’,’’); 

var g4 = prompt(‘Grade 4’,’’); 

var g5 = prompt(‘Grade 5’,’’); 

 

document.write(‘The grades you entered are ‘ +g1+ ‘, ‘ +g2+ ‘, ‘ +g3+ ‘, ‘ +g4+ ‘, ‘ +g5+ ‘.<p>‘); 

 

g1=parseInt(g1); 

g2=parseInt(g2); 

g3=parseInt(g3); 

g4=parseInt(g4); 

g5=parseInt(g5); 

 

tot = g1 + g2 + g3 + g4 + g5; 

ave = tot / 5; 

document.write(‘The average of your grades is ‘ +ave+ ‘.’); 

 

// end JavaScript --> 

</script> 

 

This program structure is fine, but it could be handled using functions.  Compare the following: 

 
<head> 

<script language="JavaScript"> 

var ave; 

var tot; 

 

function avg_grades() 

{ 

tot = g1 + g2 + g3 + g4 + g5; 

ave = tot / 5; 

} 

</script> 

</head> 
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<body> 

<script language="JavaScript"> 

<!--  

var g1 = prompt(‘Grade 1’,’’); 

var g2 = prompt(‘Grade 2’,’’); 

var g3 = prompt(‘Grade 3’,’’); 

var g4 = prompt(‘Grade 4’,’’); 

var g5 = prompt(‘Grade 5’,’’); 

g1=parseInt(g1); 

g2=parseInt(g2); 

g3=parseInt(g3); 

g4=parseInt(g4); 

g5=parseInt(g5); 

 

document.write(‘The grades you entered are ‘ +g1+ ‘, ‘ +g2+ ‘, ‘ +g3+ ‘, ‘ +g4+ ‘, ‘ +g5+ ‘.<p>‘); 

avg_grades(); 

document.write(‘The average of your grades is ‘ +ave+ ‘.’); 

 

// end JavaScript --> 

</script> 

</body> 

 

Notice the function ave_grades() does the same as the lines of code in the original program did.   

 

There are two steps to using a function: 

 

 The function declaration is where you give the function a name and write the JavaScript 

to tell it what to do.  

 The function call is part of the main program and it instructs the function to begin 

executing.   

 

Some things to keep in mind when using functions: 

 

 Functions must be defined (using a function declaration) before they can be called.  For this 

reason, the functions are always declared in the <head> of the html document, while function calls 

generally appear in the <body> section.  

 

 All parts of a function must appear between the <script> and </script> commands.  

 

 Functions are declared using the syntax  

                 function name() {  }.  

 

 Any variables declared within a function are local variables and will be undefined outside the 

function.   

 

 A function can call another function.  

 

 Variables that are (not declared or) declared outside of the function are global variables and can be 

accessed anywhere in your script. 
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Functions are particularly useful if you need to do the same thing several times in a program.  For example: 

 

<head> 

<script language="JavaScript"> 

var birth1, name1, birth2, name2, birth3, name3, birth4, name4; 

 

function zodiac(name, date) 

{ 

if (date >= 121 && date <= 220) document.write(name + ' is an Aquarius <p>'); 

if (date >= 221 && date <= 320) document.write(name + ' is a Pisces <p>'); 

if (date >= 321 && date <= 420) document.write(name + ' is an Aries <p>'); 

if (date >= 421 && date <= 520) document.write(name + ' is a Taurus <p>'); 

if (date >= 521 && date <= 620) document.write(name + ' is a Gemini <p>'); 

if (date >= 621 && date <= 720) document.write(name + ' is a Cancer <p>'); 

if (date >= 721 && date <= 820) document.write(name + ' is a Leo <p>'); 

if (date >= 821 && date <= 920) document.write(name + ' is a Virgo <p>'); 

if (date >= 921 && date <= 1020) document.write(name + ' is a Libra <p>'); 

if (date >= 1021 && date <= 1120) document.write(name + ' is a Scorpio <p>'); 

if (date >= 1121 && date <= 1220) document.write(name + ' is a Sagitarius <p>'); 

if (date >= 1221 || date <= 120) document.write(name + ' is a Capricorn <p>'); 

} 

</script> 

</head> 

<body> 

<script language='JavaScript'> 

<!--  

name1=prompt('Name1',''); 

birth1 = prompt('Enter birthday - mdd or mmdd (no leading zero on the month, please)',''); 

birth1 = parseInt(birth1); 

name2=prompt('Name2',''); 

birth2 = prompt('Enter birthday - mdd or mmdd (no leading zero on the month, please)',''); 

birth2 = parseInt(birth2); 

name3=prompt('Name3',''); 

birth3=prompt('Enter birthday - mdd or mmdd (no leading zero on the month, please)',''); 

birth3 = parseInt(birth3); 

name4=prompt('Name4',''); 

birth4=prompt('Enter birthday - mdd or mmdd (no leading zero on the month, please)',''); 

birth4=parseInt(birth4); 

 

zodiac(name1,birth1); 

zodiac(name2,birth2); 

zodiac(name3,birth3); 

zodiac(name4,birth4); 

// end JavaScript --> 

</script> 

</body> 
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Function Activity 1 
  
Identify what (if anything) is wrong with each of the following JavaScript programs, then correct the code 

(you may want to type each into a browser): 

 

 1. <HTML> 

<HEAD>  

 <!-- 

function Hello() 

{ 

document.write(‘World’); 

} 

//--> 

  

</HEAD> 

<BODY> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

 

Hello(); 

 

</SCRIPT> 

</BODY> 

</HTML>  

 

2.   <HTML> 

<HEAD>  

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

function Hello() 

{ 

document.write(‘World’); 

} 

//--> 

</SCRIPT> 

</HEAD> 

<BODY> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

 

Hello; 

 

</SCRIPT> 

</BODY> 

</HTML>  

 

3.  
  

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

function Hello() 

{ 

document.write(‘Hello’); 

} 

function GoodBye() 

{ 

document.write(‘GoodBye’); 

Hello(); 

} 
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//--> 

</SCRIPT> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

Hello(); 

GoodBye(); 

</SCRIPT> 

  

4. <SCRIPT LANGUAGE = "JAVASCRIPT"> 

Hello(); 

GoodBye(); 

</SCRIPT> 

 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

function Hello() 

{ 

GoodBye(); 

document.write(‘Hello’); 

} 

function GoodBye() 

{ 

document.write(‘GoodBye’); 

Hello(); 

} 

//--> 

</SCRIPT> 

  

5. <HTML> 

<HEAD>  

 <SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

function getinput() 

{ 

var name = prompt(‘What is your name?’,’’); 

} 

//--> 

 </SCRIPT> 

</HEAD> 

 

<BODY> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

 

getinput(); 

document.write(‘Howdy, ‘ + name); 

</SCRIPT> 

</BODY> 

</HTML> 

 

Webmastering Lab Assignment 03 
 

Revise Lab02 parts A and B to use functions.  Part A should use a function to determine the fine, 

and part B should use a function to assign a grade.  Save as Lab03a and Lab03b. 

 

Purpose:  To demonstrate knowledge of functions. 
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Section 7:  Beginning Forms  

 
Forms are one of the most common ways of interacting with web pages.  There are a variety of input and 

output methods which can be used with forms.  We study forms as part of JavaScript because although you 

can create buttons and text objects in HTML, you need a way to do something with the input, and that 

requires a form handler either in CGI or JavaScript or another programming language.  All elements of a 

form must be included between the <FORM> </FORM> tags.  

 

From this point on (in the interest of space), we will no longer be adding the HTML comments hiding the 

JavaScript commands into the examples, but keep in mind you should still use them in your programs. 

 

7.1  Event Handlers 

 
To handle a users' interaction with a form, you must be able to keep track of what the user is doing with the 

cursor or mouse.  Some of the most common events we can keep track of are: 

 

onClick Occurs when the user clicks on a form element  

onMouseOver Occurs when the user moves the mouse over a link or other form element 

onChange Occurs when the user changes the value of a form field 

onFocus 
Occurs when the user "gives focus" to a form field or window (generally by 

clicking in the field) 

onBlur 
Occurs when the user "removes focus" from a form field or a window (generally 

by clicking somewhere else on the page) 

onMouseOut Occurs when the user moves the mouse off a link or other form element 

 

We're going to take a look at several form elements: 

 

7.2  Buttons 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello() 

{ 

alert(‘Hello World!’); 

} 

</SCRIPT> 

<FORM> 

<INPUT TYPE="BUTTON" VALUE = "CLICK ON ME!" onclick=Hello()> 

</FORM> 

 

 To create a button, you must specify the TYPE of input as "BUTTON" and the VALUE which will be 

whatever text you want to appear on the button.  The only event handler generally used for the button is 

onClick.  In this case, when the user clicks on the button, the function Hello() is called. 
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7.3  Checkboxes 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello()  

{  

  alert(‘Hello World!’);  

} 

</SCRIPT> 

<FORM> 

<INPUT TYPE="CHECKBOX" NAME="CB1" onclick=Hello()> CHECK ME! 

</FORM> 

 
Checkboxes allow the user to decide whether an item should be selected or not selected.  The above script 

uses the onClick handler.  To create a checkbox, the TYPE must equal "CHECKBOX" and you should give 

the checkbox a NAME (in this case NAME = "CB1").  You should also specify some text to appear next to 

the checkbox (in this case "CLICK ME!)  If you have multiple check boxes (and you want the user to be 

able to select one or more), they should each have different names, as follows: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function box1() { alert(‘You clicked box 1!’); } 

function box2() { alert(‘You clicked box 2!’); } 

function box3() { alert(‘You clicked box 3!’); } 

</SCRIPT> 

Click any of the following boxes: <br> 

<FORM> 

<INPUT TYPE="CHECKBOX" NAME="CB1" CHECKED onclick=box1()>  Box 1 <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB2" onclick=box2()> Box 2 <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB3" onclick=box3()>  Box 3 <BR> 

</FORM> 

 
If you execute the above script, you will notice that it doesn't care if you are checking or unchecking the 

box, any activity will generate a response.  You should also notice that box 1 is already checked.  This is a 

result of adding the word CHECKED as an attribute.    

  

7.4  Radio Buttons 
 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello() { alert(‘Thanks!’); } 

</SCRIPT> 

<FORM> 

<INPUT TYPE="RADIO" NAME="RADIO1" onclick=Hello()> #1 

</FORM> 

 
Radio buttons are similar to check boxes.  The main difference is how they are used.  In general, the user 

can check multiple check boxes, but only one radio button at a time.   Try the following example: 
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<HTML> 

Click any of the following buttons: <br> 

<FORM> 

<INPUT TYPE="RADIO" NAME="R1" CHECKED> #1 <BR> 

<INPUT TYPE="RADIO" NAME="R1"> #2 <BR> 

<INPUT TYPE="RADIO" NAME="R1"> #3 <BR> 

</FORM> 

</HTML> 

 
The reason you can only check one radio button at a time is because they all have the same name (in this 

case NAME = "R1").  This prevents multiple buttons from being selected.   

 

7.5  Text Box 

 
A text box allows the user to type information into a box.  In the first example, we will also see how to use 

the information entered: 

 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello() { alert(‘Hello ‘ + FORM1.TEXT1.value); } 

</SCRIPT> 

<FORM NAME="FORM1"> 

ENTER YOUR NAME: 

<INPUT TYPE="TEXT" NAME="TEXT1" onblur=Hello()> <br> AND THEN CLICK SOMEWHERE OUTSIDE 

THE TEXT BOX. 

</FORM> 

 
This script introduces several new concepts.  First, we need to create a text box.  We do this using the 

INPUT tag, where TYPE = "TEXT".  Our text box needs a name, in this case NAME = "TEXT1".  For the 

event handler, there is nothing to click so we will use onBlur which will detect when the user "removes 

focus" from the text box by clicking somewhere else on the page (something is in focus while it is active, 

when it is no longer active it is blurred).   

 

In this example, we want to use the input to personalize our alert message, so we will send what the person 

typed to our function that creates the alert box.  There are several things that must match up to do this 

correctly:   

 

 First, you must give your form a name (so the function knows what form it is looking at).  In this 

case, our form is named FORM1 (not creative, but functional).    

 You must give your text box a name (so the function knows what part of the form to look at).  In 

this case "TEXT1" (JavaScript is case-sensitive, so be careful).  

 JavaScript considers whatever you type into the text box to be the value of the box.  To use what is 

in the box, you can refer to it as "FORM1.TEXT1.value" (which is the value of the box named 

TEXT1 in the form named FORM1).    

 To print out our greeting, the alert box should print ‘Hello, ‘ + FORM1.TEXT1.value (which is 

the value of what's in the box).  

 

You can also put something in the box by assigning a value to FORM1.TEXT1.value like this: 
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<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello() { FORM1.TEXT1.value = ‘JavaScript Master’; } 

</SCRIPT> 

<FORM NAME="FORM1"> 

ENTER YOUR NAME: 

<INPUT TYPE="TEXT" NAME="TEXT1" onblur=Hello()> <br> AND THEN CLICK SOMEWHERE OUTSIDE 

THE TEXT BOX. 

</FORM> 

 

If you want to be able to use the same script with different forms, you can pass the name of the form you 

want to use to the function.  Take a look at the following: 
 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello(form) { alert(‘Hello ‘ + form.TEXT1.value); } 

</SCRIPT> 

<FORM NAME="FORM1"> 

ENTER YOUR NAME: 

<INPUT TYPE="TEXT" NAME="TEXT1" onblur=Hello(FORM1)> <br> AND THEN CLICK SOMEWHERE 

OUTSIDE THE TEXT BOX. 

</FORM> 

 

In this example, you are sending the name of the form to the function by including it between the () of the 

function call.  Function Hello then creates a local variable named form which will contain the name of 

whatever form name you sent (form = FORM1).  When you print out the alert, you refer to the info in the 

text box as form.TEXT1.value (remember, form = Form1, so it is the same statement as before).  This is 

nice if you want to use the same function to handle different forms, like this: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello(form) { alert(‘Hello ‘ + form.TEXT1.value); } 

</SCRIPT> 

 

<FORM NAME="FORM1"> 

ENTER YOUR NAME HERE: 

<INPUT TYPE="TEXT" NAME="TEXT1" onblur=Hello(FORM1)> <br>  

</FORM> 

<FORM NAME="FORM2"> 

OR HERE: 

<INPUT TYPE="TEXT" NAME="TEXT1" onblur=Hello(FORM2)> <br> AND THEN CLICK SOMEWHERE 

OUTSIDE THE TEXT BOX. 

</FORM> 

 
Now, the variable form = FORM1 or form=FORM2, depending on which box you typed in most recently.   

 

 

7.6  Text Area 

 
A text area works like a text box, except there is a much larger space to enter information.  Look at 

the following: 
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<SCRIPT LANGUAGE = "JAVASCRIPT"> 

<!-- 

function Hello(form) 

{ 

alert(‘YOU TYPED THE FOLLOWING:\r \r’ + form.TA1.value); 

} 

//--> 

</SCRIPT> 

 

<FORM NAME="FORM1"> 

TYPE A QUICK PARAGRAPH IN THE SPACE BELOW:<BR> 

<TEXTAREA ROWS="5" COLS="50" NAME="TA1" onblur=Hello(FORM1)>  

</TEXTAREA> <br> 

AND THEN CLICK SOMEWHERE OUTSIDE THE TEXT AREA. 

</FORM> 

 
Text area are created differently than other form elements because you don't use the "INPUT" command, 

you use the "TEXTAREA" command.  You can specify how big you want your text area to be by 

specifying the number of rows (ROWS=5) and columns (COLS=50).  You also need to give the box a 

name (NAME="TA1").  This example uses the onblur() event handler to determine when the user has 

clicked outside the box, and passes the name of the form to the function.    

  

7.7  Drop-Down Menus 

 
Drop-down menus allow the user to choose one of a list of items.  We will also use a different event 

handler called onChange.  Look at the following example: 

 
<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello(form) 

{ 

if (form.DD1[8].selected) // Even though Pluto is the 9th planet, we need index 8 

alert(‘CORRECT!’); 

else 

alert(‘WRONG!’); 

} 

</SCRIPT> 

 

<FORM NAME=‘FORM1’> 

WHAT IS THE FARTHEST PLANET FROM THE SUN? 

<SELECT NAME = "DD1" onChange=Hello(FORM1)>  

<OPTION>MERCURY <OPTION>VENUS <OPTION>EARTH 

<OPTION>MARS <OPTION>JUPITER <OPTION>SATURN 

<OPTION>URANUS <OPTION>NEPTUNE <OPTION>PLUTO 

</SELECT> <br> 

</FORM> 



243 

 

To create a drop-down menu, you must specify several components.   

 

 Use the <SELECT></SELECT> tags to create a drop-down menu  

 Use the <OPTION> tag (no end tag is necessary) to create the list of choices for the drop-down 

menu.  

 Use the onChange() event handler to determine when the user has selected a choice from the 

menu.  

 

This will create the drop-down menu with your options as choices.  JavaScript will number the options 

beginning with 0 (the first choice is choice 0, then choice 1, then 2, etc.)  and assign each option a value.  

The one that was selected will be set to "selected."  In this case, the correct choice is the 9th option that is 

assigned number 8 (remember, it starts counting at 0).  If the user selected this option, then 

FORM1.DD1[8].selected will be true.  If the user selected a different option, then  

FORM1.DD1[8].selected will be false.  (Remember that since we are passing the form name to the 

function, form = FORM1, so form.DD1[8].selected is the same as FORM1.DD1[8].selected.) 

 

If it is too confusing to remember to start counting with 0, you might consider leaving the first option 

blank, or using the question as the first option: 

 
<HTML> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello(form) 

{ 

if (form.DD1[9].selected) // Now Pluto is option #9 

alert(‘CORRECT!’); 

else 

alert(‘WRONG!’); 

} 

</SCRIPT> 

<FORM NAME="FORM1"> 

<SELECT NAME = "DD1" ONCHANGE="Hello(FORM1)">  

<OPTION>What is the farthest planet from the sun? 

<OPTION>MERCURY <OPTION>VENUS <OPTION>EARTH 

<OPTION>MARS <OPTION>JUPITER <OPTION>SATURN 

<OPTION>URANUS <OPTION>NEPTUNE <OPTION>PLUTO 

</SELECT> <br> 

</FORM> 

</HTML> 

 
 Now, the question is choice 0, Mercury is choice 1 instead of 0, so Pluto is choice 9 instead of 8. 

  

Exercise 7.7: 
 

Which of the following are not created using the <INPUT> tag? 

 

 Button  

 Checkbox  
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 Radio Button  

 Text Box  

 Text Area  

 Drop-down Menu  

Which of the event handlers (onClick, onBlur, onChange) is generally used with each form 

component:   

 

 Button  

 Checkbox  

 Radio Button  

 Text Box  

 Text Area  

 Drop-down Menu  

 

True or false:  If you use several checkboxes, and you want the user to select as many as he/she 

wants, they should all have the same name (ex:  NAME=CB1).   

 

True or false:  If you use several radio buttons, and you want the user to select only one, they should 

all have the same name (ex:  NAME=R1).   

 

True or false:  If you were going to create a multiple choice test using radio buttons, every button on 

the page should have the exact same name. 

 

Section 8:  Using Forms 

 
In this section, we will take a look at how to use the information collected with a form to interact with a 

user.  In general, you will let the user complete information, then press a button to indicate that he/she is 

finished.  Here is an example where the user answers a question using a radio button, then clicks a submit 

button to call the function to check the answer: 

 

<HTML> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello()  

{ 

if (Form1.RADIO1[4].checked) // Jupiter (5th choice) is the correct answer 

alert('CORRECT!'); 

else 

alert('WRONG!'); 

} 

</SCRIPT> 

<FORM NAME="Form1"> 

What is the largest planet in the Solar System? <BR><BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Mercury <BR> 
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<INPUT TYPE="RADIO" NAME="RADIO1"> Venus <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Earth <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Mars <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Jupiter <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Saturn <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Uranus <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Neptune <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Pluto <BR><BR> 

<INPUT TYPE="BUTTON" Value="Grade Me!" onclick=Hello()> 

</FORM> 

</HTML 

 

This form has 9 radio buttons (all called RADIO1 - remember, if they all have the same name only one can 

be selected at a time).  It also has one button on the bottom to do the grading.  Once the user clicks the 

"Grade Me!" button, it calls the function Hello().  Hello looks to see if Form1.RADIO1[4].checked is true 

(meaning the 5th option is checked - JavaScript counts the buttons as 0, 1, 2, etc.).  If so, it is correct, if not 

it is wrong.   

 

8.2  Reset and Submit Buttons 
 
You can also include a reset button using the built-in reset button: 

 
<HTML> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello()  

{ 

if (Form1.RADIO1[4].checked) alert(‘CORRECT!’); 

else alert(‘WRONG!’); 

} 

</SCRIPT> 

 

<FORM NAME=”Form1”> 

What is the largest planet in the Solar System? 

<BR><BR><INPUT TYPE="RADIO" NAME="RADIO1"> Mercury <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Venus <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Earth <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Mars <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Jupiter <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Saturn <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Uranus <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Neptune <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Pluto <BR> <BR> 

<INPUT TYPE="BUTTON" VALUE="Grade Me!" onclick=Hello()> 

<INPUT TYPE="RESET"> 

</FORM> 

</HTML> 
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The reset button allows the user to clear all the answers at once.  There is also a built-in 

Submit button: 

 
<HTML> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello()  

{ 

if (Form1.RADIO1[4].checked) alert(‘CORRECT!’); 

else alert(‘WRONG!’); 

} 

</SCRIPT> 

 

<FORM NAME=”Form1”> 

What is the largest planet in the Solar System? 

<BR><BR><INPUT TYPE="RADIO" NAME="RADIO1"> Mercury <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Venus <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Earth <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Mars <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Jupiter <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Saturn <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Uranus <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Neptune <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> Pluto <BR> <BR> 

<INPUT TYPE="SUBMIT" onclick=Hello()> 

<INPUT TYPE="RESET"> 

</FORM> 

</HTML> 

 

8.3  Multiple Questions and Forms 

 
If you want to have separate questions, each set of radio buttons should have the same name (all the choices 

for question 1 should be the same, the ones for question 2 should be the same, etc.) 

 

<HTML> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello(form) 

{ 

if (form.RADIO1[4].checked && form.RADIO2[1].checked) alert('You got both right!'); 

else if (form.RADIO1[4].checked || form.RADIO2[1].checked) alert('You got one right.');  

else alert('You got both wrong!'); 

} 

</SCRIPT> 

<FORM NAME="Form1"> 

2 + 3 = <BR><BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> 1 <BR> 
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<INPUT TYPE="RADIO" NAME="RADIO1"> 2 <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> 3 <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> 4 <BR> 

<INPUT TYPE="RADIO" NAME="RADIO1"> 5 <BR><BR><BR> 

17 - 4 = <BR><BR> 

<INPUT TYPE="RADIO" NAME="RADIO2"> 12 <BR> 

<INPUT TYPE="RADIO" NAME="RADIO2"> 13 <BR> 

<INPUT TYPE="RADIO" NAME="RADIO2"> 14 <BR> 

<INPUT TYPE="RADIO" NAME="RADIO2"> 15 <BR> 

<INPUT TYPE="RADIO" NAME="RADIO2"> 16 <BR><BR><BR> 

<INPUT TYPE="BUTTON" Value="Grade Me!" onclick=Hello(Form1)> 

</FORM> 

</HTML> 

 

Here we have created two questions with two sets of radio buttons, the RADIO1 set and the RADIO2 set.  

We also have a more complicated function to handle them.  We need to determine if both are correct, one 

or the other is correct, or neither is correct.  

 

This is a good time to bring up the topic of formatting forms.  The above question would look much better 

if the answers were lined up horizontally.  You should use a table to organize your form whenever possible. 

In the example below the borders are visible to demonstrate how they are used.  When you create your 

tables, make sure you set BORDER=0. 

 

<HTML> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello(form) 

{ 

if (form.RADIO1[4].checked && form.RADIO2[1].checked) alert(‘You got both right!’); 

else if (form.RADIO1[4].checked || form.RADIO2[1].checked) alert(‘You got one right.’);  

else alert(‘You got both wrong!’); 

} 

</SCRIPT> 

<FORM NAME=Bob> 

<TABLE BORDER=1> 

<TR> 

<TD COLSPAN = 5> 

2 + 3 = <BR><BR></TD> 

</TR> 

<TR> 

<TD><INPUT TYPE="RADIO" NAME="RADIO1"> 1 <br></TD> 

<TD><INPUT TYPE="RADIO" NAME="RADIO1"> 2 <br></TD> 

<TD><INPUT TYPE="RADIO" NAME="RADIO1"> 3 <br></TD> 

<TD><INPUT TYPE="RADIO" NAME="RADIO1"> 4 <br></TD> 

<TD><INPUT TYPE="RADIO" NAME="RADIO1"> 5 <BR></TD> 

</TR> 

<TR> 

<TD COLSPAN = 5> 
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<BR><BR>17 - 4 = <BR><BR></TD></TR> 

<TR> 

<TD><INPUT TYPE="RADIO" NAME="RADIO2"> 12 <br></TD> 

<TD><INPUT TYPE="RADIO" NAME="RADIO2"> 13 <br></TD> 

<TD><INPUT TYPE="RADIO" NAME="RADIO2"> 14 <br></TD> 

<TD><INPUT TYPE="RADIO" NAME="RADIO2"> 15 <br></TD> 

<TD><INPUT TYPE="RADIO" NAME="RADIO2"> 16 <BR></TD></TR> 

<TR> 

<TD COLSPAN = 5><INPUT TYPE="BUTTON" Value="Grade Me!" onclick=Hello(BOB)></TD></TR></TABLE> 

</FORM> 

</HTML> 

 
With radio buttons, you only need to check if the correct answer was selected, since only one answer can be 

selected at a time.  When you use checkboxes, you should check the status of every box to make sure the 

ones that are supposed to be checked are, and the ones that are not supposed to be aren't.   

 

Here is an example: 

 
<HTML> 

<SCRIPT LANGUAGE = "JAVASCRIPT"> 

function Hello(form) 

{ 

// we must  make sure the correct ones are checked and the  incorrect ones are not checked 

if (!form.CB1[0].checked &&  

!form.CB1[1].checked &&  

!form.CB1[2].checked &&  

!form.CB1[3].checked &&  

form.CB1[4].checked &&  

form.CB1[5].checked &&  

form.CB1[6].checked &&  

form.CB1[7].checked &&  

!form.CB1[8].checked) 

alert(‘CORRECT!’); 

else 

alert(‘WRONG!’); 

} 

</SCRIPT> 

<FORM NAME=BOB> 

Which planet(s) in the solar system have rings? <BR><BR> 

<INPUT TYPE="CHECKBOX" NAME="CB1"> Mercury <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB1"> Venus <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB1"> Earth <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB1"> Mars <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB1"> Jupiter <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB1"> Saturn <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB1"> Uranus <BR> 

<INPUT TYPE="CHECKBOX" NAME="CB1"> Neptune <BR> 
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<INPUT TYPE="CHECKBOX" NAME="CB1"> Pluto <BR> 

<BR> 

<INPUT TYPE="BUTTON" Value="Grade Me!"  

onclick=Hello(BOB)> 

<INPUT TYPE="RESET"> 

</FORM> 

</HTML>  

 
The function checks each item to make sure the correct ones are checked (form.CB1[0].checked) and the 

incorrect ones are not checked (!form.CB1[0].checked ) - the ! means "not."   

 

Webmastering Lab Assignment 04 
 

The Interactive Test 
 

Write the script that will create an on-line test with 25 questions 

 

There need to be at least 5 questions from each category: 

 

· True/False  

· Single-Answer Multiple Choice 

· Multiple-Answer Multiple Choice 

· Fill in the blank 

· Drop-down menu 

 

Each of your JavaScript programs should include a comment section with the following information:  

 

           /*  JavaScript Lab04 

Your Name 

Date 

Brief Description of Program 

*/ 

 

You should also include the correct html comment tags to make sure your program is compatible with non-

JavaScript enabled browsers. 

  

 

You will decide what this test is on. Pick a subject that you are very knowledgeable in. It does not have to 

be a school subject. It can be trivia for sports, music groups, movies, etc. 

 

5 True/False Questions  

 These will use radio buttons.   

 Each question will have the exact same 2 choices: True and False.  

5 Single-Answer Multiple Choice Questions 

 These will use radio buttons.   

 Each question will have from 3 to 5 choices.  

 Only one answer is correct. 

5 More Single-Answer Multiple Choice Questions 
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 These will use drop-down menus.   

 Each question will have from 3 to 5 choices.  

 Only one answer is correct. 

5 Multiple-Answer Multiple Choice Questions 

 These will use check boxes.   

 Each question will have from 5 to 10 choices.  

 There need to be a minimum of 2 selections, which comprise the correct answer.  

 This does not mean there is more than one possible answer! There is only one correct 

combination! 

5 Fill in the Blank Questions 

 These will use text boxes.   

 Each question should have a simple one or two word answer.  

 Remember case sensitivity and provide appropriate directions for the user accordingly. 

You should include a submit and reset button.  At minimum, you should tell the user his/her score 

(calculated as a percentage of correct answers - each question should be weighted the same). 

  

Your grade will be based on how well you have met the criteria, accuracy of content and answers, correct 

grammar and spelling, clarity of directions provided to the user, and overall creativity. 
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Embedding Sound or Video 
 

     The basic embed format looks like this:  

<EMBED SRC="filename.???"></EMBED> 

 

Put a sound or video file name in for "filename.???", you'll get the sound to play if the 

user has the plug-in to play the file type.  In past versions of Internet Explorer the embed 

command didn’t work, however in the lastest versions it appears to work fine.   

 

Here is an example of embedding a sound:  

 

<EMBED SRC="peanuts.mid" AUTOSTART=false LOOP=false WIDTH=145 

HEIGHT=55 ALIGN="center"> 

</EMBED> 

 

EMBED tells the browser an embedded sound or video is here -- go get the plug-in. 

Remember, embed commands are associated with plug-ins. 

Note: If no plug-in is available, the browser will do one of three things: 

 Do nothing. This is true of very early level browsers or browsers other than 

Netscape.  

 Put up a dialogue box asking you how you want to handle the file.  

 Tell you a plug-in is needed and ask you if you'd like to go get it. 

 

Inside the main EMBED command, you have the ability to place a bunch of different 

attributes or sub-commands.   

 HEIGHT="--" and WIDTH="--" This sets the height and width of the space in 

which the embedded item will play. With a sound, this matters little. In fact, if 

you don’t want to see the control panel, set them both to 0.  With video it matters 

quite a bit.  Make sure your window is big enough to see the video.  

 LOOP="--" This states if the sound or video will play again and again ("true") or 

if it should play once and stop ("false" or no use of the LOOP command.)  

 HIDDEN="--" This will work to hide the control panel. Fine for sound, not for 

video.  The problem is it also hides the video. That's not good. Don't use it.  

 AUTOSTART="--" This tells the browser to start the video right away ("true") 

upon its download completion or to wait for viewer clicks to start playing ("false" 

or no use of the command).  
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Formats 
      
Audio: 

 

Some of the main formats of interest in digital audio are wave (.wav), MP3 (.mp3), MIDI 

(.mid), RealAudio (.ra), and Windows Media (.wma). Each format has its particular 

strengths and specific uses. Wave and MP3 files are the two kinds of files generally 

involved in creating custom CDs. When you convert analog sound to digital by recording 

music with your computer, the resulting file will be in wave (.wav) format.  

 

Wave (.wav) Wave is the standard form for uncompressed audio on a PC. Since a wave 

file is uncompressed data - as close a copy to the original analog data as possible - it is 

therefore much larger than the same file would be in a compressed format such as mp3 or 

RealAudio.  

 

MP3 (.mp3) is a popular compressed audio format widely used to transfer music over the 

internet. MP3s are created by taking wave audio data and processing it with a special 

algorithm. This algorithm removes parts of the audio that theoretically cannot be detected 

with the human ear; in actuality, there will be some degradation of quality, but this 

depends on the quality (bitrate) with which you choose to encode the file. The net result 

is an MP3 file which is vastly smaller than the original wave file, but sounds very nearly 

as good. As an example of the huge size difference between a wave file and an MP3, a 

three minute song will take up 30 Mb as a wave file, but only between 2 and 7 Mb as an 

MP3 (depending on the bitrate you choose). This explains why MP3 files are so popular 

for trading music on the internet.  Note: though they are controversial because of certain 

copyright abuses, MP3 files themselves are not illegal.  

 

RealAudio (.ra) is a streaming audio format often used by internet radio stations and for 

posting sound files on websites. RealAudio files are smaller even than MP3 files - around 

500 Kb a song - but are of lower quality if compressed enough to play over a slow 

connection (such as a 56 kbps modem).  

 

MIDI (.mid) is an entirely different sort of file. Unlike the previous two formats, it is not 

compressed audio. MIDI is a kind of ‘language’ that allows computers and certain 

musical instruments to communicate. This language consists of instructions telling the 

instrument (or the MIDI synthesizer in your sound card) which notes to play, with what 

instrument, and when. MIDI can be used entirely within a computer, with no external 

instruments. MIDI files have a synthesized sound, and are quite small, around 30-60 Kb 

for your average song.  You won’t be able to reproduce vocals, though, and the sound is 

generally pretty cheesy. 

 
http://www.blazeaudio.com/howto/bg-formats.html 
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Video:   
 

The three biggies are AVI, Quicktime, and MPEG. 

 

AVI (short for audio/video interlaced) is the video file-type used by Video for Windows, 

which is the multimedia architecture developed for Windows 95. AVI is supposed to play 

back faster and smoother than other formats by interleaving the audio data with every 

video frame.  

 

Quicktime (.mov) was developed by Apple for their Macintosh computers and has been 

adapted for other computer platforms. Most CD-ROMs use Quicktime movies and there 

are several sites on the Internet that make use of the format. The images are of higher 

quality, but file sizes can be significantly larger than other video storage formats. 

 

MPEG – Similar to the MP3 format for audio, MPEG ("Motion Picture Experts Group") 

can also be used for playback of video on computers. The use of MPEG on the Internet is 

limited to fairly short segments and a user will need a player capable of viewing the files. 

Quality can be quite good with the format; the user has the option of playing the clip full-

screen with most MPEG players.  
http://cit.duke.edu/resource-guides/tutorial-web-multimedia/17-video-formats.html 

 

Multimedia Project 

 

You will create a web page that includes Multimedia. 

 

You must include the following in your web page: 

o A music clip captured from a cd that plays automatically when the page loads, 

and continues to play until the user stops it using the controller (which should be 

visible) 

o An audio clip of your voice which can be played (using the visible controller) 

o A video which will play when the user chooses (using the visible controller) 

o A Photostory containing at least 10 pictures with music and transitions (~ 1 min)  

  

Each of your clips should be accompanied by a written explanation of what the clip is and 

what the user needs to do to stop or start it.   

 

Use a table to organize your players.  Your page should demonstrate good design 

technique and have at least some content besides explanations.  You may choose to 

explain why you chose the music and/or greeting you did, or just tell me something 

interesting about yourself and the clip. 

 

Do good work – this should be an easy grade! 
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Banner Ads 
 

How do you make $$ from web pages?  There are basically three ways . . . 

 

 Sites that are “pay per view” or require subscriptions.  These are sites you 

must pay for before you are allowed access to the content.  Consumer Reports 

would be an example.  Some magazines and newspapers will provide excerpts 

from the current issue, but require you to be a subscriber to access archive 

information.   

 Selling products.  These are sites that sell actual merchandise like books, toys, 

clothes, or music.  You must enter a credit card number and they will either ship 

the product to you or allow you to download it electronically.  

 Advertisements.  Some sites which do not charge for their content instead 

include ads on their site.  Not unlike TV commercials, the ads are generally for 

products not related to the sire.  Also similar to TV commercials, it is sometimes 

difficult to tell what is content and what is advertising. 

 

Banner Ads are ads that appear on web pages.  They range in size from quite small to 

standard horizontal banner styles (468x60) to “Skyscraper” style (120x600) that fill a 

vertical column to “Half-page” size.  If you click them, you will go to the advertiser’s 

page.  Hate them?  Never look at them?  Which ones bother you the most?  Amazing that 

you can remember them, isn’t it? 

 

There are three general types of Ad Banners: 

 

 Static (simple graphic linked to a site) 

 Animated (animated GIF linked to site) 

 Rich media (audio, video, Java, Shockwave – may be interactive) 

 

How is a banner ad different than a print ad?  Banner ads can be dynamic (“slap the 

mosquito” or “catch the dog”).  Some of them look like mini games.  Once the user clicks 

on the banner, they are transported to the seller’s website. 

 

There are basically two goals of advertisers when they use ad banners.   

 

 Click-throughs happen when a user clicks the ad banner and (hopefully) 

purchases something. 

 Branding occurs when the user begins to associate the product with the service 

and may affect decision making down the road.  Which on-line company do you 

think of when you want to order a book?  Sell something on an on-line auction?  

True branding has occurred when you can remove a product reference and 

consumers still make the association between the concept and the product.  Does 

the expression “Bah-da-ba-ba-baaaa . . . I’m loving it” make you hungry?  Does 

seeing President Palmer on 24 make you think of auto insurance?     
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In general, there are three ways to measures how successful a banner ad is: 

 

 Number of Click-throughs (number of people who actually click on the banner 

and are sent to the seller’s page) 

 Number of Page Views (number of people who view the page, generally 

expressed as CPM – cost per thousand views) 

 Click-through rate (percent of viewers who click-through) 

 

If you have a product to sell and want to advertise on the web, there are many ways to get 

started.  Some of the most common include: 

 

 Make a deal with other pages.  You post ads for them on your page, and they 

agree to post ads for you on theirs.  This is relatively simple and does not require 

you to actually spend money for advertising (beyond what you already pay for 

your site).  It does have drawbacks, though.   The products should not be 

competing (booksellers don’t generally post ads of other booksellers on their 

sites), and there has to be sufficient and quality content on the site to draw people 

to the site.   

 Pay sites directly to display your ad.  You can work out a deal to pay a website 

to include your banner on their site.    

 Pay an organization to post the banner on a number of sites.  These 

organizations (like DoubleClick) are like banner brokers who have a list of clients 

and websites and try to find the best space for you. 

 

If you have a great website and you are interested in selling advertising space, there are 

several ways to get started.  The easiest option is to join a banner ad network.  The 

network will recruit advertisers and keep track of your earnings.  They keep a big 

percentage of the profits. 

 

Many banner networks require you to have at least 250,000 visitors per month to join. 

Networks generally restrict site content (generally they will avoid sites with adult content 

and those that promote illegal activity such as hacking or pirating software).  They 

generally require you to own your own domain name, you cannot use a free site, and they 

will not post ads on personal home pages.  Many also avoid sites that contain message 

boards or forums (or allow “unregulated content” to be published).   

 

Many Banner Ad Networks offer “Targeting” which displays ads only on sites that meet 

certain criteria set by the advertiser (content, language, visitor location) or only at certain 

times of the day.   For example, if a company wants to advertise a new video game, they 

will assist you by targeting sites that are in categories like “computers and gaming” or 

“sports and recreation” and might stay away from sites in categories like “health and 

fitness.”   

 

If you are interested in advertising a product or service of your own and displaying 

advertising for other people, you might want to consider a Banner Exchange Program.  If 

you join a Banner Exchange Program, they will display your banner on 1 site for every 2 
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banner ads of theirs you display on yours.  The advantage is that you get free advertising 

for your product or service on other sites.  The disadvantage is that in general, you have 

virtually no control over what ads appear on your site.  If you decide to do a banner 

exchange, you should investigate different programs.  Some are more flexible about ad 

placement, others give you some control over the types of ads you display. 

 

Another option for web advertising is a Click-through Program.  Joining a click-through 

program, you earn money each time a visitor clicks on an ad.  The downside is that very 

few people actually click on the ads (< 1% do) so you’d better have lots of traffic if you 

expect to make any money 

 

Show me the money!  Expected revenue: 

 

Banner Ad Networks: 

 Assume you earn $5 CPM (cost per thousand page viewings) rate for the ads. 

 The network takes between 30% and 50% as its cut, so you earn $3 per thousand 

viewings as you rate.  

 If your site generates 100,000 impressions per month, you can expect to receive a 

check for $300 every month.  

 

Click-through Program: 

 If you are getting paid per click, you might receive anywhere from 3 cents to 20 

cents per click.  

 5 cents might be a typical average. If you get a 1% click rate and you have 

100,000 impressions per month, that means that you might expect to receive $50 

per month.  

 

Tips for creating effective banner ads 

 

 Post banner ads on pages with related Web content -- the more related, the better.  

 Advertise a particular product or service in your banner, rather than a website.  

 Put banner ads at the top of the page, rather than farther down.  

 Use simple messages rather than complicated ones.  

 Use animated ads or rich media rather than static ones.  

 Keep banner ad size small. If the page takes too long to load, a lot of visitors will 

go on to another page.  

 

If you want to make money from banner ads, the most important thing is to make sure 

you create a quality site that attracts a lot of traffic.  The more traffic, the more money 

you can earn for the ads you display.  You should also shop around for the best deal and 

the best situation.  Ideally, you want to maintain control of the type and location of ads on 

your page if possible. 
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Other types of web advertising: 

 

 Pop under windows display under the website and are visible when the user 

closes the site. 

 Interstitial ads are pages or pop up windows that appear after you click on a link 

but before you actually launch the new page.  Sometimes these pages open and 

close automatically, sometimes they are designed to appear during file downloads.  

The goal is for these ads to act as mini-commercials, filling “dead time,” rich in 

media and entertaining to the user.   

 Text ads are often mixed in with the content of the page.  Google and about.com 

use text ads as part of their content (they refer to them as “Sponsored Links”).  

Text ads are generally considered less annoying, they require lower production 

costs, and they are targeted specifically to address the content on the page.  A 

search for Hawaii on Google may yield information about geography, culture, or 

climate plus lots of text ads for travel agencies, hotels, and airlines.     
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CSS – Adding Style to Web Pages 
 

What is CSS?  Why use it? 
 

CSS stands for cascading style sheets and is the coding that allows you to control the visual formatting of 

web pages and sites.  

 

The main advantage of using CSS to control the format of web pages is that it helps separate the content of 

the document from the design.  This is the key to creating web pages that are not only useful but accessible 

to all users (including users who are visually impaired, or otherwise viewing the web page in a 

nontraditional manner).  It also facilitates site maintenance by allowing the user to make changes in the 

design of one page consistent throughout the site.   

 

In general, web page designers tend to think of themselves as designers.  Most of the focus of the creation 

is on how the page looks, and too little is on how the page functions or the quality of the content of the 

page.  CSS allows the style of the page (colors, fonts, background images) to be specified separately from 

the content of the page itself.  In theory, it encourages the webmaster to focus on the meat of the page, 

rather than its appearance.   

  

The Basics 
 

There are several ways to add CSS formatting to your web page, but in each of the ways you have to 

specify what formatting you want to apply to which elements of the page.  This is done through the use of 

rules. 

 

In general, a style rule looks like this: 

  

A {color: navy;} 

  

 This rule tells the page that you want the links (A stands for Anchor) to be navy. 

  

Structure 
 
CSS rules consist of a selector and a declaration. It will look somewhat like this (the part between the {  } is 

called the declaration):  

 

selector {property: value;}    

 

The selector identifies what element on the page will be affected by the rule. In the example above, A is 

the selector. The selector is usually an HTML tag, but there are other types of selectors which we will 

discuss later. 

  

The declaration has two parts, the property and the value contained within two braces.  The property 

identifies which attribute of the selector you are going to change (font-face, color, size) and is followed by 

a colon.  The value is the value you want the property to take on (Arial, red, 12pt), and it is followed by a 

semicolon.  In the example above, the property is color and the value is blue.    
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Applying CSS to a Page  
 
Now that you know how to create rules, you need to be able to tell your html document which rules you 

want to use.  You can do this three different ways:  

 

Inline Style Sheets  

Embedded Style Sheets  

External Style Sheets  

  

Inline Style Sheets: This is a style you would put as an attribute for an HTML tag. This style will only 

effect the information that this tag effects. Note that by changing this rule, you will only affect that one tag. 

In this case, only the "Hello" link would be navy. This is how you would put the "universal example" in 

inline styles: 

  

    <A HREF="hello.htm" STYLE="color: navy;">Hello</A> 

  

This would cause the link to be navy. 

 

One common way to use inline style sheets is to position the background image on a page.  For example, to 

set the background image to appear once, positioned in the upper-left corner of the page, you can use: 

<BODY BGCOLOR=”GREEN” BACKGROUND=”IMAGE.JPG” STYLE=”background-repeat: no-

repeat”> 

 

To set the background image to tile (or repeat) across the top: 

<BODY BGCOLOR=”BLUE” BACKGROUND=”IMAGE.JPG” STYLE=”background-repeat: repeat-x”> 

 

To set the background image to tile (or repeat) down the left side: 

<BODY BGCOLOR=”BLUE” BACKGROUND=”IMAGE.JPG” STYLE=”background-repeat: repeat-y”> 

  

Embedded Style Sheets: These are style sheets that show up in your head tag. You must use the style tag 

with the type attribute “text/css.”   

 

<HTML> 

<HEAD> 

    <STYLE TYPE="text/css"> 

       <!-- 

        A {color: navy;} 

 --> 

    </STYLE> 

</HEAD> 

... 

</HTML> 

 

The actual style rules are generally enclosed between comment tags.  This causes any older browsers that 

don’t understand the STYLE tag to simply ignore the rules (rather than display them on the page as if they 

were text).   

 

Adding rules using embedded style sheets only affect selectors on that one page. In this case, only the links 

on this page would be navy. This is how you would put the above example in an embedded style sheet: 

  

External Style Sheets: Another way to add style rules to your page is by using external style sheets.  The 

nice thing about doing it this way is that you can use the same rules for an entire site rather than just one 

page. That means if I wanted to change the color of all the links on a billion page website, all I'd have to do 

is change the color value on one style sheet (assuming all the pages were linked to the same external style 

sheet.)   
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The first step is to create an external style sheet.  The easiest way to do that is to use a text editor like 

Notepad.  Create a blank document and save it as filename.css (not .txt – it makes a big difference).  

 

The external style sheet itself just contains a list of the rules you want to use on your site.  It doesn't have 

any extra codes.  For example: 

  

A {color: navy;} 

H1 {color: red; font-size:30pt;} 

H2 {color: green; font-size:24pt;} 

  

This style sheet would set the hyperlink color to navy, the H1 text to be red, 30pt, and the H2 text to be 

green, 24 point.  If you later decide that you want all the pages to have green hyperlinks, you change the 

style sheet and all the pages that refer to it will change. 

 

Once you have created your external style sheet, you must create a special link to it from every HTML 

document you want to use it.  There are two different ways you can link to an external style sheet. It doesn't 

matter which code you use; both are correct.  

  

<html> 

<head> 

    <link rel="stylesheet" type="text/css" href="filename.css"> 

</head> 

... 

</html> 

  

Or 

  

<html> 

<head> 

    <style type="text/css"> 

        @import url(filename.css) 

    </style> 

</head> 

... 

</html> 

  

In both cases, filename.css is the name you give your style sheet when you save it (and you must save it as 

a .css document)   

  

Types of Selectors 

 
There are different types of selectors you can use, including: 

 

 Element Selectors  

 Contextual Selectors  

 Class Selectors  

 Psuedo Class/Element Selectors  

 

Element Selectors: these are your HTML Tags. You can use almost anything. We used the <A> tag earlier 

as well as the <H1> and <H2> tags above.   You can use several sets of properties and values for one 

selector, just separate them with semicolons: 

  

b {color: navy; font-size: 18pt;} 
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You can also add multiple element selectors to a declaration by inserting commas between them. For 

example, if you wanted to make all bold words and all lists navy, you could group selectors such as below. 

  

li, b {color: navy;} 

  

  

Contextual Selectors: With element selectors, you can apply the same rules to several selectors by listing 

them separated by commas.  Contextual selectors allow you to set several conditions to a selector with 

several characteristics.  To indicate a contextual selector, you list multiple elements separated by white 

space: 

 

 li b {color: navy;} 

  

Would make only text that is both bold and part of a list navy.   

 

So if you wanted any words that were either bold or italicized to be red, you could use: 

 

b, i {color: red;} 

 

If you wanted only words that were both bold and italicized to be green, you could use: 

 

b i {color: green;} 

  

  

Class Selectors:  These are sort of like Inline Style Sheets, except you use a word of your choice instead of 

an HTML tag. Basically you add a period and a word to make a class name. For example, look at this rule: 

  

a.hello {color: navy} 

  

.hello is the class. When you put it in a tag, you use the "class" attribute and it will look something like this: 

  

<a href="hello.htm" class="hello">Hello</a> 

  

 Class selectors are particularly handy when dealing with tables.  As you may recall, if you want a table to 

have text that has a font color, style, or face, you had to repeat the <FONT> tag in each cell of the table.  

But if you want to apply a style to the entire table, you can do it using CSS.   

 

Add this rule to either your embedded style sheet (in the head of your HTML document) or to your external 

style sheet: 

 

.boldtable, .boldtable TD, .boldtable TH 

 {font-family:sans-serif; font-size:20pt; color:white; background-color:navy;} 

 

 

Then, when you create your table, add the class to your table tag: 

 

<TABLE BORDER=1  CLASS="boldtable"> 

 

And the rules will be applied to the entire table.  Note: you really need to include “.boldtable” “.boldtable 

TD” and “boldtable TH” as your selectors to make it work properly. 

 

 

Pseudo Class/Element Selectors: Pseudo Class/Element selectors allow you to specify styles for certain 

states of a tag (rather than all the time)  For example, you may want your links to turn pink and become 

bold when you move your mouse over them (don’t recommend it, but you might want to). Perhaps you’d 
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like your visited links to be green. This is basically what pseudo classes/selectors do. They set style rules 

for different states of a tag. Here is an example using all the pseudo classes of anchor tags: 

  

a:link {color: navy;} 

a:hover {color: pink; font-weight: strong;} 

a:active {color: orange;} 

a:visited {color: green;} 

  

   

Examples of selectors, properties, and values: 

 

Selector Property Values Purpose 

    
body background-color color or “transparent” Sets the background 

color of the page 

 color color Sets the default text 

color for the page 

 background-image URL Sets your background 

image 

 background-attachment scroll, fixed Background image will 

either scroll or stay fixed 

 background-position percentage, length, top, center, 

bottom, left, right. 

Positions the 

background image. 

 background-repeat repeat, repeat-x, repeat-y, no-

repeat 

Refers to how the 

background image 

repeats itself. 

font font-family generic family (Serif), family 

name (Arial) 

Changes the font type. 

 font-size xx-small, x-small, small, 

medium, large, x-large, xx-large, 

larger, smaller, length, 

percentage 

Changes the size of your 

font 

 font-style normal, italic, oblique Changes emphasis of 

text. 

 font-variant normal, small-caps Changes the 

capitalization of text. 

 font-weight normal, bold, bolder, lighter, 100, 

200, 300, 400, 500, 600, 700, 

800, 900 

Changes how bold or 

light your text is. 

UL or OL list-style-image url, none Uses an image instead of 

the default disc for 

bullets. (Note – if you 

use this, you should also 

include the list-style-

type as a backup) 

 list-style-type disc, circle, square, decimal, 

lower-roman, upper-roman, 

lower-alpha, upper-alpha, none 

Uses one of the text 

symbols as a bullet. 

A text-decoration none Eliminates the underline 

from the hyperlink 

A:link   Declarations apply to 

unvisited links 

A:hover   Declarations apply on 

mouseover 
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A:active   declarations apply to 

active links 

A:visited   Declarations apply to 

visited links 

Border border-bottom   Deals w/ the bottom 

edge of the box border. 

  border-bottom-width thin, medium, thick, length Sets the thickness of the 

bottom border. 

  border-color color Sets the color of a 

border. 

  border-left   Deals w/ the left edge of 

the box border. 

  border-left-width thin, medium, thick, length Sets the thickness of the 

left border. 

  border-right   Deals w/ the right edge 

of the box border. 

  border-right-width thin, medium, thick, length Sets the thickness of the 

right border. 

  border-style none, dotted, dashed, solid, 

double, groove, ridge, inset, 

outset 

sets the type of 

  border-top   Deals w/ the top edge of 

the box border. 

  border-top-width thin, medium, thick, length Sets the thickness of the 

top border. 

  border-width thin, medium, thick, length Sets the thickness of the 

all borders. 

Color color color This changes the color 

of your tag that you 

apply this style to. 

Float float left, right, none Same as in HTML tables 

(refer to HTML notes).. 

Height height length, auto Changes the length of an 

item. 

Letter Spacing letter-spacing normal, length Changes the amount of 

space between text. 

Line Height line-height normal, number, length, 

percentage 

Changes the amount of 

space between lines. 

Margin margin length, percentage, auto Sets the margin widths 

all around. 

  margin-bottom length, percentage, auto Sets the margin bottom 

for the bottom. 

  margin-left length, percentage, auto Sets the margin left for 

the bottom. 

  margin-right length, percentage, auto Sets the margin right for 

the bottom. 

  margin-top length, percentage, auto Sets the margin top for 

the bottom. 

Padding padding length, percentage Adjusts overall padding 

in a table. 

  padding-bottom length, percentage Adjusts bottom border 

padding in a table. 

  padding-left length, percentage Adjusts left border 

padding in a table. 

  padding-right length, percentage Adjusts right border 
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padding in a table. 

  padding-top length, percentage Adjusts top border 

padding in a table. 

Text text-align left, right, center, justify Changes the alignment 

of the text. 

  text-decoration none, underline, overline, line-

through, blink 

Changes the style of the 

text. 

  text-indent length, percentage Changes the length 

indention. 

  text-transform capitalize, uppercase, lowercase Changes the 

capitalization  of text. 

Vertical Align vertical-align baseline, sub, sup, top, text-top, 

middle, bottom, text-bottom, 

percentage 

Changes the vertical 

position of text or 

elements. 

White Space white-space normal, pre, nowrap Changes the amount of 

white space. 

Width width length, percentage, auto Sets the width of an 

element 

Word Spacing word-spacing normal, length Changes the width 

between words (similar 

to letter spacing). 

  

Ways to express Length in CSS: 

  

inches (in)  

centimeters (cm)  

millimeters (mm)  

points (pt)  

picas (pc)  

em-height (em)  

x-height (ex)  

pixels (px)  

 
Ways to describe color in CSS: 

 

Method Format Example 

Hexadecimal code #RRGGBB #C30A0A 

RGB rgb(rrr,ggg,bbb) rgb(195,10,10) 

RGB as a percent rgb(rrr.rr%,ggg,gg%,bbb.bb%) rgb(76.2%,3.9%,3.9% 

Keyword Color word Red, blue, gray 
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Topics in Web Mastering II:  Beyond the Basics 
 
In web mastering, we cover a variety of basic topics, but there is much more to learn.  Here are a few more 

advanced topics that you may cover if you take Web 2 (Independent Study) or you may choose to research 

on your own. 

 

Topic:  SGML (Standard Generalized Markup Language) 
 

What is it? 

 A standard for how to specify a document markup language or tag set 

 SGML does not specify any particular formatting; rather, it specifies the rules for tagging elements 

 HTML & XML are examples of SGML based languages 

 SGML allows the definition of new mark-up languages 

 

How does it function? 

 Authors mark up their documents by representing structural, presentational, and semantic 

information alongside content  (HTML is one example of a markup language) 

 Languages identified in SGML are known as an SGML application 

 

How does it relate to other topics and the Internet? 

 SGML is HTML & XML’s big brother 

 Due to its complexity, many SGML functions are being ported to XML 

 Properly authored documents will automatically be readable by new browsers 

 

Advantages: Disadvantages: 

 Has been around for quite some time 

 Used by large companies and the federal government 

 Can be written using any text editor 

 More customizable than HTML & XML 

 Very complex language 

 Tough to learn 

 Expensive to implement 

 

Resources: 

 

Books: 

1. HTML, Java, CGI, VRML, SGML Web Publishing Unleashed  by William Robert Stanek, et al 

2. Developing SGML DTDs: From Text to Model to  Markup  by Eve Maler, Jeanne El Andoloussi 

3. The Concise SGML Companion  by Neil Bradley 

4. The SGML Handbook  by Charles F. Goldfarb, et al 

5. PARSEME.1st: SGML for Software Developers  by Sean McGrath 

6. SGML on the Web: Small Steps Beyond HTM by Yuri Rubinsky, Murray Maloney 

  

Web Sites:  
1. Core Standards:  http://xml.coverpages.org/sgml.html 

2. Overview of SGML Resources:  http://www.w3.org/MarkUp/SGML/ 

3. SGML Introduction:  http://www.users.cloud9.net/~bradmcc/WhatIsSGML.html 

 

What kinds of things could you do with SGML? 

 Apply SGML parser to selected documents 

 Create a catalog for retail business or University course listing 

 Build a card catalog for a set of technical manuals 
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Topic:  XML (Extensible Markup Language) 
 

What is it? 

 A markup language that separates the actual content of a document from the way the content is 

displayed and formatted 

 XML can be said to be based on SGML 

 XML documents can be exchanged across platforms, languages, and applications 

 

How does it function? 

 Allows the creation of custom elements – DTDs 

 Most commonly used in the definition, organization, and transfer of data between applications 

 User agents display (or store for later use) XML documents based on document specific code 

 

How does it relate to other topics and the Internet? 

 XML may (or may not) become the standard for Web coding 

 XML is the basis for RDF, the Resource Description Framework, which allows the control of large 

amounts of related data 

 XML crosses over to other devices such as cell phones and PDAs 

 

Advantages: Disadvantages: 

 Custom elements means greater flexibility in coding 

 Is becoming the standard Web language, thus it may be 

required learning in the future 

 Can be created in any text editor 

 Useful for database interaction 

 Not just useful for creating documents, but can be used to 

pass information between various systems 

 Valid XML documents can be used outside the Web 

environment 

 D: XML is still a bit shaky as a platform 

 D: Larger, more complex XML files are 

hard to construct manually 

 D: Must be coded properly 

 

Resources: 

 

Books: 

1.    Professional XML by Mark Birbeck, et al 

2.    The XML Companion by Neil Bradley 

3.    XML Bible by Elliotte Rusty Harold 

4.    XML Handbook  by Charles F. Goldfarb 

5.    XML in a Nutshell by W. Scott Means, Elliotte Rusty Harold 

6.    Learning XML by Erik T. Ray 

7.    XML: A Primer by Simon St.Laurent 
  

Web Sites: 

1.    The XML FAQ:  http://www.ucc.ie:8080/cocoon/xmlfaq 

2.    XML: It’s the Future:  http://www.sun.com/980602/xml/ 

3.    XML Tutorial:  http://www.w3schools.com/xml/default.asp 
 

What can you do with XML?: 

 Convert existing HTML documents to XML 

 Create DTDs to perform a variety of functions (color change, alignment, etc) 

 Create documents that output to a database using XML 

 Create simple math problems 
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Topic:  XHTML (Extensible Hypertext Markup Language) 
 

What is it? 

 An HTML-like markup language 

 Combines HTML with XML into a single language 

 Designed as a bridge between HTML and the future of Web programming 

 

How does it function? 

 Functions the same as HTML with support for XML-enabled agents 

 Forces HTML to be well-formed 

 Introduces metadata in the HEAD section 

 

How does it relate to other topics and the Internet? 

 Transition from HTML to XML 

 Considered by W3C as the new HTML standard 

 XHTML 1.0 is actually HTML 5.0 

 It is just a matter of time until XML is standard across the Web 

 

Advantages: Disadvantages: 

 Gets you used to coding in proper XML format 

 Facilitates portability, allowing Web pages to be 

easily displayed on any Web enabled device 

 Extensibility means that new elements can be 

added without altering the entire DTD 

 Not as easy to jump into as HTML 

 Offers limited accessibility options for 

accommodating disabled users 

 

Resources: 

 

Books: 

1.  Special Edition Using XHTML by Molly Holzschlag 

2. Creating Web Pages with XHTML by Don Gosselin 

3.  Web Design & Development Using XHTML by Jeffrey Griffin, Carlos Morales, John Finnegan 

4.  Mastering XHTML Premium Edition by Ed Tittle, et al 

5.  Beginning HTML by Cassandra Greer, et al 

6. XHTML Complete  by Sybex Inc. 

7. XHTML Fast & Easy Web Development  by Brian Proffitt, Ann Zupan 

  

Web Sites: 

1. HTML Goodies: XHTML:  http://www.htmlgoodies.com/tutors/xhtml.html 

2.     XHTML tutorial:  http://www.w3schools.com/xhtml/default.asp 

3.     Learn XHTML:  http://www.topxml.com/xhtml/default.asp 

 

What can you do with it?: 

 Convert HTML files to XHTML (any HTML file can be converted to XHTML) 

 Create any basic Web document from scratch in XHTML 
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Topic: DHTML (Dynamic Hypertext Markup Language) 
 

What is it? 

 A combination of HTML, CSS (Cascading Style Sheets), CSS-P (Cascading Style Sheets – 

Positioning), & JavaScript 

 Not actually a language or specific technology, but really just an idea 

 Additional items can be defined as being DHTML (such as VBScript and various DOMs) 

 

How does it function? 

 Page elements created in HTML 

 Formatted with CSS 

 Positioned with CSS-P 

 Manipulated with JavaScript 

 Various other technologies can be applied at any time in the sequence 

 

How does it relate to other topics and the Internet? 

 DHTML is a natural outgrowth of HTML 

 Can serve as a bridge between learning HTML and learning JavaScript 

 Helps to stress the importance of browser and platform compatibility 

 

Advantages: Disadvantages: 

 Adds interactivity to Web pages 

 Small learning curve 

 Can be used to perform a wide variety of functions 

 Cross-platform and cross-browser 

problems possible 

 Code can get lengthy 

 Small coding error can result in large 

display problems 

 

What can you do with it?: 

 Multiple image rollovers (also known as image flips) 

 Image slide shows 

 Mouse-over link color change 

 Drop-down menus 

 Capturing mouse/keyboard events 

 Dynamic form processing 

 

Resources: 

 

Books: 

1.    Dynamic HTML: The Definitive Reference by Danny Goodman 

2. Dynamic HTML  by Bruce Campbell, Rick Darnell 

3. Dynamic HTML: The HTML Developer’s Guide by Jeff Rule 

4. Essential Dynamic HTML Fast by Aladdin Ayesh 

5. Dynamic HTML for Webmasters by Tom Dell 

8. DHTML for the World Wide Web by Jason Cransford Teague 

7. Sams Teach Yourself DHTML by Michael Moncur 

  

Web Sites:  
1. DHTML tutorial:  www.w3schools.com/dhtml/default.asp 

2.    Learn DHTML:   http://www.geocities.com/pakevernew/learndhtml.html 

3. Taylor’s Dynamic DHTML Tutorial:  

http://hotwired.lycos.com/webmonkey/authoring/dynamic_html/tutorials/tutorial1.html 

4. Beginner’s Guide to DHTML:  http://www.geocities.com/ResearchTriangle/Facility/4490/ 
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Topic:  CGI (Common Gateway Interface) and  Perl (Practical 

Extraction and Reporting Language 
 

What are they? 

 CGI is the protocol that allows a Web server to communicate with CGI scripts 

 Perl is the most common language to construct CGI scripts 

 Perl was designed for text manipulation, but is now used for a wide range of functions 

 

How do they function? 

 CGI is often used to access data – i.e. from databases, files, other programs, etc. 

 Perl is intended to be practical and easy to use (as opposed to small or elegant) 

 Perl is used to create scripts that run server-side applications 

 

How do they relate to other topics and the Internet? 

 CGI scripts can be written in a variety of languages (C++, Java, Python, Tcl/Tk, VBScript, etc.) 

 CGI is simply a protocol, not a programming language 

 Perl can be used to create a common Web applications, such as guestbooks, hit counters, cookies, and 

chat rooms 

 

Advantages: Disadvantages: 

 

 Perl is powerful – can manipulate text in an enormous number 

of ways 

 Perl is easy to learn and free! 

 Perl supports both procedural and object-oriented programming 

 Perl has a large number of third-party modules 

 Perl can process very large files 

 CGI is not good for performing 

complex functions 

 Perl can be slow 

 Perl can be cryptic 

 Errors often difficult to identify 

 Perl is not browser embedded 

 

Resources: 

 

CGI Books: 

1. CGI Programming on the World Wide Web by Shishir Gundavaram 

2. Sams Teach Yourself CGI in 24 Hours by Richard Colburn 

3. CGI Developer’s Guide by Eugene Eric Kim 

4. CGI 101 by Jacqueline Hamilton 

5. CGI/Perl by Craig Patchett, Matthew Wright 

6. PERL and CGI for the World Wide Web by Elizabeth Castro 

 

CGI Web Sites: 

1.    CGI Programming 101:  http://www.cgi101.com/class/ 

2.    CGI Made Really Easy:   http://www.jmarshall.com/easy/cgi/ 

 

Perl Books: 

1. Programming Perl by Larry Wall, Tom Christiansen, Jon Orwant 

2. Perl Cookbook by Tom Christiansen, Nathan Torkington 

3. Programming the Perl DBI by Alligator Descartes, Tim Bunce 

4. Perl Developer’s Dictionary by Clinton Pierce 

5. Sams Teach Yourself Perl in 21 Days by Laura Lemay 

6. PERL Black Book by Steven Holzner 

 

Perl Web Sites: 

1. Perl Introduction:  http://www.perldoc.com/perl5.8.0/pod/perlintro.html 

2. Perl Tutorial:  http://archive.ncsa.uiuc.edu/General/Training/PerlIntro/ 
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What can you do with them?: 

 Create a guestbook and/or page counter 

 Set a cookie to remember user’s name 

 Use Perl to convert a text document to an HTML document 

 

Topic:  PHP (Personal Home Page Tools) 

 

What is it? 

 Official name is “PHP: Hypertext Preprocessor” (PHP stands for Personal Home Page) 

 A server-side scripting language for creating dynamic Web pages 

 PHP is open source 

 Syntax is similar to C and Perl 

 

How does it function? 

 PHP code is embedded directly in HTML code 

 When users visit PHP pages, server processes the PHP commands and sends results to users browser 

 

How does it relate to other topics and the Internet? 

 Because it is a scripting language, it can perform many of the functions of DHTML, JavaScript, and 

Perl 

 Rapidly becoming one of the most popular server-side scripting languages 

 Excellent tool for creating reliable e-commerce Web pages 

 

Advantages: Disadvantages: 

 Tags embedded within HTML 

 PHP code is hidden from users 

 Can perform all the tasks that a CGI script can perform 

 Compatible with most database types 

 Very stable 

 Very fast 

 Cross platform 

 Requires a PHP supported server 

 Error handling can often be suspect 

 

Resources: 

 

Books: 

1.    Core PHP Programming by Leon Atkinson, Zeev Suraski 

2.    Programming PHP by Rasmus Lerdorf, Kevin Tatroe 

3.    PHP: Fast and Easy Web Development by Julie Meloni 

4.    PHP Developer’s Cookbook by Sterling Hughes, Andrei Zmievski 

5.    Beginning PHP4 by Chris Lea, Wankya Choi, Allan Kent, Ganesh Prasad, Chris Ullman  

6.    PHP and MySQL Web Development by Luke Welling, Laura Thomson 

 

Web Sites: 

1.    PHP:  http://www.php.net/ 

2.    PHP Builder:  http://builder.com.com/5100-31-5074693.html 

3.    About PHP:  http://www.zend.com/zend/aboutphp.php 

 

What can you do with it?: 

 Create a database to manage a mailing list 

 Create a multi-page form (form that transforms data from one page to another) 

 Set and retrieve cookies 
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Topic:  ASP (Active Server Pages) 
 

What is it? How does it Function? 

 A server-side scripting environment 

developed by Microsoft 

 Released in 1997 

 NOT a program or programming 

language 

 Allows dynamic Web page creation 

 Allows extensive database integration 

 

How does it relate to other topics and the 

Internet? 

 ASP was the precursor of Microsoft’s 

new ASP.NET 

 Database integration can be 

accomplished in several ways, ASP is 

just one way 

 Integrates with Jscript (Microsoft’s 

version of JavaScript) 

 

 

 

 

Advantages: Disadvantages: 

 

 Can be edited with Notepad or similar programs 

 Can be mixed with HTML code – no compiling necessary 

 Free to use 

 Can be created using any scripting language that supports 

VBScript 

 Cannot be learned by looking at page 

source code 

 Page must be hosted on a Microsoft 

server 

 

Resources: 

 

Books: 

1.    ASP 3.0 by Richard Anderson, John Schenken 

2.     ASP Cookbook by J.C. Janicot 

3.    ASP.NET Developer’s Guide by Grg Buczek 

4.    Microsoft ASP.NET Step by Step by G. Andrew Duthie 

5.    Beginning Active Server Pages 3.0 by Brian Francis, Davis Sussman, Juan Llibre 

  

Web Sites: 

1.    Learn ASP:  http://www.learnasp.com 

2.    ASP Tutorial:  http://www.w3schools.com/asp/default.asp 

3.    ASP Tutorial:   http://www.programmingtutorials.com 

4.    Getting Started with ASP:  http://www.tagconsulting.com/GSList.asp 

5.    ASP Tutorial for Beginners:  http://www.asptutorial.info 

 

What can you do with it?: 

 Create a simple ASP server 

 On-line shopping (shopping cart functions) 

 Image gallery or slide show 

 Membership database (logins and passwords) 
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Topic:  Streaming Video 
 

What is it? 

 Moving images sent in compressed form over the Internet and displayed by the viewer as they arrive 

 Can be used to present a wide variety of videos, from movie trailers to training videos 

 Allows for continuous video display 

 

How does it function? 

 Begin by filming your video (digital or tape, it doesn’t matter) 

 Encode the video to a particular format (ex: QuickTime, Windows Media, Real Media, etc.) 

 Compress the video, then publish the video 

 

How does it relate to other topics and the Internet? 

 Streaming video can be either progressive (on demand) or real-time (live) 

 How you present it dictates how you build your page 

 RealVideo is most popular video format used on Web 

 

Advantages: Disadvantages: 

 

 Avoids having to wait for a video to completely 

download before viewing it 

 Streaming video servers attempt to match user 

speeds and maintain a constant connection 

 Requires a helper application to view the video 

 Video quality can be low 

 Requires use of a special video streaming 

server 

 Large, high quality videos may only be 

viewable for users with fast connections 

Resources: 

 

Books: 

1.    The Five Essential Steps in Digital Video by Denise Ohio 

2. The Technology of Video & Audio Streaming by David Austerberry 

3.    Streaming Video Bible by Steve Mack 

4.    The Streaming Media Handbook by Eyal Menin 

5.    The Little Digital Video Book by Michael Rubin 

6.    Streaming Media Demystified by Michael Topic 

 

Web Sites: 

1.    Streaming Video for the Masses:  

http://hotwired.lycos.com/webmonkey/01/03/index4a.html?tw=multimedia 

2.    Streaming Video Tutorials: http://www.streamingmediaworld.com/video/tutor/ 

3.    How to Create Streaming Video Files:  http://www.mediacollege.com/video/streaming/create-

file.html 

 

What can you do with it?: 

 Set up streaming server 

 Create, edit, encode, and compress video for distribution over the Internet 

 Create an HTML document that offers up a streaming video 
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Topic:  VRML  (Virtual Reality Modeling Language) 
 

What is it? 

 The defined standard format for displaying 3D on the Web 

 VRML describes the layout of 3D environments and objects 

 When you call up a VRML file, you are entering an entire 3D world 

 

How does it function? 

 Uses hierarchical scene descriptions that define the geometry and behavior of a 3D scene or “world” 

 Controls the way in which scenes are navigated by the user 

 VRML is the only standardized 3D format suitable for Web delivery 

 

How does it relate to other topics and the Internet? 

 VRML is a descriptive language just like HTML (it also uses the ASCII) 

 If HTML is a building’s blueprint, then VRML is a physical plastic model 

 Considered by many to be arcane and archaic 

 

Advantages: Disadvantages: 

 

 Can be created using any text editor 

 Format is supported by most 3D programs 

 Variable viewing positions 

 Files are generally small 

 Requires a plug-in to view 

 Requires the full download of the 3D data before 

displaying world 

 Can’t really deliver a true interactive 3D environment 

 Large environments generally require the use of 

authoring packages that can be costly 

 

Books: 

1.    The VRML Sourcebook  by Andrea Ames, David Nadeau, John Moreland 

2.    The Annotated VRML 2.0 Reference Manual  by Rikk Carey, Gavin Bell 

3.    Teach Yourself VRML 1.0 in 21 Days by Chris Marrin, Bruce Campbell 

4. Laura Lemay’s Web Workshop 3D Graphics and VRML 2 by Laura Lemay, et al 

5.    Special Edition Using VRML by Stephen Matsuba, et al 

6.    Instant VRML Worlds by Randall Kennedy, et al 

7.    Building VRML Worlds by Ed Tittle, et al 

 

Web Sites: 

1.    VRML Tutorial:  http://www.virtualrealms.com.au/vrml/tute01/tutorial.htm 

2.    VRML Interactive Tutorial: http://sim.di.uminho.pt/vrmltut/ 

 

What can you do with it?: 

 Create a chat “world” (3D room where users chat) 

 Build an animal with bone structure – removing the skin displays the bones 

 Create a 3D maze 

Develop a 3D representation of your school 
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Additional Topics: 
 

 SQL 

 Python 

 .net 

 JSP 

 Visual Basic 

 VBScript 

 SVG images 

 ColdFusion 

 Advanced Cookies 

 TEI-XML 

 Advanced Databases 

 Java Applet Programming 

 

Resources: 

 

Books: 

1. Java How to Program  

2. Head First Java 

3. Developing Java Web Services 

4. Developing Games in Java 

5. Sams Teach Yourself SQL 

6. SQL in a Nutshell 

7. SQL Unleashed 

8. The Quick Python Book 

9. Learning Python 

10. Beginning JSP Web Development 

11. Programming .NET Components 

12. Microsoft .NET Core Requirements 

13. SVG Essentials 

14. Designing SVG Web Graphics 

15. ColdFusion MX Web Application Construction Kit 

16. ColdFusion MX Bible 

17. VBScript Programmer’s Reference 

18. Learning VBScript 

19. Teach Yourself VBScript in 21 Days 

20. VBScript Unleashed 

 

Web Sites: 

1.   Java Technology & Web Services:  http://java.sun.com/webservices/ 

2.   Java:   http://www.java.com/en/index.jsp 

3.   SQL Tutorial:  http://www.w3schools.com/sql/default.asp 

4.   Introduction to SQL:  http://www.free-ed.net/fr03/lfc/030101/121/ 

5.   Python Tutorial:   http://www.python.org/doc/current/tut/tut.html 

6.   JSP Tutorial:  http://www.apl.jhu.edu/~hall/java/Servlet-Tutorial/ 

7.   Advanced C#/.NET Tutorial:  http://my.execpc.com/~gopalan/dotnet/net_tutorial.html 

8.   SVG: Executive Summary:   http://wwws.sun.com/software/xml/developers/svg/ 

9.   ColdFusion Tutorial:   http://hotwired.lycos.com/webmonkey/programming/coldfusion/ 

 tutorials/tutorial2.html 

10.   VBScript Tutorial:    http://www.w3schools.com/vbscript/default.asp
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Appendix 
 

 

90 HTML Tags to Know 

Tag Function 
1. <!--…--> Defines a comment 

2. <a>…</a> Defines an anchor or link 

3. <address>…</address> Defines an address element 

4. <applet>…</apple> Embeds a Java applet 

Deprecated in HTML 4.0 - use <object> 

5. <area> Defines links and anchors inside an image map 

6. <b>…</b> Defines bold text 

7. <base>…</base> Defines the base address of the HTML document 

8. <bdo>…</bdo> Defines a bidirectional algorithm for text direction 

override 

9. <basefont>…</basefont> Defines the default font 

Deprecated in HTML 4.0 - use style sheet 

10. <big>…</big> Defines big text 

11. <blockquote>…</blockquote> Defines a long quotation 

12. <body>…</body> Defines the body element 

13. <br> Inserts a single line break 

14. <button>…</button> Defines a push button in a form 

15. <caption>…</caption> Defines a table caption 

16. <center>…</center> Centers text 

Deprecated in HTML 4.0 – use <div> or style sheet 

17. <cite>…</cite> Cites a reference 

18. <code>…</code> Defines a piece of for display 

19. <col> Defines attributes for table columns 

20. <colgroup>…</colgroup> Defines groups of table columns 

21. <dd>…</dd> Defines a definition description 

22. <del>…</del> Defines text deleted from document since last change 

New element in HTML 4.0 

23. <dfn>…</dfn> Defines a definition term 

24. <dir>…</dir> Defines a directory list 

Deprecated in HTML 4.0 - use <ul> 

25. <div>…</div> Defines a section in a document 

<div align=”…”> deprecated in HTML 4.0 - use style 

sheet 

26. <dl>…</dl> Defines a definition list 

27. <!DOCTYPE…> Defines document version (SGML* declaration) 

28. <dt>…</dt> Defines a definition term 

29. <em>…</em> Defines emphasized text 

30. <embed>…</embed> Embeds Netscape plug-in technology 

Deprecated in HTML 4.0 – use <object> 
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31. <fieldset>…</fieldset> Defines groups of related controls in a form 

32. <font>…</font> Defines font properties 

Deprecated in HTML 4.0 – use style sheet 

33. <form>…</form> Defines a form 

34. <frame> Defines a frame 

35. <frameset>…</frameset> Defines the layout of a set of frames 

36. <h1>…</h1> to <h6>…</h6> Defines header 1 to header 6 

37. <head>…</head> Defines information about the document 

38. <hr> Defines a horizontal rule 

39. <html>…</html> Defines a html document 

40. <i>…</i> Defines italic text 

41. <iframe>…</iframe> Defines an inline frame 

42. <img> Defines an image 

43. <input> Defines an input field in a form 

44. <ins>…</ins> Defines text added from document since last change 

New element in HTML 4.0 

45. <isindex> Defines a prompt for user input in a form 

Deprecated in HTML 4.0 - use <button> 

46. <kbd>…</kbd> Defines text a user would type into a document 

47. <label>…</label> Defines a control label in a form 

48. <legend>…</legend> Defines a caption of a <fieldset> 

49. <li> Defines a list item 

50. <link>  

51. <map>…</map> Defines an image map 

52. <marquee>…</marquee> Defines marquee text 

53. <menu>…</menu> Defines a single-column menu list 

Deprecated in HTML 4.0 - use <ul> 

54. <meta> Defines meta information 

55. <nobr>…</nobr> Defines non-breaking text 

56. <noframes>…</noframes> Defines content for non-frame browsers 

57. <noscript>…</noscript Defines alternate content for non-script browsers 

58. <object>…</object> Defines an embedded object 

59. <ol>…</ol> Defines an ordered list 

60. <optgroup>…</optgroup> Defines an option group within a select menu in a form 

61. <option>…</option> Defines an item in a list box in a form 

62. <p> Defines a paragraph 

<p align=”…”> deprecated in HTML 4.0 - use <div> 

63. <param> Defines the initialization of an object 

64. <pre>…</pre> Defines preformatted text 

65. <q>…</q> Defines a short quotation 

66. <s>…</s> Defines strikethrough text 

Deprecated in HTML 4.0 - use style sheet 

67. <samp>…</samp> Defines sample  

68. <script>…</script> Defines a script 

69. <select>…</select> Defines a selectable list in a form 

70. <small>…</small> Defines small text 

71. <span>…</span> Defines a span of text 
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72. <strike>…</strike> Defines strikethrough text 

Deprecated in HTML 4.0 - use style sheet 

73. <strong>…</strong> Defines strong text 

74. <style>…</style> Defines an internal style sheet 

75. <sub>…</sub> Defines subscripted text 

76. <sup>…</sup> Defines superscripted text 

77. <table>…</table> Defines a table 

78. <tbody>…</tbody> Defines a table body 

79. <td>…</td> Defines a table cell 

80. <textarea>…</textarea> Defines a text area in a form 

81. <tfoot>…</tfoot> Defines a table footer 

82. <th>…</th> Defines the cell contents of a table header 

83. <thead>…</thead> Defines a table header 

84. <title>…</title> Defines the document title 

85. <tr>…</tr> Defines a table row 

86. <tt>…</tt> Defines teletype text 

87. <u>…</u> Defines underlined text 

Deprecated in HTML 4.0 - use style sheet 

88. <ul>…</ul> Defines an unordered list 

89. <var>…</var> Defines a variable 

90. <wbr> Defines location of allowed work break 

 

Additional tags to know to comply with ADA* 

Tag Function 

<abbr>…</abbr> Defines an abbreviation 

<acronym>…</acronym> Defines an acronym 

 

*Standard Generalized Markup Language 

*Americans with Disabilities Act 
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HTML Colors 

In general: 

 

FF = full brightness  99 means 60% brightness  33 means 20% brightness 

CC means 80% brightness 66 means 40% brightness  00 means none of color  

 
White = #FFFFFF 

Red =# FF0000 

Green =# 00FF00 

Blue =# 0000FF 

Magenta = #FF00FF 

Cyan = #00FFFF 

Yellow = #FFFF00 

Black = #000000 

Aquamarine = #70DB93 

Baker's Chocolate = #5C3317 

Blue Violet = #9F5F9F 

Bluish Purple = #660099 

Brass = #B5A642 

Bright Gold = #D9D919 

Bright Red = #FF0000 

Brown = #A62A2A 

Bronze = #8C7853 

Bronze II = #A67D3D 

Cadet Blue = #5F9F9F 

Cool Copper = #D98719 

Copper = #FF7F00 

Coral = #FF7F00 

Corn Flower Blue = #4A766E 

Dark Brown = #5C4033 

Dark Green = #2F4F2F 

Darker Green = #003300 

Dark Green Copper = 

#4A766E 

Dark Olive Green - #4F4F2F 

Dark Orchid - #9932CD 

Dark Purple = #871F78 

Dark Slate Blue = #6B238E 

Dark Slate Grey = #2F4F4F 

Dark Tan = #97694F 

Dark Turquoise = #7093DB 

Dark Wood = #855E42 

Dim Grey = #545454 

Dusty Rose = #856363 

Feldspar = D19275 

Firebrick = #8E2323 

Forest Green = #238E23 

Gold = #CD7F32 

Goldenrod = #DBDB70 

Grey = #C0C0C0 

Green Copper = #527F76 

Green Yellow = #9EDB70 

Hunter Green = #215E21 

Indian Red = #4E2F2F 

Khaki = #9F9F5F 

Light Blue = #C0D9D9 

Light Grey = A8A8A8 

Light Steel Blue = #8F8FBD 

Light Wood = E9C2A6 

Lime Green = #32CD32 

Mandarian Orange = E47833 

Maroon = #8E236B 

Medium Aquamarine = 

#32CD99 

Medium Blue = #3232CD 

Medium Forest Green = 

#6B8E23 

Medium Goldenrod = 

#EAEAAE 

   = #999999 

Medium Orchid = #9370DB 

Medium Sea Green = #426F42 

Medium Slate Blue = #7F00FF 

Medium Spring Green = 

#7FFF00 

Medium Turquoise = #70DBDB 

Medium Violet Red = #DB7093 

Medium Wood = #A68064 

Midnight Blue = #2F2F4F 

Navy Blue = #23238E 

Neon Blue = #4D4DFF 

New Midnight Blue = #00009C 

New Tan = #EBC79E 

Old Gold = #CFB53B 

Orange = #FF7F00 

Orange Red = #FF2400 

Orchid = #DB70DB 

Pale Green = #8FBC8F 

Pink = #BC8F8F 

Plum = #EAADEA 

Quartz = #D9D9F3 

Rich Blue = #5959AB 

Salmon = #6F4242 

Scarlet = #8C1717 

Sea Green = #238E68 

Semi-Sweet Chocolate = 

#6B4226 

Sienna = #8E6B23 

Silver = #E6E8FA 

Sky Blue = #3299CC 

Slate Blue = #007FFF 

Spicy Pink = #FF1CAE 

Spring Green = #00FF7F 

Steel Blue = #236B8E 

Summer Sky = #38B0DE 

Tan = #DB9370 

Thistle = #D8BFD8 

Turquoise = #ADEAEA 

Very Dark Brown = #5C4033 

Very Light Grey = #CDCDCD 

Violet = #4F2F4F 

Violet Red = #CC3299 

Wheat = #D8D8BF 

Yellow Green = #99CC32 
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Compliance with Americans with Disabilities Act:  

Section 508 

Accessibility 
 

The more people who can access your site, the more potential customers you have.  If 

someone with a disability wants to buy a widget, and you are the only site they can 

navigate, guess who is going to get their business? 

 

Access to whom? 
 

Websites should be accessible to everyone.  Who is everyone? 

 

Everyone includes users who are: 

 Visually impaired 

 Hearing impaired or deaf 

 Mobility impaired (and cannot use a mouse) 

 Color blind 

 Challenged with differences in attention/perception 

 

The single most important factor to consider is that accessibility depends on the ability to 

separate the information of the website from the design of the website.  If the content is 

only understandable within the context of the design, it will be difficult if not impossible 

for some users to access the information.   

 

WCAG 1.0 
 

There are many organizations working on guidelines for making a website accessible.  

The World Wide Web Consortium (W3C) developed a list of guidelines in May of 

1999 called the Web Content Accessibility Guidelines 1.0 (WCAG (pronounced wuh-

kag) http://www.w3.org/TR/WCAG10/).  These guidelines are extremely detailed and 

include guidelines and checkpoints.  The guidelines are specific statements (for 

example, Guideline 1 recommends you “Provide equivalent alternatives to auditory 

and visual content.”)  The checkpoints provide details for implementing the 

guidelines,( for example “Provide a text equivalent for every non-text element (e.g., 

via "alt", "longdesc", or in element content).)”   

Checkpoints are assigned a priority.   

 Checkpoints labeled “Priority 1” must be implemented in order for users to 

access the content on your site 

 Checkpoints labeled “Priority 2” should be implemented, otherwise some 

users will find it difficult to access the content on your site 

 Checkpoints labeled “Priority 3” may be implemented to facilitate maximum 

usage of your site by all users. 
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Section 508 
 

The federal government addressed the issue of Internet accessibility with an 

amendment to the Rehabilitation Act of 1973, Section 508, which requires federal 

websites to be accessible to persons with disabilities.  Essentially, section 508 is 

based on the WCAG 1.0, but the language is designed to be clear and specific from a 

legal perspective.  There are 16 standards listed in Section 508, section 1194.22 

which deals with Internet and Intranet applications. 

(http://www.section508.gov/index.cfm).   

 

WCAG 2.0 
 

WCAG 1.0 goes into great detail how to make HTML documents web-accessible – but 

how would the W3 folks deal with Flash?  Java?  XML?  JavaScript?  Rather than 

write specific guidelines for each new web development (and have to update as 

each evolved) the W3 consortium began work on WCAG 2.0 

(http://www.w3.org/TR/2003/WD-WCAG20-20030624/) – a set of guidelines 

which would describe the key aspects of accessibility in a way that would allow 

for new innovation. 

 

In order for a website to be accessible, it must be: 

 Perceivable 

 Operable 

 Understandable 

 Robust 

 

But what do each of these mean? 

 

For a website to be perceivable, the content must be able to be “seen” by the user in 

whatever manner needed.  This includes the use of screen readers and Braille readers.  

This also includes readers who need to use large fonts or certain colors to aid visual 

perception of content.  Content includes text, graphics, and multimedia (including 

sound, video, or animation). 

 

For a website to be operable, all users must be able to navigate the site.  Areas of 

concern may include: 

 

 Graphic links without Alt text 

 Image maps without Alt text 

 Features which require a mouseover or double-click to access 

 

 

For a website to be understandable, it should be free of clutter or distraction, 

including animated graphics which may cause problems for users with attention 

http://www.section508.gov/index.cfm
http://www.w3.org/TR/2003/WD-WCAG20-20030624/
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problems.  Control elements should be placed consistently on each page so that once 

the user has learned to navigate he/she does not have to re-learn the system on other 

pages.  The designer should also try to anticipate typical user responses to page 

elements, for example, navigating within a form.  Focus should automatically be 

placed in the first field of the form, and using the tab key (or its equivalent) should 

cause the focus to move through the form in a predictable manner.     

 

The designer should also identify elements of the page which are acronyms (with the 

proper HTML tag) – this prompts the reader to read the individual letters, rather than 

try to pronounce the acronym.  Also, phrases of non-English origin should be 

identified as such, so the reader can react appropriately. 

 

A website which is robust means that the site is adaptable for future technology.  At 

the minimum, the designer needs to specify what plug-ins, multimedia players, or 

other technology must be available in order to properly experience the site.  This will 

help the user determine whether he/she has the capability to view the site.   

 

Ideally, the designer should provide alternatives for users who will not or cannot use 

the plug-ins specified.  Pages should still be displayed correctly to users with older 

browser versions.       
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Glossary 

<SCRIPT>…</SCRIPT> - The beginning and end tags that are necessary in a Web document for a 

JavaScript statement to be executed.  All JavaScript code must be placed within the beginning and 

ending tag. 

Active Server Pages (ASP) - Web pages that allow users to change their appearance by resizing pictures 

and moving things around. 

ActiveX - Used to embed animated objects, data, and computer code on Web pages.  

Additive color - Color produced by illumination (as on a CRT).  The primary additive colors are red, 

green, and blue (RGB)  

Aliasing - The inability of computer screens to accurately represent curves and diagonal lines, resulting in a 

"star-stepped" look. 

Anchor - A named point on a Web page.      

Animated GIF - An animated graphic exploiting looping and timing features in the GIF89a format. 

Anti-aliasing - The blending of colors on curves and diagonal lines with the background color to trick the 

eye to think aliased graphics are really smooth. 

Applet - A small Java program that can be embedded in an HTML page.  Differs from full JAVA 

applications in that they are not allowed to access certain resources on the local computer, such as 

files and serial devices (modems, printers, etc.), and are prohibited from communicating with most 

other computers across a network. 

Arithmetic operators - Symbols that allow you to program scripts to manipulate variable mathematically. 

Array - A collection of similar objects that are accessed by a variable name and an index.  When you give 

several controls the same name, they are considered an array of objects.  The array is required to 

have an index value that will always start with zero and increase for each element in the array. 

Attributes - Special code words used inside an HTML tag to control exactly what the tag does. 

Bandwidth - a general term for the amount of data that can be sent over a connection (either wired or 

wireless) during a particular time period (generally 1 second for digital devices). 

Binary code - After JavaScript code has been translated by interpretation, it becomes binary code, or 

machine-readable code. 

Bit map (or bitmap) - also called raster graphics, a bitmap describes an image as rows of dots (or pixels) 

with each dot having a value indicating whether and in what color it is displayed.    

Boolean operators - Words such as AND, OR, and NOT used in search strings to refine the scope of the 

search.  Developed by 19th century mathematician George Boole. 

BRB - Internet lingo for "be right back".       

Browser - A software program for viewing HTML pages.  Examples are Microsoft Internet Explorer and 

Netscape Navigator 

Browser canvas - The space a browser uses to display Web content.    

Browser offset - The default margin between the edge of the browser window and the page canvas. 

Browser-detection script - A script that determines the user's browser brand and generation.  

BTW - Internet lingo for "by the way".       

Buttons - Input controls that are defined with the TYPE attribute instead of the INPUT tag.  

Cable Modem - a device that enables you to hook up your PC to a local cable TV line and receive data at 

about 1.5 Mbps.  Offers a continuous connection. 

Cache - (pronounced CASH) is a place to store something temporarily (like copies of web pages). 

Call - To trigger or use a named object, such as a style function, within your Web page code.  

Cascading - The system of precedence in CSS; embedded styles take precedence over external styles, and 

inline style takes precedence over both embedded and external style. 

Cascading Style Sheets (CSS) - A tool that allows you to specify attributes such as color and font size for 

all page elements marked by a specific tag. 

CD-ROM (Compact Disk – Read Only Memory) - Small, optical disks that use the same laser technology 

as audio compact disks.  Can store 550 times more information than a 3 ½ floppy disk. 

CGI (Common Gateway Interface) - An interface for external programs to talk to a Web server.  CGI 

programs, or scripts, are usually written to process HTML forms. 
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cgi-bin - The most common name of a directory on a web server in which CGI programs are stored.  The 

“bin” stands for “binary”.  Most programs found in cgi-bin directories are text files and indicate 

scripts to be executed. 

Checkboxes - An input control that allows the user to select any or all of the listed options from a set of 

options. 

Clicking - Pressing a mouse button (usually the left button) and then quickly releasing it; used to select an 

object. 

Client-side:  In a client-server system (like a web server) these are scripts (like JavaScript) which are 

executed by your browser (the client) 

Color depth - The number of computer bits used to represent colors in a graphic.  An 8-bit color depth 

means there are 256 possible colors (16-bit = 216 colors or 65,526 different colors;  24-bit = 224 or 

16,777,216 colors).  Color is a function of the amount of memory allocated to displaying graphics on 

the computer. 

Comment - Text in an HTML document that will be seen only by the people who edit the source for that 

page. 

Compiler - Software that converts a programming language that humans can understand into a language 

that computers can understand. 

Condition - Made up of 2 tokens and a relational operator.  A conditional statement tells the browser IF 

this condition is met, perform this function; if not (ELSE), perform a different function. 

Controls/components - An interactive object within a JavaScript form. Controls or components must be 

given a name so they can be referenced within the JavaScript code. 

Cookie - Information created by a Web site and stored on the user's hard drive.  Provides a way for the 

Web server to keep track of the user's patterns and preference. 

CPU (Central Processing Unit) - The ‘brains’ of the computer.  Carries out the functions that the user tells 

the computer to do. 

Cross-platform code - Code that will works on both IE and NN 4.X version browsers.  

Cursor - A lighted indicator on the display screen that shows a user’s exact position within a program or 

document. 

Custom data definitions - In XML, tagsets that describe a specific type of data.   

Cyberspace - A broad expression used to describe the activity, communication, and culture happening on 

the Internet and other computer networks. 

Cybersquatting - the practice of registering a domain name with the intent to resell it at an inflated rate at 

a later time without ever intending to use it. 

Cycling banner - Several graphics that are displayed one after another with a pause between images.  The 

graphics scroll in either a fixed or random order.  Also called an ad banner. 

Data binding - Linking a Web page to an external data file, such as an Excel or Access file.  

Data validation - The process of checking user input data to make sure it is complete and accurate. 

Data-awareness - DHTML feature allowing a user to instantly view and manipulate a database in a Web 

page. 

DATAFLD - An HTML attribute that indicates the element from an XML document to be bound to a 

column.  

DATAFORMATAS - An HTML-Based attribute that specifies how XML-based data should be displayed 

in HTML.  

Debugging - Process of systematically identifying and fixing your script's errors (bugs).  

Decrement - To subtract one number from a value.      

Definition list - An indented list without a number or symbol in front of each item.   

Deprecated tags - Those HTML tags and attributes that are now discouraged in favor of style sheets 

or other element definitions. 

Desktop - Represented by the screen; a workspace for projects and for the tools that are needed to 

manipulate those projects. 

DHTML - A family of technologies, including CSS, HTML, scripting languages like JavaScript, and the 

document object model (DOM), that together allow you to create dynamic and interactive sites. 

Direct Connection – A permanent 24-hour link between a computer and the Internet.  

Disk - The most common storage medium used with microcomputers.    
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Dithering - A way to make up for the small numbers of colors in some palettes.  If 2 pixels of different 

color are placed next to each other your eye sees only one color that is "in between" the two.  These 

are placed in a pattern:  (ex: to make orange, use red and yellow).   

DNS (domain name system) - An Internet addressing system that uses a group of names that are listed with 

dots (.) between them, working from the most specific to the most general group.  In the United 

States, the top (most general) domains are network categories such as .edu (education), .com 

(commercial), and .gov (government).  In other countries, a two-letter abbreviation for the country is 

used, such as ca (Canada) and au (Australia). 

DOCTYPE - A declaration in HTML documents that defines the DTD (Document Type Definition) in use 

for the document. 

Document Window - Area on the display screen where text is keyed.    

DOM (Document Object Model) - A Web browser's hierarchical system of organization that allows Web 

page developers to describe and work with the Web page elements in a browser window; categorizes 

and groups Web page elements into a tree-like structure. 

Domain - The address of a computer on the Internet.  A user's Internet address is made up of a username 

and a domain name. 

Dot syntax - Method of referencing objects in an object hierarchy, beginning on the document level and 

then separating each level name with a period. 

Double-clicking - Pressing the mouse button twice in rapid succession; usually used to launch programs. 

Dragging - Moving an object to a new location by clicking and holding the mouse button, then moving the 

mouse; also used to highlight text. 

DSL - (digital subscriber line) sends data signals packed very tightly via copper telephone lines. DSL lines 

are continuously connected. 

DTD (Document Type Definition) - The formal specification of the rules of an XML document, namely 

which elements are allowed and in what combination. 

E-Business - The conducting of business electronically, either over the Internet or on private computer 

networks based on the same technology as the Internet.  Also known as E-Commerce. 

E-mail (Electronic mail) - A system that enables a person to compose a message on a computer and 

transmit that message through a computer network, such as the Internet, to another computer user. 

E-mail address - The word-based Internet address of a user; typically made up of a username, an at (@) 

sign, and a domain name (that is: user@domain). 

Embedded style - CSS style formatting associated with HTML tags, class names, or IDs between the 

HEAD tags at the top of your Web page. 

Emoticons - Keyboard symbols arranged to express emotion.  Examples (there are many more, and they go 

by many different names):  :-)   smiley, ;-)   wink, o-)   Cyclops, :-(   frown, :-I   indifferent, @};---   

Rose, :-0   yell; :-D   laughing; (_8^(I)   Homer J. Simpson 

Empty elements - Those HTML elements, like <br> and <hr>, that have traditionally prohibited the use of 

a closing tag. As non-containers, they don't have to be closed. If you want to make your documents 

XHTML compliant, you'll need to add a forward slash after the element name to "close" the tag. 

Encryption - The translation of data into a secret code. To read an encrypted file, you must have access to 

a secret key or password that enables you to decrypt it. 

Enter/Return - Key used to enter information into a computer or to return the cursor to the beginning of a 

new line. 

Event - The operating system's response to the occurrence of a specific condition.   

Event Handlers - Terms that specify possible user actions.     

Expandable outline - A Web page feature that hides the explanatory paragraphs in a bulleted list, 

displaying each only when the user clicks its corresponding bulleted item. 

External style - A style sheet contained in an external file and linked to a Web page.  Also called linked 

style. 

FAQ (Frequently Asked Questions) - A computer file containing the answers to frequently asked questions 

about a particular Internet resource. 

Firewall – A security device placed on a LAN to protect it from Internet intruders.  This can be a special 

kind of hardware router, a piece of software, or both. 

Flame - An email message or other type posting that is argumentative, abusive, insulting, or in any other 

way meant to attack another user. 

Flatten – Process of permanently combining several sprites into a new sprite.   
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Floppy disks – 3 ½ inch wide plastic storage devices.  Can hold 1.44 megabytes (MB) of information. 

Font-family - Refers to a specific font face and all of its variations. 

Form - A page that includes areas to be filled out by the reader.    

Frame - A rectangular region within the browser window that displays a Web page alongside other pages 

in other frames. 

FTP (file transfer protocol) - The basic method for copying a file from one computer to another through the 

Internet. 

Function - A piece of JavaScript code that can be called upon to perform certain tasks.  Functions are 

written by the programmer and can contain any number of JavaScript statements, including calls to 

other functions or methods. 

Gateway - A computer that connects two physically separate networks.  Can translate packets of one 

network to possibly dissimilar networks. 

Generic family - Refers to a type of font; for example, monospace, serif, sans-serif, cursive, or fantasy. 

GIF - (Graphics Interchange Format) - a raster or bitmapped graphics file format that supports 256 colors, 

transparancy, animation, and is supported by web browsers.  They are typically used for images with 

flat color, like image text, logos, and line art. 

Graphical editor - A program that allows you to edit an approximation of what a Web page would look 

like when viewed with a Web browser.  Graphical editors usually hide the actual HTML tags they 

are creating from view. 

Graphical text – Text that is subject to the rules that govern Web graphics but appears on screen as just 

like any other text. 

Graphics - Digitized pictures and computer-generated images.     

GUI - (Graphical User Interface) a way of interacting with a computer by clicking on icons rather than 

typing in commands.   

Hard Drive - Part of the computer that stores the operating system and all programs; holds large amounts 

of information. 

Helper Application – An application that is configured to launch and view files that are unreadable to a 

Web browser.  Sometimes called a plug-in. 

Hierarchical structure - A "flowchart"-type structure that delineates the hierarchy of importance, or 

simply from the most general to the most specific. 

HSV (Hue, Saturation, and Value) – Allows precise control over image color range and depth.  

HTML (Hypertext Markup Language) -The document formatting language used to create pages on the 

WWW. 

HTTP (Hypertext Transfer Protocol) -The standard method for exchanging information between HTTP 

servers and clients on the Web.  The HTTP specification lays out the rules of how Web servers and 

browsers must work together. 

Hyperlink rollover - The appearance of an image changes when the mouse pointer clicks on or moves 

over a hyperlink. 

Hypertext - Text that allows readers to jump spontaneously among onscreen documents and other 

resources by selecting highlighted keywords that appear on each screen.  Hypertext appears most 

often on the World Wide Web. 

Icon - Small pictures that represent real objects, such as disk drives, software, and documents.  

ICQ - (pronounced I-seek-you) an online messaging program that allows users to chat, share files, e-mail, 

and play games. 

Image Compression - The mathematical manipulation that images are put through to squeeze out 

repetitive patterns to make them load faster. 

Image Map - An image on a Web page that leads to two or more different links, depending on which part 

of the image the user clicks on. 

Image rollover - The appearance of an image changes when the mouse pointer moves over the image. 

IMHO - Internet lingo for "in my humble opinion".       

Increment - To add one number to a value.      

Index - A variable that usually has the value of zero assigned to it.  The index variable is used to access 

information about the array. 

Inline style - CSS style formatting specified in the opening tag surrounding an element.  

Instantiate - The process of creating a new object and assigning it a value.   
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Interlaced GIF - An image file that will appear blocky at first, then more and more detailed as it continues 

downloading. 

Internet - A large, loosely organized integrated network connecting universities, research institutions, 

government, business, and other organizations so that they can exchange messages and share 

information. 

InterNIC (Internet Network Information Center) - Organization that assigns and registers Internet domain 

names. 

Interpretation - The line-by-line conversion process that occurs automatically at run time or when the 

Web browser launches the JavaScript commands that are embedded in the Web document. 

Intranet - A private network inside a company or organization that is only for internal use.  

IP Number - (Internet Protocol Number) - Sometimes called a dotted quad.  A unique number consisting 

of 4 parts separated by dots, e.g. 165.113.245.2.  Every machine that is on the Internet has a unique 

IP number. 

JAVA - A network-oriented programming language invented by Sun Microsystems.  Specifically designed 

for writing programs that can be downloaded and run over the Internet.  Microsoft's version is 

JScript. 

JavaScript -- A scripting language that allows lines of JAVA code to be inserted into HTML pages.  

Invented by Netscape. 

JPEG - (Joint Photographic Experts Group)  - a graphics file format that supports 24-bit color and is 

supported by web browsers.  JPEG allows for significant compression at the expense of image 

quality.  Best for photographs and images with lots of colors. 

Kbps (kilobits per second) - A rate of transfer of information across a connection such as the Internet 

Keyboard - A device similar to a typewriter containing alpha/numeric and special function keys. 

Keywords - A word that is recognized by the programming language as part of its language.  A keyword, 

like IF, ELSE, or RETURN, cannot be used as a variable. 

LAN (Local Area Network) - A computer network limited to a small area.   

Layer - A transparent virtual page that determines overlap order.    

Linear structure - Any structure that moves in a predictable, linear fashion, the way a typical book reads. 

LOL - Internet lingo for "laugh out loud".       

Mbps (megabits per second) - A rate of transfer of information across a connection such as the Internet.  

Equal to 1,000Kbps. 

Methods - Specialized functions within the object that call upon the services of the object.  A method is 

invoked after you type the name of the object, followed by a period. 

MIDI - (Musical Instrument Digital Interface)  At minimum, a MIDI representation of a sound includes 

values for the note's pitch, length, and volume. It can also include additional characteristics, such as 

attack and delay time.  

Mirror site - Copy of the original site that resides on a computer in another location.  This lessens Net 

traffic to the original site and speeds up transmission by allowing users to go to the site closest to 

them. 

Modem (Modulator/Demodulator) - A device to convert the digital signals of a computer to an analog 

format for transmission across telephone lines. 

Modem mantra - The sound a modem makes while connecting with another modem:  

"EEEEnnnnnnnnnnnnnn . . . . beepboopbeepbopboopbeepbopboop . . . .brrrrrrrrrring . . . . < click >. . 

. . Screeeeeeeeeeeeeeeee!  SCREEEEEEEEEEEEEEE! . . . . ChrunchBeCrackleBeChrunch . . . ."  

Monitor - TV like screen used to display information.     

Mouse - A pointing device that helps you interact with the screen-based objects.   

MPEG - (Moving Pictures Expert Group) refers to standards for audio and video compression which allow 

for good quality despite high compression.    

MUD - (Multi-User Dungeon or Dimension) -- A (usually text-based) multi-user simulation environment. 

Some are purely for fun and flirting, others are used for serious software development, or education 

purposes and all that lies in between. A significant feature of most MUD's is that users can create 

things that stay after they leave and which other users can interact with in their absence, thus 

allowing a world to be built gradually and collectively.  

Multimedia - A description for systems capable of presenting text, pictures, sound, video, and animation. 

Network - A set of computers interconnected so that they can communicate and share information.  Most 

major networks are connected to the Internet. 
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NII (National Information Infrastructure) - An integrated communications system planned by the 

Clinton/Gore administration that will be based on a nationwide network of networks, and will 

supposedly allow all Americans to take advantage of the country's information, communication, and 

computing resources. 

Null value - A value equal to zero or nothing.      

Object - Invisible entities that have a defined set of capabilities.    

Object hierarchy - JavaScript's organization of objects; much like the system of folders used by Windows 

to keep track of disk contents. 

Object properties - Qualities such as size, location, and type.     

Operators - Placed between two tokens in a conditional statement.    

Ordered list - An indented list that has numbers or letters in front of each item.   

Overflow - Property that allows you to create the equivalent of an independent frame, anywhere within 

your browser window. 

Packet Switching - The method used to move data around on the Internet. In packet switching, all the data 

coming out of a machine is broken up into chunks, each chunk has the address of where it came from 

and where it is going. This enables chunks of data from many different sources to co-mingle on the 

same lines, and be sorted and directed to different routes by special machines along the way. This 

way many people can use the same lines at the same time.  

Packets - Small bundles of data on the Internet.  Used when downloading data from one computer to 

another.  

Page weight - Describes the total file size for a given page, including all graphics, text, scripts-everything. 

Palette - A set of colors (usually 8-bit or 256 colors) used to depict a graphic.  Win & Mac both have 

"standard" 8-bit palettes, as does Netscape.  It is also possible to have a palette that is colors selected 

from a graphic or multiple graphics. 

Parameter list - A list of information that provides a programming method what it needs to perform a 

specific function correctly. 

PERL (Practical Extraction and Reporting language) - A programming language designed to handle a 

variety of system administration functions. 

Pixel - An individual dot of color in a graphics image.     

PNG - (Portable Network Graphics) an emerging graphics file format which is finding increased support 

among web browsers, it supports 48-bit color, and variable levels of transparency. 

Pointing - Moving the mouse to place the cursor over an icon, button, text, etc.   

Portal - A marketing term that describes a Web site that is or is intended to be the first place people see 

when using the Web.  Typically a catalog of web sites, a search engine, or both.  May also offer 

email and other service to entice users. 

PPP (Point-to-Point Protocol) - A communications protocol that enables a dial-up Internet connection. 

Printer - Device attached to a computer that produces a paper copy of a document.  

Programming language - A language that has to be converted from a human-readable format into 

machine-readable format.  This process is accomplished by using a compiler to complete that 

operation. 

Progressive JPEG - An image file that appears blurry at first, then gradually comes into focus. 

Prolog - The beginning of an XML document; contains the XML declaration.   

Protocol - Specific rules and conventions defining how data may be exchanged between any two devices. 

Provider -A general reference to an Internet access provider; a company that has its own dedicated access 

to the Internet and can therefore sell dial-up IP accounts to Internet users. 

Proxy server - a server that sits between a user and the Internet to assist with security, administrative tasks, 

and caching web pages.   

Pull media - Internet content delivery system in which users access content one site at a time by visiting 

separate URL's. 

Push media - Internet content delivery system in which the user specifies the information to be delivered, 

and the system searches and downloads the information automatically to the user's computer. 

RAM (Random Access Memory) - A temporary storage area that usually holds instructions and data for the 

operating system, application programs, and documents. 

Real number - A number that has a decimal portion.  Also called a floating-point number.  

Relative Address - An address describing the path from one Web page to another, instead of a full (or 

absolute) URL address. 
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Replaced elements - Images and objects are referred to as "replaced" elements because their content 

doesn't exist in the document itself; the tag is "replaced" by an image or object that is stored outside 

of the document. 

Resolution - The number of pixels or data in a certain space.  Often measured using data per inch (dpi) or 

pixels per inch (ppi). 

Return value - Whenever a function is called, its name is replaced by the value it returns.  

RGB - A format for computer graphics wherein each color is represented by 256 shades.  In this way, there 

can be 256 shades of red, 256 shades of green, and 256 shades of blue; which make for 16,777,216 

(256 X 256 X 256) possible color combinations. 

ROTFL - Internet lingo for "rolling on the floor laughing".     

Router - A special-purpose computer (or software package) that handles the connection between 2 or more 

networks.  Routers spend all their time looking at the destination addresses of the packets passing 

through them and deciding which route to send them on. 

Run time - The period when a browser first interprets and displays the Web page and runs scripts. 

Scripting language - A language that does not have to be run through a compiler for it to be understood.  

Web browsers will take the human-readable format and convert it into machine-readable format "on 

the fly." 

Scriptlet - A script located in an external file that you can link to a Web page.   

Search Engine - A program that provides a way to search for specific information on the Internet. 

Server-side:  In a client-server system (like a web server) these are scripts (like cgi) which are executed by 

the web server 

Slide show - A collection of images that change when the user clicks on the image.   

SLIP (Serial Line Internet Protocol) - Old-style protocol used to connect a computer to the Internet.  

Replaced by PPP. 

Source - The actual text and commands stored in an HTML file; including tags, comments, and scripts; that 

may not be visible when the page is viewed with a Web browser. 

Spam - Unwanted and unsolicited messages; most often advertisements.    

SQL - (structured query language)  is a standardized query language for requesting information from a 

database.  

Steganography - hiding a message within an ordinary message or file (like a jpeg). Messages are 

encrypted in such a way that no one would suspect a message was hidden there (unless you knew 

where to look). 

Streaming - The continual flow of data from a Web site allowing audio and video to play without file 

downloads. 

Subtractive color - Color produced by reflections (as in that produced on printed paper).  

Syntax - The rules of grammar for a scripting language.     

T-1 line - A leased-line (permanent) Internet connection capable of carrying data at 1.54 Mbits per second.  

At maximum capacity, a T-1 line transfers a megabyte in under 10 seconds.  Allows hundreds of 

simultaneous Web users. 

T-3 line - A leased-line (permanent) Internet connection capable of carrying data at 44.7 Mbits per second.  

Tag -A coded HTML command used to indicate how part of a Web page should be displayed. 

TCP/IP (Transmission Control Protocol/Internet Protocol) - The agreed-on set of communications rules 

and standards that allows communication between different types of computers and networks that 

are connected to the Internet. 

Text fields - An input control that allows someone to type a string value into a specific location on a Web 

page. 

Tiled graphics - Where an image is repeated in a pattern, like floor tile.  The background of many Web 

pages use tiled graphics. 

Timeout - What occurs when one computer fails to respond to another within a predetermined interval 

during a conversation. 

Token - Either a variable name or a literal constant, which is followed by a relational operator.  A 

JavaScript condition will always consist of two tokens. 

Toolbox – Series of buttons (tools) running vertically down the left-hand side of the screen.  

Trigger event - An action, such as clicking the mouse or loading a Web page, that causes an active page or 

active element to start. 

Unity - Using a common color or style to make elements on a page look like they belong together. 
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Universal data structure - Standardized structure for defining, describing, and exchanging data on the 

Web. 

Unordered list - An indented list with a special bullet symbol in front of each item.   

URL - (Uniform Resource Locator) - Also commonly called a location or address.  This is an addressing 

system that locates documents on the Internet. 

Validation - An optional but important part of Web authoring, validation services allow you to locate 

coding errors that might produce inconsistent results in some browsers, and also help you to become 

a better developer by pointing out such things as nesting errors, syntax errors, and DTD mismatches. 

Validation usually requires that you specify which DTD you want your documents to conform to; 

HTML transitional, HTML strict, and so on. 

Variable - A name that is assigned to a literal value or to an object.  Once assigned, that name can be used 

throughout the HTML document to refer to that particular value or object. 

Visual theme - A general concept, idea, or style around which all the visual elements of a Web page, or 

graphic, are based. 

VRML (Virtual Reality Modeling Language) - Language used to simulate 3-D objects, lights, and textures.  

Viewable using a VRML viewer with the Web browser.  Allows contents to be rotated and 

manipulated, and simulated rooms to be "walked into, as well as interaction with other Web surfers. 

W3C (World Wide Web Consortium) - An international body whose mission is the creation of standards 

for WWW technologies. 

WAN (Wide Area Network) - A computer network spread out over a large area.   

Web designer - Individual involved in the creation of Web pages with a focus on layout, design, look, and 

other artistic elements. 

Web developer - Individual involved in the creation of Web pages with a focus on coding (HTML) and 

programming (ex:  JAVA, Visual Basic, CGI, Active Server Pages, Active-X, JavaScript, Cold 

Fusion, DHTML, VRML, etc.). 

Web server - A computer on the Internet that hosts data that can be accessed by Web browsers using the 

HTTP protocol. 

Web structure - A more loose site structure that allows the user to navigate in whatever direction that 

might be of interest. The content structure of a site like this would typically involve several 

independent content areas, rather than a series sections that flow in a particular direction. 

Webmaster - Individual who manages a Web site.  Involved in the creation of Web pages including input 

to and control over layout, design, look, content, coding, scripting, graphics, etc.  Usually involved 

at some level in all areas of Web page creation. 

Well-formed - Adheres to the rules of structure necessary to be correctly parsed by and XML-compliant 

program.  

windows (with a lowercase w) - Defines work areas on the desktop; each program runs within its own 

window. 

Wiki –  technology that allows users to add, remove, or edit content of a website.  Designed for mass 

collaborative authoring.    

WWW (World Wide Web) - A set of Internet computers and services that provide an easy-to-use system 

for finding information and moving among resources. 

WYSIWYG - Pronounced "Wizzy-wig" -What You See Is What You Get. This term is typically used to 

describe software that shows your results as you work. 

XHTML - A strict version of HTML that is likely to grow in preponderance on the Web-fast. XHTML is 

an application of XML that will make Web documents leaner and viable in multiple client devices. 

XML (Extensible Markup Language) - A text-based syntax especially designed to describe, deliver, and 

exchange structured data. 

XML declaration - A processing instruction for the browser or other XML-compliant program reading an 

XML document; appears in the prolog. 

XML DSO - Enable binding of XML data to an HEML document using the DHTML Object Model; 

including in XML-compliant browsers. 

XML VERSION - Instruction that indicates to a browser or XML-compliant program in which version of 

XML the document should be read. 

XSL stylesheet - A set of programming rules that determine how XML data is formatted and displayed in 

an HTML document.   


